aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-02-08 10:38:53 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-02-08 10:38:53 +0000
commit037f81756f61ef9c922a0ec6f7ed99a00e3a9a7e (patch)
treeb4bad684a885b73d74c0306107c07452b2bef5e9 /x11-toolkits
parent4d43ecb327000e49934036418a03aeb6972a28ea (diff)
Turn gnome-pty-helper into a stand-alone port. Copy parts of the vte3
Makefile and the patches from the current vte3 port. The next update of the vte3 port to 0.42.x doesn't bundle this code anymore. Obtained from: gnome devel repo
Notes
Notes: svn path=/head/; revision=408471
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnome-pty-helper/Makefile40
-rw-r--r--x11-toolkits/gnome-pty-helper/distinfo2
-rw-r--r--x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_config.h.in12
-rw-r--r--x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_configure11
-rw-r--r--x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_gnome-pty-helper.c10
-rw-r--r--x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_gnome-utmp.c11
6 files changed, 75 insertions, 11 deletions
diff --git a/x11-toolkits/gnome-pty-helper/Makefile b/x11-toolkits/gnome-pty-helper/Makefile
index c34738dad5b5..8836d20849f7 100644
--- a/x11-toolkits/gnome-pty-helper/Makefile
+++ b/x11-toolkits/gnome-pty-helper/Makefile
@@ -1,23 +1,41 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/x11-toolkits/gnome-pty-helper/Makefile 18942 2013-12-08 01:31:37Z kwm $
PORTNAME= gnome-pty-helper
-PORTREVISION= 0
-PKGNAMESUFFIX= #empty
+PORTVERSION= 0.40.2
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= GNOME/sources/vte/${PORTVERSION:R}
+DISTNAME= vte-${PORTVERSION}
+DIST_SUBDIR= gnome3
+MAINTAINER= gnome@FreeBSD.org
COMMENT= utmp/wtmp/lastlog helper program for the vte Terminal widget
-VTE3_SLAVE= yes
+BUILD_DEPENDS+= gnutls>=0:${PORTSDIR}/security/gnutls
+
+PORTSCOUT= ignore:1
+
+USES= gmake tar:xz
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
-MASTERDIR= ${.CURDIR}/../../x11-toolkits/vte3
CONFIGURE_WRKSRC= ${WRKSRC}/gnome-pty-helper
BUILD_WRKSRC= ${WRKSRC}/gnome-pty-helper
INSTALL_WRKSRC= ${WRKSRC}/gnome-pty-helper
-PLIST= ${.CURDIR}/pkg-plist
-USE_GNOME= gnomeprefix
-CONFIGURE_ARGS= # empty
-#PATCH_STRIP= -p1
-#EXTRA_PATCHES+= ${MASTERDIR}/files/patch-gnome-pty-helper_gnome-pty-helper.c
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.options.mk>
+
+post-patch:
+# borrowed osversion from bsd.ssp.mk
+.if ${OSVERSION} < 1000036 && ${ARCH} == i386
+ @${REINPLACE_CMD} -e 's|-fstack-protector-strong||g; \
+ s|-fstack-protector||g' \
+ ${WRKSRC}/configure
+.endif
+ @${REINPLACE_CMD} -e 's|(AM_MAKEFLAGS) install-exec-hook|(AM_MAKEFLAGS)|g' \
+ ${WRKSRC}/gnome-pty-helper/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gnome-pty-helper/distinfo b/x11-toolkits/gnome-pty-helper/distinfo
new file mode 100644
index 000000000000..f51564204901
--- /dev/null
+++ b/x11-toolkits/gnome-pty-helper/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gnome3/vte-0.40.2.tar.xz) = 9b68fbc16b27f2d79e6271f2b0708808594ac5acf979d0fccea118608199fd2d
+SIZE (gnome3/vte-0.40.2.tar.xz) = 923852
diff --git a/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_config.h.in b/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_config.h.in
new file mode 100644
index 000000000000..d07c7bce3919
--- /dev/null
+++ b/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_config.h.in
@@ -0,0 +1,12 @@
+--- gnome-pty-helper/config.h.in.orig 2012-03-24 17:31:26.000000000 -0400
++++ gnome-pty-helper/config.h.in 2012-03-24 17:31:43.000000000 -0400
+@@ -24,6 +24,9 @@
+ /* Define to 1 if you have the `getutmpx' function. */
+ #undef HAVE_GETUTMPX
+
++/* Define to 1 if you have the `getutxid' function. */
++#undef HAVE_GETUTXID
++
+ /* Define to 1 if you have the `grantpt' function. */
+ #undef HAVE_GRANTPT
+
diff --git a/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_configure b/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_configure
new file mode 100644
index 000000000000..737b74e59ca5
--- /dev/null
+++ b/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_configure
@@ -0,0 +1,11 @@
+--- gnome-pty-helper/configure.orig 2012-03-24 17:31:04.000000000 -0400
++++ gnome-pty-helper/configure 2012-03-24 17:31:21.000000000 -0400
+@@ -5699,7 +5699,7 @@ fi
+
+ fi
+
+-for ac_func in endutent fcntl forkpty getttyent getutent getutmpx grantpt flock login_tty openpty revoke sendmsg seteuid setreuid setutent strrchr updwtmp updwtmpx utmpname utmpxname
++for ac_func in endutent fcntl forkpty getttyent getutent getutmpx grantpt flock login_tty openpty revoke sendmsg seteuid setreuid setutent strrchr updwtmp updwtmpx utmpname utmpxname getutxid
+ do :
+ as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
diff --git a/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_gnome-pty-helper.c b/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_gnome-pty-helper.c
new file mode 100644
index 000000000000..ab80c5364b55
--- /dev/null
+++ b/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_gnome-pty-helper.c
@@ -0,0 +1,10 @@
+--- gnome-pty-helper/gnome-pty-helper.c
++++ gnome-pty-helper/gnome-pty-helper.c
+@@ -51,7 +51,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
+-#include <utmp.h>
+ #include <grp.h>
+ #include "gnome-pty.h"
+ #include "gnome-login-support.h"
diff --git a/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_gnome-utmp.c b/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_gnome-utmp.c
new file mode 100644
index 000000000000..fa2750ccd5ba
--- /dev/null
+++ b/x11-toolkits/gnome-pty-helper/files/patch-gnome-pty-helper_gnome-utmp.c
@@ -0,0 +1,11 @@
+--- gnome-pty-helper/gnome-utmp.c.orig 2012-03-24 17:30:46.000000000 -0400
++++ gnome-pty-helper/gnome-utmp.c 2012-03-24 17:30:25.000000000 -0400
+@@ -152,7 +152,7 @@ update_wtmp (char *file, UTMP *putmp)
+ #endif /* !HAVE_GETUTMPX */
+
+
+-#if defined(HAVE_GETUTMPX)
++#if defined(HAVE_GETUTMPX) || defined(HAVE_GETUTXID)
+ static void
+ update_utmp (UTMP *ut)
+ {