aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-02 07:49:25 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-02 07:49:25 +0000
commit350026a189ea4dbae0d727ed6905c89c5d628b12 (patch)
tree003ac962f6f0eb552b38e5bb2f034256bb590ed6 /x11-toolkits
parentdda3f4e27ce5c469021353ebc18074945e57e68c (diff)
downloadports-350026a189ea4dbae0d727ed6905c89c5d628b12.tar.gz
ports-350026a189ea4dbae0d727ed6905c89c5d628b12.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/wxmozilla/Makefile31
-rw-r--r--x11-toolkits/wxmozilla/distinfo1
-rw-r--r--x11-toolkits/wxmozilla/files/patch-configure20
-rw-r--r--x11-toolkits/wxmozilla/files/patch-ltmain.sh15
-rw-r--r--x11-toolkits/wxmozilla/pkg-descr7
-rw-r--r--x11-toolkits/wxmozilla/pkg-plist16
7 files changed, 91 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index a5d02cfb5a44..6d842c0c62bf 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -204,6 +204,7 @@
SUBDIR += wxgtk2-contrib
SUBDIR += wxgtk2-unicode
SUBDIR += wxgtk2-unicode-contrib
+ SUBDIR += wxmozilla
SUBDIR += xbae
SUBDIR += xclasses
SUBDIR += xenophilia
diff --git a/x11-toolkits/wxmozilla/Makefile b/x11-toolkits/wxmozilla/Makefile
new file mode 100644
index 000000000000..a913cfe3b295
--- /dev/null
+++ b/x11-toolkits/wxmozilla/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: wxmozilla
+# Date created: Oct 27, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxmozilla
+PORTVERSION= 0.5.3
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Embedding Mozilla in wxWindows
+
+BUILD_DEPENDS= ${X11BASE}/lib/firebird/lib/pkgconfig/mozilla-nspr.pc:${PORTSDIR}/www/mozilla-firebird \
+ ${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython
+LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_GNOME= gnomehack
+WXGTK_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= PKG_CONFIG_PATH="${X11BASE}/lib/firebird/lib/pkgconfig"
+CONFIGURE_ARGS= --with-wx-config=${WXGTK_CONFIG} --enable-python
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/wxmozilla/distinfo b/x11-toolkits/wxmozilla/distinfo
new file mode 100644
index 000000000000..16917aad789b
--- /dev/null
+++ b/x11-toolkits/wxmozilla/distinfo
@@ -0,0 +1 @@
+MD5 (wxmozilla-0.5.3.tar.gz) = c353300bfd1f45e1fa3e413cdbdd48d2
diff --git a/x11-toolkits/wxmozilla/files/patch-configure b/x11-toolkits/wxmozilla/files/patch-configure
new file mode 100644
index 000000000000..c4262ed8b201
--- /dev/null
+++ b/x11-toolkits/wxmozilla/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Mon Feb 2 14:55:50 2004
++++ configure Mon Feb 2 14:56:59 2004
+@@ -10135,7 +10135,7 @@
+ fi
+
+
+-if test "$build_python" == "yes" ; then
++if test "$build_python" = "yes" ; then
+
+
+
+@@ -10315,7 +10315,7 @@
+ fi
+
+
+-if test $build_python == yes; then
++if test $build_python = yes; then
+ BUILD_PYTHON_TRUE=
+ BUILD_PYTHON_FALSE='#'
+ else
diff --git a/x11-toolkits/wxmozilla/files/patch-ltmain.sh b/x11-toolkits/wxmozilla/files/patch-ltmain.sh
new file mode 100644
index 000000000000..e5e27078e805
--- /dev/null
+++ b/x11-toolkits/wxmozilla/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Mon Feb 2 14:01:02 2004
++++ ltmain.sh Mon Feb 2 14:01:19 2004
+@@ -4394,10 +4394,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/x11-toolkits/wxmozilla/pkg-descr b/x11-toolkits/wxmozilla/pkg-descr
new file mode 100644
index 000000000000..3d58a57a92de
--- /dev/null
+++ b/x11-toolkits/wxmozilla/pkg-descr
@@ -0,0 +1,7 @@
+wxMozilla is a project underway to develop a wxWindows component for embedding
+the Mozilla browser into any wxWindows application. The wxMozilla classes will
+utilize minimal, if any, platform dependant code and utilize directly the
+XPCOM (Cross Platrom COM) interface to instantate a html browser or editor
+within the application.
+
+WWW: http://wxmozilla.sourceforge.net/
diff --git a/x11-toolkits/wxmozilla/pkg-plist b/x11-toolkits/wxmozilla/pkg-plist
new file mode 100644
index 000000000000..21afd4c589c2
--- /dev/null
+++ b/x11-toolkits/wxmozilla/pkg-plist
@@ -0,0 +1,16 @@
+lib/libwxmozilla_gtk2-2.4.a
+lib/libwxmozilla_gtk2-2.4.so
+lib/libwxmozilla_gtk2-2.4.so.0
+include/wxmozilla/wxMozilla.h
+include/wxmozilla/wxMozillaBrowser.h
+include/wxmozilla/wxMozillaBrowserChrome.h
+include/wxmozilla/wxMozillaEvents.h
+include/wxmozilla/wxMozillaSettings.h
+include/wxmozilla/wxMozillaWindow.h
+@dirrm include/wxmozilla
+libdata/pkgconfig/wxmozilla.pc
+%%PYTHON_SITELIBDIR%%/wxPython/mozilla.py
+%%PYTHON_SITELIBDIR%%/wxPython/mozilla.pyc
+%%PYTHON_SITELIBDIR%%/wxPython/mozilla.pyo
+%%PYTHON_SITELIBDIR%%/wxPython/mozillac.a
+%%PYTHON_SITELIBDIR%%/wxPython/mozillac.so