aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-01-05 16:15:26 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-01-05 16:15:26 +0000
commit277236d9bbcb64efe965bf4e4f8df43547085db0 (patch)
treed75e639a951dfa70854142dc754b7ff9b363a476 /x11-toolkits
parentc8afd8e9b7e91a9e8d61158feac9288b4416468a (diff)
downloadports-277236d9bbcb64efe965bf4e4f8df43547085db0.tar.gz
ports-277236d9bbcb64efe965bf4e4f8df43547085db0.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox17/Makefile36
-rw-r--r--x11-toolkits/fox17/distinfo4
-rw-r--r--x11-toolkits/fox17/files/patch-lib_FXThread.cpp15
-rw-r--r--x11-toolkits/fox17/pkg-plist2
4 files changed, 35 insertions, 22 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 1374c03be126..9171a6aa1e29 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fox
-PORTVERSION= 1.7.31
+PORTVERSION= 1.7.32
CATEGORIES= x11-toolkits
MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/
@@ -14,13 +14,15 @@ MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
MAINTAINER= gahr@FreeBSD.org
COMMENT= Fast and extensive C++ GUI toolkit -- devel version
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- Xft.2:${PORTSDIR}/x11-fonts/libXft
+LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
CONFLICTS= fox-1.4.* fox-1.6.*
+OPTIONS= JPEG "Enable JPEG support" ON \
+ PNG "Enable PNG support" ON \
+ TIFF "Enable TIFF support" ON \
+ WEBP "Enable WebP support" ON
+
LATEST_LINK= fox17
MAJORVER= ${PORTVERSION:R}
@@ -42,6 +44,30 @@ MAN1= reswrap.1 shutterbug.1 adie.1 PathFinder.1 calculator.1 \
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_JPEG)
+CONFIGURE_ARGS+=--disable-jpeg
+.else
+LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+.endif
+
+.if defined(WITHOUT_PNG)
+CONFIGURE_ARGS+=--disable-png
+.else
+LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+.endif
+
+.if defined(WITHOUT_TIFF)
+CONFIGURE_ARGS+=--disable-tiff
+.else
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+.endif
+
+.if defined(WITHOUT_WEBP)
+CONFIGURE_ARGS+=--disable-webp
+.else
+LIB_DEPENDS+= webp.2:${PORTSDIR}/graphics/webp
+.endif
+
.if ${ARCH} == "amd64" && ${OSVERSION} < 900000
BROKEN= does not build on amd64
.endif
diff --git a/x11-toolkits/fox17/distinfo b/x11-toolkits/fox17/distinfo
index f092f3fc7043..ac3de03091f6 100644
--- a/x11-toolkits/fox17/distinfo
+++ b/x11-toolkits/fox17/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fox-1.7.31.tar.gz) = 171b0e42bf9266997e4b605413fda963e5b081520335c634a4d59709735ec626
-SIZE (fox-1.7.31.tar.gz) = 4950129
+SHA256 (fox-1.7.32.tar.gz) = 4f6b850450b25793d5147b120c446926d0f1b71f34a4c6873bcf65dbcc223879
+SIZE (fox-1.7.32.tar.gz) = 4954127
diff --git a/x11-toolkits/fox17/files/patch-lib_FXThread.cpp b/x11-toolkits/fox17/files/patch-lib_FXThread.cpp
deleted file mode 100644
index 2d82346c3269..000000000000
--- a/x11-toolkits/fox17/files/patch-lib_FXThread.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- lib/FXThread.cpp.orig 2011-08-05 09:26:49.000000000 +0200
-+++ lib/FXThread.cpp 2011-08-05 09:32:51.000000000 +0200
-@@ -25,6 +25,12 @@
- #include "FXAutoThreadStorageKey.h"
- #include "FXThread.h"
-
-+#ifdef __FreeBSD__
-+#include <pthread_np.h>
-+#include <sys/cpuset.h>
-+#define cpu_set_t cpuset_t
-+#endif
-+
- /*
- Notes:
-
diff --git a/x11-toolkits/fox17/pkg-plist b/x11-toolkits/fox17/pkg-plist
index fb0de96cf9d0..d3bbbaa8acfd 100644
--- a/x11-toolkits/fox17/pkg-plist
+++ b/x11-toolkits/fox17/pkg-plist
@@ -320,6 +320,8 @@ include/fox-%%MAJORVER%%/FXVec4d.h
include/fox-%%MAJORVER%%/FXVec4f.h
include/fox-%%MAJORVER%%/FXVerticalFrame.h
include/fox-%%MAJORVER%%/FXVisual.h
+include/fox-%%MAJORVER%%/FXWEBPIcon.h
+include/fox-%%MAJORVER%%/FXWEBPImage.h
include/fox-%%MAJORVER%%/FXWindow.h
include/fox-%%MAJORVER%%/FXWizard.h
include/fox-%%MAJORVER%%/FXWorker.h