aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-04-07 12:18:21 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-04-07 12:18:21 +0000
commit676e30f52b2e65b65a54032ec0da9f68fa8127d0 (patch)
treef16271de16f7f420a70e8acbd834bfdec82e9082 /x11-toolkits
parentfc1537cd32853823e54e83f287e713fbe2874aff (diff)
downloadports-676e30f52b2e65b65a54032ec0da9f68fa8127d0.tar.gz
ports-676e30f52b2e65b65a54032ec0da9f68fa8127d0.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gigi/Makefile27
-rw-r--r--x11-toolkits/gigi/distinfo6
-rw-r--r--x11-toolkits/gigi/pkg-plist1
3 files changed, 24 insertions, 10 deletions
diff --git a/x11-toolkits/gigi/Makefile b/x11-toolkits/gigi/Makefile
index eb55a93df95b..38007139c6a7 100644
--- a/x11-toolkits/gigi/Makefile
+++ b/x11-toolkits/gigi/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= gigi
-PORTVERSION= 0.6.0.20071206
-PORTREVISION= 2
+PORTVERSION= 0.7.0
CATEGORIES= x11-toolkits
-MASTER_SITES= ftp://ftp.alepulver.com.ar/distfiles/
+MASTER_SITES= SF
+DISTNAME= GG-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL Graphic User Interface Library
@@ -18,12 +18,10 @@ LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
boost_python.4:${PORTSDIR}/devel/boost-python \
freetype.9:${PORTSDIR}/print/freetype2
-USE_BZIP2= yes
USE_SCONS= yes
SCONS_ARGS= prefix="" pkgconfigdir=""
USE_SDL= sdl
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}/GG
# Ensure local headers are found first, otherwise updating would fail.
CFLAGS+= -I.
@@ -36,8 +34,10 @@ GIGI_LIBS= GiGi GiGiSDL
.include <bsd.port.pre.mk>
.if defined(WITH_OGRE)
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d
-RUN_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
+ ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
+RUN_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
+ ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
PLIST_SUB+= OGRE=""
GIGI_LIBS+= GiGiOgre
.else
@@ -49,6 +49,19 @@ PLIST_SUB+= OGRE="@comment "
BROKEN= Does not compile
.endif
+post-patch:
+ ${REINPLACE_CMD} -E 's|#include <boost/serialization/is_abstract.hpp>||g; \
+ s|BOOST_IS_ABSTRACT.*||g' \
+ ${WRKSRC}/GG/BrowseInfoWnd.h \
+ ${WRKSRC}/GG/Control.h
+ @rm -f ${WRKSRC}/GG/BrowseInfoWnd.h.bak ${WRKSRC}/GG/Control.h.bak
+ ${REINPLACE_CMD} -E 's|system_error\(\) == EIO|code\(\) == boost::system::posix_error::io_error|g; \
+ s|filesystem/cerrno|system/system_error|g' \
+ ${WRKSRC}/src/dialogs/FileDlg.cpp
+# for graphics/ogre3d version 1.6.x
+# ${REINPLACE_CMD} -E 's|CMPF_ALWAYS_PASS, 0)|CMPF_ALWAYS_PASS, 0, false)|g' \
+# ${WRKSRC}/src/Ogre/OgreGUI.cpp
+
post-build:
@${REINPLACE_CMD} -Ee 's,^(prefix|(lib|include)dir)=,&${PREFIX},' \
${WRKSRC}/*.pc
diff --git a/x11-toolkits/gigi/distinfo b/x11-toolkits/gigi/distinfo
index 4ad3e35a2c3c..2d36163e5fb1 100644
--- a/x11-toolkits/gigi/distinfo
+++ b/x11-toolkits/gigi/distinfo
@@ -1,3 +1,3 @@
-MD5 (gigi-0.6.0.20071206.tar.bz2) = 558ae774b9de74b60e9f3d0e7188f6f4
-SHA256 (gigi-0.6.0.20071206.tar.bz2) = 88a6f726f6cb5aabdb9bb10752e3eb13f233a1e63d4e5052755c79ee480d2d7d
-SIZE (gigi-0.6.0.20071206.tar.bz2) = 601431
+MD5 (GG-0.7.0.tar.gz) = 360e7131fde11da55efbdd555eabf665
+SHA256 (GG-0.7.0.tar.gz) = f4ef86c2b8344085217163b6310f9c2f868929a22e864eebb200786f42a0aa54
+SIZE (GG-0.7.0.tar.gz) = 1730169
diff --git a/x11-toolkits/gigi/pkg-plist b/x11-toolkits/gigi/pkg-plist
index c1cccc7942de..1a5e745b4372 100644
--- a/x11-toolkits/gigi/pkg-plist
+++ b/x11-toolkits/gigi/pkg-plist
@@ -61,6 +61,7 @@ lib/libGiGi.so.0
lib/libGiGiSDL.so
lib/libGiGiSDL.so.0
libdata/pkgconfig/GiGi.pc
+%%OGRE%%libdata/pkgconfig/GiGiOgre.pc
libdata/pkgconfig/GiGiSDL.pc
@dirrm include/GG/dialogs
@dirrm include/GG/SDL