aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-02-05 11:16:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-02-05 11:16:17 +0000
commit93dee75a9a4d12cdf8b703fcb3f95cd48d2ce48a (patch)
treeb8ba282d665b87110b46ea1effb71b69b248da04 /x11-toolkits
parent84aa9264a608a71325dd3b0dda016e41cf510da8 (diff)
downloadports-93dee75a9a4d12cdf8b703fcb3f95cd48d2ce48a.tar.gz
ports-93dee75a9a4d12cdf8b703fcb3f95cd48d2ce48a.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/fltk2/Makefile149
-rw-r--r--x11-toolkits/fltk2/distinfo2
-rw-r--r--x11-toolkits/fltk2/files/extra-patch-Makefile11
-rw-r--r--x11-toolkits/fltk2/files/patch-Makefile11
-rw-r--r--x11-toolkits/fltk2/files/patch-OpenGL-Makefile20
-rw-r--r--x11-toolkits/fltk2/files/patch-configure20
-rw-r--r--x11-toolkits/fltk2/files/patch-fltk-fltk_cairo.h10
-rw-r--r--x11-toolkits/fltk2/files/patch-fltk2-config.in11
-rw-r--r--x11-toolkits/fltk2/files/patch-fluid-Makefile14
-rw-r--r--x11-toolkits/fltk2/files/patch-images-Makefile23
-rw-r--r--x11-toolkits/fltk2/files/patch-makeinclude.in16
-rw-r--r--x11-toolkits/fltk2/files/patch-src-Makefile45
-rw-r--r--x11-toolkits/fltk2/pkg-descr8
-rw-r--r--x11-toolkits/fltk2/pkg-plist200
15 files changed, 0 insertions, 541 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 155a25861040..0d392e692163 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -16,7 +16,6 @@
SUBDIR += fl_editor
SUBDIR += flowcanvas
SUBDIR += fltk
- SUBDIR += fltk2
SUBDIR += flvw
SUBDIR += fox14
SUBDIR += fox16
diff --git a/x11-toolkits/fltk2/Makefile b/x11-toolkits/fltk2/Makefile
deleted file mode 100644
index 75867b3710a4..000000000000
--- a/x11-toolkits/fltk2/Makefile
+++ /dev/null
@@ -1,149 +0,0 @@
-# Created by: Thomas-Martin Seck <tmseck@netcologne.de>
-# $FreeBSD$
-
-PORTNAME= fltk
-PORTVERSION= 2.0.${SNAPSHOT}
-PORTREVISION= 1
-CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_EASYSW}
-MASTER_SITE_SUBDIR= fltk/snapshots
-DISTNAME= fltk-2.0.x-alpha-${SNAPSHOT}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Fast Light Toolkit version 2 (development snapshot)
-
-DEPRECATED= No more public distfiles for version 2
-EXPIRATION_DATE= 2012-11-26
-
-LICENSE= FLTK
-LICENSE_GROUPS= GPL
-LICENSE_NAME= FLTK License
-LICENSE_FILE= ${WRKSRC}/COPYING
-LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-
-# XXX:
-# FLTK2's configure script tries to find out whether the running X server
-# supports overlay visuals; this is a bit difficult to find out if you
-# are building in an environment where it cannot connect to an X server...
-# If one wants to force a certain setting one needs to set ac_cv_have_overlay
-# to "yes" or "no" in the configure environment. Since I am not sure whether
-# this is desirable, leave this as is for now.
-# If xprop cannot connect to an X server of if xprop cannot be found, X overlay
-# support will be disabled without breaking the build.
-BUILD_DEPENDS= xprop:${PORTSDIR}/x11/xprop
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
-
-SNAPSHOT= r9166
-
-OPTIONS_DEFINE= THREADS CAIRO EXAMPLES XINERAMA DOCS
-OPTIONS_DEFAULT= THREADS XINERAMA
-#OPTIONS= THREADS "Install with threads support" on \
-# CAIRO "Use cairo as graphics backend" off \
-# EXAMPLES "Build and install example programs" on \
-# XINERAMA "Enable Xinerama support" on
-
-EXAMPLESDIR= ${PREFIX}/share/examples/fltk2
-LATEST_LINK= fltk2
-
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_GL= yes
-USE_XORG= xcursor xft xi
-GNU_CONFIGURE= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
-CONFIGURE_ARGS+= --enable-jpeg --enable-png --enable-gl --enable-xft \
- --enable-zlib
-# Turn shared library support off for now since fltk2 is not yet stable.
-# fltk2 applications should only be linked statically for now to avoid trouble
-# after possibly incompatible updates to fltk2.
-CONFIGURE_ARGS+= --disable-shared
-
-DOCSDIR= ${PREFIX}/share/doc/fltk2
-PORTDOCS= *
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MTHREADS}
-CONFIGURE_ARGS+= --enable-threads
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-.else
-CONFIGURE_ARGS+= --disable-threads
-.endif
-
-.if ${PORT_OPTIONS:MCAIRO}
-CONFIGURE_ARGS+= --enable-cairo
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
-# XXX:
-# FLTK2's configure check currently depends on pkg-config being available...
-USE_PKGCONFIG= yes
-.else
-CONFIGURE_ARGS+= --disable-cairo
-.endif
-
-.if ${PORT_OPTIONS:MEXAMPLES}
-example_apps= ansiwidget arc \
- bitmap boxtype browser button buttons \
- cairo callbacks checkers clock color_chooser cube \
- CubeView cursor curve \
- demo doublebuffer drawing drawtiming \
- editor exception \
- file_chooser fonts fractals fullscreen \
- gl_overlay glpuzzle \
- hello \
- image image_transform inactive input \
- keyboard \
- label line_style list list_visuals \
- mandelbrot menu message monitors \
- navigation \
- output \
- pack pixmap progress \
- qubix \
- radio resizable resizealign \
- scroll shape sizes subwindow symbols \
- tabs threads tile timer \
- utf \
- valuators wizard
-example_data= demo.menu
-example_img= images/ulon.bmp
-PORTEXAMPLES= *
-.else
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-Makefile
-.endif
-
-.if ${PORT_OPTIONS:MXINERAMA}
-USE_XORG+= xinerama
-CONFIGURE_ARGS+= --enable-xinerama
-.else
-CONFIGURE_ARGS+= --disable-xinerama
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e 's:%%CXX%%:${CXX}:g' \
- ${WRKSRC}/fltk2-config.in \
- ${WRKSRC}/makeinclude.in
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC}/documentation && ${INSTALL_DATA} *.html *.gif ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README_fltk1_to_fltk2.txt ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}/images
- for f in ${example_apps} ; do \
- ${INSTALL_PROGRAM} ${WRKSRC}/test/$${f} ${EXAMPLESDIR} ; \
- done
- for f in ${example_data} ; do \
- ${INSTALL_DATA} ${WRKSRC}/test/$${f} ${EXAMPLESDIR} ; \
- done
- for f in ${example_img} ; do \
- ${INSTALL_DATA} ${WRKSRC}/test/$${f} ${EXAMPLESDIR}/images ; \
- done
-.endif
-
-.include <bsd.port.mk>
diff --git a/x11-toolkits/fltk2/distinfo b/x11-toolkits/fltk2/distinfo
deleted file mode 100644
index 2b6614bbe32c..000000000000
--- a/x11-toolkits/fltk2/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (fltk-2.0.x-alpha-r9166.tar.bz2) = e68c3ef3599c3e215db4011c3e68f61b155e7c05e2f220c188f14adb0a8d604b
-SIZE (fltk-2.0.x-alpha-r9166.tar.bz2) = 2656645
diff --git a/x11-toolkits/fltk2/files/extra-patch-Makefile b/x11-toolkits/fltk2/files/extra-patch-Makefile
deleted file mode 100644
index 93d4de9ccdc4..000000000000
--- a/x11-toolkits/fltk2/files/extra-patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Sun Jun 24 17:30:12 2007
-+++ Makefile Sun Jun 24 17:30:19 2007
-@@ -25,7 +25,7 @@
-
- include makeinclude
-
--DIRS = src $(LOCALIMAGES) images OpenGL fluid glut test
-+DIRS = src $(LOCALIMAGES) images OpenGL fluid glut
-
- all: makeinclude
- for dir in $(DIRS); do\
diff --git a/x11-toolkits/fltk2/files/patch-Makefile b/x11-toolkits/fltk2/files/patch-Makefile
deleted file mode 100644
index c58f96675eab..000000000000
--- a/x11-toolkits/fltk2/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Mon Apr 24 12:07:29 2006
-+++ Makefile Mon Jun 5 14:44:17 2006
-@@ -34,7 +34,7 @@
- done
-
- install: makeinclude
-- for dir in $(DIRS) documentation; do\
-+ for dir in $(DIRS); do\
- echo "=== installing $$dir ===";\
- (cd $$dir; $(MAKE) $(MFLAGS) DESTDIR=$(DESTDIR) install) || exit $$?;\
- done
diff --git a/x11-toolkits/fltk2/files/patch-OpenGL-Makefile b/x11-toolkits/fltk2/files/patch-OpenGL-Makefile
deleted file mode 100644
index 49beae7c0e2b..000000000000
--- a/x11-toolkits/fltk2/files/patch-OpenGL-Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- OpenGL/Makefile.orig Tue Apr 25 09:40:40 2006
-+++ OpenGL/Makefile Mon Jun 5 14:44:17 2006
-@@ -117,15 +117,13 @@
- ifneq (,$(wildcard ../lib/$(LIBNAME)))
- echo "Installing static OpenGL library in $(libdir)"
- $(MKDIR) $(DESTDIR)$(libdir)
-- $(RM) $(DESTDIR)$(libdir)/$(LIBNAME)
-- $(CP) ../lib/$(LIBNAME) $(DESTDIR)$(libdir)
-+ $(BSD_INSTALL_DATA) ../lib/$(LIBNAME) $(DESTDIR)$(libdir)
- endif
- ifneq (,$(wildcard ../lib/$(DSONAME)))
- echo "Installing shared OpenGL library in $(libdir)"
- $(MKDIR) $(DESTDIR)$(libdir)
-- $(RM) $(DESTDIR)$(libdir)/$(DSONAME)
- $(RM) $(DESTDIR)$(libdir)/$(DSOLINK)
-- $(CP) ../lib/$(DSONAME) $(DESTDIR)$(libdir)
-+ $(BSD_INSTALL_DATA) ../lib/$(DSONAME) $(DESTDIR)$(libdir)
- $(LN) -s $(DSONAME) $(DESTDIR)$(libdir)/$(DSOLINK)
- endif
- ifeq ($(DSONAME), fltk2_gl.dll)
diff --git a/x11-toolkits/fltk2/files/patch-configure b/x11-toolkits/fltk2/files/patch-configure
deleted file mode 100644
index a12bee5344ca..000000000000
--- a/x11-toolkits/fltk2/files/patch-configure
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.orig 2008-03-14 16:01:49.000000000 +0100
-+++ configure 2008-03-16 16:28:03.000000000 +0100
-@@ -1762,7 +1762,7 @@
- FL_MINOR_VERSION=0
- FL_PATCH_VERSION=0
- FL_RELEASE_VERSION=a0
--FL_API_VERSION=${FL_MAJOR_VERSION}.${FL_MINOR_VERSION}
-+FL_API_VERSION=${FL_MAJOR_VERSION}
-
-
-
-@@ -11085,7 +11085,7 @@
- enableval=$enable_xshm;
- fi
-
-- if test x$enable_xshm == xyes; then
-+ if test "x$enable_xshm" = xyes; then
- { echo "$as_me:$LINENO: checking for X11/extensions/XShm.h" >&5
- echo $ECHO_N "checking for X11/extensions/XShm.h... $ECHO_C" >&6; }
- if test "${ac_cv_header_X11_extensions_XShm_h+set}" = set; then
diff --git a/x11-toolkits/fltk2/files/patch-fltk-fltk_cairo.h b/x11-toolkits/fltk2/files/patch-fltk-fltk_cairo.h
deleted file mode 100644
index ee999dba6e5e..000000000000
--- a/x11-toolkits/fltk2/files/patch-fltk-fltk_cairo.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- fltk/fltk_cairo.h.orig 2009-03-08 14:41:16.000000000 +0100
-+++ fltk/fltk_cairo.h 2009-03-08 14:41:47.000000000 +0100
-@@ -35,6 +35,7 @@
-
- #include <fltk/FL_API.h>
- #include <cairo.h>
-+#include <string.h> /* for memcpy() */
-
- namespace fltk {
- extern FL_API cairo_t * cr;
diff --git a/x11-toolkits/fltk2/files/patch-fltk2-config.in b/x11-toolkits/fltk2/files/patch-fltk2-config.in
deleted file mode 100644
index 80af424837bd..000000000000
--- a/x11-toolkits/fltk2/files/patch-fltk2-config.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./fltk2-config.in.orig Tue Apr 11 00:08:47 2006
-+++ ./fltk2-config.in Fri Apr 14 15:42:24 2006
-@@ -62,7 +62,7 @@
- srcdir=@srcdir@
-
- # compiler names
--CXX="@CXX@"
-+CXX="%%CXX%%"
- CC="@CC@"
-
- # post-process command (only needed for MacOS)
diff --git a/x11-toolkits/fltk2/files/patch-fluid-Makefile b/x11-toolkits/fltk2/files/patch-fluid-Makefile
deleted file mode 100644
index dd219299c381..000000000000
--- a/x11-toolkits/fltk2/files/patch-fluid-Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
---- fluid/Makefile.orig 2010-06-04 21:04:07.000000000 +0200
-+++ fluid/Makefile 2010-06-04 21:06:16.000000000 +0200
-@@ -132,10 +132,8 @@
- install:
- echo "Installing FLUID2 in $(bindir)..."
- -$(MKDIR) $(DESTDIR)$(bindir)
-- $(CP) $(FLUID) $(DESTDIR)$(bindir)/fluid2$(EXEEXT)
-- $(STRIP) $(DESTDIR)$(bindir)/fluid2$(EXEEXT)
-+ $(BSD_INSTALL_PROGRAM) $(FLUID) $(DESTDIR)$(bindir)/fluid2$(EXEEXT)
- $(DESTDIR)$(bindir)/fltk2-config --post $(DESTDIR)$(bindir)/fluid2$(EXEEXT)
-- $(CHMOD) 755 $(DESTDIR)$(bindir)/fluid2$(EXEEXT)
-
-
- uninstall:
diff --git a/x11-toolkits/fltk2/files/patch-images-Makefile b/x11-toolkits/fltk2/files/patch-images-Makefile
deleted file mode 100644
index c8bebb3554b0..000000000000
--- a/x11-toolkits/fltk2/files/patch-images-Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- images/Makefile.orig Tue Apr 25 09:40:40 2006
-+++ images/Makefile Mon Jun 5 14:44:17 2006
-@@ -124,8 +124,7 @@
- ifneq (,$(wildcard ../lib/$(LIBNAME)))
- echo "Installing static images library in $(libdir)"
- $(MKDIR) $(DESTDIR)$(libdir)
-- $(RM) $(DESTDIR)$(libdir)/$(LIBNAME)
-- $(CP) ../lib/$(LIBNAME) $(DESTDIR)$(libdir)
-+ $(BSD_INSTALL_DATA) ../lib/$(LIBNAME) $(DESTDIR)$(libdir)
- $(RANLIB) $(DESTDIR)$(libdir)/$(LIBNAME)
- $(RM) -f $(DESTDIR)$(libdir)/$(LIBPREFIX)fltk2_z$(LIBSUFFIX)
- $(RM) -f $(DESTDIR)$(libdir)/$(LIBPREFIX)fltk2_png$(LIBSUFFIX)
-@@ -138,9 +137,8 @@
- ifneq (,$(wildcard ../lib/$(DSONAME)))
- echo "Installing shared images library in $(libdir)"
- $(MKDIR) $(DESTDIR)$(libdir)
-- $(RM) $(DESTDIR)$(libdir)/$(DSONAME)
- $(RM) $(DESTDIR)$(libdir)/$(DSOLINK)
-- $(CP) ../lib/$(DSONAME) $(DESTDIR)$(libdir)
-+ $(BSD_INSTALL_DATA) ../lib/$(DSONAME) $(DESTDIR)$(libdir)
- $(LN) -s $(DSONAME) $(DESTDIR)$(libdir)/$(DSOLINK)
- endif
- ifeq ($(DSONAME), fltk2_images.dll)
diff --git a/x11-toolkits/fltk2/files/patch-makeinclude.in b/x11-toolkits/fltk2/files/patch-makeinclude.in
deleted file mode 100644
index b2a46bb32e21..000000000000
--- a/x11-toolkits/fltk2/files/patch-makeinclude.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./makeinclude.in.orig Tue Apr 11 00:06:06 2006
-+++ ./makeinclude.in Fri Apr 14 15:42:25 2006
-@@ -49,11 +49,11 @@
-
- # compiler names:
- CC = @CC@
--CXX = @CXX@
-+CXX = %%CXX%%
- MAKEDEPEND = @MAKEDEPEND@
-
- # flags for C++ compiler:
--OPTIM = @OPTIM@
-+OPTIM =
- CFLAGS = $(OPTIM) @CFLAGS@
- CXXFLAGS = $(OPTIM) @CXXFLAGS@
-
diff --git a/x11-toolkits/fltk2/files/patch-src-Makefile b/x11-toolkits/fltk2/files/patch-src-Makefile
deleted file mode 100644
index f51008a859a8..000000000000
--- a/x11-toolkits/fltk2/files/patch-src-Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
---- src/Makefile.orig Sun Jun 24 17:08:53 2007
-+++ src/Makefile Sun Jun 24 17:10:34 2007
-@@ -251,37 +251,27 @@
- mkdir $(DESTDIR); \
- fi \
- fi
--
-- $(RMDIR) $(DESTDIR)$(includedir)/fltk
- $(MKDIR) $(DESTDIR)$(includedir)/fltk
-- $(CP) ../fltk/*.h ../fltk/*.r $(DESTDIR)$(includedir)/fltk
-- $(CHMOD) 755 $(DESTDIR)$(includedir)/fltk
-- $(CHMOD) 644 $(DESTDIR)$(includedir)/fltk/*
-+ $(BSD_INSTALL_DATA) ../fltk/*.h ../fltk/*.r $(DESTDIR)$(includedir)/fltk
- echo "Installing FLTK1.1 emulation include files in $(includedir)/fltk..."
-- $(RMDIR) $(DESTDIR)$(includedir)/fltk/compat/FL
- $(MKDIR) $(DESTDIR)$(includedir)/fltk/compat/FL
-- $(CP) ../fltk/compat/FL/*.H ../fltk/compat/FL/*.h $(DESTDIR)$(includedir)/fltk/compat/FL
-- $(CHMOD) 755 $(DESTDIR)$(includedir)/fltk/compat/FL
-- $(CHMOD) 644 $(DESTDIR)$(includedir)/fltk/compat/FL/*
-+ $(BSD_INSTALL_DATA) ../fltk/compat/FL/*.H ../fltk/compat/FL/*.h $(DESTDIR)$(includedir)/fltk/compat/FL
- ifneq (,$(wildcard ../fltk2-config))
- echo "Installing fltk2-config in $(bindir)..."
- $(MKDIR) $(DESTDIR)$(bindir)
-- $(CP) ../fltk2-config $(DESTDIR)$(bindir)
-- $(CHMOD) 755 $(DESTDIR)$(bindir)/fltk2-config
-+ $(BSD_INSTALL_SCRIPT) ../fltk2-config $(DESTDIR)$(bindir)
- endif
- ifneq (,$(wildcard ../lib/$(LIBNAME)))
- echo "Installing static core library in $(libdir)"
- $(MKDIR) $(DESTDIR)$(libdir)
-- $(RM) $(DESTDIR)$(libdir)/$(LIBNAME)
-- $(CP) ../lib/$(LIBNAME) $(DESTDIR)$(libdir)
-+ $(BSD_INSTALL_DATA) ../lib/$(LIBNAME) $(DESTDIR)$(libdir)
- $(RANLIB) $(DESTDIR)$(libdir)/$(LIBNAME)
- endif
- ifneq (,$(wildcard ../lib/$(DSONAME)))
- echo "Installing shared core library in $(libdir)"
- $(MKDIR) $(DESTDIR)$(libdir)
-- $(RM) $(DESTDIR)$(libdir)/$(DSONAME)
- $(RM) $(DESTDIR)$(libdir)/$(DSOLINK)
-- $(CP) ../lib/$(DSONAME) $(DESTDIR)$(libdir)
-+ $(BSD_INSTALL_DATA) ../lib/$(DSONAME) $(DESTDIR)$(libdir)
- $(LN) $(DSONAME) $(DESTDIR)$(libdir)/$(DSOLINK)
- endif
- ifeq ($(DSONAME), fltk.dll)
diff --git a/x11-toolkits/fltk2/pkg-descr b/x11-toolkits/fltk2/pkg-descr
deleted file mode 100644
index ad842a6f1efb..000000000000
--- a/x11-toolkits/fltk2/pkg-descr
+++ /dev/null
@@ -1,8 +0,0 @@
-FLTK is a cross-plattform C++ graphical user interface toolkit for X, OpenGL
-and Microsoft Windows systems.
-
-It is provided under the terms of the GNU Library Public License, Version 2.
-
-This port supplies a snapshot of the current 2.0 development version.
-
-WWW: http://www.fltk.org/
diff --git a/x11-toolkits/fltk2/pkg-plist b/x11-toolkits/fltk2/pkg-plist
deleted file mode 100644
index 9e6f0aa4697e..000000000000
--- a/x11-toolkits/fltk2/pkg-plist
+++ /dev/null
@@ -1,200 +0,0 @@
-@comment $FreeBSD$
-bin/fltk2-config
-bin/fluid2
-include/fltk/compat/FL/Enumerations.H
-include/fltk/compat/FL/Fl.H
-include/fltk/compat/FL/Fl_Adjuster.H
-include/fltk/compat/FL/Fl_Box.H
-include/fltk/compat/FL/Fl_Browser.H
-include/fltk/compat/FL/Fl_Button.H
-include/fltk/compat/FL/Fl_Chart.H
-include/fltk/compat/FL/Fl_Check_Button.H
-include/fltk/compat/FL/Fl_Choice.H
-include/fltk/compat/FL/Fl_Clock.H
-include/fltk/compat/FL/Fl_Color_Chooser.H
-include/fltk/compat/FL/Fl_Counter.H
-include/fltk/compat/FL/Fl_Dial.H
-include/fltk/compat/FL/Fl_Double_Window.H
-include/fltk/compat/FL/Fl_File_Chooser.H
-include/fltk/compat/FL/Fl_Gl_Window.H
-include/fltk/compat/FL/Fl_Group.H
-include/fltk/compat/FL/Fl_Hold_Browser.H
-include/fltk/compat/FL/Fl_Hor_Slider.H
-include/fltk/compat/FL/Fl_Hor_Value_Slider.H
-include/fltk/compat/FL/Fl_Input.H
-include/fltk/compat/FL/Fl_Int_Input.H
-include/fltk/compat/FL/Fl_Light_Button.H
-include/fltk/compat/FL/Fl_Menu_.H
-include/fltk/compat/FL/Fl_Menu_Bar.H
-include/fltk/compat/FL/Fl_Menu_Button.H
-include/fltk/compat/FL/Fl_Menu_Item.H
-include/fltk/compat/FL/Fl_Output.H
-include/fltk/compat/FL/Fl_Overlay_Window.H
-include/fltk/compat/FL/Fl_Pack.H
-include/fltk/compat/FL/Fl_Pixmap.H
-include/fltk/compat/FL/Fl_Return_Button.H
-include/fltk/compat/FL/Fl_Roller.H
-include/fltk/compat/FL/Fl_Scroll.H
-include/fltk/compat/FL/Fl_Scrollbar.H
-include/fltk/compat/FL/Fl_Shared_Image.H
-include/fltk/compat/FL/Fl_Select_Browser.H
-include/fltk/compat/FL/Fl_Single_Window.H
-include/fltk/compat/FL/Fl_Slider.H
-include/fltk/compat/FL/Fl_Tabs.H
-include/fltk/compat/FL/Fl_Text_Buffer.H
-include/fltk/compat/FL/Fl_Text_Editor.H
-include/fltk/compat/FL/Fl_Tile.H
-include/fltk/compat/FL/Fl_Toggle_Button.H
-include/fltk/compat/FL/Fl_Toggle_Light_Button.H
-include/fltk/compat/FL/Fl_Valuator.H
-include/fltk/compat/FL/Fl_Value_Input.H
-include/fltk/compat/FL/Fl_Value_Output.H
-include/fltk/compat/FL/Fl_Value_Slider.H
-include/fltk/compat/FL/Fl_Widget.H
-include/fltk/compat/FL/Fl_Window.H
-include/fltk/compat/FL/filename.H
-include/fltk/compat/FL/fl_ask.H
-include/fltk/compat/FL/fl_draw.H
-include/fltk/compat/FL/fl_message.H
-include/fltk/compat/FL/forms.H
-include/fltk/compat/FL/gl.h
-include/fltk/compat/FL/glut.H
-include/fltk/compat/FL/math.h
-include/fltk/compat/FL/menubar.h
-include/fltk/compat/FL/x.H
-@dirrm include/fltk/compat/FL
-@dirrm include/fltk/compat
-include/fltk/Adjuster.h
-include/fltk/AlignGroup.h
-include/fltk/AnsiWidget.h
-include/fltk/BarGroup.h
-include/fltk/Box.h
-include/fltk/Browser.h
-include/fltk/Button.h
-include/fltk/CheckButton.h
-include/fltk/Choice.h
-include/fltk/Clock.h
-include/fltk/Color.h
-include/fltk/ColorChooser.h
-include/fltk/ComboBox.h
-include/fltk/Cursor.h
-include/fltk/CycleButton.h
-include/fltk/Dial.h
-include/fltk/Divider.h
-include/fltk/DoubleBufferWindow.h
-include/fltk/FL_API.h
-include/fltk/FL_VERSION.h
-include/fltk/FileBrowser.h
-include/fltk/FileChooser.h
-include/fltk/FileIcon.h
-include/fltk/FileInput.h
-include/fltk/FillDial.h
-include/fltk/FillSlider.h
-include/fltk/Flags.h
-include/fltk/FloatInput.h
-include/fltk/Font.h
-include/fltk/GlWindow.h
-include/fltk/Group.h
-include/fltk/HelpDialog.h
-include/fltk/HelpView.h
-include/fltk/HighlightButton.h
-include/fltk/Image.h
-include/fltk/Input.h
-include/fltk/InputBrowser.h
-include/fltk/IntInput.h
-include/fltk/InvisibleBox.h
-include/fltk/Item.h
-include/fltk/ItemGroup.h
-include/fltk/LabelType.h
-include/fltk/LightButton.h
-include/fltk/LineDial.h
-include/fltk/Menu.h
-include/fltk/MenuBar.h
-include/fltk/MenuBuild.h
-include/fltk/MenuWindow.h
-include/fltk/Monitor.h
-include/fltk/MultiBrowser.h
-include/fltk/MultiImage.h
-include/fltk/MultiLineInput.h
-include/fltk/MultiLineOutput.h
-include/fltk/NumericInput.h
-include/fltk/Output.h
-include/fltk/PackedGroup.h
-include/fltk/PixelType.h
-include/fltk/PopupMenu.h
-include/fltk/Preferences.h
-include/fltk/ProgressBar.h
-include/fltk/RadioButton.h
-include/fltk/RadioItem.h
-include/fltk/RadioLightButton.h
-include/fltk/Rectangle.h
-include/fltk/RepeatButton.h
-include/fltk/ReturnButton.h
-include/fltk/ScrollGroup.h
-include/fltk/Scrollbar.h
-include/fltk/SecretInput.h
-include/fltk/ShapedWindow.h
-include/fltk/SharedImage.h
-include/fltk/Slider.h
-include/fltk/StatusBarGroup.h
-include/fltk/StringList.h
-include/fltk/Style.h
-include/fltk/StyleSet.h
-include/fltk/Symbol.h
-include/fltk/SystemMenuBar.h
-include/fltk/TabGroup.h
-include/fltk/TextBuffer.h
-include/fltk/TextDisplay.h
-include/fltk/TextEditor.h
-include/fltk/Threads.h
-include/fltk/ThumbWheel.h
-include/fltk/TiledGroup.h
-include/fltk/TiledImage.h
-include/fltk/ToggleButton.h
-include/fltk/ToggleItem.h
-include/fltk/Tooltip.h
-include/fltk/Valuator.h
-include/fltk/ValueInput.h
-include/fltk/ValueOutput.h
-include/fltk/ValueSlider.h
-include/fltk/Widget.h
-include/fltk/WidgetAssociation.h
-include/fltk/Window.h
-include/fltk/WizardGroup.h
-include/fltk/WordwrapInput.h
-include/fltk/WordwrapOutput.h
-include/fltk/ask.h
-include/fltk/damage.h
-include/fltk/dirent.h
-include/fltk/draw.h
-include/fltk/error.h
-include/fltk/events.h
-include/fltk/file_chooser.h
-include/fltk/filename.h
-include/fltk/fltk_cairo.h
-include/fltk/forms.h
-include/fltk/gl.h
-include/fltk/gl2opengl.h
-include/fltk/glut.h
-include/fltk/layout.h
-include/fltk/load_plugin.h
-include/fltk/mac.r
-include/fltk/math.h
-include/fltk/osx.h
-include/fltk/pnmImage.h
-include/fltk/rgbImage.h
-include/fltk/run.h
-include/fltk/show_colormap.h
-include/fltk/string.h
-include/fltk/utf.h
-include/fltk/visual.h
-include/fltk/win32.h
-include/fltk/x.h
-include/fltk/x11.h
-include/fltk/xbmImage.h
-include/fltk/xpmImage.h
-@dirrm include/fltk
-lib/libfltk2.a
-lib/libfltk2_gl.a
-lib/libfltk2_glut.a
-lib/libfltk2_images.a