aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-11-08 07:28:39 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-11-08 07:28:39 +0000
commit31a8351b98bb6c70ae0786f55eea4b624d6bbce6 (patch)
treee9db7b6806918ebd3b748aa79f4a20364f5be362 /x11-toolkits
parent3bbf3779bf14229965d330a9f5a23f8c7669fca3 (diff)
downloadports-31a8351b98bb6c70ae0786f55eea4b624d6bbce6.tar.gz
ports-31a8351b98bb6c70ae0786f55eea4b624d6bbce6.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/wxgtk26-unicode/Makefile1
-rw-r--r--x11-toolkits/wxgtk26/Makefile1
-rw-r--r--x11-toolkits/wxgtk26/files/patch-src-common-intl.cpp23
-rw-r--r--x11-toolkits/wxgtk28-unicode/Makefile1
-rw-r--r--x11-toolkits/wxgtk28/Makefile1
-rw-r--r--x11-toolkits/wxgtk28/files/patch-src-common-intl.cpp23
-rw-r--r--x11-toolkits/wxgtk29-unicode/Makefile1
-rw-r--r--x11-toolkits/wxgtk29/Makefile1
-rw-r--r--x11-toolkits/wxgtk29/files/patch-src-common-intl.cpp23
9 files changed, 75 insertions, 0 deletions
diff --git a/x11-toolkits/wxgtk26-unicode/Makefile b/x11-toolkits/wxgtk26-unicode/Makefile
index 049949a2ab60..82ce75a41e8c 100644
--- a/x11-toolkits/wxgtk26-unicode/Makefile
+++ b/x11-toolkits/wxgtk26-unicode/Makefile
@@ -5,6 +5,7 @@
# $FreeBSD$
#
+PORTREVISION= 1
MAINTAINER= fjoe@FreeBSD.org
COMMENT= The wxWidgets GUI toolkit (Unicode)
diff --git a/x11-toolkits/wxgtk26/Makefile b/x11-toolkits/wxgtk26/Makefile
index 074af7a1ec6a..04c248ba60dc 100644
--- a/x11-toolkits/wxgtk26/Makefile
+++ b/x11-toolkits/wxgtk26/Makefile
@@ -50,6 +50,7 @@ PLIST= ${.CURDIR}/pkg-plist
WXGTK_FLAVOR?= gtk2
.if ${WXGTK_FLAVOR} == "gtk2"
+PORTREVISION= 1
CONFLICTS= wxgtk2-contrib-devel-2.5.2*
.endif
diff --git a/x11-toolkits/wxgtk26/files/patch-src-common-intl.cpp b/x11-toolkits/wxgtk26/files/patch-src-common-intl.cpp
new file mode 100644
index 000000000000..12488d2b710e
--- /dev/null
+++ b/x11-toolkits/wxgtk26/files/patch-src-common-intl.cpp
@@ -0,0 +1,23 @@
+===================================================================
+RCS file: /pack/cvsroots/wxwidgets/wxWidgets/src/common/intl.cpp,v
+retrieving revision 1.166
+retrieving revision 1.166.2.1
+diff -u -r1.166 -r1.166.2.1
+--- src/common/intl.cpp 2005/09/18 23:38:06 1.166
++++ src/common/intl.cpp 2005/09/28 09:48:03 1.166.2.1
+@@ -1260,9 +1260,14 @@
+ inputConv =
+ csConv = new wxCSConv(m_charset);
+ }
+- else // no conversion needed
++ else // no need to convert the encoding
+ {
++ // we still need the conversion for Unicode build
++#if wxUSE_UNICODE
++ inputConv = wxConvCurrent;
++#else // !wxUSE_UNICODE
+ inputConv = NULL;
++#endif
+ }
+
+ // conversion to apply to msgid strings before looking them up: we only
diff --git a/x11-toolkits/wxgtk28-unicode/Makefile b/x11-toolkits/wxgtk28-unicode/Makefile
index 049949a2ab60..82ce75a41e8c 100644
--- a/x11-toolkits/wxgtk28-unicode/Makefile
+++ b/x11-toolkits/wxgtk28-unicode/Makefile
@@ -5,6 +5,7 @@
# $FreeBSD$
#
+PORTREVISION= 1
MAINTAINER= fjoe@FreeBSD.org
COMMENT= The wxWidgets GUI toolkit (Unicode)
diff --git a/x11-toolkits/wxgtk28/Makefile b/x11-toolkits/wxgtk28/Makefile
index 074af7a1ec6a..04c248ba60dc 100644
--- a/x11-toolkits/wxgtk28/Makefile
+++ b/x11-toolkits/wxgtk28/Makefile
@@ -50,6 +50,7 @@ PLIST= ${.CURDIR}/pkg-plist
WXGTK_FLAVOR?= gtk2
.if ${WXGTK_FLAVOR} == "gtk2"
+PORTREVISION= 1
CONFLICTS= wxgtk2-contrib-devel-2.5.2*
.endif
diff --git a/x11-toolkits/wxgtk28/files/patch-src-common-intl.cpp b/x11-toolkits/wxgtk28/files/patch-src-common-intl.cpp
new file mode 100644
index 000000000000..12488d2b710e
--- /dev/null
+++ b/x11-toolkits/wxgtk28/files/patch-src-common-intl.cpp
@@ -0,0 +1,23 @@
+===================================================================
+RCS file: /pack/cvsroots/wxwidgets/wxWidgets/src/common/intl.cpp,v
+retrieving revision 1.166
+retrieving revision 1.166.2.1
+diff -u -r1.166 -r1.166.2.1
+--- src/common/intl.cpp 2005/09/18 23:38:06 1.166
++++ src/common/intl.cpp 2005/09/28 09:48:03 1.166.2.1
+@@ -1260,9 +1260,14 @@
+ inputConv =
+ csConv = new wxCSConv(m_charset);
+ }
+- else // no conversion needed
++ else // no need to convert the encoding
+ {
++ // we still need the conversion for Unicode build
++#if wxUSE_UNICODE
++ inputConv = wxConvCurrent;
++#else // !wxUSE_UNICODE
+ inputConv = NULL;
++#endif
+ }
+
+ // conversion to apply to msgid strings before looking them up: we only
diff --git a/x11-toolkits/wxgtk29-unicode/Makefile b/x11-toolkits/wxgtk29-unicode/Makefile
index 049949a2ab60..82ce75a41e8c 100644
--- a/x11-toolkits/wxgtk29-unicode/Makefile
+++ b/x11-toolkits/wxgtk29-unicode/Makefile
@@ -5,6 +5,7 @@
# $FreeBSD$
#
+PORTREVISION= 1
MAINTAINER= fjoe@FreeBSD.org
COMMENT= The wxWidgets GUI toolkit (Unicode)
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
index 074af7a1ec6a..04c248ba60dc 100644
--- a/x11-toolkits/wxgtk29/Makefile
+++ b/x11-toolkits/wxgtk29/Makefile
@@ -50,6 +50,7 @@ PLIST= ${.CURDIR}/pkg-plist
WXGTK_FLAVOR?= gtk2
.if ${WXGTK_FLAVOR} == "gtk2"
+PORTREVISION= 1
CONFLICTS= wxgtk2-contrib-devel-2.5.2*
.endif
diff --git a/x11-toolkits/wxgtk29/files/patch-src-common-intl.cpp b/x11-toolkits/wxgtk29/files/patch-src-common-intl.cpp
new file mode 100644
index 000000000000..12488d2b710e
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-src-common-intl.cpp
@@ -0,0 +1,23 @@
+===================================================================
+RCS file: /pack/cvsroots/wxwidgets/wxWidgets/src/common/intl.cpp,v
+retrieving revision 1.166
+retrieving revision 1.166.2.1
+diff -u -r1.166 -r1.166.2.1
+--- src/common/intl.cpp 2005/09/18 23:38:06 1.166
++++ src/common/intl.cpp 2005/09/28 09:48:03 1.166.2.1
+@@ -1260,9 +1260,14 @@
+ inputConv =
+ csConv = new wxCSConv(m_charset);
+ }
+- else // no conversion needed
++ else // no need to convert the encoding
+ {
++ // we still need the conversion for Unicode build
++#if wxUSE_UNICODE
++ inputConv = wxConvCurrent;
++#else // !wxUSE_UNICODE
+ inputConv = NULL;
++#endif
+ }
+
+ // conversion to apply to msgid strings before looking them up: we only