aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2011-12-03 18:51:57 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2011-12-03 18:51:57 +0000
commit37a9bb6057862d15b6bc44dd282bf1b2a9fa0b44 (patch)
tree4598ae04356b07489cb1c564296514c4135d4260 /x11-toolkits
parentcda6b3488f6aa5a786ca69eb88dfb4e8e939ba4e (diff)
downloadports-37a9bb6057862d15b6bc44dd282bf1b2a9fa0b44.tar.gz
ports-37a9bb6057862d15b6bc44dd282bf1b2a9fa0b44.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fltk2/Makefile49
-rw-r--r--x11-toolkits/fltk2/distinfo4
-rw-r--r--x11-toolkits/fltk2/files/patch-images-fl_png.cxx11
3 files changed, 33 insertions, 31 deletions
diff --git a/x11-toolkits/fltk2/Makefile b/x11-toolkits/fltk2/Makefile
index 79fa6cf4f8af..b7f7fb26879e 100644
--- a/x11-toolkits/fltk2/Makefile
+++ b/x11-toolkits/fltk2/Makefile
@@ -10,11 +10,17 @@ PORTVERSION= 2.0.${SNAPSHOT}
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_EASYSW}
MASTER_SITE_SUBDIR= fltk/snapshots
-DISTNAME= fltk-2.0.x-${SNAPSHOT}
+DISTNAME= fltk-2.0.x-alpha-${SNAPSHOT}
-MAINTAINER= tmseck@web.de
+MAINTAINER= ports@freebsd.org
COMMENT= Fast Light Toolkit version 2 (development snapshot)
+LICENSE= FLTK
+LICENSE_GROUPS= GPL
+LICENSE_NAME= FLTK License
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
# XXX:
# FLTK2's configure script tries to find out whether the running X server
# supports overlay visuals; this is a bit difficult to find out if you
@@ -28,7 +34,7 @@ BUILD_DEPENDS= xprop:${PORTSDIR}/x11/xprop
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
-SNAPSHOT= r7725
+SNAPSHOT= r9166
OPTIONS= FLTK_THREADS "Install with threads support" on \
FLTK_CAIRO "Use cairo as graphics backend" off \
@@ -44,12 +50,6 @@ USE_GL= yes
USE_XORG= xcursor xft xi
GNU_CONFIGURE= yes
-LICENSE= FLTK
-LICENSE_FILE= ${WRKSRC}/COPYING
-LICENSE_GROUPS= GPL
-LICENSE_NAME= FLTK License
-LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -84,15 +84,28 @@ CONFIGURE_ARGS+= --disable-cairo
.endif
.if defined(WITH_FLTK_EXAMPLES) && !defined (NOPORTEXAMPLES)
-example_apps= ansiwidget arc bitmap boxtype browser button buttons cairo \
- checkers clock color_chooser cube CubeView cursor curve \
- demo doublebuffer drawing drawtiming editor exception \
- file_chooser fonts fractals fullscreen gl_overlay glpuzzle \
- hello image inactive input keyboard label line_style list \
- list_visuals mandelbrot menu message monitors navigation \
- output pack pixmap progress qubix radio resizable resizealign \
- scroll shape sizes symbols tabs threads tile timer \
- utf valuators wizard
+example_apps= ansiwidget arc \
+ bitmap boxtype browser button buttons \
+ cairo callbacks checkers clock color_chooser cube \
+ CubeView cursor curve \
+ demo doublebuffer drawing drawtiming \
+ editor exception \
+ file_chooser fonts fractals fullscreen \
+ gl_overlay glpuzzle \
+ hello \
+ image image_transform inactive input \
+ keyboard \
+ label line_style list list_visuals \
+ mandelbrot menu message monitors \
+ navigation \
+ output \
+ pack pixmap progress \
+ qubix \
+ radio resizable resizealign \
+ scroll shape sizes subwindow symbols \
+ tabs threads tile timer \
+ utf \
+ valuators wizard
example_data= demo.menu
example_img= images/ulon.bmp
PORTEXAMPLES= *
diff --git a/x11-toolkits/fltk2/distinfo b/x11-toolkits/fltk2/distinfo
index 24b9c404e0ec..2b6614bbe32c 100644
--- a/x11-toolkits/fltk2/distinfo
+++ b/x11-toolkits/fltk2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fltk-2.0.x-r7725.tar.bz2) = 45a064cb882b7c84026722936c92d0b689f686159a55f68662b3b3080ac37a66
-SIZE (fltk-2.0.x-r7725.tar.bz2) = 2529067
+SHA256 (fltk-2.0.x-alpha-r9166.tar.bz2) = e68c3ef3599c3e215db4011c3e68f61b155e7c05e2f220c188f14adb0a8d604b
+SIZE (fltk-2.0.x-alpha-r9166.tar.bz2) = 2656645
diff --git a/x11-toolkits/fltk2/files/patch-images-fl_png.cxx b/x11-toolkits/fltk2/files/patch-images-fl_png.cxx
deleted file mode 100644
index 0648912434b9..000000000000
--- a/x11-toolkits/fltk2/files/patch-images-fl_png.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- images/fl_png.cxx.orig 2007-04-16 16:48:06.000000000 +0200
-+++ images/fl_png.cxx 2010-03-29 19:55:26.000000000 +0200
-@@ -62,7 +62,7 @@
- #if !HAVE_LIBPNG
- return 0;
- #else
-- return png_check_sig((png_byte*)datas, (int)size)!=0;
-+ return !png_sig_cmp((png_byte*)datas, 0, (int)size)!=0;
- #endif
- }
-