aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-13 10:31:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-13 10:31:41 +0000
commit53d691d7463a76c6887113cdbfc3898329bbe099 (patch)
tree6e6e27bd89cef7fd5f30a16b8b5cbba08bdcf56a /x11-toolkits
parent9f8b0662a2a748e967615cd23b0d0f9675a41665 (diff)
downloadports-53d691d7463a76c6887113cdbfc3898329bbe099.tar.gz
ports-53d691d7463a76c6887113cdbfc3898329bbe099.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/tk84/Makefile26
-rw-r--r--x11-toolkits/tk84/files/patch-ab27
-rw-r--r--x11-toolkits/tk84/pkg-plist4
3 files changed, 36 insertions, 21 deletions
diff --git a/x11-toolkits/tk84/Makefile b/x11-toolkits/tk84/Makefile
index bb756817daac..7d5260548d28 100644
--- a/x11-toolkits/tk84/Makefile
+++ b/x11-toolkits/tk84/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tk
PORTVERSION= 8.4.14
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 2
CATEGORIES= x11-toolkits tk84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -69,7 +69,14 @@ CONFLICTS= tk-threads-8.4*
RUN_DEPENDS+= wish:${PORTSDIR}/lang/tcl-tk-wrapper
.endif
-.if !defined(NO_INSTALL_MANPAGES) && !defined(WITHOUT_TK84_MAN)
+.if defined(NO_INSTALL_MANPAGES) || !defined(WITH_TK84_MAN)
+
+PLIST_SUB+= INSTMAN='@comment '
+
+.else
+
+DATADIR= ${PREFIX}/share/${PORTNAME}${TCL_VER}
+PLIST_SUB+= INSTMAN=''
MAN1= wish.1
MAN3= 3DBorder.3 AddOption.3 BindTable.3 CanvPsY.3 CanvTkwin.3 \
@@ -382,24 +389,23 @@ pre-everything::
pre-configure:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
-.for mp in ${MAN1} ${MAN3} ${MANN}
- @${REINPLACE_CMD} -e 's|^.so man.macros|.so ${DATADIR}/man.macros|' \
- ${WRKSRC}/../doc/${mp}
-.endfor
post-configure:
${REINPLACE_CMD} \
-e 's|${WRKDIRPREFIX}${.CURDIR}|$${WRKDIRPREFIX}${TKBASE}|' \
${WRKSRC}/tkConfig.sh
-.if defined(NO_INSTALL_MANPAGES) || defined(WITHOUT_TK84_MAN)
- ${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
- ${WRKSRC}/Makefile
-.endif
post-install:
${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/tk${TK_VER}/
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/../doc/man.macros ${DATADIR}
+.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TK84_MAN)
+.for mp in ${MAN1} ${MAN3} ${MANN}
+ @${REINPLACE_CMD} -e 's|^.so man.macros|.so ${DATADIR}/man.macros|' \
+ ${WRKSRC}/../doc/${mp}
+.endfor
+ @cd ${WRKSRC} && ${MAKE} install-doc ${MAKE_ENV}
+.endif
regression-test: build
cd ${WRKSRC}; ${MAKE} test
diff --git a/x11-toolkits/tk84/files/patch-ab b/x11-toolkits/tk84/files/patch-ab
index ddbdc1702d37..ea781cd6c152 100644
--- a/x11-toolkits/tk84/files/patch-ab
+++ b/x11-toolkits/tk84/files/patch-ab
@@ -1,6 +1,6 @@
---- Makefile.in.orig Wed Apr 19 14:29:37 2006
-+++ Makefile.in Sun Jun 4 22:40:52 2006
-@@ -63,6 +63,8 @@
+--- Makefile.in.orig Thu Oct 19 19:27:34 2006
++++ Makefile.in Mon Mar 12 18:18:40 2007
+@@ -64,6 +64,8 @@
# Directory in which to install the include file tk.h:
INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
@@ -9,7 +9,7 @@
# Path to the private tk header dir:
PRIVATE_INCLUDE_DIR = @PRIVATE_INCLUDE_DIR@
-@@ -93,7 +95,7 @@
+@@ -94,7 +96,7 @@
# The directory containing the Tcl sources and headers appropriate
# for this version of Tk ("srcdir" will be replaced or has already
# been replaced by the configure script):
@@ -18,7 +18,7 @@
# The directory containing the Tcl library archive file appropriate
# for this version of Tk:
-@@ -129,7 +131,7 @@
+@@ -130,7 +132,7 @@
#CFLAGS = $(CFLAGS_DEBUG)
#CFLAGS = $(CFLAGS_OPTIMIZE)
#CFLAGS = $(CFLAGS_DEBUG) $(CFLAGS_OPTIMIZE)
@@ -27,7 +27,7 @@
# Flags to pass to the linker
LDFLAGS_DEBUG = @LDFLAGS_DEBUG@
-@@ -264,7 +266,7 @@
+@@ -265,7 +267,7 @@
STLIB_LD = @STLIB_LD@
SHLIB_LD = @SHLIB_LD@
SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
@@ -36,7 +36,7 @@
# Additional search flags needed to find the various shared libraries
# at run-time. The first symbol is for use when creating a binary
-@@ -476,6 +478,8 @@
+@@ -477,6 +479,8 @@
default.h ks_names.h tkPatch.h tk.h tkButton.h tkCanvas.h tkInt.h \
tkPort.h tkScrollbar.h tkText.h
@@ -45,7 +45,7 @@
DEMOPROGS = browse hello ixset rmt rolodex square tcolor timer widget
all: binaries libraries doc
-@@ -495,6 +499,12 @@
+@@ -496,6 +500,12 @@
${LIB_FILE}: ${OBJS} ${STUB_LIB_FILE} @LIB_RSRC_FILE@
rm -f $@
@MAKE_LIB@
@@ -58,7 +58,16 @@
${STUB_LIB_FILE}: ${STUB_LIB_OBJS}
rm -f $@
-@@ -613,7 +623,8 @@
+@@ -601,7 +611,7 @@
+ gdb ./wish --command=gdb.run
+ rm gdb.run
+
+-INSTALL_TARGETS = install-binaries install-libraries install-demos install-doc @EXTRA_INSTALL@
++INSTALL_TARGETS = install-binaries install-libraries install-demos @EXTRA_INSTALL@
+
+ install: $(INSTALL_TARGETS)
+
+@@ -614,7 +624,8 @@
# some ranlibs write to current directory, and this might not always be
# possible (e.g. if installing as root).
diff --git a/x11-toolkits/tk84/pkg-plist b/x11-toolkits/tk84/pkg-plist
index 2b5b10c43f5f..ad96bde1bf8b 100644
--- a/x11-toolkits/tk84/pkg-plist
+++ b/x11-toolkits/tk84/pkg-plist
@@ -159,8 +159,8 @@ lib/tk%%TK_VER%%/tkConfig.sh
lib/tk%%TK_VER%%/tkfbox.tcl
lib/tk%%TK_VER%%/unsupported.tcl
lib/tk%%TK_VER%%/xmfbox.tcl
-%%DATADIR%%/man.macros
-@dirrm %%DATADIR%%
+%%INSTMAN%%%%DATADIR%%/man.macros
+%%INSTMAN%%@dirrm %%DATADIR%%
@dirrm lib/tk%%TK_VER%%/demos/images
@dirrm lib/tk%%TK_VER%%/demos
@dirrm lib/tk%%TK_VER%%/images