aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-11 09:00:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-11 09:00:49 +0000
commit5736d4e84dbfc17d0680d23fdb7537cd1481f47f (patch)
tree515ae89920b412d39160ed12db6ffca56c3f5668 /x11-toolkits
parenta751740d85e3551b960df305bce70c78a89cf249 (diff)
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/py-AnyQt/Makefile19
-rw-r--r--x11-toolkits/py-AnyQt/distinfo3
-rw-r--r--x11-toolkits/py-AnyQt/pkg-descr13
4 files changed, 36 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index edff189e2e11..46c1be2af44a 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -199,6 +199,7 @@
SUBDIR += plib
SUBDIR += pure-gtk
SUBDIR += pure-tk
+ SUBDIR += py-AnyQt
SUBDIR += py-Pmw
SUBDIR += py-SquareMap
SUBDIR += py-fltk
diff --git a/x11-toolkits/py-AnyQt/Makefile b/x11-toolkits/py-AnyQt/Makefile
new file mode 100644
index 000000000000..a170eb4e17d8
--- /dev/null
+++ b/x11-toolkits/py-AnyQt/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= AnyQt
+DISTVERSION= 0.0.8
+CATEGORIES= x11-toolkits devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= PyQt4/PyQt5 compatibility layer
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= distutils autoplist
+xNO_BUILD= yes
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-AnyQt/distinfo b/x11-toolkits/py-AnyQt/distinfo
new file mode 100644
index 000000000000..ff62f87aaa7e
--- /dev/null
+++ b/x11-toolkits/py-AnyQt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1528707243
+SHA256 (AnyQt-0.0.8.tar.gz) = 7f1f71ce744e940fb49da0a302d972a9561c0844ab67df77091d631c6f2687b6
+SIZE (AnyQt-0.0.8.tar.gz) = 34328
diff --git a/x11-toolkits/py-AnyQt/pkg-descr b/x11-toolkits/py-AnyQt/pkg-descr
new file mode 100644
index 000000000000..2727fbc7e785
--- /dev/null
+++ b/x11-toolkits/py-AnyQt/pkg-descr
@@ -0,0 +1,13 @@
+PyQt4/PyQt5 compatibility layer.
+
+Features:
+* At the top level AnyQt exports a Qt5 compatible module namespace along with
+ some minimal renames to better support portability between different versions
+* Which Qt api/backend is chosen can be controlled by a QT_API env variable
+* The api can be chosen/forced programmatically (as long as no
+ PyQt4/PyQt5/PySide was already imported)
+* Provides an optional compatibility import hook, that denys imports from
+ conflicting Qt api, or intercepts and fakes a Qt4 api imports, to use a Qt5
+ compatible API (some monkey patching is involved).
+
+WWW: https://github.com/ales-erjavec/anyqt