aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-18 16:01:29 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-18 16:01:29 +0000
commit918ce346fac69e3dd87468cb6595de43f9f35b3d (patch)
tree79793132a8109ea5917de596a4613a4375f4350b /x11-toolkits
parent39c3073910e87b3077013946b861d4090a6a70eb (diff)
downloadports-918ce346fac69e3dd87468cb6595de43f9f35b3d.tar.gz
ports-918ce346fac69e3dd87468cb6595de43f9f35b3d.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-gtk/Makefile2
-rw-r--r--x11-toolkits/py-gtk/files/patch-..::ltmain.sh28
-rw-r--r--x11-toolkits/py-gtk/files/patch-configure13
-rw-r--r--x11-toolkits/py-gtk2/Makefile2
-rw-r--r--x11-toolkits/py-gtk2/files/patch-..::ltmain.sh28
-rw-r--r--x11-toolkits/py-gtk2/files/patch-configure13
6 files changed, 28 insertions, 58 deletions
diff --git a/x11-toolkits/py-gtk/Makefile b/x11-toolkits/py-gtk/Makefile
index ce731d55a1a4..25748c483290 100644
--- a/x11-toolkits/py-gtk/Makefile
+++ b/x11-toolkits/py-gtk/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= gnomelibs gdkpixbuf libglade
USE_PYTHON= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= PYTHON=${PYTHON_CMD}
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/x11-toolkits/py-gtk/files/patch-..::ltmain.sh b/x11-toolkits/py-gtk/files/patch-..::ltmain.sh
deleted file mode 100644
index 1af2b247a7af..000000000000
--- a/x11-toolkits/py-gtk/files/patch-..::ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ../ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ../ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/x11-toolkits/py-gtk/files/patch-configure b/x11-toolkits/py-gtk/files/patch-configure
new file mode 100644
index 000000000000..f91c22b56f99
--- /dev/null
+++ b/x11-toolkits/py-gtk/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/07/14 12:15:07 1.1
++++ configure 2002/07/14 12:15:18
+@@ -6321,6 +6321,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index ce731d55a1a4..25748c483290 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= gnomelibs gdkpixbuf libglade
USE_PYTHON= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ENV= PYTHON=${PYTHON_CMD}
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/x11-toolkits/py-gtk2/files/patch-..::ltmain.sh b/x11-toolkits/py-gtk2/files/patch-..::ltmain.sh
deleted file mode 100644
index 1af2b247a7af..000000000000
--- a/x11-toolkits/py-gtk2/files/patch-..::ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ../ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ../ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/x11-toolkits/py-gtk2/files/patch-configure b/x11-toolkits/py-gtk2/files/patch-configure
new file mode 100644
index 000000000000..f91c22b56f99
--- /dev/null
+++ b/x11-toolkits/py-gtk2/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure 2002/07/14 12:15:07 1.1
++++ configure 2002/07/14 12:15:18
+@@ -6321,6 +6321,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'