aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-04-16 06:42:34 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-04-16 06:42:34 +0000
commitfda9f74f4f60de1daf685a65add86f2e90cb78c6 (patch)
tree820258aba4b363ff653c3c24431d810331eb9012 /x11-toolkits
parent38516cd1663e3f44210e6ae270e32beffa79e7cf (diff)
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/vte/Makefile2
-rw-r--r--x11-toolkits/vte/files/patch-gnome-pty-helper_config.h.in12
-rw-r--r--x11-toolkits/vte/files/patch-gnome-pty-helper_configure11
-rw-r--r--x11-toolkits/vte/files/patch-gnome-pty-helper_gnome-utmp.c11
4 files changed, 35 insertions, 1 deletions
diff --git a/x11-toolkits/vte/Makefile b/x11-toolkits/vte/Makefile
index 3b1da46b071a..149251245e6d 100644
--- a/x11-toolkits/vte/Makefile
+++ b/x11-toolkits/vte/Makefile
@@ -8,7 +8,7 @@
PORTNAME= vte
PORTVERSION= 0.26.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/x11-toolkits/vte/files/patch-gnome-pty-helper_config.h.in b/x11-toolkits/vte/files/patch-gnome-pty-helper_config.h.in
new file mode 100644
index 000000000000..d07c7bce3919
--- /dev/null
+++ b/x11-toolkits/vte/files/patch-gnome-pty-helper_config.h.in
@@ -0,0 +1,12 @@
+--- gnome-pty-helper/config.h.in.orig 2012-03-24 17:31:26.000000000 -0400
++++ gnome-pty-helper/config.h.in 2012-03-24 17:31:43.000000000 -0400
+@@ -24,6 +24,9 @@
+ /* Define to 1 if you have the `getutmpx' function. */
+ #undef HAVE_GETUTMPX
+
++/* Define to 1 if you have the `getutxid' function. */
++#undef HAVE_GETUTXID
++
+ /* Define to 1 if you have the `grantpt' function. */
+ #undef HAVE_GRANTPT
+
diff --git a/x11-toolkits/vte/files/patch-gnome-pty-helper_configure b/x11-toolkits/vte/files/patch-gnome-pty-helper_configure
new file mode 100644
index 000000000000..737b74e59ca5
--- /dev/null
+++ b/x11-toolkits/vte/files/patch-gnome-pty-helper_configure
@@ -0,0 +1,11 @@
+--- gnome-pty-helper/configure.orig 2012-03-24 17:31:04.000000000 -0400
++++ gnome-pty-helper/configure 2012-03-24 17:31:21.000000000 -0400
+@@ -5699,7 +5699,7 @@ fi
+
+ fi
+
+-for ac_func in endutent fcntl forkpty getttyent getutent getutmpx grantpt flock login_tty openpty revoke sendmsg seteuid setreuid setutent strrchr updwtmp updwtmpx utmpname utmpxname
++for ac_func in endutent fcntl forkpty getttyent getutent getutmpx grantpt flock login_tty openpty revoke sendmsg seteuid setreuid setutent strrchr updwtmp updwtmpx utmpname utmpxname getutxid
+ do :
+ as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
diff --git a/x11-toolkits/vte/files/patch-gnome-pty-helper_gnome-utmp.c b/x11-toolkits/vte/files/patch-gnome-pty-helper_gnome-utmp.c
new file mode 100644
index 000000000000..fa2750ccd5ba
--- /dev/null
+++ b/x11-toolkits/vte/files/patch-gnome-pty-helper_gnome-utmp.c
@@ -0,0 +1,11 @@
+--- gnome-pty-helper/gnome-utmp.c.orig 2012-03-24 17:30:46.000000000 -0400
++++ gnome-pty-helper/gnome-utmp.c 2012-03-24 17:30:25.000000000 -0400
+@@ -152,7 +152,7 @@ update_wtmp (char *file, UTMP *putmp)
+ #endif /* !HAVE_GETUTMPX */
+
+
+-#if defined(HAVE_GETUTMPX)
++#if defined(HAVE_GETUTMPX) || defined(HAVE_GETUTXID)
+ static void
+ update_utmp (UTMP *ut)
+ {