aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-14 13:03:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-14 13:03:37 +0000
commit0469af19db41b26f305fbe80f81eebd977261369 (patch)
treec54399c7e2aa3dd43971b4a8512fcbccf45aacee /x11-toolkits
parent66dd74df466d6c8baf67cacd569485b8125f0e31 (diff)
downloadports-0469af19db41b26f305fbe80f81eebd977261369.tar.gz
ports-0469af19db41b26f305fbe80f81eebd977261369.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/freeglut/Makefile22
-rw-r--r--x11-toolkits/freeglut/distinfo2
-rw-r--r--x11-toolkits/freeglut/files/patch-progs::demos::CallbackMaker::CallbackMaker.c11
-rw-r--r--x11-toolkits/freeglut/files/patch-progs::demos::Fractals_random::fractals_random.c38
-rw-r--r--x11-toolkits/freeglut/files/patch-progs::demos::Lorenz::lorenz.c10
-rw-r--r--x11-toolkits/freeglut/files/patch-progs::demos::shapes::shapes.c11
-rw-r--r--x11-toolkits/freeglut/files/patch-src::Makefile.am31
-rw-r--r--x11-toolkits/freeglut/pkg-message10
-rw-r--r--x11-toolkits/freeglut/pkg-plist3
9 files changed, 107 insertions, 31 deletions
diff --git a/x11-toolkits/freeglut/Makefile b/x11-toolkits/freeglut/Makefile
index 6a4cc7190019..d4d5eb98189e 100644
--- a/x11-toolkits/freeglut/Makefile
+++ b/x11-toolkits/freeglut/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= freeglut
-PORTVERSION= 2.0.1
+PORTVERSION= 2.2.0
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,7 +20,9 @@ HAS_CONFIGURE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
USE_XLIB= yes
-CONFIGURE_ARGS= --x-includes=${X11BASE}/include --x-libraries=${X11BASE}/lib
+CONFIGURE_ARGS= --x-includes=${X11BASE}/include \
+ --x-libraries=${X11BASE}/lib \
+ --enable-replace-glut
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
ACLOCAL="${ACLOCAL}" \
AUTOCONF="${AUTOCONF}" \
@@ -30,20 +32,28 @@ CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
DOCS= download.html freeglut.html freeglut_logo.png \
freeglut_user_interface.html index.html ogl_sm.png \
progress.html structure.html
-BINS= Fractals Fractals_random Lorenz One
+BINS= CallbackMaker Fractals Fractals_random Lorenz One shapes
post-patch:
@${REINPLACE_CMD} -e "s|/usr/X11R6|${X11BASE}|g" \
-e "s|/usr/local|${LOCALBASE}|g" \
${WRKSRC}/aclocal.m4
.for fract in /fractals.c _random/fractals_random.c
- @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
+ @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
${WRKSRC}/progs/demos/Fractals${fract}
.endfor
+post-build:
+ @${MV} ${WRKSRC}/progs/demos/CallbackMaker/.libs/CallbackMaker \
+ ${WRKSRC}/progs/demos/CallbackMaker/.libs/callbackmaker
+ @${CAT} pkg-message | ${SED} 's|%%X11BASE%%|${X11BASE}| ; \
+ s|%%PREFIX%%|${PREFIX}|' > ${PKGMESSAGE}
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -54,8 +64,8 @@ post-install:
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/progs/demos/Fractals/fractals.dat \
${EXAMPLESDIR}
-.for FILE in ${BINS}
- @${INSTALL_PROGRAM} ${WRKSRC}/progs/demos/${FILE}/.libs/${FILE:L} \
+.for prog in ${BINS}
+ @${INSTALL_PROGRAM} ${WRKSRC}/progs/demos/${prog}/.libs/${prog:L} \
${EXAMPLESDIR}
.endfor
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
diff --git a/x11-toolkits/freeglut/distinfo b/x11-toolkits/freeglut/distinfo
index 8b5cd3a60f6d..718abf858fbb 100644
--- a/x11-toolkits/freeglut/distinfo
+++ b/x11-toolkits/freeglut/distinfo
@@ -1 +1 @@
-MD5 (freeglut-2.0.1.tar.gz) = da82607f76eb218539ee2265080b10ec
+MD5 (freeglut-2.2.0.tar.gz) = 9439b8745f443131c2dad00bc93dc0ef
diff --git a/x11-toolkits/freeglut/files/patch-progs::demos::CallbackMaker::CallbackMaker.c b/x11-toolkits/freeglut/files/patch-progs::demos::CallbackMaker::CallbackMaker.c
new file mode 100644
index 000000000000..bbe8f1761274
--- /dev/null
+++ b/x11-toolkits/freeglut/files/patch-progs::demos::CallbackMaker::CallbackMaker.c
@@ -0,0 +1,11 @@
+--- progs/demos/CallbackMaker/CallbackMaker.c.orig Mon Nov 10 17:01:05 2003
++++ progs/demos/CallbackMaker/CallbackMaker.c Sat Dec 13 14:43:35 2003
+@@ -4,7 +4,7 @@
+ */
+
+
+-#include <GL/freeglut.h>
++#include "../../../include/GL/freeglut.h"
+ #include <stdio.h>
+ #include <stdlib.h>
+
diff --git a/x11-toolkits/freeglut/files/patch-progs::demos::Fractals_random::fractals_random.c b/x11-toolkits/freeglut/files/patch-progs::demos::Fractals_random::fractals_random.c
index 6c57c49b571b..4d97f39f1720 100644
--- a/x11-toolkits/freeglut/files/patch-progs::demos::Fractals_random::fractals_random.c
+++ b/x11-toolkits/freeglut/files/patch-progs::demos::Fractals_random::fractals_random.c
@@ -1,20 +1,20 @@
---- progs/demos/Fractals_random/fractals_random.c.orig Tue Sep 23 07:17:13 2003
-+++ progs/demos/Fractals_random/fractals_random.c Sat Oct 4 02:43:15 2003
+--- progs/demos/Fractals_random/fractals_random.c.orig Thu Dec 11 02:32:08 2003
++++ progs/demos/Fractals_random/fractals_random.c Sat Dec 13 10:17:10 2003
@@ -20,7 +20,7 @@
- * Escape - quit
- */
-
--#include <GL/freeglut.h>
-+#include <../../../include/GL/freeglut.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <math.h>
-@@ -253,7 +253,7 @@
- if ( argc > 1 )
- readConfigFile ( argv[1] ) ;
- else
-- readConfigFile ( "fractals.dat" ) ;
-+ readConfigFile ( "/usr/local/share/examples/freeglut/fractals.dat" ) ;
-
- glutInit(&argc, argv);
- glutInitWindowSize(500, 250);
+ * Escape - quit
+ */
+
+-#include <GL/freeglut.h>
++#include "../../../include/GL/freeglut.h"
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <math.h>
+@@ -346,7 +346,7 @@
+ if ( argc > 1 )
+ readConfigFile ( argv[1] ) ;
+ else
+- readConfigFile ( "fractals.dat" ) ;
++ readConfigFile ( "/usr/local/share/examples/freeglut/fractals.dat" ) ;
+
+ fractal_window = glutCreateWindow( window_title );
+
diff --git a/x11-toolkits/freeglut/files/patch-progs::demos::Lorenz::lorenz.c b/x11-toolkits/freeglut/files/patch-progs::demos::Lorenz::lorenz.c
index 43c9adda3bec..16fbfb15078b 100644
--- a/x11-toolkits/freeglut/files/patch-progs::demos::Lorenz::lorenz.c
+++ b/x11-toolkits/freeglut/files/patch-progs::demos::Lorenz::lorenz.c
@@ -1,11 +1,11 @@
---- progs/demos/Lorenz/lorenz.c.orig Thu Jul 10 13:46:34 2003
-+++ progs/demos/Lorenz/lorenz.c Mon Sep 22 21:52:40 2003
+--- progs/demos/Lorenz/lorenz.c.orig Thu Dec 11 02:32:08 2003
++++ progs/demos/Lorenz/lorenz.c Sat Dec 13 10:19:26 2003
@@ -32,7 +32,7 @@
#include <string.h>
#include <math.h>
#include <time.h>
-#include <GL/freeglut.h>
+#include "../../../include/GL/freeglut.h"
-
-
- /************************************** Defined Constants ***************************************/
+ #ifdef WIN32
+ #include <crtdbg.h> // DUMP MEMORY LEAKS
+ #endif
diff --git a/x11-toolkits/freeglut/files/patch-progs::demos::shapes::shapes.c b/x11-toolkits/freeglut/files/patch-progs::demos::shapes::shapes.c
new file mode 100644
index 000000000000..596ee6c84b98
--- /dev/null
+++ b/x11-toolkits/freeglut/files/patch-progs::demos::shapes::shapes.c
@@ -0,0 +1,11 @@
+--- progs/demos/shapes/shapes.c.orig Sun Dec 7 11:12:22 2003
++++ progs/demos/shapes/shapes.c Sat Dec 13 14:51:38 2003
+@@ -12,7 +12,7 @@
+ * using the + and - keys.
+ */
+
+-#include <GL/freeglut.h>
++#include "../../../include/GL/freeglut.h"
+
+ #include <stdlib.h>
+
diff --git a/x11-toolkits/freeglut/files/patch-src::Makefile.am b/x11-toolkits/freeglut/files/patch-src::Makefile.am
new file mode 100644
index 000000000000..91705102960b
--- /dev/null
+++ b/x11-toolkits/freeglut/files/patch-src::Makefile.am
@@ -0,0 +1,31 @@
+--- src/Makefile.am.orig Thu Dec 11 02:32:09 2003
++++ src/Makefile.am Sat Dec 13 14:20:21 2003
+@@ -3,13 +3,13 @@
+ #
+ # The library we want to build
+ #
+-lib_LTLIBRARIES = lib@LIBRARY@.la
++lib_LTLIBRARIES = libglut.la
+
+ noinst_HEADERS = freeglut_internal.h
+ #
+ # Those source files build the freeglut library
+ #
+-lib@LIBRARY@_la_SOURCES = freeglut_callbacks.c \
++libglut_la_SOURCES = freeglut_callbacks.c \
+ freeglut_cursor.c \
+ freeglut_display.c \
+ freeglut_ext.c \
+@@ -35,9 +35,9 @@
+ #
+ # Additional linker flags
+ #
+-lib@LIBRARY@_la_LIBADD = $(LIBM) $(X_LIBS) -lGL -lGLU -lXext -lX11 $(LIBXXF86VM)
+-lib@LIBRARY@_la_LDFLAGS = -version-info 11:0:8
+-lib@LIBRARY@_la_CFLAGS = $(X_CFLAGS)
++libglut_la_LIBADD = $(LIBM) $(X_LIBS) -lGL -lGLU -lXext -lX11 $(LIBXXF86VM)
++libglut_la_LDFLAGS = -version-info 11:0:8
++libglut_la_CFLAGS = $(X_CFLAGS)
+
+ #
+ # End of file
diff --git a/x11-toolkits/freeglut/pkg-message b/x11-toolkits/freeglut/pkg-message
new file mode 100644
index 000000000000..d4009cb79482
--- /dev/null
+++ b/x11-toolkits/freeglut/pkg-message
@@ -0,0 +1,10 @@
+******************************************************************
+freeglut requires a DRI / OpenGL enabled-graphic card;
+You may try to run the sample programs to check your installation.
+
+Notice: freeglut is now a GLUT replacement.
+=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
+
+It has been installed into %%PREFIX%%/lib/
+and the original GLUT is installed under %%X11BASE%%/lib/
+******************************************************************
diff --git a/x11-toolkits/freeglut/pkg-plist b/x11-toolkits/freeglut/pkg-plist
index c27f90b0525c..9632aa3acec8 100644
--- a/x11-toolkits/freeglut/pkg-plist
+++ b/x11-toolkits/freeglut/pkg-plist
@@ -1,14 +1,17 @@
include/GL/freeglut.h
include/GL/freeglut_ext.h
+include/GL/freeglut_std.h
include/GL/glut.h
lib/libglut.a
lib/libglut.so
lib/libglut.so.11
+%%PORTDOCS%%%%EXAMPLESDIR%%/callbackmaker
%%PORTDOCS%%%%EXAMPLESDIR%%/fractals
%%PORTDOCS%%%%EXAMPLESDIR%%/fractals_random
%%PORTDOCS%%%%EXAMPLESDIR%%/fractals.dat
%%PORTDOCS%%%%EXAMPLESDIR%%/lorenz
%%PORTDOCS%%%%EXAMPLESDIR%%/one
+%%PORTDOCS%%%%EXAMPLESDIR%%/shapes
%%PORTDOCS%%%%DOCSDIR%%/download.html
%%PORTDOCS%%%%DOCSDIR%%/freeglut.html
%%PORTDOCS%%%%DOCSDIR%%/freeglut_logo.png