aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-04-22 02:35:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-04-22 02:35:38 +0000
commit8ae3562de170eb8e0a75e63e4b19ba3c00baea23 (patch)
treea88b63246ba7a03b059895f6280bd9573256f458 /x11-toolkits
parent6c1a505bfb26bf7c0cc4ead5cc68d97d8c5459f8 (diff)
downloadports-8ae3562de170eb8e0a75e63e4b19ba3c00baea23.tar.gz
ports-8ae3562de170eb8e0a75e63e4b19ba3c00baea23.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/mygui/Makefile13
-rw-r--r--x11-toolkits/mygui/distinfo4
-rw-r--r--x11-toolkits/mygui/files/patch-CMake__Packages__FindFreetype.cmake (renamed from x11-toolkits/mygui/files/patch-CMake-Packages-FindFreetype.cmake)4
-rw-r--r--x11-toolkits/mygui/files/patch-Common-FileSystemInfo-FileSystemInfo.h10
-rw-r--r--x11-toolkits/mygui/files/patch-Common__FileSystemInfo__FileSystemInfo.h10
-rw-r--r--x11-toolkits/mygui/pkg-plist3
6 files changed, 23 insertions, 21 deletions
diff --git a/x11-toolkits/mygui/Makefile b/x11-toolkits/mygui/Makefile
index 21ef33f0ca99..c911e535da49 100644
--- a/x11-toolkits/mygui/Makefile
+++ b/x11-toolkits/mygui/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mygui
-PORTVERSION= 3.2.0
-PORTREVISION= 3
+PORTVERSION= 3.2.0.git20140422
CATEGORIES= x11-toolkits graphics devel
MASTER_SITES= SF/my-gui/MyGUI/MyGUI_${PORTVERSION}
DISTNAME= MyGUI_${PORTVERSION}
@@ -15,13 +14,13 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
libOIS.so:${PORTSDIR}/devel/ois
-BROKEN= Does not compile with graphics/ogre3d 1.9.0
-
-USES= cmake pkgconfig zip
+USES= cmake pkgconfig zip dos2unix compiler:c++11-lib
CMAKE_ARGS= -DMYGUI_BUILD_DEMOS=OFF -DMYGUI_BUILD_DOCS=OFF
USE_LDCONFIG= yes
-USE_GCC= yes
-USE_DOS2UNIX= *.cpp *.h
+DOS2UNIX_GLOB= *.cpp *.h *.cmake
+
+USE_CXXSTD= c++11
+CXXFLAGS+= -fPIC
post-patch:
@${REINPLACE_CMD} -e '/install/ s|lib/pkgconfig|libdata/pkgconfig|' \
diff --git a/x11-toolkits/mygui/distinfo b/x11-toolkits/mygui/distinfo
index 2f3fe18b5ca6..6a0e835bd60f 100644
--- a/x11-toolkits/mygui/distinfo
+++ b/x11-toolkits/mygui/distinfo
@@ -1,2 +1,2 @@
-SHA256 (MyGUI_3.2.0.zip) = 1704006f364b733b2d2cc6807c6dc10833cf695542b797aee50b8fd061eea19a
-SIZE (MyGUI_3.2.0.zip) = 14383788
+SHA256 (MyGUI_3.2.0.git20140422.zip) = 56cefd283d70d4f48766ee5a34a3ddc1412d3247974cb9cfeb5f5494bea1ae98
+SIZE (MyGUI_3.2.0.git20140422.zip) = 23170181
diff --git a/x11-toolkits/mygui/files/patch-CMake-Packages-FindFreetype.cmake b/x11-toolkits/mygui/files/patch-CMake__Packages__FindFreetype.cmake
index c7ca37c928fb..216463ef2a26 100644
--- a/x11-toolkits/mygui/files/patch-CMake-Packages-FindFreetype.cmake
+++ b/x11-toolkits/mygui/files/patch-CMake__Packages__FindFreetype.cmake
@@ -1,5 +1,5 @@
---- CMake/Packages/FindFreetype.cmake.orig 2012-02-22 22:27:34.000000000 +0100
-+++ CMake/Packages/FindFreetype.cmake 2013-12-28 14:15:26.000000000 +0100
+--- CMake/Packages/FindFreetype.cmake.orig 2013-12-09 04:56:26.000000000 +0400
++++ CMake/Packages/FindFreetype.cmake 2014-04-22 05:18:05.042699865 +0400
@@ -33,7 +33,7 @@
findpkg_framework(FREETYPE)
message(STATUS "CMAKE_PREFIX_PATH: ${CMAKE_PREFIX_PATH}")
diff --git a/x11-toolkits/mygui/files/patch-Common-FileSystemInfo-FileSystemInfo.h b/x11-toolkits/mygui/files/patch-Common-FileSystemInfo-FileSystemInfo.h
deleted file mode 100644
index ac617bb6883b..000000000000
--- a/x11-toolkits/mygui/files/patch-Common-FileSystemInfo-FileSystemInfo.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- Common/FileSystemInfo/FileSystemInfo.h.orig 2012-02-22 22:28:12.000000000 +0400
-+++ Common/FileSystemInfo/FileSystemInfo.h 2012-07-16 22:55:36.977549896 +0400
-@@ -14,6 +14,7 @@
- #else
- #include <unistd.h>
- #include <dirent.h>
-+#include <sys/syslimits.h>
- #endif
-
- #include <string>
diff --git a/x11-toolkits/mygui/files/patch-Common__FileSystemInfo__FileSystemInfo.h b/x11-toolkits/mygui/files/patch-Common__FileSystemInfo__FileSystemInfo.h
new file mode 100644
index 000000000000..91346cb219fe
--- /dev/null
+++ b/x11-toolkits/mygui/files/patch-Common__FileSystemInfo__FileSystemInfo.h
@@ -0,0 +1,10 @@
+--- Common/FileSystemInfo/FileSystemInfo.h.orig 2014-04-22 06:12:03.384476313 +0400
++++ Common/FileSystemInfo/FileSystemInfo.h 2014-04-22 06:12:29.104475139 +0400
+@@ -14,6 +14,7 @@
+ #else
+ #include <unistd.h>
+ #include <dirent.h>
++#include <sys/syslimits.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
diff --git a/x11-toolkits/mygui/pkg-plist b/x11-toolkits/mygui/pkg-plist
index f80f05317c5e..44b512f52332 100644
--- a/x11-toolkits/mygui/pkg-plist
+++ b/x11-toolkits/mygui/pkg-plist
@@ -27,7 +27,9 @@ include/MYGUI/MyGUI_DDContainer.h
include/MYGUI/MyGUI_DDItemInfo.h
include/MYGUI/MyGUI_DataFileStream.h
include/MYGUI/MyGUI_DataManager.h
+include/MYGUI/MyGUI_DataMemoryStream.h
include/MYGUI/MyGUI_DataStream.h
+include/MYGUI/MyGUI_DataStreamHolder.h
include/MYGUI/MyGUI_Delegate.h
include/MYGUI/MyGUI_DelegateImplement.h
include/MYGUI/MyGUI_DeprecatedTypes.h
@@ -178,6 +180,7 @@ include/MYGUI/MyGUI_Window.h
include/MYGUI/MyGUI_XmlDocument.h
include/MYGUI/Plugin.h
include/MYGUI/StrangeButton.h
+lib/libEditorFramework.so
lib/libMyGUI.OgrePlatform.a
lib/libMyGUIEngine.so
lib/libMyGUIEngine.so.3