aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-04-04 09:53:12 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-04-04 09:53:12 +0000
commit9c0d74037cd7d9e74084678fb5a53a0fb6c7e374 (patch)
treeb9399ec3ba0c7cb63522a8f7460bbdc4eea87781 /x11-toolkits
parent69f7b9eebc293bad5d507b5094486089ece45d06 (diff)
downloadports-9c0d74037cd7d9e74084678fb5a53a0fb6c7e374.tar.gz
ports-9c0d74037cd7d9e74084678fb5a53a0fb6c7e374.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/pmw/Makefile3
-rw-r--r--x11-toolkits/py-Pmw/Makefile3
-rw-r--r--x11-toolkits/py-tkinter/Makefile39
-rw-r--r--x11-toolkits/py-tkinter/distinfo1
-rw-r--r--x11-toolkits/py-tkinter/files/Setup47
-rw-r--r--x11-toolkits/py-tkinter/pkg-comment1
-rw-r--r--x11-toolkits/py-tkinter/pkg-descr1
-rw-r--r--x11-toolkits/py-tkinter/pkg-plist1
9 files changed, 93 insertions, 4 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 107f7fec102d..6b6954ceebe0 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -29,6 +29,7 @@
SUBDIR += pmw
SUBDIR += py-gnome
SUBDIR += py-gtk
+ SUBDIR += py-tkinter
SUBDIR += py-wxPython
SUBDIR += qt-i18n
SUBDIR += qt145
diff --git a/x11-toolkits/pmw/Makefile b/x11-toolkits/pmw/Makefile
index e62156061f28..2c3bc10277ec 100644
--- a/x11-toolkits/pmw/Makefile
+++ b/x11-toolkits/pmw/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= ftp://ftp.dscpl.com.au/pub/pmw/
MAINTAINER= tg@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= ${SITEPYDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
PLIST_SUB= PMWVERSION="${PMWVERSION}"
diff --git a/x11-toolkits/py-Pmw/Makefile b/x11-toolkits/py-Pmw/Makefile
index e62156061f28..2c3bc10277ec 100644
--- a/x11-toolkits/py-Pmw/Makefile
+++ b/x11-toolkits/py-Pmw/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= ftp://ftp.dscpl.com.au/pub/pmw/
MAINTAINER= tg@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= ${SITEPYDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
PLIST_SUB= PMWVERSION="${PMWVERSION}"
diff --git a/x11-toolkits/py-tkinter/Makefile b/x11-toolkits/py-tkinter/Makefile
new file mode 100644
index 000000000000..8d38458dc6a2
--- /dev/null
+++ b/x11-toolkits/py-tkinter/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: py-Tkinter
+# Version required: 1.5.2
+# Date created: 12 Jan 1999
+# Whom: Thomas Gellekum <tg@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= py152
+PKGNAME= py-tkinter-1.5.2
+CATEGORIES= x11-toolkits python
+MASTER_SITES= ftp://www.python.org/pub/python/src/ \
+ ftp://ftp.cwi.nl/pub/python/src/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= tg@FreeBSD.org
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+DIST_SUBDIR= python
+WRKSRC= ${WRKDIR}/Python-1.5.2/Modules
+ALL_TARGET= sharedmods
+MAKE_FLAGS= OPT="${CFLAGS}"
+
+PYTHONSCRIPTDIR= ${PREFIX}/lib/python1.5
+
+post-extract:
+ @${CP} ${FILESDIR}/Setup ${WRKSRC}
+ @${CP} ${PYTHONSCRIPTDIR}/config/Makefile.pre.in ${WRKSRC}
+
+do-configure:
+ @(cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${MAKE} -f Makefile.pre.in boot)
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/_tkinter.so ${PYTHONSCRIPTDIR}/site-packages
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-tkinter/distinfo b/x11-toolkits/py-tkinter/distinfo
new file mode 100644
index 000000000000..72ca6a75cf6c
--- /dev/null
+++ b/x11-toolkits/py-tkinter/distinfo
@@ -0,0 +1 @@
+MD5 (python/py152.tgz) = e9d677ae6d5a3efc6937627ed8a3e752
diff --git a/x11-toolkits/py-tkinter/files/Setup b/x11-toolkits/py-tkinter/files/Setup
new file mode 100644
index 000000000000..d0c27c930ba2
--- /dev/null
+++ b/x11-toolkits/py-tkinter/files/Setup
@@ -0,0 +1,47 @@
+*shared*
+
+# The _tkinter module.
+#
+# The TKPATH variable is always enabled, to save you the effort.
+TKPATH=:lib-tk
+
+# The command for _tkinter is long and site specific. Please
+# uncomment and/or edit those parts as indicated. If you don't have a
+# specific extension (e.g. Tix or BLT), leave the corresponding line
+# commented out. (Leave the trailing backslashes in! If you
+# experience strange errors, you may want to join all uncommented
+# lines and remove the backslashes -- the backslash interpretation is
+# done by the shell's "read" command and it may not be implemented on
+# every system.
+
+# *** Always uncomment this (leave the leading underscore in!):
+_tkinter _tkinter.c tkappinit.c -DWITH_APPINIT -I${X11BASE}/include -I${PREFIX}/include/tcl8.2 -I${PREFIX}/include/tk8.2 -L${PREFIX}/lib -ltk82 -ltcl82 -L${X11BASE}/lib -lX11
+
+# *** Uncommend and edit to reflect where your X11 header files are:
+# -I/usr/X11R6/include \
+# *** Or uncomment this for Solaris:
+# -I/usr/openwin/include \
+# *** Uncomment and edit to reflect where your Tcl/Tk headers are:
+# -I/usr/local/include/tcl8.1 -I/usr/local/include/tk8.1 \
+# *** Uncomment and edit for Tix extension only:
+# -DWITH_TIX -ltix4.1.8.0 \
+# *** Uncomment and edit for BLT extension only:
+# -DWITH_BLT -I/usr/local/blt/blt8.0-unoff/include -lBLT8.0 \
+# *** Uncomment and edit for PIL (TkImaging) extension only:
+# -DWITH_PIL -I../Extensions/Imaging/libImaging tkImaging.c \
+# *** Uncomment and edit for Mesa (what's Mesa?):
+# -lGL -lGLU -lMesatk -lMesaaux \
+# *** Uncomment and edit for TOGL extension only:
+# -DWITH_TOGL togl.c \
+# *** Uncomment and edit to reflect where your Tcl/Tk libraries are:
+# -L/usr/local/lib \
+# *** Uncomment and edit to reflect your Tcl/Tk versions:
+# -ltk80 -ltcl80 \
+# *** Uncomment and edit to reflect where your X11 libraries are:
+# -L/usr/X11R6/lib \
+# *** Or uncomment this for Solaris:
+# -L/usr/openwin/lib \
+# *** Always uncomment this; X11 libraries to link with:
+# -lX11 -lXext -lXmu
+
+
diff --git a/x11-toolkits/py-tkinter/pkg-comment b/x11-toolkits/py-tkinter/pkg-comment
new file mode 100644
index 000000000000..2af2980ff94f
--- /dev/null
+++ b/x11-toolkits/py-tkinter/pkg-comment
@@ -0,0 +1 @@
+Python bindings to the Tk widget set.
diff --git a/x11-toolkits/py-tkinter/pkg-descr b/x11-toolkits/py-tkinter/pkg-descr
new file mode 100644
index 000000000000..2af2980ff94f
--- /dev/null
+++ b/x11-toolkits/py-tkinter/pkg-descr
@@ -0,0 +1 @@
+Python bindings to the Tk widget set.
diff --git a/x11-toolkits/py-tkinter/pkg-plist b/x11-toolkits/py-tkinter/pkg-plist
new file mode 100644
index 000000000000..b8deafa6c8f2
--- /dev/null
+++ b/x11-toolkits/py-tkinter/pkg-plist
@@ -0,0 +1 @@
+lib/python1.5/site-packages/_tkinter.so