aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-01-29 18:31:49 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-01-29 18:31:49 +0000
commit01cb4a76849d390b6c0fdaf64d6849a0876e9198 (patch)
treebf5e1a8f7d94f79c98f550f7eccb03b901dbf339 /x11-toolkits
parent1a107e04904356170f25ea80c299780f6b89ef0f (diff)
downloadports-01cb4a76849d390b6c0fdaf64d6849a0876e9198.tar.gz
ports-01cb4a76849d390b6c0fdaf64d6849a0876e9198.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-qt/Makefile14
-rw-r--r--x11-toolkits/py-qt/pkg-plist31
2 files changed, 38 insertions, 7 deletions
diff --git a/x11-toolkits/py-qt/Makefile b/x11-toolkits/py-qt/Makefile
index 99222f9313be..c70ab586fd8f 100644
--- a/x11-toolkits/py-qt/Makefile
+++ b/x11-toolkits/py-qt/Makefile
@@ -6,6 +6,7 @@
PORTNAME= qt
PORTVERSION= 3.10
+PORTREVISION= 1
CATEGORIES= x11-toolkits python
MASTER_SITES= http://www.river-bank.demon.co.uk/download/PyQt/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,15 +15,26 @@ DISTNAME= PyQt-x11-gpl-${PORTVERSION}
MAINTAINER= eugos@gmx.net
COMMENT= Python bindings for the Qt toolkit
+LIB_DEPENDS= qscintilla.3:${PORTSDIR}/x11-toolkits/qscintilla
BUILD_DEPENDS= ${LOCALBASE}/bin/sip:${PORTSDIR}/devel/py-sip
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_QT_VER= 3
USE_PYTHON= yes
+.include <bsd.port.pre.mk>
+
+WITH_GL!= ldd ${X11BASE}/lib/libqt-mt.so | ${GREP} 'libGL' || ${TRUE}
+.if !empty(WITH_GL)
+PLIST_SUB+= GL=""
+.else
+PLIST_SUB+= GL="@comment "
+.endif
+
do-configure:
@(cd ${WRKSRC} && ${ECHO} "yes" | ${PYTHON_CMD} configure.py \
-b ${PREFIX}/bin -d ${PYTHONPREFIX_SITELIBDIR} \
+ -n ${X11BASE}/include -o ${X11BASE}/lib \
-v ${PREFIX}/share/sip)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/py-qt/pkg-plist b/x11-toolkits/py-qt/pkg-plist
index 4a4cf790b69d..e2806772090b 100644
--- a/x11-toolkits/py-qt/pkg-plist
+++ b/x11-toolkits/py-qt/pkg-plist
@@ -3,7 +3,7 @@ bin/pyuic
%%PYTHON_SITELIBDIR%%/pyqtconfig.py
%%PYTHON_SITELIBDIR%%/qt.so
%%PYTHON_SITELIBDIR%%/qtcanvas.so
-%%PYTHON_SITELIBDIR%%/qtgl.so
+%%GL%%%%PYTHON_SITELIBDIR%%/qtgl.so
%%PYTHON_SITELIBDIR%%/qtnetwork.so
%%PYTHON_SITELIBDIR%%/qtsql.so
%%PYTHON_SITELIBDIR%%/qttable.so
@@ -190,10 +190,28 @@ share/sip/qt/versions.sip
share/sip/qtcanvas/copying.sip
share/sip/qtcanvas/qcanvas.sip
share/sip/qtcanvas/qtcanvasmod.sip
-share/sip/qtgl/copying.sip
-share/sip/qtgl/qgl.sip
-share/sip/qtgl/qglcolormap.sip
-share/sip/qtgl/qtglmod.sip
+share/sip/qtext/qtextmod.sip
+share/sip/qtext/copying.sip
+share/sip/qtext/qextscintillaapis.sip
+share/sip/qtext/qextscintillabase.sip
+share/sip/qtext/qextscintilla.sip
+share/sip/qtext/qextscintillacommand.sip
+share/sip/qtext/qextscintillacommandset.sip
+share/sip/qtext/qextscintillalexer.sip
+share/sip/qtext/qextscintillalexercpp.sip
+share/sip/qtext/qextscintillalexercsharp.sip
+share/sip/qtext/qextscintillalexerhtml.sip
+share/sip/qtext/qextscintillalexeridl.sip
+share/sip/qtext/qextscintillalexerjava.sip
+share/sip/qtext/qextscintillalexerjavascript.sip
+share/sip/qtext/qextscintillalexerpython.sip
+share/sip/qtext/qextscintillalexersql.sip
+share/sip/qtext/qextscintillamacro.sip
+share/sip/qtext/qextscintillaprinter.sip
+%%GL%%share/sip/qtgl/copying.sip
+%%GL%%share/sip/qtgl/qgl.sip
+%%GL%%share/sip/qtgl/qglcolormap.sip
+%%GL%%share/sip/qtgl/qtglmod.sip
share/sip/qtnetwork/copying.sip
share/sip/qtnetwork/qdns.sip
share/sip/qtnetwork/qftp.sip
@@ -235,7 +253,8 @@ share/sip/qtxml/qdom.sip
share/sip/qtxml/qtxmlmod.sip
@dirrm share/sip/qt
@dirrm share/sip/qtcanvas
-@dirrm share/sip/qtgl
+@dirrm share/sip/qtext
+%%GL%%@dirrm share/sip/qtgl
@dirrm share/sip/qtnetwork
@dirrm share/sip/qtsql
@dirrm share/sip/qttable