aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-06-15 16:16:32 +0000
committerWill Andrews <will@FreeBSD.org>2002-06-15 16:16:32 +0000
commit1aced58dae2e4b271f74d726a0e8f0edcc323838 (patch)
treeaa290e0641e0448ee8919195bad0a9b5bf828e59 /x11-toolkits
parent26687091c458f586e024178035ef42cf319d663d (diff)
downloadports-1aced58dae2e4b271f74d726a0e8f0edcc323838.tar.gz
ports-1aced58dae2e4b271f74d726a0e8f0edcc323838.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt30/Makefile14
-rw-r--r--x11-toolkits/qt31/Makefile14
-rw-r--r--x11-toolkits/qt32/Makefile14
-rw-r--r--x11-toolkits/qt33/Makefile14
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index de1904daaf00..2f46eb5dd176 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -67,6 +67,10 @@ ALL_TARGET= symlinks sub-src sub-tools
CFLAGS+= -O0
.endif
+.if ${XFREE86_VERSION} < 4
+BROKEN= "The QT 3.x port does not support any XFree86 < 4.x"
+.endif
+
.if defined(WITH_OPENGL)
# Display WITH_OPENGL advisory.
pre-everything:
@@ -76,6 +80,16 @@ pre-everything:
@${ECHO_MSG} '===> **************************************************'
.endif
+pre-fetch:
+.if exists(${X11BASE}/include/qt2/qapp.h)
+ @${ECHO}
+ @${ECHO} " NOTICE"
+ @${ECHO}
+ @${ECHO} "You have QT2 headers installed! Installing this port"
+ @${ECHO} "will result in conflicts between QT3 and QT2!"
+ @${FALSE}
+.endif
+
# Remove unneeded dirs (speedup) and fake netscape files.
post-patch:
@${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -fr
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index de1904daaf00..2f46eb5dd176 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -67,6 +67,10 @@ ALL_TARGET= symlinks sub-src sub-tools
CFLAGS+= -O0
.endif
+.if ${XFREE86_VERSION} < 4
+BROKEN= "The QT 3.x port does not support any XFree86 < 4.x"
+.endif
+
.if defined(WITH_OPENGL)
# Display WITH_OPENGL advisory.
pre-everything:
@@ -76,6 +80,16 @@ pre-everything:
@${ECHO_MSG} '===> **************************************************'
.endif
+pre-fetch:
+.if exists(${X11BASE}/include/qt2/qapp.h)
+ @${ECHO}
+ @${ECHO} " NOTICE"
+ @${ECHO}
+ @${ECHO} "You have QT2 headers installed! Installing this port"
+ @${ECHO} "will result in conflicts between QT3 and QT2!"
+ @${FALSE}
+.endif
+
# Remove unneeded dirs (speedup) and fake netscape files.
post-patch:
@${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -fr
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index de1904daaf00..2f46eb5dd176 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -67,6 +67,10 @@ ALL_TARGET= symlinks sub-src sub-tools
CFLAGS+= -O0
.endif
+.if ${XFREE86_VERSION} < 4
+BROKEN= "The QT 3.x port does not support any XFree86 < 4.x"
+.endif
+
.if defined(WITH_OPENGL)
# Display WITH_OPENGL advisory.
pre-everything:
@@ -76,6 +80,16 @@ pre-everything:
@${ECHO_MSG} '===> **************************************************'
.endif
+pre-fetch:
+.if exists(${X11BASE}/include/qt2/qapp.h)
+ @${ECHO}
+ @${ECHO} " NOTICE"
+ @${ECHO}
+ @${ECHO} "You have QT2 headers installed! Installing this port"
+ @${ECHO} "will result in conflicts between QT3 and QT2!"
+ @${FALSE}
+.endif
+
# Remove unneeded dirs (speedup) and fake netscape files.
post-patch:
@${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -fr
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index de1904daaf00..2f46eb5dd176 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -67,6 +67,10 @@ ALL_TARGET= symlinks sub-src sub-tools
CFLAGS+= -O0
.endif
+.if ${XFREE86_VERSION} < 4
+BROKEN= "The QT 3.x port does not support any XFree86 < 4.x"
+.endif
+
.if defined(WITH_OPENGL)
# Display WITH_OPENGL advisory.
pre-everything:
@@ -76,6 +80,16 @@ pre-everything:
@${ECHO_MSG} '===> **************************************************'
.endif
+pre-fetch:
+.if exists(${X11BASE}/include/qt2/qapp.h)
+ @${ECHO}
+ @${ECHO} " NOTICE"
+ @${ECHO}
+ @${ECHO} "You have QT2 headers installed! Installing this port"
+ @${ECHO} "will result in conflicts between QT3 and QT2!"
+ @${FALSE}
+.endif
+
# Remove unneeded dirs (speedup) and fake netscape files.
post-patch:
@${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -fr