aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2019-02-09 20:48:10 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2019-02-09 20:48:10 +0000
commit3d7743507430985382199e13c7ac2d952e9e7665 (patch)
tree9c794b06eba933533761631b5a83732af0d344af /x11-toolkits
parenta73d80796cc81b3051c2cd78a263be4c23f07cd2 (diff)
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/soqt-devel/Makefile32
-rw-r--r--x11-toolkits/soqt-devel/distinfo3
-rw-r--r--x11-toolkits/soqt-devel/files/patch-CMakeLists.txt29
-rw-r--r--x11-toolkits/soqt-devel/files/patch-soqt-config.cmake.in11
-rw-r--r--x11-toolkits/soqt-devel/files/patch-test-code_CMakeLists.txt38
-rw-r--r--x11-toolkits/soqt-devel/pkg-descr8
-rw-r--r--x11-toolkits/soqt-devel/pkg-plist473
8 files changed, 595 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 1844045b3f2c..2189cb1d77d7 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -263,6 +263,7 @@
SUBDIR += skinlf
SUBDIR += slingshot
SUBDIR += soqt
+ SUBDIR += soqt-devel
SUBDIR += swt
SUBDIR += swt-devel
SUBDIR += tepl
diff --git a/x11-toolkits/soqt-devel/Makefile b/x11-toolkits/soqt-devel/Makefile
new file mode 100644
index 000000000000..bba5928723c4
--- /dev/null
+++ b/x11-toolkits/soqt-devel/Makefile
@@ -0,0 +1,32 @@
+# Created by: roland.jesse@gmx.net
+# $FreeBSD$
+
+PORTNAME= SoQt
+PORTVERSION= 1.6.0a
+PKGNAMESUFFIX= -devel
+DISTNAME= soqt_${PORTVERSION}
+CATEGORIES= x11-toolkits
+MASTER_SITES= https://github.com/FreeCAD/pivy/releases/download/0.6.4/
+DIST_SUBDIR= KDE
+
+MAINTAINER= cmt@FreeBSD.org
+COMMENT= Qt5-fork of the SoQt toolkit library for Coin
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libCoin.so:graphics/Coin
+
+CONFLICTS_INSTALL= SoQt
+
+USES= cmake dos2unix gl libtool pathfix pkgconfig qmake:no_env qt:5
+USE_QT= buildtools core gui opengl qmake widgets
+USE_GL= gl
+USE_XORG= ice sm x11 xext xi
+USE_LDCONFIG= yes
+
+CPPFLAGS+= -I${QT_INCDIR}/QtCore -I${QT_INCDIR} -I${LOCALBASE}/include
+LDFLAGS+= -L${QT_LIBDIR} -L${LOCALBASE}/lib
+
+WRKSRC= ${WRKDIR}/soqt
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/soqt-devel/distinfo b/x11-toolkits/soqt-devel/distinfo
new file mode 100644
index 000000000000..6ed7945d027f
--- /dev/null
+++ b/x11-toolkits/soqt-devel/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549725427
+SHA256 (KDE/soqt_1.6.0a.tar.gz) = a36664382e6a35873b7d0f65a1d302bdb3198d8bf8ae80e7f2db10c5f3bf895f
+SIZE (KDE/soqt_1.6.0a.tar.gz) = 12855141
diff --git a/x11-toolkits/soqt-devel/files/patch-CMakeLists.txt b/x11-toolkits/soqt-devel/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..74908565c3f0
--- /dev/null
+++ b/x11-toolkits/soqt-devel/files/patch-CMakeLists.txt
@@ -0,0 +1,29 @@
+--- CMakeLists.txt.orig 2019-02-09 16:08:58 UTC
++++ CMakeLists.txt
+@@ -47,7 +47,7 @@ set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin)
+
+ find_package(OpenGL REQUIRED)
+-find_package(Coin REQUIRED)
++find_package(Coin3D REQUIRED)
+ #find_package(superglu REQUIRED)
+
+ if(USE_QT5)
+@@ -119,7 +119,7 @@ else()
+ " HAVE_PTHREAD_TIMESPEC_NSEC)
+ endif()
+
+-set(CMAKE_REQUIRED_LIBRARIES Coin::Coin)
++set(CMAKE_REQUIRED_LIBRARIES Coin)
+
+ check_cxx_source_compiles("
+ #include <Inventor/SbImage.h>
+@@ -340,7 +340,7 @@ target_include_directories(${PROJECT_NAME}
+ ${OPENGL_INCLUDE_DIR}
+ )
+
+-target_link_libraries(${PROJECT_NAME} Coin::Coin ${OPENGL_LIBRARIES} ${QT_LIBRARIES})
++target_link_libraries(${PROJECT_NAME} Coin ${OPENGL_LIBRARIES} ${QT_LIBRARIES})
+
+ if(X11_FOUND)
+ target_include_directories(${PROJECT_NAME} PUBLIC ${X11_INCLUDE_DIR})
diff --git a/x11-toolkits/soqt-devel/files/patch-soqt-config.cmake.in b/x11-toolkits/soqt-devel/files/patch-soqt-config.cmake.in
new file mode 100644
index 000000000000..6e3c73955c32
--- /dev/null
+++ b/x11-toolkits/soqt-devel/files/patch-soqt-config.cmake.in
@@ -0,0 +1,11 @@
+--- soqt-config.cmake.in.orig 2019-02-09 17:01:29 UTC
++++ soqt-config.cmake.in
+@@ -8,7 +8,7 @@ set(SoQt_VERSION_PATCH "@SOQT_MICRO_VERSION@")
+ include(CMakeFindDependencyMacro)
+ include(GNUInstallDirs)
+
+-find_dependency(Coin)
++find_dependency(Coin3D)
+
+ if(@Qt5_FOUND@)
+ find_dependency(Qt5Core)
diff --git a/x11-toolkits/soqt-devel/files/patch-test-code_CMakeLists.txt b/x11-toolkits/soqt-devel/files/patch-test-code_CMakeLists.txt
new file mode 100644
index 000000000000..e0c87a271705
--- /dev/null
+++ b/x11-toolkits/soqt-devel/files/patch-test-code_CMakeLists.txt
@@ -0,0 +1,38 @@
+--- test-code/CMakeLists.txt.orig 2019-02-09 16:10:46 UTC
++++ test-code/CMakeLists.txt
+@@ -1,26 +1,26 @@
+ add_executable(crash assertdbg/crash.cpp)
+-target_link_libraries(crash Coin::Coin SoQt)
++target_link_libraries(crash Coin SoQt)
+
+ #add_executable(coloreditor components/coloreditor.cpp)
+-#target_link_libraries(coloreditor Coin::Coin SoQt)
++#target_link_libraries(coloreditor Coin SoQt)
+
+ add_executable(embeddedexaminer components/embeddedexaminer.cpp)
+-target_link_libraries(embeddedexaminer Coin::Coin SoQt)
++target_link_libraries(embeddedexaminer Coin SoQt)
+
+ add_executable(renderarea components/renderarea.cpp)
+-target_link_libraries(renderarea Coin::Coin SoQt)
++target_link_libraries(renderarea Coin SoQt)
+
+ add_executable(scrollview components/scrollview.cpp)
+-target_link_libraries(scrollview Coin::Coin SoQt)
++target_link_libraries(scrollview Coin SoQt)
+
+ add_executable(tripleview components/tripleview.cpp)
+-target_link_libraries(tripleview Coin::Coin SoQt)
++target_link_libraries(tripleview Coin SoQt)
+
+ add_executable(withoutdecor0 components/withoutdecor0.cpp)
+-target_link_libraries(withoutdecor0 Coin::Coin SoQt)
++target_link_libraries(withoutdecor0 Coin SoQt)
+
+ add_executable(withoutdecor1 components/withoutdecor1.cpp)
+-target_link_libraries(withoutdecor1 Coin::Coin SoQt)
++target_link_libraries(withoutdecor1 Coin SoQt)
+
+ add_executable(thumbwheel widgets/thumbwheel.cpp)
+-target_link_libraries(thumbwheel Coin::Coin SoQt)
++target_link_libraries(thumbwheel Coin SoQt)
diff --git a/x11-toolkits/soqt-devel/pkg-descr b/x11-toolkits/soqt-devel/pkg-descr
new file mode 100644
index 000000000000..01ad38d0b443
--- /dev/null
+++ b/x11-toolkits/soqt-devel/pkg-descr
@@ -0,0 +1,8 @@
+SoQt is a Qt GUI component toolkit library for Coin. It is also compatible
+with SGI and TGS Open Inventor, and the API is based on the API of the
+InventorXt GUI component toolkit.
+
+This is a fork of the original project provided by the FreeCAD project, it
+uses Qt5.
+
+WWW: https://bitbucket.org/Coin3D/coin/wiki/Home
diff --git a/x11-toolkits/soqt-devel/pkg-plist b/x11-toolkits/soqt-devel/pkg-plist
new file mode 100644
index 000000000000..5aab14ed5e01
--- /dev/null
+++ b/x11-toolkits/soqt-devel/pkg-plist
@@ -0,0 +1,473 @@
+include/Inventor/Qt/SoQt.h
+include/Inventor/Qt/SoQtBasic.h
+include/Inventor/Qt/SoQtColorEditor.h
+include/Inventor/Qt/SoQtComponent.h
+include/Inventor/Qt/SoQtCursor.h
+include/Inventor/Qt/SoQtGLWidget.h
+include/Inventor/Qt/SoQtObject.h
+include/Inventor/Qt/SoQtRenderArea.h
+include/Inventor/Qt/devices/SoQtDevice.h
+include/Inventor/Qt/devices/SoQtKeyboard.h
+include/Inventor/Qt/devices/SoQtMouse.h
+include/Inventor/Qt/editors/SoQtColorEditor.h
+include/Inventor/Qt/editors/SoQtMaterialEditor.h
+include/Inventor/Qt/editors/SoQtSpacenavDevice.h
+include/Inventor/Qt/nodes/SoGuiColorEditor.h
+include/Inventor/Qt/nodes/SoGuiMaterialEditor.h
+include/Inventor/Qt/viewers/SoQtConstrainedViewer.h
+include/Inventor/Qt/viewers/SoQtExaminerViewer.h
+include/Inventor/Qt/viewers/SoQtFlyViewer.h
+include/Inventor/Qt/viewers/SoQtFullViewer.h
+include/Inventor/Qt/viewers/SoQtPlaneViewer.h
+include/Inventor/Qt/viewers/SoQtViewer.h
+include/Inventor/Qt/widgets/SoQtPopupMenu.h
+include/Inventor/Qt/widgets/SoQtThumbWheel.h
+lib/cmake/SoQt-1.6.0/soqt-config-version.cmake
+lib/cmake/SoQt-1.6.0/soqt-config.cmake
+lib/cmake/SoQt-1.6.0/soqt-export-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/SoQt-1.6.0/soqt-export.cmake
+lib/libSoQt.so
+lib/libSoQt.so.1.6.0a
+lib/libSoQt.so.20
+share/materials/artdeco/artdeco1.h
+share/materials/artdeco/artdeco10.h
+share/materials/artdeco/artdeco11.h
+share/materials/artdeco/artdeco12.h
+share/materials/artdeco/artdeco13.h
+share/materials/artdeco/artdeco14.h
+share/materials/artdeco/artdeco15.h
+share/materials/artdeco/artdeco16.h
+share/materials/artdeco/artdeco17.h
+share/materials/artdeco/artdeco18.h
+share/materials/artdeco/artdeco19.h
+share/materials/artdeco/artdeco2.h
+share/materials/artdeco/artdeco20.h
+share/materials/artdeco/artdeco21.h
+share/materials/artdeco/artdeco22.h
+share/materials/artdeco/artdeco23.h
+share/materials/artdeco/artdeco24.h
+share/materials/artdeco/artdeco25.h
+share/materials/artdeco/artdeco26.h
+share/materials/artdeco/artdeco27.h
+share/materials/artdeco/artdeco28.h
+share/materials/artdeco/artdeco29.h
+share/materials/artdeco/artdeco3.h
+share/materials/artdeco/artdeco30.h
+share/materials/artdeco/artdeco31.h
+share/materials/artdeco/artdeco32.h
+share/materials/artdeco/artdeco33.h
+share/materials/artdeco/artdeco34.h
+share/materials/artdeco/artdeco4.h
+share/materials/artdeco/artdeco5.h
+share/materials/artdeco/artdeco6.h
+share/materials/artdeco/artdeco7.h
+share/materials/artdeco/artdeco8.h
+share/materials/artdeco/artdeco9.h
+share/materials/autumn/autumn1.h
+share/materials/autumn/autumn10.h
+share/materials/autumn/autumn11.h
+share/materials/autumn/autumn12.h
+share/materials/autumn/autumn13.h
+share/materials/autumn/autumn14.h
+share/materials/autumn/autumn15.h
+share/materials/autumn/autumn16.h
+share/materials/autumn/autumn17.h
+share/materials/autumn/autumn18.h
+share/materials/autumn/autumn19.h
+share/materials/autumn/autumn2.h
+share/materials/autumn/autumn20.h
+share/materials/autumn/autumn21.h
+share/materials/autumn/autumn22.h
+share/materials/autumn/autumn23.h
+share/materials/autumn/autumn24.h
+share/materials/autumn/autumn25.h
+share/materials/autumn/autumn26.h
+share/materials/autumn/autumn27.h
+share/materials/autumn/autumn28.h
+share/materials/autumn/autumn29.h
+share/materials/autumn/autumn3.h
+share/materials/autumn/autumn30.h
+share/materials/autumn/autumn31.h
+share/materials/autumn/autumn32.h
+share/materials/autumn/autumn33.h
+share/materials/autumn/autumn34.h
+share/materials/autumn/autumn4.h
+share/materials/autumn/autumn5.h
+share/materials/autumn/autumn6.h
+share/materials/autumn/autumn7.h
+share/materials/autumn/autumn8.h
+share/materials/autumn/autumn9.h
+share/materials/glass/glass1.h
+share/materials/glass/glass10.h
+share/materials/glass/glass11.h
+share/materials/glass/glass12.h
+share/materials/glass/glass13.h
+share/materials/glass/glass14.h
+share/materials/glass/glass15.h
+share/materials/glass/glass16.h
+share/materials/glass/glass17.h
+share/materials/glass/glass18.h
+share/materials/glass/glass19.h
+share/materials/glass/glass2.h
+share/materials/glass/glass20.h
+share/materials/glass/glass21.h
+share/materials/glass/glass22.h
+share/materials/glass/glass23.h
+share/materials/glass/glass24.h
+share/materials/glass/glass25.h
+share/materials/glass/glass26.h
+share/materials/glass/glass27.h
+share/materials/glass/glass28.h
+share/materials/glass/glass29.h
+share/materials/glass/glass3.h
+share/materials/glass/glass30.h
+share/materials/glass/glass31.h
+share/materials/glass/glass32.h
+share/materials/glass/glass33.h
+share/materials/glass/glass34.h
+share/materials/glass/glass4.h
+share/materials/glass/glass5.h
+share/materials/glass/glass6.h
+share/materials/glass/glass7.h
+share/materials/glass/glass8.h
+share/materials/glass/glass9.h
+share/materials/metal/metal1.h
+share/materials/metal/metal10.h
+share/materials/metal/metal11.h
+share/materials/metal/metal12.h
+share/materials/metal/metal13.h
+share/materials/metal/metal14.h
+share/materials/metal/metal15.h
+share/materials/metal/metal16.h
+share/materials/metal/metal17.h
+share/materials/metal/metal18.h
+share/materials/metal/metal19.h
+share/materials/metal/metal2.h
+share/materials/metal/metal20.h
+share/materials/metal/metal21.h
+share/materials/metal/metal22.h
+share/materials/metal/metal23.h
+share/materials/metal/metal24.h
+share/materials/metal/metal25.h
+share/materials/metal/metal26.h
+share/materials/metal/metal27.h
+share/materials/metal/metal28.h
+share/materials/metal/metal29.h
+share/materials/metal/metal3.h
+share/materials/metal/metal30.h
+share/materials/metal/metal31.h
+share/materials/metal/metal32.h
+share/materials/metal/metal33.h
+share/materials/metal/metal34.h
+share/materials/metal/metal4.h
+share/materials/metal/metal5.h
+share/materials/metal/metal6.h
+share/materials/metal/metal7.h
+share/materials/metal/metal8.h
+share/materials/metal/metal9.h
+share/materials/neon/neon1.h
+share/materials/neon/neon10.h
+share/materials/neon/neon11.h
+share/materials/neon/neon12.h
+share/materials/neon/neon13.h
+share/materials/neon/neon14.h
+share/materials/neon/neon15.h
+share/materials/neon/neon16.h
+share/materials/neon/neon17.h
+share/materials/neon/neon18.h
+share/materials/neon/neon19.h
+share/materials/neon/neon2.h
+share/materials/neon/neon20.h
+share/materials/neon/neon21.h
+share/materials/neon/neon22.h
+share/materials/neon/neon23.h
+share/materials/neon/neon24.h
+share/materials/neon/neon25.h
+share/materials/neon/neon26.h
+share/materials/neon/neon27.h
+share/materials/neon/neon28.h
+share/materials/neon/neon29.h
+share/materials/neon/neon3.h
+share/materials/neon/neon30.h
+share/materials/neon/neon31.h
+share/materials/neon/neon32.h
+share/materials/neon/neon33.h
+share/materials/neon/neon34.h
+share/materials/neon/neon4.h
+share/materials/neon/neon5.h
+share/materials/neon/neon6.h
+share/materials/neon/neon7.h
+share/materials/neon/neon8.h
+share/materials/neon/neon9.h
+share/materials/rococo/rococo1.h
+share/materials/rococo/rococo10.h
+share/materials/rococo/rococo11.h
+share/materials/rococo/rococo12.h
+share/materials/rococo/rococo13.h
+share/materials/rococo/rococo14.h
+share/materials/rococo/rococo15.h
+share/materials/rococo/rococo16.h
+share/materials/rococo/rococo17.h
+share/materials/rococo/rococo18.h
+share/materials/rococo/rococo19.h
+share/materials/rococo/rococo2.h
+share/materials/rococo/rococo20.h
+share/materials/rococo/rococo21.h
+share/materials/rococo/rococo22.h
+share/materials/rococo/rococo23.h
+share/materials/rococo/rococo24.h
+share/materials/rococo/rococo25.h
+share/materials/rococo/rococo26.h
+share/materials/rococo/rococo27.h
+share/materials/rococo/rococo28.h
+share/materials/rococo/rococo29.h
+share/materials/rococo/rococo3.h
+share/materials/rococo/rococo30.h
+share/materials/rococo/rococo31.h
+share/materials/rococo/rococo32.h
+share/materials/rococo/rococo33.h
+share/materials/rococo/rococo34.h
+share/materials/rococo/rococo4.h
+share/materials/rococo/rococo5.h
+share/materials/rococo/rococo6.h
+share/materials/rococo/rococo7.h
+share/materials/rococo/rococo8.h
+share/materials/rococo/rococo9.h
+share/materials/santafe/santafe1.h
+share/materials/santafe/santafe10.h
+share/materials/santafe/santafe11.h
+share/materials/santafe/santafe12.h
+share/materials/santafe/santafe13.h
+share/materials/santafe/santafe14.h
+share/materials/santafe/santafe15.h
+share/materials/santafe/santafe16.h
+share/materials/santafe/santafe17.h
+share/materials/santafe/santafe18.h
+share/materials/santafe/santafe19.h
+share/materials/santafe/santafe2.h
+share/materials/santafe/santafe20.h
+share/materials/santafe/santafe21.h
+share/materials/santafe/santafe22.h
+share/materials/santafe/santafe23.h
+share/materials/santafe/santafe24.h
+share/materials/santafe/santafe25.h
+share/materials/santafe/santafe26.h
+share/materials/santafe/santafe27.h
+share/materials/santafe/santafe28.h
+share/materials/santafe/santafe29.h
+share/materials/santafe/santafe3.h
+share/materials/santafe/santafe30.h
+share/materials/santafe/santafe31.h
+share/materials/santafe/santafe32.h
+share/materials/santafe/santafe33.h
+share/materials/santafe/santafe34.h
+share/materials/santafe/santafe4.h
+share/materials/santafe/santafe5.h
+share/materials/santafe/santafe6.h
+share/materials/santafe/santafe7.h
+share/materials/santafe/santafe8.h
+share/materials/santafe/santafe9.h
+share/materials/sheen/sheen1.h
+share/materials/sheen/sheen10.h
+share/materials/sheen/sheen11.h
+share/materials/sheen/sheen12.h
+share/materials/sheen/sheen13.h
+share/materials/sheen/sheen14.h
+share/materials/sheen/sheen15.h
+share/materials/sheen/sheen16.h
+share/materials/sheen/sheen17.h
+share/materials/sheen/sheen18.h
+share/materials/sheen/sheen19.h
+share/materials/sheen/sheen2.h
+share/materials/sheen/sheen20.h
+share/materials/sheen/sheen21.h
+share/materials/sheen/sheen22.h
+share/materials/sheen/sheen23.h
+share/materials/sheen/sheen24.h
+share/materials/sheen/sheen25.h
+share/materials/sheen/sheen26.h
+share/materials/sheen/sheen27.h
+share/materials/sheen/sheen28.h
+share/materials/sheen/sheen29.h
+share/materials/sheen/sheen3.h
+share/materials/sheen/sheen30.h
+share/materials/sheen/sheen31.h
+share/materials/sheen/sheen32.h
+share/materials/sheen/sheen33.h
+share/materials/sheen/sheen34.h
+share/materials/sheen/sheen4.h
+share/materials/sheen/sheen5.h
+share/materials/sheen/sheen6.h
+share/materials/sheen/sheen7.h
+share/materials/sheen/sheen8.h
+share/materials/sheen/sheen9.h
+share/materials/silky/silky1.h
+share/materials/silky/silky10.h
+share/materials/silky/silky11.h
+share/materials/silky/silky12.h
+share/materials/silky/silky13.h
+share/materials/silky/silky14.h
+share/materials/silky/silky15.h
+share/materials/silky/silky16.h
+share/materials/silky/silky17.h
+share/materials/silky/silky18.h
+share/materials/silky/silky19.h
+share/materials/silky/silky2.h
+share/materials/silky/silky20.h
+share/materials/silky/silky21.h
+share/materials/silky/silky22.h
+share/materials/silky/silky23.h
+share/materials/silky/silky24.h
+share/materials/silky/silky25.h
+share/materials/silky/silky26.h
+share/materials/silky/silky27.h
+share/materials/silky/silky28.h
+share/materials/silky/silky29.h
+share/materials/silky/silky3.h
+share/materials/silky/silky30.h
+share/materials/silky/silky31.h
+share/materials/silky/silky32.h
+share/materials/silky/silky33.h
+share/materials/silky/silky34.h
+share/materials/silky/silky4.h
+share/materials/silky/silky5.h
+share/materials/silky/silky6.h
+share/materials/silky/silky7.h
+share/materials/silky/silky8.h
+share/materials/silky/silky9.h
+share/materials/spring/spring1.h
+share/materials/spring/spring10.h
+share/materials/spring/spring11.h
+share/materials/spring/spring12.h
+share/materials/spring/spring13.h
+share/materials/spring/spring14.h
+share/materials/spring/spring15.h
+share/materials/spring/spring16.h
+share/materials/spring/spring17.h
+share/materials/spring/spring18.h
+share/materials/spring/spring19.h
+share/materials/spring/spring2.h
+share/materials/spring/spring20.h
+share/materials/spring/spring21.h
+share/materials/spring/spring22.h
+share/materials/spring/spring23.h
+share/materials/spring/spring24.h
+share/materials/spring/spring25.h
+share/materials/spring/spring26.h
+share/materials/spring/spring27.h
+share/materials/spring/spring28.h
+share/materials/spring/spring29.h
+share/materials/spring/spring3.h
+share/materials/spring/spring30.h
+share/materials/spring/spring31.h
+share/materials/spring/spring32.h
+share/materials/spring/spring33.h
+share/materials/spring/spring34.h
+share/materials/spring/spring4.h
+share/materials/spring/spring5.h
+share/materials/spring/spring6.h
+share/materials/spring/spring7.h
+share/materials/spring/spring8.h
+share/materials/spring/spring9.h
+share/materials/summer/summer1.h
+share/materials/summer/summer10.h
+share/materials/summer/summer11.h
+share/materials/summer/summer12.h
+share/materials/summer/summer13.h
+share/materials/summer/summer14.h
+share/materials/summer/summer15.h
+share/materials/summer/summer16.h
+share/materials/summer/summer17.h
+share/materials/summer/summer18.h
+share/materials/summer/summer19.h
+share/materials/summer/summer2.h
+share/materials/summer/summer20.h
+share/materials/summer/summer21.h
+share/materials/summer/summer22.h
+share/materials/summer/summer23.h
+share/materials/summer/summer24.h
+share/materials/summer/summer25.h
+share/materials/summer/summer26.h
+share/materials/summer/summer27.h
+share/materials/summer/summer28.h
+share/materials/summer/summer29.h
+share/materials/summer/summer3.h
+share/materials/summer/summer30.h
+share/materials/summer/summer31.h
+share/materials/summer/summer32.h
+share/materials/summer/summer33.h
+share/materials/summer/summer34.h
+share/materials/summer/summer4.h
+share/materials/summer/summer5.h
+share/materials/summer/summer6.h
+share/materials/summer/summer7.h
+share/materials/summer/summer8.h
+share/materials/summer/summer9.h
+share/materials/tropical/tropical1.h
+share/materials/tropical/tropical10.h
+share/materials/tropical/tropical11.h
+share/materials/tropical/tropical12.h
+share/materials/tropical/tropical13.h
+share/materials/tropical/tropical14.h
+share/materials/tropical/tropical15.h
+share/materials/tropical/tropical16.h
+share/materials/tropical/tropical17.h
+share/materials/tropical/tropical18.h
+share/materials/tropical/tropical19.h
+share/materials/tropical/tropical2.h
+share/materials/tropical/tropical20.h
+share/materials/tropical/tropical21.h
+share/materials/tropical/tropical22.h
+share/materials/tropical/tropical23.h
+share/materials/tropical/tropical24.h
+share/materials/tropical/tropical25.h
+share/materials/tropical/tropical26.h
+share/materials/tropical/tropical27.h
+share/materials/tropical/tropical28.h
+share/materials/tropical/tropical29.h
+share/materials/tropical/tropical3.h
+share/materials/tropical/tropical30.h
+share/materials/tropical/tropical31.h
+share/materials/tropical/tropical32.h
+share/materials/tropical/tropical33.h
+share/materials/tropical/tropical34.h
+share/materials/tropical/tropical4.h
+share/materials/tropical/tropical5.h
+share/materials/tropical/tropical6.h
+share/materials/tropical/tropical7.h
+share/materials/tropical/tropical8.h
+share/materials/tropical/tropical9.h
+share/materials/winter/winter1.h
+share/materials/winter/winter10.h
+share/materials/winter/winter11.h
+share/materials/winter/winter12.h
+share/materials/winter/winter13.h
+share/materials/winter/winter14.h
+share/materials/winter/winter15.h
+share/materials/winter/winter16.h
+share/materials/winter/winter17.h
+share/materials/winter/winter18.h
+share/materials/winter/winter19.h
+share/materials/winter/winter2.h
+share/materials/winter/winter20.h
+share/materials/winter/winter21.h
+share/materials/winter/winter22.h
+share/materials/winter/winter23.h
+share/materials/winter/winter24.h
+share/materials/winter/winter25.h
+share/materials/winter/winter26.h
+share/materials/winter/winter27.h
+share/materials/winter/winter28.h
+share/materials/winter/winter29.h
+share/materials/winter/winter3.h
+share/materials/winter/winter30.h
+share/materials/winter/winter31.h
+share/materials/winter/winter32.h
+share/materials/winter/winter33.h
+share/materials/winter/winter34.h
+share/materials/winter/winter4.h
+share/materials/winter/winter5.h
+share/materials/winter/winter6.h
+share/materials/winter/winter7.h
+share/materials/winter/winter8.h
+share/materials/winter/winter9.h