aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-11-21 11:01:31 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-11-21 11:01:31 +0000
commit726a55f00e2d70866392bc56c928a36bcd472b3f (patch)
tree8dff2ced462264ba6b69bd7517a27cfc745daead /x11-toolkits
parentf6830785c8c90964cff9c90ba3506333aa45b75b (diff)
downloadports-726a55f00e2d70866392bc56c928a36bcd472b3f.tar.gz
ports-726a55f00e2d70866392bc56c928a36bcd472b3f.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/blt/Makefile11
-rw-r--r--x11-toolkits/blt/files/patch-generic_bltInt.h2
2 files changed, 10 insertions, 3 deletions
diff --git a/x11-toolkits/blt/Makefile b/x11-toolkits/blt/Makefile
index 33956ba8db4e..af81d9ac05f8 100644
--- a/x11-toolkits/blt/Makefile
+++ b/x11-toolkits/blt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= blt
PORTVERSION= 2.5.3
+PORTREVISION= 1
CATEGORIES= x11-toolkits tk
MASTER_SITES= SF/wize
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
@@ -16,7 +17,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION:R}
-USES+= gmake tk:84,85
+USES+= gmake tk
USE_ZIP= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -42,4 +43,10 @@ post-patch:
${FIND} ${WRKSRC}/demos -name "*.tcl" | ${XARGS} \
${REINPLACE_CMD} -e 's|../src/bltwish|${LOCALBASE}/bin/bltwish|'
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${TCL_VER} > 8.5
+CFLAGS+= -DUSE_INTERP_RESULT -DUSE_INTERP_ERRORLINE
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/blt/files/patch-generic_bltInt.h b/x11-toolkits/blt/files/patch-generic_bltInt.h
index 8cef95fb7004..f9a31eac5126 100644
--- a/x11-toolkits/blt/files/patch-generic_bltInt.h
+++ b/x11-toolkits/blt/files/patch-generic_bltInt.h
@@ -14,7 +14,7 @@
#ifdef TCL_UTF_MAX
#define HAVE_UTF 1
-extern FILE *Blt_OpenUtfFile _ANSI_ARGS_((char *fileName, char *mode));
-+extern FILE *Blt_OpenUtfFile _ANSI_ARGS_((CONST char *fileName, char *mode));
++extern FILE *Blt_OpenUtfFile _ANSI_ARGS_((CONST char *fileName, CONST char *mode));
#define fopen(f,m) Blt_OpenUtfFile((f),(m));
#else
#define HAVE_UTF 0