aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-10-25 13:48:21 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-10-25 13:48:21 +0000
commit4e96f31450ebf099c466dd06ad99661fe0b9a8b3 (patch)
treee41b5bd1c64120c303fab6294b9cb002220a20fb /x11-toolkits
parent92227a857dd32ca967bb248e55129820a00e5861 (diff)
downloadports-4e96f31450ebf099c466dd06ad99661fe0b9a8b3.tar.gz
ports-4e96f31450ebf099c466dd06ad99661fe0b9a8b3.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox17/Makefile3
-rw-r--r--x11-toolkits/fox17/distinfo4
-rw-r--r--x11-toolkits/fox17/files/patch-bugs199
-rw-r--r--x11-toolkits/fox17/files/patch-warnings170
-rw-r--r--x11-toolkits/fox17/pkg-plist2
5 files changed, 5 insertions, 373 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 9195bd419a0a..b8b116685006 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= fox
-PORTVERSION= 1.7.42
-PORTREVISION= 1
+PORTVERSION= 1.7.43
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.fox-toolkit.org/pub/ \
ftp://ftp.fox-toolkit.org/pub/
diff --git a/x11-toolkits/fox17/distinfo b/x11-toolkits/fox17/distinfo
index 352ae3e6d04a..b8bcfae6e57f 100644
--- a/x11-toolkits/fox17/distinfo
+++ b/x11-toolkits/fox17/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fox-1.7.42.tar.gz) = 5e7a69c64ecfc704c130ea890385256c568fadbb472f91d8256f576b6d87ecf4
-SIZE (fox-1.7.42.tar.gz) = 5062065
+SHA256 (fox-1.7.43.tar.gz) = 6d3c41c431d01179866b114f24cd749a9aef8ef8dab1dec4f657895107eb70ee
+SIZE (fox-1.7.43.tar.gz) = 5077930
diff --git a/x11-toolkits/fox17/files/patch-bugs b/x11-toolkits/fox17/files/patch-bugs
index e8a0002ce7e8..19573d78e4ea 100644
--- a/x11-toolkits/fox17/files/patch-bugs
+++ b/x11-toolkits/fox17/files/patch-bugs
@@ -1,193 +1,3 @@
---- lib/fxxpmio.cpp.orig 2013-09-18 16:02:08.000000000 +0200
-+++ lib/fxxpmio.cpp 2013-09-18 16:07:33.000000000 +0200
-@@ -128,13 +128,14 @@
- FXchar lookuptable[1024][8],name[100],word[100],flag,best;
- FXColor colortable[16384],*pix,color;
- const FXchar *src,*line;
-- FXint i,j,ncolors,cpp,c;
-+ FXint i,j,ncolors,cpp,c,nchar;
-
- // Null out
- data=NULL;
- width=0;
- height=0;
- color=0;
-+ nchar=0;
-
- // NULL pointer passed in
- if(!pixels) return false;
-@@ -172,7 +173,7 @@
- flag=word[0];
- name[0]=0;
- while(nextword(src,word) && !iskey(word)){
-- strncat(name,word,sizeof(name));
-+ nchar += snprintf(name+nchar,sizeof(name)-nchar,"%s",word);
- }
- if(flag<best){ // c < g < m < s
- color=colorFromName(name);
-@@ -227,13 +228,14 @@
- FXchar lookuptable[1024][8],line[100],name[100],word[100],flag,best,ch;
- FXColor colortable[16384],*pix,color;
- const FXchar *src;
-- FXint i,j,ncolors,cpp,c;
-+ FXint i,j,ncolors,cpp,c,nchar;
-
- // Null out
- data=NULL;
- width=0;
- height=0;
- color=0;
-+ nchar=0;
-
- // Read header line
- readline(store,name,sizeof(name));
-@@ -269,7 +271,7 @@
- flag=word[0];
- name[0]=0;
- while(nextword(src,word) && !iskey(word)){
-- strncat(name,word,sizeof(name));
-+ nchar += snprintf(name+nchar,sizeof(name)-nchar,"%s",word);
- }
- if(flag<best){ // c < g < m < s
- color=colorFromName(name);
---- lib/FXFont.cpp.orig 2013-09-18 15:42:34.000000000 +0200
-+++ lib/FXFont.cpp 2013-09-18 15:47:14.000000000 +0200
-@@ -2180,6 +2180,7 @@
- FXString family;
- FXString foundry;
- double points;
-+ size_t famlen;
-
- fonts=NULL;
- numfonts=0;
-@@ -2243,11 +2244,10 @@
- // Get full face name
- fullname[0]=0;
- if(FcPatternGetString(p,FC_FAMILY,0,&fam)==FcResultMatch){
-+ famlen = strlen((const char *)fam);
- strncpy(fullname,(const char*)fam,sizeof(fullname));
- if(FcPatternGetString(p,FC_FOUNDRY,0,&fdy)==FcResultMatch){
-- strncat(fullname," [",sizeof(fullname));
-- strncat(fullname,(const char*)fdy,sizeof(fullname));
-- strncat(fullname,"]",sizeof(fullname));
-+ snprintf(fullname+famlen, sizeof(fullname)-famlen, " [%s]", (const char *)fdy);
- }
- }
-
---- lib/FXApp.cpp.orig 2013-09-18 15:31:42.000000000 +0200
-+++ lib/FXApp.cpp 2013-09-18 15:33:59.000000000 +0200
-@@ -1495,8 +1495,7 @@
- if(XSupportsLocale()){
- FXchar mods[100]="";
- if(inputmethod[0]){
-- strncpy(mods,"@im=",sizeof(mods));
-- strncat(mods,inputmethod,sizeof(mods));
-+ snprintf(mods, sizeof(mods), "@im=%s", inputmethod);
- }
- if(!XSetLocaleModifiers(mods)){
- if(!XSetLocaleModifiers("")){
---- tests/minheritance.cpp.orig 2013-09-18 16:26:29.000000000 +0200
-+++ tests/minheritance.cpp 2013-09-18 16:27:36.000000000 +0200
-@@ -161,7 +161,7 @@
- /*******************************************************************************/
-
- Base1::Base1(){
-- FXTRACE((100,"Base1::Base1 at %08p\n",this));
-+ FXTRACE((100,"Base1::Base1 at %p\n",this));
- a=1;
- }
-
-@@ -180,12 +180,12 @@
- FXIMPLEMENT(Base2,FXObject,Base2Map,ARRAYNUMBER(Base2Map))
-
- Base2::Base2(){
-- FXTRACE((100,"Base2::Base2 at %08p\n",this));
-+ FXTRACE((100,"Base2::Base2 at %p\n",this));
- b=2;
- }
-
- long Base2::onCmdBase2(FXObject*,FXSelector,void*){
-- FXTRACE((100,"Base2::onCmdBase2 at %08p b=%d\n",this,b));
-+ FXTRACE((100,"Base2::onCmdBase2 at %p b=%d\n",this,b));
- return 1;
- }
-
-@@ -198,7 +198,7 @@
-
-
- Base3::Base3(){
-- FXTRACE((100,"Base3::Base3 at %08p\n",this));
-+ FXTRACE((100,"Base3::Base3 at %p\n",this));
- c=3;
- }
-
-@@ -219,12 +219,12 @@
- FXIMPLEMENT(TwoBaseOne,Base2,TwoBaseOneMap,ARRAYNUMBER(TwoBaseOneMap))
-
- TwoBaseOne::TwoBaseOne(){
-- FXTRACE((100,"TwoBaseOne::TwoBaseOne at %08p\n",this));
-+ FXTRACE((100,"TwoBaseOne::TwoBaseOne at %p\n",this));
- d=4;
- }
-
- long TwoBaseOne::onCmdTwoBaseOne(FXObject*,FXSelector,void*){
-- FXTRACE((100,"TwoBaseOne::onCmdTwoBaseOne at %08p d=%d\n",this,d));
-+ FXTRACE((100,"TwoBaseOne::onCmdTwoBaseOne at %p d=%d\n",this,d));
- return 1;
- }
-
-@@ -242,12 +242,12 @@
- FXIMPLEMENT(TwoBaseTwo,Base2,TwoBaseTwoMap,ARRAYNUMBER(TwoBaseTwoMap))
-
- TwoBaseTwo::TwoBaseTwo(){
-- FXTRACE((100,"TwoBaseTwo::TwoBaseTwo at %08p\n",this));
-+ FXTRACE((100,"TwoBaseTwo::TwoBaseTwo at %p\n",this));
- e=4;
- }
-
- long TwoBaseTwo::onCmdTwoBaseTwo(FXObject*,FXSelector,void*){
-- FXTRACE((100,"TwoBaseTwo::onCmdTwoBaseTwo at %08p e=%d\n",this,e));
-+ FXTRACE((100,"TwoBaseTwo::onCmdTwoBaseTwo at %p e=%d\n",this,e));
- return 1;
- }
-
-@@ -268,12 +268,12 @@
- FXIMPLEMENT(ThreeBase,TwoBaseOne,ThreeBaseMap,ARRAYNUMBER(ThreeBaseMap))
-
- ThreeBase::ThreeBase(){
-- FXTRACE((100,"ThreeBase::ThreeBase at %08p\n",this));
-+ FXTRACE((100,"ThreeBase::ThreeBase at %p\n",this));
- f=5;
- }
-
- long ThreeBase::onCmdThreeBase(FXObject*,FXSelector,void*){
-- FXTRACE((100,"ThreeBase::onCmdThreeBase at %08p f=%d\n",this,f));
-+ FXTRACE((100,"ThreeBase::onCmdThreeBase at %p f=%d\n",this,f));
- return 1;
- }
-
---- lib/FXDebugTarget.cpp.orig 2013-09-18 15:36:13.000000000 +0200
-+++ lib/FXDebugTarget.cpp 2013-09-18 15:40:25.000000000 +0200
-@@ -169,7 +169,7 @@
- FXuint msid=FXSELID(sel);
- FXASSERT(ARRAYNUMBER(messageTypeName)==SEL_LAST);
- if(sender!=lastsender || sel!=lastsel){
-- fxmessage("\nTYPE:%-23s ID:%-5d SENDER: %-15s PTR: 0x%08p #%-4d",type<SEL_LAST?messageTypeName[type]:"ILLEGAL",msid,sender?sender->getClassName():"NULL",ptr,1);
-+ fxmessage("\nTYPE:%-23s ID:%-5d SENDER: %-15s PTR: %p #%-4d",type<SEL_LAST?messageTypeName[type]:"ILLEGAL",msid,sender?sender->getClassName():"NULL",ptr,1);
- lastsender=sender;
- lastsel=sel;
- count=1;
---- tests/thread.cpp.orig 2013-09-18 16:13:12.000000000 +0200
-+++ tests/thread.cpp 2013-09-18 16:20:51.000000000 +0200
-@@ -61,7 +61,7 @@
- // Generate jobs
- FXint Producer::run(){
- FXint job=0;
-- fxmessage("producer start on cpus: %llb\n",affinity());
-+ fxmessage("producer start on cpus: %lx\n",affinity());
- FXuint seed=1013904223u;
- for(FXint g=0; g<groups; ++g){
- for(FXint c=0; c<count; c++){
--- adie/FindInFiles.cpp.orig 2013-09-18 16:55:45.000000000 +0200
+++ adie/FindInFiles.cpp 2013-09-18 16:57:42.000000000 +0200
@@ -434,7 +434,7 @@
@@ -245,12 +55,3 @@
}
else if(strcmp(argv[arg],"-W")==0 || strcmp(argv[arg],"--wait")==0){
wait=1;
-@@ -198,7 +198,7 @@
- }
- }
-
-- fxmessage("main thread %p\n",FXThread::current());
-+ fxmessage("main thread %lx\n",FXThread::current());
-
- nthreads=minimum;
-
diff --git a/x11-toolkits/fox17/files/patch-warnings b/x11-toolkits/fox17/files/patch-warnings
index f6fafb06e86c..7b34d0ece75d 100644
--- a/x11-toolkits/fox17/files/patch-warnings
+++ b/x11-toolkits/fox17/files/patch-warnings
@@ -9,173 +9,3 @@
#define __restrict __restrict__
#else
#define __restrict
---- lib/FXFileList.cpp.orig 2013-09-18 15:41:48.000000000 +0200
-+++ lib/FXFileList.cpp 2013-09-18 15:42:11.000000000 +0200
-@@ -1474,7 +1474,7 @@
- }
-
- // Update item information
-- label.format("%s\t%s\t%lld\t%s\t%s\t%s\t%s\t%s",name.text(),extension.text(),newitem->size,modtm.text(),usrid.text(),grpid.text(),attrs.text(),lnknm.text());
-+ label.format("%s\t%s\t%lld\t%s\t%s\t%s\t%s\t%s",name.text(),extension.text(),static_cast<long long>(newitem->size),modtm.text(),usrid.text(),grpid.text(),attrs.text(),lnknm.text());
-
- // New label
- newitem->setText(label);
---- pathfinder/PathFinder.cpp.orig 2013-09-18 16:59:43.000000000 +0200
-+++ pathfinder/PathFinder.cpp 2013-09-18 17:10:58.000000000 +0200
-@@ -1051,7 +1051,7 @@
- selectedModeBits[15]+=FXBIT(mode,15); // SVTX
- selectedSpace+=size;
- selectedCount+=1;
-- FXTRACE((10,"selected : %3d %7lld [%3d %7lld] %s\n",index,size,selectedCount,selectedSpace,filelist->getItemFilename(index).text()));
-+ FXTRACE((10,"selected : %3d %7lld [%3d %7lld] %s\n",index,static_cast<long long>(size),selectedCount,static_cast<long long>(selectedSpace),filelist->getItemFilename(index).text()));
- return 1;
- }
-
-@@ -1075,7 +1075,7 @@
- selectedModeBits[15]-=FXBIT(mode,15); // SVTX
- selectedSpace-=size;
- selectedCount-=1;
-- FXTRACE((10,"deselected: %3d %7lld [%3d %7lld] %s\n",index,size,selectedCount,selectedSpace,filelist->getItemFilename(index).text()));
-+ FXTRACE((10,"deselected: %3d %7lld [%3d %7lld] %s\n",index,static_cast<long long>(size),selectedCount,static_cast<long long>(selectedSpace),filelist->getItemFilename(index).text()));
- return 1;
- }
-
-@@ -1088,7 +1088,7 @@
- }
- totalSpace+=filelist->getItemSize(index);
- totalCount+=1;
-- FXTRACE((10,"inserted : %3d %7lld [%3d %7lld] %s\n",index,filelist->getItemSize(index),totalCount,totalSpace,filelist->getItemFilename(index).text()));
-+ FXTRACE((10,"inserted : %3d %7lld [%3d %7lld] %s\n",index,static_cast<long long>(filelist->getItemSize(index)),totalCount,static_cast<long long>(totalSpace),filelist->getItemFilename(index).text()));
- return 1;
- }
-
-@@ -1101,7 +1101,7 @@
- }
- totalSpace-=filelist->getItemSize(index);
- totalCount-=1;
-- FXTRACE((10,"deleted : %3d %7lld [%3d %7lld] %s\n",index,filelist->getItemSize(index),totalCount,totalSpace,filelist->getItemFilename(index).text()));
-+ FXTRACE((10,"deleted : %3d %7lld [%3d %7lld] %s\n",index,static_cast<long long>(filelist->getItemSize(index)),totalCount,static_cast<long long>(totalSpace),filelist->getItemFilename(index).text()));
- return 1;
- }
-
-@@ -1368,15 +1368,15 @@
- info.format(tr("File \"%s\" -> \"%s\"."),filelist->getItemFilename(currentitem).text(),filelist->getItemText(currentitem).section('\t',7).text());
- }
- else{
-- info.format(tr("File \"%s\" [%s] (%lld bytes)."),filelist->getItemFilename(currentitem).text(),filelist->getItemText(currentitem).section('\t',1).text(),filelist->getItemSize(currentitem));
-+ info.format(tr("File \"%s\" [%s] (%lld bytes)."),filelist->getItemFilename(currentitem).text(),filelist->getItemText(currentitem).section('\t',1).text(),static_cast<long long>(filelist->getItemSize(currentitem)));
- }
- }
- }
- else if(1<=selectedCount){
-- info.format(tr("Selected %d items (%lld bytes)."),selectedCount,selectedSpace);
-+ info.format(tr("Selected %d items (%lld bytes)."),selectedCount,static_cast<long long>(selectedSpace));
- }
- else{
-- info.format(tr("Total %d items (%lld bytes)."),totalCount,totalSpace);
-+ info.format(tr("Total %d items (%lld bytes)."),totalCount,static_cast<long long>(totalSpace));
- }
- sender->handle(this,FXSEL(SEL_COMMAND,ID_SETSTRINGVALUE),(void*)&info);
- return 1;
---- tests/parallel.cpp.orig 2013-09-18 16:31:08.000000000 +0200
-+++ tests/parallel.cpp 2013-09-18 16:55:25.000000000 +0200
-@@ -60,8 +59,8 @@
- fxmessage("%p: npull=%ld\n",self(),npull);
- fxmessage("%p: ncros=%ld\n",self(),ncros);
- fxmessage("%p: niter=%ld\n",self(),niter);
-- fxmessage("%p: avg=%lld\n",self(),tot/npush);
-- fxmessage("%p: ticks=%lld (%.16lfs) tick/push=%.2lf push/s=%.2lf\n",self(),tot,FXdouble(tot)*0.33333333333333E-9,FXdouble(tot)/FXdouble(npush),FXdouble(npush)/(FXdouble(tot)*0.33333333333333E-9));
-+ fxmessage("%p: avg=%lld\n",self(),static_cast<long long>(tot/npush));
-+ fxmessage("%p: ticks=%lld (%.16lfs) tick/push=%.2lf push/s=%.2lf\n",self(),static_cast<long long>(tot),FXdouble(tot)*0.33333333333333E-9,FXdouble(tot)/FXdouble(npush),FXdouble(npush)/(FXdouble(tot)*0.33333333333333E-9));
- return 0;
- }
-
-@@ -70,18 +69,18 @@
- // Churn cpu for a random while, then return
- void churn(){
- FXRandom random(fxgetticks());
-- fxmessage("Churn start th %p core %d/%d\n",FXThread::current(),FXThread::processor(),FXThread::processors());
-+ fxmessage("Churn start th %08lx core %d/%d\n",FXThread::current(),FXThread::processor(),FXThread::processors());
- while(random.randDouble()<0.99999999){ }
-- fxmessage("Churn done th %p code %d/%d\n",FXThread::current(),FXThread::processor(),FXThread::processors());
-+ fxmessage("Churn done th %08lx code %d/%d\n",FXThread::current(),FXThread::processor(),FXThread::processors());
- }
-
-
- // Loop through index range
- void looping(FXint i){
- FXRandom random(fxgetticks());
-- fxmessage("Looping %03d start th %p\n",i,FXThread::current());
-+ fxmessage("Looping %03d start th %08lx\n",i,FXThread::current());
- while(random.randDouble()<0.9999999){ }
-- fxmessage("Looping %03d done th %p\n",i,FXThread::current());
-+ fxmessage("Looping %03d done th %08lx\n",i,FXThread::current());
- }
-
-
-@@ -278,7 +278,7 @@
-
- fxmessage("running: %d!\n",pool.getRunningThreads());
-
-- fxmessage("main thread %p\n",FXThread::current());
-+ fxmessage("main thread %lx\n",FXThread::current());
-
-
- // 8-way parallelism if you got the cores
---- tests/codecs.cpp.orig 2013-09-18 17:56:47.000000000 +0200
-+++ tests/codecs.cpp 2013-09-18 16:26:21.000000000 +0200
-@@ -44,7 +44,7 @@
- // Test roundtrip for codec
- void roundtriptest(FXTextCodec *codec){
- FXchar dst[32],src[32];
-- FXint c,n,i,j;
-+ FXint i,j;
- FXwchar wc;
- printf("Roundtrip test for: %s..\n",codec->name());
- for(i=0; i<256; i++){
-@@ -61,8 +61,7 @@
- // Test utf8 roundtrip for codec
- void utf8roundtriptest(FXTextCodec *codec){
- FXchar dst[32],src[32];
-- FXint c,n,i,j;
-- FXwchar wc;
-+ FXint n,i,j;
- printf("UTF8 Roundtrip test for: %s..\n",codec->name());
- for(i=0; i<256; i++){
- src[0]=i;
-@@ -100,7 +99,7 @@
- if(w1!=w2 || m!=4 || n!=1) printf("%06X: Problem: %06X\n",w1,w2);
- }
- end=fxgetticks();
-- printf("4-Byte case: %lld ticks/character\n",(end-beg)/(0x110000-0x10000));
-+ printf("4-Byte case: %lld ticks/character\n",static_cast<long long>((end-beg)/(0x110000-0x10000)));
-
- // Test utf for codes of 3 bytes
- beg=fxgetticks();
-@@ -110,7 +109,7 @@
- if(w1!=w2 || m!=3 || n!=1) printf("%06X: Problem: %06X\n",w1,w2);
- }
- end=fxgetticks();
-- printf("3-Byte case: %lld ticks/character\n",(end-beg)/(0x10000-0x800));
-+ printf("3-Byte case: %lld ticks/character\n",static_cast<long long>((end-beg)/(0x10000-0x800)));
-
- // Test utf for codes of 2 bytes
- beg=fxgetticks();
-@@ -120,7 +119,7 @@
- if(w1!=w2 || m!=2 || n!=1) printf("%06X: Problem: %06X\n",w1,w2);
- }
- end=fxgetticks();
-- printf("2-Byte case: %lld ticks/character\n",(end-beg)/(0x800-0x80));
-+ printf("2-Byte case: %lld ticks/character\n",static_cast<long long>((end-beg)/(0x800-0x80)));
-
- // Test utf for codes of 1 byte
- beg=fxgetticks();
-@@ -130,7 +129,7 @@
- if(w1!=w2 || m!=1 || n!=1) printf("%06X: Problem: %06X\n",w1,w2);
- }
- end=fxgetticks();
-- printf("1-Byte case: %lld ticks/character\n",(end-beg)/0x80);
-+ printf("1-Byte case: %lld ticks/character\n",static_cast<long long>((end-beg)/0x80));
-
- /*
-
diff --git a/x11-toolkits/fox17/pkg-plist b/x11-toolkits/fox17/pkg-plist
index c9831061a6da..4e3bf2f81404 100644
--- a/x11-toolkits/fox17/pkg-plist
+++ b/x11-toolkits/fox17/pkg-plist
@@ -106,6 +106,7 @@ include/fox-%%MAJORVER%%/FXDelegator.h
include/fox-%%MAJORVER%%/FXDial.h
include/fox-%%MAJORVER%%/FXDialogBox.h
include/fox-%%MAJORVER%%/FXDict.h
+include/fox-%%MAJORVER%%/FXDictionary.h
include/fox-%%MAJORVER%%/FXDir.h
include/fox-%%MAJORVER%%/FXDirBox.h
include/fox-%%MAJORVER%%/FXDirDialog.h
@@ -177,6 +178,7 @@ include/fox-%%MAJORVER%%/FXJP2Icon.h
include/fox-%%MAJORVER%%/FXJP2Image.h
include/fox-%%MAJORVER%%/FXJPGIcon.h
include/fox-%%MAJORVER%%/FXJPGImage.h
+include/fox-%%MAJORVER%%/FXJSON.h
include/fox-%%MAJORVER%%/FXKOI8RCodec.h
include/fox-%%MAJORVER%%/FXKnob.h
include/fox-%%MAJORVER%%/FXLFQueue.h