aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2019-10-10 19:02:28 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2019-10-10 19:02:28 +0000
commitc0558c205f4e0ac4a0f45f900c60f64fc93942fd (patch)
tree14c2563f6ad3e0944d6932fe5fcf39d2e8f1fb3f /x11-toolkits
parent3eb157d399e5fecfa3b8e1ddfd9ee59f8cba9d7c (diff)
downloadports-c0558c205f4e0ac4a0f45f900c60f64fc93942fd.tar.gz
ports-c0558c205f4e0ac4a0f45f900c60f64fc93942fd.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt5-gui/Makefile5
-rw-r--r--x11-toolkits/qt5-gui/files/patch-src_platformsupport_devicediscovery_qdevicediscovery__static.cpp14
-rw-r--r--x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevkeyboard_qevdevkeyboard__defaultmap__p.h14
-rw-r--r--x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevkeyboard_qevdevkeyboardhandler.cpp14
-rw-r--r--x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevmouse_qevdevmousehandler.cpp15
-rw-r--r--x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevtablet_qevdevtablethandler.cpp14
-rw-r--r--x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevtouch_qevdevtouchhandler.cpp14
7 files changed, 88 insertions, 2 deletions
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index a5f5c1ce79f7..d636ed747e7c 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -2,14 +2,15 @@
PORTNAME= gui
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits graphics
PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt graphical user interface module
-BUILD_DEPENDS= at-spi2-core>=0:accessibility/at-spi2-core
+BUILD_DEPENDS= at-spi2-core>=0:accessibility/at-spi2-core \
+ ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libevdev.so:devel/libevdev \
libfontconfig.so:x11-fonts/fontconfig \
diff --git a/x11-toolkits/qt5-gui/files/patch-src_platformsupport_devicediscovery_qdevicediscovery__static.cpp b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_devicediscovery_qdevicediscovery__static.cpp
new file mode 100644
index 000000000000..395718a25555
--- /dev/null
+++ b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_devicediscovery_qdevicediscovery__static.cpp
@@ -0,0 +1,14 @@
+--- src/platformsupport/devicediscovery/qdevicediscovery_static.cpp.orig 2019-06-13 04:18:18 UTC
++++ src/platformsupport/devicediscovery/qdevicediscovery_static.cpp
+@@ -47,11 +47,7 @@
+ #include <QLoggingCategory>
+ #include <QtCore/private/qcore_unix_p.h>
+
+-#ifdef Q_OS_FREEBSD
+-#include <dev/evdev/input.h>
+-#else
+ #include <linux/input.h>
+-#endif
+ #include <fcntl.h>
+
+ /* android (and perhaps some other linux-derived stuff) don't define everything
diff --git a/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevkeyboard_qevdevkeyboard__defaultmap__p.h b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevkeyboard_qevdevkeyboard__defaultmap__p.h
new file mode 100644
index 000000000000..b17544dad911
--- /dev/null
+++ b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevkeyboard_qevdevkeyboard__defaultmap__p.h
@@ -0,0 +1,14 @@
+--- src/platformsupport/input/evdevkeyboard/qevdevkeyboard_defaultmap_p.h.orig 2019-06-13 04:18:18 UTC
++++ src/platformsupport/input/evdevkeyboard/qevdevkeyboard_defaultmap_p.h
+@@ -52,11 +52,7 @@
+ //
+
+ #include "qnamespace.h"
+-#ifdef Q_OS_FREEBSD
+-#include <dev/evdev/input.h>
+-#else
+ #include "linux/input.h"
+-#endif
+
+ // no QT_BEGIN_NAMESPACE, since we include it internally...
+
diff --git a/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevkeyboard_qevdevkeyboardhandler.cpp b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevkeyboard_qevdevkeyboardhandler.cpp
new file mode 100644
index 000000000000..bdc2a37893ef
--- /dev/null
+++ b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevkeyboard_qevdevkeyboardhandler.cpp
@@ -0,0 +1,14 @@
+--- src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp.orig 2019-06-13 04:18:18 UTC
++++ src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp
+@@ -52,11 +52,7 @@
+ #include <QtGui/private/qguiapplication_p.h>
+ #include <QtGui/private/qinputdevicemanager_p.h>
+
+-#ifdef Q_OS_FREEBSD
+-#include <dev/evdev/input.h>
+-#else
+ #include <linux/input.h>
+-#endif
+
+ QT_BEGIN_NAMESPACE
+
diff --git a/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevmouse_qevdevmousehandler.cpp b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevmouse_qevdevmousehandler.cpp
new file mode 100644
index 000000000000..e2fae07899dd
--- /dev/null
+++ b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevmouse_qevdevmousehandler.cpp
@@ -0,0 +1,15 @@
+--- src/platformsupport/input/evdevmouse/qevdevmousehandler.cpp.orig 2019-06-13 04:18:18 UTC
++++ src/platformsupport/input/evdevmouse/qevdevmousehandler.cpp
+@@ -53,12 +53,8 @@
+
+ #include <errno.h>
+
+-#ifdef Q_OS_FREEBSD
+-#include <dev/evdev/input.h>
+-#else
+ #include <linux/kd.h>
+ #include <linux/input.h>
+-#endif
+
+ #define TEST_BIT(array, bit) (array[bit/8] & (1<<(bit%8)))
+
diff --git a/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevtablet_qevdevtablethandler.cpp b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevtablet_qevdevtablethandler.cpp
new file mode 100644
index 000000000000..7889a22e2ec3
--- /dev/null
+++ b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevtablet_qevdevtablethandler.cpp
@@ -0,0 +1,14 @@
+--- src/platformsupport/input/evdevtablet/qevdevtablethandler.cpp.orig 2019-06-13 04:18:18 UTC
++++ src/platformsupport/input/evdevtablet/qevdevtablethandler.cpp
+@@ -45,11 +45,7 @@
+ #include <QLoggingCategory>
+ #include <QtCore/private/qcore_unix_p.h>
+ #include <qpa/qwindowsysteminterface.h>
+-#ifdef Q_OS_FREEBSD
+-#include <dev/evdev/input.h>
+-#else
+ #include <linux/input.h>
+-#endif
+
+ QT_BEGIN_NAMESPACE
+
diff --git a/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevtouch_qevdevtouchhandler.cpp b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevtouch_qevdevtouchhandler.cpp
new file mode 100644
index 000000000000..2a0f875f10ff
--- /dev/null
+++ b/x11-toolkits/qt5-gui/files/patch-src_platformsupport_input_evdevtouch_qevdevtouchhandler.cpp
@@ -0,0 +1,14 @@
+--- src/platformsupport/input/evdevtouch/qevdevtouchhandler.cpp.orig 2019-06-13 04:18:18 UTC
++++ src/platformsupport/input/evdevtouch/qevdevtouchhandler.cpp
+@@ -49,11 +49,7 @@
+ #include <QtCore/private/qcore_unix_p.h>
+ #include <QtGui/private/qhighdpiscaling_p.h>
+ #include <QtGui/private/qguiapplication_p.h>
+-#ifdef Q_OS_FREEBSD
+-#include <dev/evdev/input.h>
+-#else
+ #include <linux/input.h>
+-#endif
+
+ #include <math.h>
+