aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 07:17:31 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 07:17:31 +0000
commitc76cf46929051f9dd322487d888c82f104026e6d (patch)
treef415aeddadc6782b1474ebd88710bfa86cf08711 /x11-toolkits
parentb7bdcd418e7aca3dd98409e16a4c4ae9bc289d02 (diff)
downloadports-c76cf46929051f9dd322487d888c82f104026e6d.tar.gz
ports-c76cf46929051f9dd322487d888c82f104026e6d.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/bakery/Makefile13
-rw-r--r--x11-toolkits/gnome--/Makefile10
-rw-r--r--x11-toolkits/gnome--/pkg-plist2
-rw-r--r--x11-toolkits/py-gnome/Makefile14
-rw-r--r--x11-toolkits/py-gnome/pkg-plist1
-rw-r--r--x11-toolkits/py-gnome2/Makefile14
-rw-r--r--x11-toolkits/py-gnome2/pkg-plist1
7 files changed, 16 insertions, 39 deletions
diff --git a/x11-toolkits/bakery/Makefile b/x11-toolkits/bakery/Makefile
index f62ff9698646..ea15d2d0b8e6 100644
--- a/x11-toolkits/bakery/Makefile
+++ b/x11-toolkits/bakery/Makefile
@@ -13,23 +13,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ade@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
- gtkmm-1.2.1:${PORTSDIR}/x11-toolkits/gtk-- \
- gnomemm-1.1.3:${PORTSDIR}/x11-toolkits/gnome--
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+LIB_DEPENDS= gtkmm.1:${PORTSDIR}/x11-toolkits/gtk-- \
+ gnomemm.3:${PORTSDIR}/x11-toolkits/gnome--
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
+USE_GNOME= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GTK_CONFIG="${GTK_CONFIG}" \
- GLIB_CONFIG="${GLIB_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
diff --git a/x11-toolkits/gnome--/Makefile b/x11-toolkits/gnome--/Makefile
index 37e6b153624d..145f4a6b049e 100644
--- a/x11-toolkits/gnome--/Makefile
+++ b/x11-toolkits/gnome--/Makefile
@@ -12,17 +12,15 @@ MASTER_SITES= http://download.sourceforge.net/gtkmm/
MAINTAINER= erich@tacni.net
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
- gtkmm-1.2.1:${PORTSDIR}/x11-toolkits/gtk--
+LIB_DEPENDS= gtkmm.1:${PORTSDIR}/x11-toolkits/gtk--
BUILD_DEPENDS= m4:${PORTSDIR}/devel/m4
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_GNOME= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS+=--enable-static=yes
-CONFIGURE_ENV+= GTK_CONFIG="${GTK_CONFIG}"
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-static
.include <bsd.port.mk>
diff --git a/x11-toolkits/gnome--/pkg-plist b/x11-toolkits/gnome--/pkg-plist
index 4e2bee137e99..ca525423501f 100644
--- a/x11-toolkits/gnome--/pkg-plist
+++ b/x11-toolkits/gnome--/pkg-plist
@@ -112,8 +112,8 @@ include/gnome--/procbar.h
include/gnome--/propertybox.h
include/gnome--/stock.h
include/gnome--/types.h
-lib/libgnomemm-1.1.so.3
lib/libgnomemm.a
lib/libgnomemm.so
+lib/libgnomemm.so.3
@dirrm include/gnome--/private
@dirrm include/gnome--
diff --git a/x11-toolkits/py-gnome/Makefile b/x11-toolkits/py-gnome/Makefile
index cb480197e7ea..4828e386d5ed 100644
--- a/x11-toolkits/py-gnome/Makefile
+++ b/x11-toolkits/py-gnome/Makefile
@@ -15,30 +15,22 @@ DISTNAME= gnome-python-${PORTVERSION}
MAINTAINER= nectar@FreeBSD.org
BUILD_DEPENDS= ${PYGTK_DEP}
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- capplet.4:${PORTSDIR}/sysutils/gnomecontrolcenter \
- panel_applet.4:${PORTSDIR}/x11/gnomecore
+LIB_DEPENDS= glade.4:${PORTSDIR}/devel/libglade
RUN_DEPENDS= ${PYGTK_DEP}
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_GMAKE= yes
USE_PYTHON= yes
+USE_GNOME= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure pygnome/configure pygtk/configure
-CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}"
CONFIGURE_ARGS= --with-python=${PYTHON_CMD} \
--with-gnome-config=${X11BASE}/bin/gnome-config
EG_SRC_DIR= ${WRKSRC}/pygnome/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gnome
PYGTK_DEP= ${PYTHON_LIBDIR}/site-packages/_gtkmodule.so:${PORTSDIR}/x11-toolkits/py-gtk
-PLIST_COMPLETE= ${PKGDIR}/PLIST
.if !defined(NOPORTDOCS)
-PLIST= ${PLIST_COMPLETE}
post-install:
${MKDIR} ${EG_DST_DIR}
${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EG_DST_DIR} -xvf -
@@ -50,7 +42,7 @@ PLIST= ${WRKDIR}/PLIST.nodocs
pre-install:
${RM} -f ${PLIST}
${GREP} -E -v '^(@dirrm )?(share/examples/)|(share/doc/)' \
- ${PLIST_COMPLETE} > ${PLIST}
+ ${PKGDIR}/PLIST > ${PLIST}
.endif
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-gnome/pkg-plist b/x11-toolkits/py-gnome/pkg-plist
index f134b3e7f6fb..6b0255a25157 100644
--- a/x11-toolkits/py-gnome/pkg-plist
+++ b/x11-toolkits/py-gnome/pkg-plist
@@ -1,5 +1,6 @@
lib/%%PYTHON_VERSION%%/site-packages/_appletmodule.so
lib/%%PYTHON_VERSION%%/site-packages/_cappletmodule.so
+lib/%%PYTHON_VERSION%%/site-packages/_gladegnomemodule.so
lib/%%PYTHON_VERSION%%/site-packages/_gnomemodule.so
lib/%%PYTHON_VERSION%%/site-packages/_gnomeuimodule.so
lib/%%PYTHON_VERSION%%/site-packages/_gtkxmhtmlmodule.so
diff --git a/x11-toolkits/py-gnome2/Makefile b/x11-toolkits/py-gnome2/Makefile
index cb480197e7ea..4828e386d5ed 100644
--- a/x11-toolkits/py-gnome2/Makefile
+++ b/x11-toolkits/py-gnome2/Makefile
@@ -15,30 +15,22 @@ DISTNAME= gnome-python-${PORTVERSION}
MAINTAINER= nectar@FreeBSD.org
BUILD_DEPENDS= ${PYGTK_DEP}
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- capplet.4:${PORTSDIR}/sysutils/gnomecontrolcenter \
- panel_applet.4:${PORTSDIR}/x11/gnomecore
+LIB_DEPENDS= glade.4:${PORTSDIR}/devel/libglade
RUN_DEPENDS= ${PYGTK_DEP}
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_GMAKE= yes
USE_PYTHON= yes
+USE_GNOME= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure pygnome/configure pygtk/configure
-CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}"
CONFIGURE_ARGS= --with-python=${PYTHON_CMD} \
--with-gnome-config=${X11BASE}/bin/gnome-config
EG_SRC_DIR= ${WRKSRC}/pygnome/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gnome
PYGTK_DEP= ${PYTHON_LIBDIR}/site-packages/_gtkmodule.so:${PORTSDIR}/x11-toolkits/py-gtk
-PLIST_COMPLETE= ${PKGDIR}/PLIST
.if !defined(NOPORTDOCS)
-PLIST= ${PLIST_COMPLETE}
post-install:
${MKDIR} ${EG_DST_DIR}
${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EG_DST_DIR} -xvf -
@@ -50,7 +42,7 @@ PLIST= ${WRKDIR}/PLIST.nodocs
pre-install:
${RM} -f ${PLIST}
${GREP} -E -v '^(@dirrm )?(share/examples/)|(share/doc/)' \
- ${PLIST_COMPLETE} > ${PLIST}
+ ${PKGDIR}/PLIST > ${PLIST}
.endif
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-gnome2/pkg-plist b/x11-toolkits/py-gnome2/pkg-plist
index f134b3e7f6fb..6b0255a25157 100644
--- a/x11-toolkits/py-gnome2/pkg-plist
+++ b/x11-toolkits/py-gnome2/pkg-plist
@@ -1,5 +1,6 @@
lib/%%PYTHON_VERSION%%/site-packages/_appletmodule.so
lib/%%PYTHON_VERSION%%/site-packages/_cappletmodule.so
+lib/%%PYTHON_VERSION%%/site-packages/_gladegnomemodule.so
lib/%%PYTHON_VERSION%%/site-packages/_gnomemodule.so
lib/%%PYTHON_VERSION%%/site-packages/_gnomeuimodule.so
lib/%%PYTHON_VERSION%%/site-packages/_gtkxmhtmlmodule.so