aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-09-25 03:34:43 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-09-25 03:34:43 +0000
commit3007ae14cb30263a94de1638ec0febc09cf96412 (patch)
treef1ab98006cebbae24b0a7e286409795a2c51519c /x11-toolkits
parent393ec322270d7e031da1edcc513d7f39cedfa3cc (diff)
downloadports-3007ae14cb30263a94de1638ec0febc09cf96412.tar.gz
ports-3007ae14cb30263a94de1638ec0febc09cf96412.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/etox/Makefile1
-rw-r--r--x11-toolkits/etox/files/patch-src_Etox_private.h31
-rw-r--r--x11-toolkits/etox/files/patch-src_srtle_Etox_style.h26
-rw-r--r--x11-toolkits/etox/files/patch-src_style_etox_style_private.h16
4 files changed, 74 insertions, 0 deletions
diff --git a/x11-toolkits/etox/Makefile b/x11-toolkits/etox/Makefile
index c6aac56d3bec..741ad66c0204 100644
--- a/x11-toolkits/etox/Makefile
+++ b/x11-toolkits/etox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= etox
PORTVERSION= 0.9.0.004
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= http://enlightenment.freedesktop.org/files/
diff --git a/x11-toolkits/etox/files/patch-src_Etox_private.h b/x11-toolkits/etox/files/patch-src_Etox_private.h
new file mode 100644
index 000000000000..fcb59a3f640f
--- /dev/null
+++ b/x11-toolkits/etox/files/patch-src_Etox_private.h
@@ -0,0 +1,31 @@
+--- src/Etox_private.h.orig Mon May 24 09:34:45 2004
++++ src/Etox_private.h Sun Sep 25 11:00:18 2005
+@@ -6,6 +6,28 @@
+ #include <Edb.h>
+ #include "style/Etox_Style.h"
+
++#include <stdlib.h>
++#include <stdio.h>
++#include <string.h>
++#include <limits.h>
++
++#define IF_FREE(ptr) if (ptr) free(ptr); ptr = NULL;
++#define FREE(ptr) free(ptr); ptr = NULL;
++
++#define CHECK_PARAM_POINTER_RETURN(sparam, param, ret) \
++ if (!(param)) \
++ { \
++ fprintf(stderr, "Fix: func: %s, param: %s\n", __FUNCTION__, sparam); \
++ return ret; \
++ }
++
++#define CHECK_PARAM_POINTER(sparam, param) \
++ if (!(param)) \
++ { \
++ fprintf(stderr, "Fix: func: %s, param: %s\n", __FUNCTION__, sparam); \
++ return; \
++ }
++
+ typedef enum _etox_flags Etox_Flags;
+ enum _etox_flags
+ {
diff --git a/x11-toolkits/etox/files/patch-src_srtle_Etox_style.h b/x11-toolkits/etox/files/patch-src_srtle_Etox_style.h
new file mode 100644
index 000000000000..e2c71d4b2e30
--- /dev/null
+++ b/x11-toolkits/etox/files/patch-src_srtle_Etox_style.h
@@ -0,0 +1,26 @@
+--- src/style/Etox_Style.h.orig Sun Sep 25 10:48:36 2005
++++ src/style/Etox_Style.h Sun Sep 25 11:01:48 2005
+@@ -4,6 +4,23 @@
+ #include <Edb.h>
+ #include <Evas.h>
+
++#define IF_FREE(ptr) if (ptr) free(ptr); ptr = NULL;
++#define FREE(ptr) free(ptr); ptr = NULL;
++
++#define CHECK_PARAM_POINTER_RETURN(sparam, param, ret) \
++ if (!(param)) \
++ { \
++ fprintf(stderr, "Fix: func: %s, param: %s\n", __FUNCTION__, sparam); \
++ return ret; \
++ }
++
++#define CHECK_PARAM_POINTER(sparam, param) \
++ if (!(param)) \
++ { \
++ fprintf(stderr, "Fix: func: %s, param: %s\n", __FUNCTION__, sparam); \
++ return; \
++ }
++
+
+ #ifdef __cplusplus
+ extern "C"
diff --git a/x11-toolkits/etox/files/patch-src_style_etox_style_private.h b/x11-toolkits/etox/files/patch-src_style_etox_style_private.h
new file mode 100644
index 000000000000..728a39c4a020
--- /dev/null
+++ b/x11-toolkits/etox/files/patch-src_style_etox_style_private.h
@@ -0,0 +1,16 @@
+--- src/style/etox_style_private.h.orig Sun Sep 25 11:07:21 2005
++++ src/style/etox_style_private.h Sun Sep 25 11:02:44 2005
+@@ -2,7 +2,13 @@
+ #define _ETOX_STYLE_PRIVATE_H
+
+ #include <Ecore.h>
++#include <Ecore_Data.h>
+ #include "Etox_Style.h"
++
++#include <stdlib.h>
++#include <stdio.h>
++#include <string.h>
++#include <limits.h>
+
+ /*
+ * The etox_style holds all information necessary for display and layout of the text