aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-10-28 17:49:34 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-10-28 17:49:34 +0000
commit8c82d344e7afe30c049a9672bd66d992e1ec954a (patch)
tree830f295c77cdbd141be59b3e61d99dbea3986f33 /x11-toolkits
parent17af7fcdb93e62a857f94735fc197b23f3f9c03f (diff)
downloadports-8c82d344e7afe30c049a9672bd66d992e1ec954a.tar.gz
ports-8c82d344e7afe30c049a9672bd66d992e1ec954a.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtkextra2/Makefile2
-rw-r--r--x11-toolkits/gtkextra2/files/patch-Makefile.in16
-rw-r--r--x11-toolkits/gtkextra2/files/patch-gtkcolorcombo.c11
3 files changed, 28 insertions, 1 deletions
diff --git a/x11-toolkits/gtkextra2/Makefile b/x11-toolkits/gtkextra2/Makefile
index 04efbe1a0741..bd0284e55fd1 100644
--- a/x11-toolkits/gtkextra2/Makefile
+++ b/x11-toolkits/gtkextra2/Makefile
@@ -16,7 +16,7 @@ COMMENT= A useful widget set complementary to GTK+ 2.0
USE_GNOME= gtk20 gnomehack
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:22
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
LATEST_LINK= gtkextra2
diff --git a/x11-toolkits/gtkextra2/files/patch-Makefile.in b/x11-toolkits/gtkextra2/files/patch-Makefile.in
new file mode 100644
index 000000000000..04ee2fb51548
--- /dev/null
+++ b/x11-toolkits/gtkextra2/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- gtkextra/Makefile.in.orig 2011-10-27 00:29:46.287956897 +0200
++++ gtkextra/Makefile.in 2011-10-27 00:30:31.199394384 +0200
+@@ -1028,11 +1028,11 @@
+ $(libgtkextra_x11_2_0_la_OBJECTS) $(libgtkextra_linux_fb_2_0_la_OBJECTS) $(libgtkextra_win32_2_0_la_OBJECTS): ${gtkextra_built_public_sources} ${gtkextra_built_private_headers}
+
+ $(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
++ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
+ && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+ $(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
++ ( glib-genmarshal --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
+ && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
+ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+
diff --git a/x11-toolkits/gtkextra2/files/patch-gtkcolorcombo.c b/x11-toolkits/gtkextra2/files/patch-gtkcolorcombo.c
new file mode 100644
index 000000000000..459335b5475e
--- /dev/null
+++ b/x11-toolkits/gtkextra2/files/patch-gtkcolorcombo.c
@@ -0,0 +1,11 @@
+--- gtkextra/gtkcolorcombo.c.orig 2011-10-27 00:08:40.655552360 +0200
++++ gtkextra/gtkcolorcombo.c 2011-10-27 00:09:03.934648236 +0200
+@@ -146,7 +146,7 @@
+ GTK_CLASS_TYPE(object_class),
+ GTK_SIGNAL_OFFSET(GtkColorComboClass,
+ changed),
+- gtkextra_VOID__INT_BOXED,
++ gtkextra_VOID__BOXED_BOXED,
+ GTK_TYPE_NONE,
+ 2, GTK_TYPE_INT, GDK_TYPE_COLOR);
+