aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-04-18 20:10:24 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-04-18 20:10:24 +0000
commit96e17924c3e21e6a5b6ac4d47e7082018ad37b8e (patch)
tree0380c67629af17b1bbafcd94dfc7c8f6fce23e12 /x11-toolkits
parent4680dc73b0222aeca4844d4e219984b080ccf4e6 (diff)
downloadports-96e17924c3e21e6a5b6ac4d47e7082018ad37b8e.tar.gz
ports-96e17924c3e21e6a5b6ac4d47e7082018ad37b8e.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox12/Makefile40
1 files changed, 8 insertions, 32 deletions
diff --git a/x11-toolkits/fox12/Makefile b/x11-toolkits/fox12/Makefile
index 79c014b590af..27d1f08afbbb 100644
--- a/x11-toolkits/fox12/Makefile
+++ b/x11-toolkits/fox12/Makefile
@@ -41,6 +41,14 @@ MAN1= shutterbug.1 reswrap.1
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+OPTIONS= XFT "Enable Xft support" on \
+ SHM "Enable Shared Memory support" on \
+ CUPS "Enable CUPS support" off \
+ DEBUG "Build with DEBUG support" off \
+ FOX_APPLICATIONS "Install sample applications" off \
+ OPTIMIZED_CXXFLAGS "Enable additional optimizations" off \
+ PROFILING "Build with PROFILING support" off
+
.include <bsd.port.pre.mk>
##
@@ -119,36 +127,4 @@ post-patch:
${WRKSRC}/Makefile.in
.endif
-pre-everything::
-.if !defined(WITH_OPTIMIZED_CXXFLAGS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can enable additional compilation optimizations'
- @${ECHO_MSG} 'by defining WITH_OPTIMIZED_CXXFLAGS'
-.endif
-.if !defined(WITH_CUPS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can enable CUPS support by defining WITH_CUPS'
-.endif
-.if !defined(WITH_DEBUG)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can build DEBUG support by defining WITH_DEBUG'
-.endif
-.if !defined(WITH_FOX_APPLICATIONS)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can install FOX sample applications by defining WITH_FOX_APPLICATIONS"
-.endif
-.if !defined(WITH_PROFILING)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can build PROFILING support by defining WITH_PROFILING'
-.endif
-.if !defined(WITHOUT_SHM)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can disable Shared Memory support by defining WITHOUT_SHM'
-.endif
-.if !defined(WITHOUT_XFT)
- @${ECHO_MSG}
- @${ECHO_MSG} 'You can disable Xft support by defining WITHOUT_XFT'
-.endif
- @${ECHO_MSG}
-
.include <bsd.port.post.mk>