aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-07-24 15:59:51 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-07-24 15:59:51 +0000
commit1780acf1bf594e43200c3266b04bd49756b89bd1 (patch)
tree6e29a044f2511c304a63a1dc284ae897b7b3cb65 /x11-toolkits
parent165386783ba6531e28f1bca60cd816a88a4f565f (diff)
downloadports-1780acf1bf594e43200c3266b04bd49756b89bd1.tar.gz
ports-1780acf1bf594e43200c3266b04bd49756b89bd1.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qwt5-designerplugin/Makefile40
-rw-r--r--x11-toolkits/qwt5-designerplugin/distinfo3
-rw-r--r--x11-toolkits/qwt5-designerplugin/files/patch-designer__designer.pro (renamed from x11-toolkits/qwt5/files/patch-designer__designer.pro)0
-rw-r--r--x11-toolkits/qwt5-designerplugin/pkg-descr9
-rw-r--r--x11-toolkits/qwt5-designerplugin/pkg-plist3
-rw-r--r--x11-toolkits/qwt5/Makefile12
-rw-r--r--x11-toolkits/qwt5/pkg-plist3
-rw-r--r--x11-toolkits/qwt6-designerplugin/Makefile40
-rw-r--r--x11-toolkits/qwt6-designerplugin/distinfo3
-rw-r--r--x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro (renamed from x11-toolkits/qwt6/files/patch-designer__designer.pro)0
-rw-r--r--x11-toolkits/qwt6-designerplugin/pkg-descr9
-rw-r--r--x11-toolkits/qwt6-designerplugin/pkg-plist3
-rw-r--r--x11-toolkits/qwt6/Makefile12
-rw-r--r--x11-toolkits/qwt6/pkg-plist3
14 files changed, 112 insertions, 28 deletions
diff --git a/x11-toolkits/qwt5-designerplugin/Makefile b/x11-toolkits/qwt5-designerplugin/Makefile
new file mode 100644
index 000000000000..3a6e11e33500
--- /dev/null
+++ b/x11-toolkits/qwt5-designerplugin/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: qwt5-designerplugin
+# Date created: 2010-07-02
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qwt
+PORTVERSION= 5.2.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= SF
+PKGNAMESUFFIX= -designerplugin
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Qt Designer plugin for Qwt
+
+LIB_DEPENDS= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
+
+USE_QT_VER= 4
+QT_COMPONENTS= designer moc_build qmake_build rcc_build
+USE_BZIP2= yes
+USE_GMAKE= yes
+QMAKE_ARGS+= -unix -recursive CONFIG+=QwtDesigner \
+ PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
+HAS_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+STRIP_FILES= ${QT_PLUGINDIR_REL}/designer/libqwt_designer_plugin.so
+
+CONFIGURE_WRKSRC= ${WRKSRC}/designer
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+
+do-configure:
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS})
+
+post-install:
+ ${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qwt5-designerplugin/distinfo b/x11-toolkits/qwt5-designerplugin/distinfo
new file mode 100644
index 000000000000..9000501966ef
--- /dev/null
+++ b/x11-toolkits/qwt5-designerplugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (qwt-5.2.1.tar.bz2) = 4a595b8db0ec3856b117836c1d60cb27
+SHA256 (qwt-5.2.1.tar.bz2) = e2b8bb755404cb3dc99e61f3e2d7262152193488f5fbe88524eb698e11ac569f
+SIZE (qwt-5.2.1.tar.bz2) = 1926453
diff --git a/x11-toolkits/qwt5/files/patch-designer__designer.pro b/x11-toolkits/qwt5-designerplugin/files/patch-designer__designer.pro
index 030bd15ede67..030bd15ede67 100644
--- a/x11-toolkits/qwt5/files/patch-designer__designer.pro
+++ b/x11-toolkits/qwt5-designerplugin/files/patch-designer__designer.pro
diff --git a/x11-toolkits/qwt5-designerplugin/pkg-descr b/x11-toolkits/qwt5-designerplugin/pkg-descr
new file mode 100644
index 000000000000..78ec23cc8883
--- /dev/null
+++ b/x11-toolkits/qwt5-designerplugin/pkg-descr
@@ -0,0 +1,9 @@
+The Qwt library contains GUI Components and utility classes which
+are primarily useful for programs with a technical background.
+Beside a 2D plot widget it provides scales, sliders, dials, compasses,
+thermometers, wheels and knobs to control or display values, arrays,
+or ranges of type double.
+
+This port installs Qt Designer plugin for Qwt library version 5.
+
+WWW: http://qwt.sourceforge.net
diff --git a/x11-toolkits/qwt5-designerplugin/pkg-plist b/x11-toolkits/qwt5-designerplugin/pkg-plist
new file mode 100644
index 000000000000..14e3c7ba01c2
--- /dev/null
+++ b/x11-toolkits/qwt5-designerplugin/pkg-plist
@@ -0,0 +1,3 @@
+%%QT_PLUGINDIR_REL%%/designer/libqwt_designer_plugin.so
+@dirrmtry %%QT_PLUGINDIR_REL%%/designer
+@dirrmtry %%QT_PLUGINDIR_REL%%
diff --git a/x11-toolkits/qwt5/Makefile b/x11-toolkits/qwt5/Makefile
index e519216c895e..a310a08dced7 100644
--- a/x11-toolkits/qwt5/Makefile
+++ b/x11-toolkits/qwt5/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qwt
PORTVERSION= 5.2.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= SF
@@ -22,22 +23,11 @@ HAS_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= DESIGNER_PLUGIN "Install plugin for Qt Designer" on
-
STRIP_FILES= lib/libqwt.so.${PORTVERSION}
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.man>
-.if !defined(WITHOUT_DESIGNER_PLUGIN)
-QT_COMPONENTS+= designer rcc_build
-QMAKE_ARGS+= CONFIG+=QwtDesigner PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
-PLIST_SUB+= DESIGNER_PLUGIN=""
-STRIP_FILES+= ${QT_PLUGINDIR_REL}/designer/libqwt_designer_plugin.so
-.else
-PLIST_SUB+= DESIGNER_PLUGIN="@comment "
-.endif
-
do-configure:
(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS})
diff --git a/x11-toolkits/qwt5/pkg-plist b/x11-toolkits/qwt5/pkg-plist
index d33fc8c81624..2f43f7ab18bc 100644
--- a/x11-toolkits/qwt5/pkg-plist
+++ b/x11-toolkits/qwt5/pkg-plist
@@ -72,7 +72,6 @@ lib/libqwt.so
lib/libqwt.so.5
lib/libqwt.so.5.2
lib/libqwt.so.5.2.1
-%%DESIGNER_PLUGIN%%lib/qt4/plugins/designer/libqwt_designer_plugin.so
%%PORTDOCS%%%%DOCSDIR%%/analogclock.png
%%PORTDOCS%%%%DOCSDIR%%/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_abstract_scale-members.html
@@ -728,6 +727,4 @@ lib/libqwt.so.5.2.1
%%PORTDOCS%%%%DOCSDIR%%/tab_r.gif
%%PORTDOCS%%%%DOCSDIR%%/tabs.css
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%DESIGNER_PLUGIN%%@dirrmtry %%QT_PLUGINDIR_REL%%/designer
-%%DESIGNER_PLUGIN%%@dirrmtry %%QT_PLUGINDIR_REL%%
@dirrm include/qwt
diff --git a/x11-toolkits/qwt6-designerplugin/Makefile b/x11-toolkits/qwt6-designerplugin/Makefile
new file mode 100644
index 000000000000..3a6e11e33500
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: qwt5-designerplugin
+# Date created: 2010-07-02
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qwt
+PORTVERSION= 5.2.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= SF
+PKGNAMESUFFIX= -designerplugin
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Qt Designer plugin for Qwt
+
+LIB_DEPENDS= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
+
+USE_QT_VER= 4
+QT_COMPONENTS= designer moc_build qmake_build rcc_build
+USE_BZIP2= yes
+USE_GMAKE= yes
+QMAKE_ARGS+= -unix -recursive CONFIG+=QwtDesigner \
+ PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
+HAS_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+STRIP_FILES= ${QT_PLUGINDIR_REL}/designer/libqwt_designer_plugin.so
+
+CONFIGURE_WRKSRC= ${WRKSRC}/designer
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+
+do-configure:
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS})
+
+post-install:
+ ${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qwt6-designerplugin/distinfo b/x11-toolkits/qwt6-designerplugin/distinfo
new file mode 100644
index 000000000000..9000501966ef
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (qwt-5.2.1.tar.bz2) = 4a595b8db0ec3856b117836c1d60cb27
+SHA256 (qwt-5.2.1.tar.bz2) = e2b8bb755404cb3dc99e61f3e2d7262152193488f5fbe88524eb698e11ac569f
+SIZE (qwt-5.2.1.tar.bz2) = 1926453
diff --git a/x11-toolkits/qwt6/files/patch-designer__designer.pro b/x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro
index 030bd15ede67..030bd15ede67 100644
--- a/x11-toolkits/qwt6/files/patch-designer__designer.pro
+++ b/x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro
diff --git a/x11-toolkits/qwt6-designerplugin/pkg-descr b/x11-toolkits/qwt6-designerplugin/pkg-descr
new file mode 100644
index 000000000000..78ec23cc8883
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/pkg-descr
@@ -0,0 +1,9 @@
+The Qwt library contains GUI Components and utility classes which
+are primarily useful for programs with a technical background.
+Beside a 2D plot widget it provides scales, sliders, dials, compasses,
+thermometers, wheels and knobs to control or display values, arrays,
+or ranges of type double.
+
+This port installs Qt Designer plugin for Qwt library version 5.
+
+WWW: http://qwt.sourceforge.net
diff --git a/x11-toolkits/qwt6-designerplugin/pkg-plist b/x11-toolkits/qwt6-designerplugin/pkg-plist
new file mode 100644
index 000000000000..14e3c7ba01c2
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/pkg-plist
@@ -0,0 +1,3 @@
+%%QT_PLUGINDIR_REL%%/designer/libqwt_designer_plugin.so
+@dirrmtry %%QT_PLUGINDIR_REL%%/designer
+@dirrmtry %%QT_PLUGINDIR_REL%%
diff --git a/x11-toolkits/qwt6/Makefile b/x11-toolkits/qwt6/Makefile
index e519216c895e..a310a08dced7 100644
--- a/x11-toolkits/qwt6/Makefile
+++ b/x11-toolkits/qwt6/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qwt
PORTVERSION= 5.2.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= SF
@@ -22,22 +23,11 @@ HAS_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-OPTIONS= DESIGNER_PLUGIN "Install plugin for Qt Designer" on
-
STRIP_FILES= lib/libqwt.so.${PORTVERSION}
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.man>
-.if !defined(WITHOUT_DESIGNER_PLUGIN)
-QT_COMPONENTS+= designer rcc_build
-QMAKE_ARGS+= CONFIG+=QwtDesigner PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
-PLIST_SUB+= DESIGNER_PLUGIN=""
-STRIP_FILES+= ${QT_PLUGINDIR_REL}/designer/libqwt_designer_plugin.so
-.else
-PLIST_SUB+= DESIGNER_PLUGIN="@comment "
-.endif
-
do-configure:
(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS})
diff --git a/x11-toolkits/qwt6/pkg-plist b/x11-toolkits/qwt6/pkg-plist
index d33fc8c81624..2f43f7ab18bc 100644
--- a/x11-toolkits/qwt6/pkg-plist
+++ b/x11-toolkits/qwt6/pkg-plist
@@ -72,7 +72,6 @@ lib/libqwt.so
lib/libqwt.so.5
lib/libqwt.so.5.2
lib/libqwt.so.5.2.1
-%%DESIGNER_PLUGIN%%lib/qt4/plugins/designer/libqwt_designer_plugin.so
%%PORTDOCS%%%%DOCSDIR%%/analogclock.png
%%PORTDOCS%%%%DOCSDIR%%/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_abstract_scale-members.html
@@ -728,6 +727,4 @@ lib/libqwt.so.5.2.1
%%PORTDOCS%%%%DOCSDIR%%/tab_r.gif
%%PORTDOCS%%%%DOCSDIR%%/tabs.css
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%DESIGNER_PLUGIN%%@dirrmtry %%QT_PLUGINDIR_REL%%/designer
-%%DESIGNER_PLUGIN%%@dirrmtry %%QT_PLUGINDIR_REL%%
@dirrm include/qwt