aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-05-22 05:42:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-05-22 05:42:59 +0000
commit17c05e71119132188dbddb9f440a33e7124eba94 (patch)
tree9117d7717abd5f0c2a6cb7158c353a50223f2677 /x11-toolkits
parente358967718c7115068b7179c0d27a3206bb37f06 (diff)
downloadports-17c05e71119132188dbddb9f440a33e7124eba94.tar.gz
ports-17c05e71119132188dbddb9f440a33e7124eba94.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/soqt/Makefile26
-rw-r--r--x11-toolkits/soqt/pkg-plist6
2 files changed, 18 insertions, 14 deletions
diff --git a/x11-toolkits/soqt/Makefile b/x11-toolkits/soqt/Makefile
index f69737db7a73..cf3be78f5161 100644
--- a/x11-toolkits/soqt/Makefile
+++ b/x11-toolkits/soqt/Makefile
@@ -12,25 +12,29 @@ DIST_SUBDIR= KDE
MAINTAINER= ports@FreeBSD.org
COMMENT= Qt4 toolkit library for Coin
-LIB_DEPENDS= Coin.61:${PORTSDIR}/graphics/Coin
+LICENSE= GPLv2
-USE_AUTOTOOLS= libtool
-USES= pathfix gmake
-USE_QT4= corelib opengl moc_build
-CPPFLAGS+= -I${QT_INCDIR} -I${QT_INCDIR}/Qt -I${LOCALBASE}/include
-LDFLAGS+= -L${QT_LIBDIR} -L${LOCALBASE}/lib
+LIB_DEPENDS= libCoin.so:${PORTSDIR}/graphics/Coin
+USES= gmake libtool pathfix pkgconfig
+USE_QT4= corelib opengl moc_build
+QT_NONSTANDARD= yes
+USE_GL= gl
GNU_CONFIGURE= yes
-CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
-
+CONFIGURE_ENV= QTDIR="${QT_PREFIX}" MOC="${MOC}"
CONFIGURE_ARGS= --with-pthread=yes --with-coin=${LOCALBASE} \
--with-qt=${QT_LIBDIR}
USE_LDCONFIG= yes
-MAN1= soqt-config.1
+CPPFLAGS+= -I${QT_INCDIR}/Qt -I${QT_INCDIR} -I${LOCALBASE}/include
+LDFLAGS+= -L${QT_LIBDIR} -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/LDFLAGS/s| $$sim_ac_coin_ldflags|| ; \
+ /CXXFLAGS/s| -fno-for-scope||' ${WRKSRC}/configure
-NO_STAGE= yes
post-install:
- @${TOUCH} ${PREFIX}/include/Inventor/Qt/engines/.keep_me
+ @${TOUCH} ${STAGEDIR}${PREFIX}/include/Inventor/Qt/engines/.keep_me
.include <bsd.port.mk>
diff --git a/x11-toolkits/soqt/pkg-plist b/x11-toolkits/soqt/pkg-plist
index 3b4fdd9be7f8..1be463bc32c9 100644
--- a/x11-toolkits/soqt/pkg-plist
+++ b/x11-toolkits/soqt/pkg-plist
@@ -23,11 +23,11 @@ include/Inventor/Qt/viewers/SoQtPlaneViewer.h
include/Inventor/Qt/viewers/SoQtViewer.h
include/Inventor/Qt/widgets/SoQtPopupMenu.h
include/Inventor/Qt/widgets/SoQtThumbWheel.h
-lib/libSoQt.a
-lib/libSoQt.la
lib/libSoQt.so
-lib/libSoQt.so.25
+lib/libSoQt.so.20
+lib/libSoQt.so.20.5.0
libdata/pkgconfig/SoQt.pc
+man/man1/soqt-config.1.gz
share/Coin/conf/soqt-default.cfg
share/aclocal/soqt.m4
@dirrmtry share/Coin/conf