aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-28 08:31:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-28 08:31:56 +0000
commit44e0ec92e93b6a4db60b8750ea02af75a1357783 (patch)
tree8659aeb2fc43b099c1a77369a295cc7f4fd19aff /x11-toolkits
parentb7d1e54746019ecd3195b4f264bfa01a531f8667 (diff)
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnustep-gui/Makefile52
-rw-r--r--x11-toolkits/gnustep-gui/pkg-plist11
2 files changed, 27 insertions, 36 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index 4824c4409dd1..ea3a2052d667 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -10,21 +10,24 @@ MASTER_SITE_SUBDIR= core
MAINTAINER= theraven@FreeBSD.org
COMMENT= GNUstep GUI library
-.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
-BUILD_DEPENDS+= texi2pdf:${PORTSDIR}/print/texinfo
-.endif
-LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
-LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
-LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile
-LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libflite.a:${PORTSDIR}/audio/flite
-
LICENSE_COMB= multi
LICENSE= GPLv3 LGPL3
+OPTIONS_DEFINE= DOCS CUPS ASPELL
+OPTIONS_DEFAULT= CUPS
+OPTIONS_SUB= yes
+
+DOCS_BUILD_DEPENDS= texi2html:${PORTSDIR}/textproc/texi2html \
+ texi2pdf:${PORTSDIR}/print/texinfo
+
+LIB_DEPENDS+= libtiff.so:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libgif.so:${PORTSDIR}/graphics/giflib
+LIB_DEPENDS+= libsndfile.so:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS+= libao.so:${PORTSDIR}/audio/libao
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libflite.a:${PORTSDIR}/audio/flite
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-tiff-library=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-tiff-include=${LOCALBASE}/include
@@ -42,7 +45,6 @@ USE_GNUSTEP_INSTALL= yes
USE_GNUSTEP_BASE= yes
USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
USE_XORG= x11 xt
-NOPORTDOCS= dvi2pdf broken
EXTRA_PATCHES+= ${FILESDIR}/GNUmakefile.patch
EXTRA_PATCHES+= ${FILESDIR}/GNUmakefile.speech.patch
@@ -50,35 +52,23 @@ EXTRA_PATCHES+= ${FILESDIR}/AudioOutputSink.m.patch
MAKE_FLAGS+= OPTFLAG="${CFLAGS}"
MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
BREAKS_IF_PEDANTIC= yes
+
PLIST_SUB+= BASEVERSION=${PORTVERSION:C/[.][0-9]*$//1}
ADDITIONAL_INCLUDE_DIRS+= -I${LOCALBASE}/include/libpng15
-.if !defined(WITHOUT_CUPS)
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
-PLIST_SUB+= WITH_CUPS=""
-.else
-PLIST_SUB+= WITH_CUPS="@comment "
-.endif
-
-ASPELL_PORT?= textproc/aspell
-.if !defined(WITHOUT_ASPELL)
-LIB_DEPENDS+= aspell:${PORTSDIR}/${ASPELL_PORT}
-PLIST_SUB+= WITH_ASPELL=""
-.else
-PLIST_SUB+= WITH_ASPELL="@comment "
-.endif
+CUPS_CONFIGURE_ENABLE= cups
+CUPS_LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
+ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
+ASPELL_CONFIGURE_ENABLE= aspell
-NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e "s|libpng/png.h|png.h|" ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e "s|doc=no|doc=yes|" ${WRKSRC}/GNUmakefile
pre-configure:
.for file in config.guess config.sub install-sh
@${CP} ${GNUSTEP_PREFIX}/System/Library/Makefiles/${file} ${WRKSRC}
.endfor
-.if !defined(NOPORTDOCS)
- ${REINPLACE_CMD} -e "s|doc=no|doc=yes|" ${WRKSRC}/GNUmakefile
-.endif
.include <bsd.port.mk>
diff --git a/x11-toolkits/gnustep-gui/pkg-plist b/x11-toolkits/gnustep-gui/pkg-plist
index 68519874c144..40175aae6a10 100644
--- a/x11-toolkits/gnustep-gui/pkg-plist
+++ b/x11-toolkits/gnustep-gui/pkg-plist
@@ -5,9 +5,9 @@ GNUstep/System/Applications/GSSpeechServer.app/stamp.make
GNUstep/System/Library/Bundles/AudioOutput.nssound/AudioOutput
GNUstep/System/Library/Bundles/AudioOutput.nssound/Resources/Info-gnustep.plist
GNUstep/System/Library/Bundles/AudioOutput.nssound/stamp.make
-%%WITH_CUPS%%GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
-%%WITH_CUPS%%GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle/Resources/Info-gnustep.plist
-%%WITH_CUPS%%GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle/stamp.make
+%%CUPS%%GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle/GSCUPS
+%%CUPS%%GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle/Resources/Info-gnustep.plist
+%%CUPS%%GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle/stamp.make
GNUstep/System/Library/Bundles/GSPrinting/GSLPR.bundle/GSLPR
GNUstep/System/Library/Bundles/GSPrinting/GSLPR.bundle/Resources/Info-gnustep.plist
GNUstep/System/Library/Bundles/GSPrinting/GSLPR.bundle/stamp.make
@@ -69,6 +69,7 @@ GNUstep/System/Library/ColorPickers/WheelPicker.bundle/stamp.make
%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/General/General.igsdoc
%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/General/OpenStepCompliance.html
%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/General/dependencies
+%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/ProgrammingManual/AppKit.pdf
%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/ProgrammingManual/AppKit.html
%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/ProgrammingManual/AppKit_1.html
%%PORTDOCS%%GNUstep/System/Library/Documentation/Developer/Gui/ProgrammingManual/AppKit_10.html
@@ -866,8 +867,8 @@ GNUstep/System/Library/Images/common_Info.tiff
@dirrm GNUstep/System/Library/Bundles/Sndfile.nssound
@dirrm GNUstep/System/Library/Bundles/GSPrinting/GSLPR.bundle/Resources
@dirrm GNUstep/System/Library/Bundles/GSPrinting/GSLPR.bundle
-%%WITH_CUPS%%@dirrm GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle/Resources
-%%WITH_CUPS%%@dirrm GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle
+%%CUPS%%@dirrm GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle/Resources
+%%CUPS%%@dirrm GNUstep/System/Library/Bundles/GSPrinting/GSCUPS.bundle
@dirrm GNUstep/System/Library/Bundles/GSPrinting
@dirrm GNUstep/System/Library/Bundles/AudioOutput.nssound/Resources
@dirrm GNUstep/System/Library/Bundles/AudioOutput.nssound