aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-08-18 07:06:39 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-08-18 07:06:39 +0000
commit5c0330b1d9b6d9dd617eefba69bfa6a2f6f73fcf (patch)
tree986c5cf709faab8f6c0b03050acc59bcc5b9f217 /x11-toolkits
parente8fea2e4e79c9102261c668e01acaf5215e76b62 (diff)
downloadports-5c0330b1d9b6d9dd617eefba69bfa6a2f6f73fcf.tar.gz
ports-5c0330b1d9b6d9dd617eefba69bfa6a2f6f73fcf.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/bakery/Makefile6
-rw-r--r--x11-toolkits/bakery/files/patch-bakery::App::App.h19
-rw-r--r--x11-toolkits/bakery/files/patch-bakery::App::App_WithDoc.h21
-rw-r--r--x11-toolkits/bakery/files/patch-bakery::View::View_Composite.h11
-rw-r--r--x11-toolkits/bakery/files/patch-ltmain.sh51
5 files changed, 56 insertions, 52 deletions
diff --git a/x11-toolkits/bakery/Makefile b/x11-toolkits/bakery/Makefile
index 400bb408a0bc..d97478a4a0ea 100644
--- a/x11-toolkits/bakery/Makefile
+++ b/x11-toolkits/bakery/Makefile
@@ -23,10 +23,14 @@ LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2 \
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intltool gnometarget
+USE_GNOME= gnomeprefix gnomehack lthack intltool gnometarget
USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/x11-toolkits/bakery/files/patch-bakery::App::App.h b/x11-toolkits/bakery/files/patch-bakery::App::App.h
new file mode 100644
index 000000000000..d64c2714ca29
--- /dev/null
+++ b/x11-toolkits/bakery/files/patch-bakery::App::App.h
@@ -0,0 +1,19 @@
+--- bakery/App/App.h.orig Thu Jan 2 08:46:33 2003
++++ bakery/App/App.h Wed Aug 18 15:50:32 2004
+@@ -93,6 +93,7 @@
+ // virtual void bring_to_front() = 0;
+ //Signal handlers:
+
++public:
+ //Menus:
+ virtual void on_menu_file_new();
+ virtual void on_menu_file_close();
+@@ -109,7 +110,7 @@
+
+ virtual void on_about_close();
+
+-
++protected:
+ //GUI abstractions:
+ virtual void ui_hide() = 0;
+ virtual void ui_bring_to_front() = 0;
diff --git a/x11-toolkits/bakery/files/patch-bakery::App::App_WithDoc.h b/x11-toolkits/bakery/files/patch-bakery::App::App_WithDoc.h
new file mode 100644
index 000000000000..b9d54c0bb660
--- /dev/null
+++ b/x11-toolkits/bakery/files/patch-bakery::App::App_WithDoc.h
@@ -0,0 +1,21 @@
+--- bakery/App/App_WithDoc.h.orig Wed Aug 18 15:44:34 2004
++++ bakery/App/App_WithDoc.h Wed Aug 18 15:45:06 2004
+@@ -90,7 +90,7 @@
+ static void session_save_document_history();
+
+ //Signal handlers:
+-
++public:
+ //Menu items:
+ virtual void on_menu_file_open();
+ virtual void on_menu_file_open_recent(guint index); //use with SigC::bind.
+@@ -102,7 +102,8 @@
+ virtual void on_menu_edit_copy();
+ virtual void on_menu_edit_paste();
+ virtual void on_menu_edit_clear();
+-
++
++protected:
+ //Document:
+ ///Update visual status.
+ virtual void on_document_modified();
diff --git a/x11-toolkits/bakery/files/patch-bakery::View::View_Composite.h b/x11-toolkits/bakery/files/patch-bakery::View::View_Composite.h
new file mode 100644
index 000000000000..cf0636cd8b5b
--- /dev/null
+++ b/x11-toolkits/bakery/files/patch-bakery::View::View_Composite.h
@@ -0,0 +1,11 @@
+--- bakery/View/View_Composite.h.orig Wed Aug 18 15:45:34 2004
++++ bakery/View/View_Composite.h Wed Aug 18 15:45:52 2004
+@@ -49,7 +49,7 @@
+ //This should be unnecessary.
+ if(pView)
+ {
+- pView->set_document(get_document());
++ pView->set_document(type_view::get_document());
+
+ //Add it to the list of child views:
+ m_vecViews.push_back(pView);
diff --git a/x11-toolkits/bakery/files/patch-ltmain.sh b/x11-toolkits/bakery/files/patch-ltmain.sh
deleted file mode 100644
index 1d5a5c7b87e1..000000000000
--- a/x11-toolkits/bakery/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Fri Sep 12 14:51:51 2003
-+++ ltmain.sh Sun Sep 21 17:49:07 2003
-@@ -1280,7 +1280,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1290,8 +1290,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3000,6 +3008,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5428,10 +5439,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"