aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-03-08 15:55:19 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-03-08 15:55:19 +0000
commite3dbe531558f13d6c4fabafc93069a363c138233 (patch)
treed621aa33d1171430aecd24c67727e632208b09f1 /x11-toolkits
parent52474e7bba66c72e0ebb2575489324aa31fbe348 (diff)
downloadports-e3dbe531558f13d6c4fabafc93069a363c138233.tar.gz
ports-e3dbe531558f13d6c4fabafc93069a363c138233.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/xmhtml/Makefile14
-rw-r--r--x11-toolkits/xmhtml/distinfo4
-rw-r--r--x11-toolkits/xmhtml/files/patch-Makefile70
-rw-r--r--x11-toolkits/xmhtml/files/patch-book_Makefile (renamed from x11-toolkits/xmhtml/files/patch-book__Makefile)6
-rw-r--r--x11-toolkits/xmhtml/files/patch-examples_Makefile (renamed from x11-toolkits/xmhtml/files/patch-examples__Makefile)8
-rw-r--r--x11-toolkits/xmhtml/files/patch-http_Makefile (renamed from x11-toolkits/xmhtml/files/patch-http__Makefile)4
-rw-r--r--x11-toolkits/xmhtml/files/patch-lib_Makefile (renamed from x11-toolkits/xmhtml/files/patch-lib__Makefile)20
-rw-r--r--x11-toolkits/xmhtml/files/patch-lib_Motif_Makefile6
-rw-r--r--x11-toolkits/xmhtml/files/patch-lib_common_Makefile6
-rw-r--r--x11-toolkits/xmhtml/files/patch-lib_gtk_Makefile6
-rw-r--r--x11-toolkits/xmhtml/files/patch-tools_Makefile (renamed from x11-toolkits/xmhtml/files/patch-tools__Makefile)8
11 files changed, 75 insertions, 77 deletions
diff --git a/x11-toolkits/xmhtml/Makefile b/x11-toolkits/xmhtml/Makefile
index 95aa4d357507..6abc364fb57d 100644
--- a/x11-toolkits/xmhtml/Makefile
+++ b/x11-toolkits/xmhtml/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= XmHTML
-PORTVERSION= 1.1.9
-PORTREVISION= 3
+PORTVERSION= 1.1.10
CATEGORIES= x11-toolkits www
MASTER_SITES= SF/${PORTNAME:tl}
@@ -33,14 +32,13 @@ do-install:
${STAGEDIR}${PREFIX}/include/XmHTML
do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- @(cd ${WRKSRC}/html && ${FIND} . ! -name "*Makefile*" | \
- ${CPIO} --quiet -dump -R ${SHAREOWN}:${SHAREGRP} \
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/html && ${COPYTREE_SHARE} . \
${STAGEDIR}${DOCSDIR})
do-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} "book contrib examples" \
- ${STAGEDIR}${EXAMPLESDIR} "! -type d ! -name Makefile"
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "book contrib examples" \
+ ${STAGEDIR}${EXAMPLESDIR} "! -name Makefile"
.include <bsd.port.mk>
diff --git a/x11-toolkits/xmhtml/distinfo b/x11-toolkits/xmhtml/distinfo
index 14bf54bf5d0b..87354e822f89 100644
--- a/x11-toolkits/xmhtml/distinfo
+++ b/x11-toolkits/xmhtml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (XmHTML-1.1.9.tgz) = 264da26421a612e4cb05a75d874785b843afe2ce7598260ec19cedeb32628da2
-SIZE (XmHTML-1.1.9.tgz) = 1349743
+SHA256 (XmHTML-1.1.10.tgz) = 379542629958d70a61a49955f44833e215c82500d6bdcc12d4e7252deefe0435
+SIZE (XmHTML-1.1.10.tgz) = 1348388
diff --git a/x11-toolkits/xmhtml/files/patch-Makefile b/x11-toolkits/xmhtml/files/patch-Makefile
index f346dfa37d9c..759cfb729d34 100644
--- a/x11-toolkits/xmhtml/files/patch-Makefile
+++ b/x11-toolkits/xmhtml/files/patch-Makefile
@@ -1,37 +1,37 @@
---- Makefile.orig
+--- Makefile.orig 2015-10-26 10:22:55 UTC
+++ Makefile
-@@ -46,7 +46,7 @@
- # remove the examples directory from this line.
- # If you want to build the XmHTML tutorial examples, add the book directory.
-
+@@ -61,7 +61,7 @@ HAVE_XPM=1
+ ifeq ($(OS),IRIX)
+ SUBDIRS= lib http
+ else
-SUBDIRS= lib http examples tools
+SUBDIRS= lib http
+ endif
# some common definitions
- #
-@@ -61,7 +61,7 @@
- RANLIB= ranlib
+@@ -81,7 +81,7 @@ RANLIB = ranlib
+ endif
- SHELL = /bin/sh
--MAKE = make
-+#MAKE = make
+ SHELL = /bin/sh
+-MAKE = make
++#MAKE = make
# change this to makedepend if your system doesn't have gcc
MAKEDEPEND= gccmakedep
-@@ -70,9 +70,9 @@
+@@ -99,9 +99,9 @@ endif
# Compiler Settings #
# #
#####################
--CC = gcc
--CFLAGS = -g -funroll-loops -Wall -pipe -ansi $(EXTRA_CFLAGS)
--LDFLAGS =
-+#CC = gcc
-+#CFLAGS = -g -funroll-loops -Wall -pipe -ansi $(EXTRA_CFLAGS)
-+#LDFLAGS =
+-CC = gcc
+-CFLAGS = -funroll-loops -Wall -pipe -ansi -fPIC $(OS_CFLAGS) $(EXTRA_CFLAGS)
+-LDFLAGS =
++#CC = gcc
++#CFLAGS = -funroll-loops -Wall -pipe -ansi -fPIC $(OS_CFLAGS) $(EXTRA_CFLAGS)
++#LDFLAGS =
# The following flags are *very* usefull if you are getting unresolved
# references to functions in libraries that you *know* to exist.
-@@ -125,7 +125,7 @@
+@@ -160,7 +160,7 @@ endif
# HAVE_LIBZ => zlib.h
ZLIBINC =
@@ -40,16 +40,16 @@
# Image libraries
# No need to add -lXpm if you need to include it with LIBS below
-@@ -136,7 +136,7 @@
+@@ -171,7 +171,7 @@ IMAGEINCLUDES = $(ZLIBINC)
# HAVE_LIBZ => libz (and possibly libm)
ZLIBLIB = -lz -lm
-IMAGELIBS = -ljpeg -lpng $(ZLIBLIB)
-+IMAGELIBS = `libpng-config --libs` -L${LOCALBASE}/lib -ljpeg $(ZLIBLIB)
++IMAGELIBS = `libpng-config --libs` -L${LOCALBASE}/lib -ljpeg $(LDFLAGS)
# It might be troublesome to know what the correct defines are for your
# system. A possible set of defines for some OS's is given below. Pick
-@@ -176,7 +176,7 @@
+@@ -211,7 +211,7 @@ IMAGELIBS = -ljpeg -lpng $(ZLIBLIB)
# Add -DDEBUG to enable selective debug output (see the file DEBUGGING for more
# info).
#
@@ -58,21 +58,21 @@
$(EXTRA_CPPFLAGS) \
$(IMAGEDEFINES) \
$(XFT_DEFINES)
-@@ -186,7 +186,7 @@
-
- # Platform specific includes
- ifeq ($(PLATFORM),Motif)
--PLATFORMINC=-I../../include/XmHTML -I/usr/X11R6/include -I/usr/include/freetype2
-+PLATFORMINC=-I../../include/XmHTML `pkg-config --cflags xft`
+@@ -224,7 +224,7 @@ ifeq ($(TOOLKIT),Motif)
+ ifeq ($(OS),IRIX)
+ TOOLKITINC=-I../../include/XmHTML -I/usr/include
+ else
+-TOOLKITINC=-I../../include/XmHTML -I/usr/X11R6/include -I/usr/include/freetype2
++TOOLKITINC=-I../../include/XmHTML `pkg-config --cflags xft`
+ endif
+ else
+ ifeq ($(TOOLKIT),gtk)
+@@ -250,7 +250,7 @@ ifeq ($(TOOLKIT),Motif)
+ ifeq ($(OS),IRIX)
+ LIBDIR = -L/usr/lib32
else
- ifeq ($(PLATFORM),gtk)
- PLATFORMINC=\
-@@ -209,7 +209,7 @@
- # Motif version (default)
- ifeq ($(PLATFORM),Motif)
-
-LIBDIR = -L/usr/X11R6/lib
+LIBDIR = -L${LOCALBASE}/lib
+ endif
# This is what is required under Linux (Motif 2.0.1).
# Your mileage may vary.
- LIBS = -lXm -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE
diff --git a/x11-toolkits/xmhtml/files/patch-book__Makefile b/x11-toolkits/xmhtml/files/patch-book_Makefile
index d2ccd2bbb76d..058f0983706d 100644
--- a/x11-toolkits/xmhtml/files/patch-book__Makefile
+++ b/x11-toolkits/xmhtml/files/patch-book_Makefile
@@ -1,6 +1,6 @@
---- book/Makefile.orig
+--- book/Makefile.orig 2015-10-26 10:22:55 UTC
+++ book/Makefile
-@@ -12,13 +12,13 @@
+@@ -12,13 +12,13 @@ EXAMPLES=simple_html simple_html2 autosi
# The library
XMHTMLINC= -I../lib
@@ -16,7 +16,7 @@
all: $(EXAMPLES)
-@@ -26,27 +26,27 @@
+@@ -26,27 +26,27 @@ all: $(EXAMPLES)
simple_html:: ../src/libXmHTML.a simple_html.o
$(RM) $@ \
diff --git a/x11-toolkits/xmhtml/files/patch-examples__Makefile b/x11-toolkits/xmhtml/files/patch-examples_Makefile
index 3949e2aeef7b..6f7c560f0e49 100644
--- a/x11-toolkits/xmhtml/files/patch-examples__Makefile
+++ b/x11-toolkits/xmhtml/files/patch-examples_Makefile
@@ -1,6 +1,6 @@
---- examples/Makefile.orig
+--- examples/Makefile.orig 2015-10-26 10:22:55 UTC
+++ examples/Makefile
-@@ -11,10 +11,10 @@
+@@ -11,10 +11,10 @@ MOBJS= visual.o misc.o cache.o menu.o hi
EXAMPLES=example_1 example_2 example_4
# The XmHTML library
@@ -13,7 +13,7 @@
# Libraries against which all examples are linked
LINKLIBS = $(XMHTMLLIB) $(LOADLIBES) $(DMALLOCLIB)
-@@ -22,7 +22,7 @@
+@@ -22,7 +22,7 @@ LINKLIBS = $(XMHTMLLIB) $(LOADLIBES) $(D
# rule to create .o files from .c files
.c.o:
$(RM) $@
@@ -22,7 +22,7 @@
all: $(EXAMPLES)
-@@ -30,15 +30,15 @@
+@@ -30,15 +30,15 @@ all: $(EXAMPLES)
example_1:: ../src/libXmHTML.a example_1.o
$(RM) $@ \
diff --git a/x11-toolkits/xmhtml/files/patch-http__Makefile b/x11-toolkits/xmhtml/files/patch-http_Makefile
index 67a9fd32202f..45aa93e42019 100644
--- a/x11-toolkits/xmhtml/files/patch-http__Makefile
+++ b/x11-toolkits/xmhtml/files/patch-http_Makefile
@@ -1,4 +1,4 @@
---- http/Makefile.orig
+--- http/Makefile.orig 2015-10-26 10:22:55 UTC
+++ http/Makefile
@@ -2,7 +2,7 @@
# lint configuration. I use lclint.
@@ -9,7 +9,7 @@
SHAREDLIB=libhttp.so.0
SONAME=libhttp.so.0
-@@ -23,16 +23,15 @@
+@@ -23,16 +23,15 @@ SUBDIRS=
# rule to create .o files from .c files
.c.o:
$(RM) $@
diff --git a/x11-toolkits/xmhtml/files/patch-lib__Makefile b/x11-toolkits/xmhtml/files/patch-lib_Makefile
index cd15195c865e..c696ea4b2e8b 100644
--- a/x11-toolkits/xmhtml/files/patch-lib__Makefile
+++ b/x11-toolkits/xmhtml/files/patch-lib_Makefile
@@ -1,4 +1,4 @@
---- lib/Makefile.orig
+--- lib/Makefile.orig 2015-10-26 10:22:55 UTC
+++ lib/Makefile
@@ -25,7 +25,7 @@
# Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. #
@@ -7,27 +7,27 @@
-LIBRARY=libXmHTML.a
+LIBRARY=libXmHTML.la
SHAREDLIB=libXmHTML.so.$(ARCHIVE)
- SONAME=$(basename $(SHAREDLIB))
-@@ -37,7 +37,7 @@
- SUBDIRS= common $(PLATFORM)
+ # Targets to make
+@@ -36,7 +36,7 @@ TARGET_SHARED=$(SHAREDLIB)
+ SUBDIRS= common $(TOOLKIT)
# Target rules
-all:: $(TARGET_STATIC) $(TARGET_SHARED)
+all:: $(TARGET_STATIC)
# Separate rules for all targets
- $(PLATFORM)::
-@@ -47,9 +47,9 @@
+ $(TOOLKIT)::
+@@ -46,9 +46,9 @@ common::
@(set -x; cd common; $(MAKE) all $(pass_flags) )
- $(TARGET_STATIC):: common $(PLATFORM)
+ $(TARGET_STATIC):: common $(TOOLKIT)
- $(RM) $@ \
-- $(AR) $@ common/*.o $(PLATFORM)/*.o
+- $(AR) $@ common/*.o $(TOOLKIT)/*.o
- $(RANLIB) $@
+ $(RM) $@
-+ $(LIBTOOL) --mode=link $(CC) -o $@ common/*.lo $(PLATFORM)/*.lo \
++ $(LIBTOOL) --mode=link $(CC) -o $@ common/*.lo $(TOOLKIT)/*.lo \
+ -rpath ${PREFIX}/lib -version-info 1:2
- $(TARGET_SHARED):: common $(PLATFORM)
+ $(TARGET_SHARED):: common $(TOOLKIT)
$(RM) $@ ; \
diff --git a/x11-toolkits/xmhtml/files/patch-lib_Motif_Makefile b/x11-toolkits/xmhtml/files/patch-lib_Motif_Makefile
index 6a52d19b8d72..0c4bf4648dda 100644
--- a/x11-toolkits/xmhtml/files/patch-lib_Motif_Makefile
+++ b/x11-toolkits/xmhtml/files/patch-lib_Motif_Makefile
@@ -1,6 +1,6 @@
---- lib/Motif/Makefile.orig 2009-07-12 11:26:03.000000000 -0500
-+++ lib/Motif/Makefile 2009-07-12 11:26:33.000000000 -0500
-@@ -50,7 +50,7 @@
+--- lib/Motif/Makefile.orig 2015-10-26 10:22:55 UTC
++++ lib/Motif/Makefile
+@@ -50,7 +50,7 @@ SUBDIRS=
# rule to create .o files from .c files
.c.o:
$(RM) $@
diff --git a/x11-toolkits/xmhtml/files/patch-lib_common_Makefile b/x11-toolkits/xmhtml/files/patch-lib_common_Makefile
index dd4a297be2b7..91f5f099da7a 100644
--- a/x11-toolkits/xmhtml/files/patch-lib_common_Makefile
+++ b/x11-toolkits/xmhtml/files/patch-lib_common_Makefile
@@ -1,6 +1,6 @@
---- lib/common/Makefile.orig 2009-07-12 11:21:10.000000000 -0500
-+++ lib/common/Makefile 2009-07-12 11:22:01.000000000 -0500
-@@ -56,7 +56,7 @@
+--- lib/common/Makefile.orig 2015-10-26 10:22:55 UTC
++++ lib/common/Makefile
+@@ -56,7 +56,7 @@ SUBDIRS=
# rule to create .o files from .c files
.c.o:
$(RM) $@
diff --git a/x11-toolkits/xmhtml/files/patch-lib_gtk_Makefile b/x11-toolkits/xmhtml/files/patch-lib_gtk_Makefile
index 4753421365dd..4c7455a542d0 100644
--- a/x11-toolkits/xmhtml/files/patch-lib_gtk_Makefile
+++ b/x11-toolkits/xmhtml/files/patch-lib_gtk_Makefile
@@ -1,6 +1,6 @@
---- lib/gtk/Makefile.orig 2009-07-12 11:27:47.000000000 -0500
-+++ lib/gtk/Makefile 2009-07-12 11:28:09.000000000 -0500
-@@ -50,7 +50,7 @@
+--- lib/gtk/Makefile.orig 2015-10-26 10:22:55 UTC
++++ lib/gtk/Makefile
+@@ -50,7 +50,7 @@ SUBDIRS=
# rule to create .o files from .c files
.c.o:
$(RM) $@
diff --git a/x11-toolkits/xmhtml/files/patch-tools__Makefile b/x11-toolkits/xmhtml/files/patch-tools_Makefile
index 6c9d60953705..409f20b36dbf 100644
--- a/x11-toolkits/xmhtml/files/patch-tools__Makefile
+++ b/x11-toolkits/xmhtml/files/patch-tools_Makefile
@@ -1,6 +1,6 @@
---- tools/Makefile.orig
+--- tools/Makefile.orig 2015-10-26 10:22:55 UTC
+++ tools/Makefile
-@@ -39,7 +39,7 @@
+@@ -39,7 +39,7 @@ TARGETS = reptype wsize gifinfo HTMLpars
# rule to create .o files from .c files
.c.o:
$(RM) $@
@@ -9,7 +9,7 @@
#
# Special object rules
-@@ -50,21 +50,21 @@
+@@ -50,21 +50,21 @@ TARGETS = reptype wsize gifinfo HTMLpars
#
gif2gzf.o: gif2gzf.c
$(RM) $@
@@ -34,7 +34,7 @@
#
# All Targets
-@@ -76,33 +76,33 @@
+@@ -76,33 +76,33 @@ all: $(TARGETS)
reptype:: GetRepTypes.o
$(RM) $@ \