aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-27 11:47:26 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-27 11:47:26 +0000
commitebc7255077a43fdc4ff8b62a534be20998119eba (patch)
treea2212c77322bef46024be014520aa922034e5765 /x11-toolkits
parent48079e5644a747705c5e7d7f47f5703d10a3a416 (diff)
downloadports-ebc7255077a43fdc4ff8b62a534be20998119eba.tar.gz
ports-ebc7255077a43fdc4ff8b62a534be20998119eba.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/scintilla/Makefile2
-rw-r--r--x11-toolkits/scintilla/distinfo4
-rw-r--r--x11-toolkits/scintilla/files/patch-aa26
3 files changed, 16 insertions, 16 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 2d67bf7afcb3..6e951f8c0f5c 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= scintilla
-PORTVERSION= 3.2.4
+PORTVERSION= 3.2.5
CATEGORIES= x11-toolkits
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= scite${PORTVERSION:S/.//g}
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index 3dae01ea1743..6f9553a4d752 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scite324.tgz) = bd20b97513aee8e4584253d6ca31ec658bd4f098ceefb354889eb8a498cb5c08
-SIZE (scite324.tgz) = 1956084
+SHA256 (scite325.tgz) = ac3ca9588bb23ef21da2e22f6ef21416bbd7bf6957130a8e4057b3e5f3c58bef
+SIZE (scite325.tgz) = 1974782
diff --git a/x11-toolkits/scintilla/files/patch-aa b/x11-toolkits/scintilla/files/patch-aa
index b2391ac65c90..0bf57df19ec4 100644
--- a/x11-toolkits/scintilla/files/patch-aa
+++ b/x11-toolkits/scintilla/files/patch-aa
@@ -1,15 +1,12 @@
---- makefile.orig 2012-06-01 04:26:24.000000000 -0400
-+++ makefile 2012-08-12 14:34:52.000000000 -0400
-@@ -7,17 +7,7 @@
+--- makefile.orig 2013-02-18 02:20:43.000000000 -0500
++++ makefile 2013-02-26 18:16:54.000000000 -0500
+@@ -7,14 +7,7 @@
# Also works with ming32-make on Windows.
.SUFFIXES: .cxx .c .o .h .a
-ifdef CLANG
--ifdef CLANG_ANALYZE
--ANALYZE=--analyze
--endif
--CC = clang $(ANALYZE)
--CCOMP = clang $(ANALYZE)
+-CC = clang --std=c++0x
+-CCOMP = clang
-else
-CC = g++
-CCOMP = gcc
@@ -19,7 +16,7 @@
RANLIB = touch
ifdef GTK3
-@@ -39,7 +29,8 @@
+@@ -36,7 +29,8 @@
COMPLIB=..\bin\scintilla.a
else
DEL = rm -f
@@ -29,7 +26,7 @@
endif
vpath %.h ../src ../include ../lexlib
-@@ -66,6 +57,7 @@
+@@ -63,16 +57,17 @@
CFLAGS:=$(CXXTFLAGS)
CONFIGFLAGS:=$(shell pkg-config --cflags $(GTKVERSION))
@@ -37,7 +34,10 @@
MARSHALLER=scintilla-marshal.o
.cxx.o:
-@@ -75,7 +67,7 @@
+ $(CC) $(CONFIGFLAGS) $(CXXTFLAGS) $(CXXFLAGS) -c $<
+ .c.o:
+- $(CCOMP) $(CONFIGFLAGS) $(CFLAGS) -w -c $<
++ $(CCOMP) $(CONFIGFLAGS) $(CFLAGS) $(CXXFLAGS) -w -c $<
LEXOBJS:=$(addsuffix .o,$(basename $(notdir $(wildcard ../lexers/Lex*.cxx))))
@@ -45,8 +45,8 @@
+all: $(COMPLIB) $(LEXRLIB)
clean:
- $(DEL) *.o $(COMPLIB)
-@@ -88,9 +80,11 @@
+ $(DEL) *.o $(COMPLIB) *.plist
+@@ -88,9 +83,11 @@
ScintillaBase.o ContractionState.o Editor.o ExternalLexer.o PropSetSimple.o PlatGTK.o \
KeyMap.o LineMarker.o PositionCache.o ScintillaGTK.o CellBuffer.o ViewStyle.o \
RESearch.o RunStyles.o Selection.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o \