aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-13 15:11:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-13 15:11:27 +0000
commit3ce0f2180809f6e79ba77264143a3d1b824a8d54 (patch)
tree20e1ada1d8086dd795eda0a0236243d21c6aaeba /x11-toolkits
parent5f8e11b89300cab751e82ccf7569f3305f04f3bc (diff)
downloadports-3ce0f2180809f6e79ba77264143a3d1b824a8d54.tar.gz
ports-3ce0f2180809f6e79ba77264143a3d1b824a8d54.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtk12/Makefile21
-rw-r--r--x11-toolkits/gtk12/files/patch-Makefile.in18
-rw-r--r--x11-toolkits/gtk12/files/patch-configure24
-rw-r--r--x11-toolkits/gtk12/files/patch-gdk.pc.in10
-rw-r--r--x11-toolkits/gtk12/files/patch-gdk__Makefile.in11
-rw-r--r--x11-toolkits/gtk12/files/patch-gtk+.pc.in9
-rw-r--r--x11-toolkits/gtk12/files/patch-gtk-config.in19
-rw-r--r--x11-toolkits/gtk12/files/patch-gtk__Makefile.in27
-rw-r--r--x11-toolkits/gtk12/pkg-plist263
-rw-r--r--x11-toolkits/p5-Gtk/Makefile1
10 files changed, 147 insertions, 256 deletions
diff --git a/x11-toolkits/gtk12/Makefile b/x11-toolkits/gtk12/Makefile
index 859819a7d273..4600fcd62c49 100644
--- a/x11-toolkits/gtk12/Makefile
+++ b/x11-toolkits/gtk12/Makefile
@@ -4,28 +4,30 @@
PORTNAME= gtk
PORTVERSION= 1.2.10
-PORTREVISION= 23
+PORTREVISION= 24
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gtk+/1.2
-PKGNAMESUFFIX= 1
+PKGNAMESUFFIX= 12
DISTNAME= gtk+-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gimp Toolkit for X11 GUI (previous stable version)
-USES= perl5
+USES= libtool pathfix perl5
USE_PERL5= build
USE_XORG= x11 ice xext sm inputproto xi
USE_GNOME= glib12
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
-CONFIGURE_ARGS= --includedir=${PREFIX}/include/gtk12 --with-native-locale \
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-native-locale \
--with-xinput=xfree
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
INFO= gdk gtk
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
@@ -36,15 +38,14 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+post-patch:
+ @${MV} ${WRKSRC}/gtk/gtkrc.zh_TW.big5 ${WRKSRC}/gtk/gtkrc.zh_TW.Big5
+
pre-build:
${RM} -rf ${WRKSRC}/docs/gtk.info*
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/gtk/themes/engines
- @${LN} -sf ${PREFIX}/bin/gtk-config ${STAGEDIR}${PREFIX}/bin/gtk12-config
-.for lib in gdk gtk
- @${RM} ${STAGEDIR}${PREFIX}/lib/lib${lib}.la ${STAGEDIR}${PREFIX}/lib/lib${lib}.so
- @${MV} ${STAGEDIR}${PREFIX}/lib/lib${lib}.a ${STAGEDIR}${PREFIX}/lib/lib${lib}-12.a
-.endfor
+ @${LN} -sf gtk-config ${STAGEDIR}${PREFIX}/bin/gtk12-config
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtk12/files/patch-Makefile.in b/x11-toolkits/gtk12/files/patch-Makefile.in
index 258db13435f7..0663b3ea4373 100644
--- a/x11-toolkits/gtk12/files/patch-Makefile.in
+++ b/x11-toolkits/gtk12/files/patch-Makefile.in
@@ -1,23 +1,5 @@
--- Makefile.in.orig Sun Apr 1 23:14:07 2001
+++ Makefile.in Wed Nov 20 14:56:58 2002
-@@ -35,7 +35,7 @@
- DESTDIR =
-
- pkgdatadir = $(datadir)/@PACKAGE@
--pkglibdir = $(libdir)/@PACKAGE@
-+pkglibdir = $(prefix)/libdata/pkgconfig
- pkgincludedir = $(includedir)/@PACKAGE@
-
- top_builddir = .
-@@ -136,7 +136,7 @@
- EXTRA_DIST = HACKING gtk+.spec.in gtk.m4 makecopyright TODO NEWS.pre-1-0 ChangeLog.pre-1-0 README.cvs-commits intl/libgettext.h intl/po2tbl.sed.in examples/aspectframe/Makefile examples/aspectframe/aspectframe.c examples/Makefile examples/README.1ST examples/extract.awk examples/extract.sh examples/base/Makefile examples/base/base.c examples/buttons/Makefile examples/buttons/buttons.c examples/buttons/info.xpm examples/calendar/Makefile examples/calendar/calendar.c examples/clist/Makefile examples/clist/clist.c examples/entry/Makefile examples/entry/entry.c examples/eventbox/Makefile examples/eventbox/eventbox.c examples/filesel/Makefile examples/filesel/filesel.c examples/gtkdial/Makefile examples/gtkdial/dial_test.c examples/gtkdial/gtkdial.c examples/gtkdial/gtkdial.h examples/helloworld/Makefile examples/helloworld/helloworld.c examples/helloworld2/Makefile examples/helloworld2/helloworld2.c examples/list/Makefile examples/list/list.c examples/menu/Makefile examples/menu/menu.c examples/menu/itemfactory.c examples/notebook/Makefile examples/notebook/notebook.c examples/packbox/Makefile examples/packbox/packbox.c examples/packer/Makefile examples/packer/pack.c examples/paned/Makefile examples/paned/paned.c examples/pixmap/Makefile examples/pixmap/pixmap.c examples/progressbar/Makefile examples/progressbar/progressbar.c examples/radiobuttons/Makefile examples/radiobuttons/radiobuttons.c examples/rangewidgets/Makefile examples/rangewidgets/rangewidgets.c examples/rulers/Makefile examples/rulers/rulers.c examples/scribble-simple/Makefile examples/scribble-simple/scribble-simple.c examples/scrolledwin/Makefile examples/scrolledwin/scrolledwin.c examples/selection/Makefile examples/selection/gettargets.c examples/selection/setselection.c examples/statusbar/Makefile examples/statusbar/statusbar.c examples/table/Makefile examples/table/table.c examples/text/Makefile examples/text/text.c examples/tictactoe/Makefile examples/tictactoe/tictactoe.c examples/tictactoe/tictactoe.h examples/tictactoe/ttt_test.c examples/tree/Makefile examples/tree/tree.c examples/wheelbarrow/Makefile examples/wheelbarrow/wheelbarrow.c examples/fixed/fixed.c examples/fixed/Makefile examples/frame/frame.c examples/frame/Makefile examples/spinbutton/spinbutton.c examples/spinbutton/Makefile examples/find-examples.sh gdk.pc.in gtk+.pc.in
-
-
--pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfigdir = $(pkglibdir)
- pkgconfig_DATA = gdk.pc gtk+.pc
-
- m4datadir = $(datadir)/aclocal
@@ -438,7 +438,6 @@
|| exit 1; \
fi; \
diff --git a/x11-toolkits/gtk12/files/patch-configure b/x11-toolkits/gtk12/files/patch-configure
index c29a6955e4e4..f80ea04b54c1 100644
--- a/x11-toolkits/gtk12/files/patch-configure
+++ b/x11-toolkits/gtk12/files/patch-configure
@@ -1,29 +1,5 @@
--- configure.orig Tue May 11 05:42:09 1999
+++ configure Mon May 17 22:59:13 1999
-@@ -606,10 +606,10 @@
-
-
- # libtool versioning
--LT_RELEASE=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION
--LT_CURRENT=`expr $GTK_MICRO_VERSION - $GTK_INTERFACE_AGE`
--LT_REVISION=$GTK_INTERFACE_AGE
--LT_AGE=`expr $GTK_BINARY_AGE - $GTK_INTERFACE_AGE`
-+LT_RELEASE=12
-+LT_CURRENT=2
-+LT_REVISION=0
-+LT_AGE=0
-
-
-
-@@ -3689,7 +3689,7 @@
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- CATOBJEXT=.mo
-- DATADIRNAME=lib
-+ DATADIRNAME=share
- fi
- rm -f conftest*
- INSTOBJEXT=.mo
@@ -4446,6 +4446,7 @@
glib_thread_cflags="$GLIB_CFLAGS"
glib_libs=`$GLIB_CONFIG glib gmodule --libs`
diff --git a/x11-toolkits/gtk12/files/patch-gdk.pc.in b/x11-toolkits/gtk12/files/patch-gdk.pc.in
deleted file mode 100644
index 5db084b049ac..000000000000
--- a/x11-toolkits/gtk12/files/patch-gdk.pc.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- gdk.pc.in.orig Wed Nov 29 20:18:35 2000
-+++ gdk.pc.in Fri Jun 14 00:04:34 2002
-@@ -7,5 +7,5 @@
- Description: GIMP Drawing Kit
- Version: @VERSION@
- Requires: glib
--Libs: -L${libdir} @x_ldflags@ -lgdk @INTLLIBS@ @GDK_WLIBS@ @x_libs@ -lm
--Cflags: -I${includedir}/gtk-1.2 @x_cflags@
-+Libs: -L${libdir} @x_ldflags@ -lgdk-12 @INTLLIBS@ @GDK_WLIBS@ @x_libs@ -lm
-+Cflags: -I${includedir} @x_cflags@
diff --git a/x11-toolkits/gtk12/files/patch-gdk__Makefile.in b/x11-toolkits/gtk12/files/patch-gdk__Makefile.in
deleted file mode 100644
index c9887ad4ae65..000000000000
--- a/x11-toolkits/gtk12/files/patch-gdk__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- gdk/Makefile.in.orig Tue Mar 6 10:45:09 2001
-+++ gdk/Makefile.in Tue Mar 6 10:45:21 2001
-@@ -134,7 +134,7 @@
- lib_LTLIBRARIES = libgdk.la
-
- # libtool stuff: set version and export symbols for resolving
--libgdkincludedir = $(includedir)/gtk-1.2/gdk
-+libgdkincludedir = $(includedir)/gdk
- libgdk_la_LDFLAGS = @STRIP_BEGIN@ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE) -export-dynamic @GLIB_DEPLIBS@ @x_ldflags@ @x_libs@ -lm @STRIP_END@
-
-
diff --git a/x11-toolkits/gtk12/files/patch-gtk+.pc.in b/x11-toolkits/gtk12/files/patch-gtk+.pc.in
deleted file mode 100644
index d9ab159ec758..000000000000
--- a/x11-toolkits/gtk12/files/patch-gtk+.pc.in
+++ /dev/null
@@ -1,9 +0,0 @@
---- gtk+.pc.in 2002/06/10 15:32:34 1.1
-+++ gtk+.pc.in 2002/06/10 15:32:40
-@@ -7,5 +7,5 @@
- Description: GIMP Tool Kit
- Version: @VERSION@
- Requires: gdk
--Libs: -L${libdir} -lgtk
-+Libs: -L${libdir} -lgtk-12
- Cflags:
diff --git a/x11-toolkits/gtk12/files/patch-gtk-config.in b/x11-toolkits/gtk12/files/patch-gtk-config.in
deleted file mode 100644
index 5ef60b088b4d..000000000000
--- a/x11-toolkits/gtk12/files/patch-gtk-config.in
+++ /dev/null
@@ -1,19 +0,0 @@
---- gtk-config.in.orig Sat Oct 21 18:20:40 2000
-+++ gtk-config.in Tue Mar 6 10:11:59 2001
-@@ -91,7 +91,7 @@
- fi
-
- if test "$echo_cflags" = "yes"; then
-- echo -I@includedir@/gtk-1.2 $glib_cflags @x_cflags@
-+ echo -I@includedir@ $glib_cflags @x_cflags@
- fi
-
- if test "$echo_libs" = "yes"; then
-@@ -107,6 +107,6 @@
- fi
- done
-
-- echo $libdirs @x_ldflags@ -lgtk -lgdk $my_glib_libs @INTLLIBS@ @x_libs@ @GDK_WLIBS@ -lm
-+ echo $libdirs @x_ldflags@ -lgtk-@LT_RELEASE@ -lgdk-@LT_RELEASE@ $my_glib_libs @INTLLIBS@ @x_libs@ @GDK_WLIBS@ -lm
- fi
-
diff --git a/x11-toolkits/gtk12/files/patch-gtk__Makefile.in b/x11-toolkits/gtk12/files/patch-gtk__Makefile.in
index ce3ac1f0c307..e0dc3531df8d 100644
--- a/x11-toolkits/gtk12/files/patch-gtk__Makefile.in
+++ b/x11-toolkits/gtk12/files/patch-gtk__Makefile.in
@@ -9,39 +9,18 @@
#
-@@ -134,10 +134,8 @@
- lib_LTLIBRARIES = libgtk.la
-
- # libtool stuff: set version and export symbols for resolving
--libgtkincludedir = $(includedir)/gtk-1.2/gtk
--libgtk_la_LDFLAGS = @STRIP_BEGIN@ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE) -export-dynamic @GLIB_DEPLIBS@ @x_ldflags@ @x_libs@ -lm @STRIP_END@
--
--# $(top_builddir)/gdk/libgdk.la
-+libgtkincludedir = $(includedir)/gtk
-+libgtk_la_LDFLAGS = @STRIP_BEGIN@ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -release $(LT_RELEASE) -export-dynamic @GLIB_DEPLIBS@ @x_ldflags@ @x_libs@ -lm $(top_builddir)/gdk/libgdk.la @STRIP_END@
-
- #
- # setup source file variables
-@@ -190,8 +188,8 @@
+@@ -190,8 +190,8 @@
gen_sources = xgen-gdef xgen-gtbh xgen-gtbvc xgen-gtbic xgen-gtbec xgen-gmh xgen-gmc
CLEANFILES = $(gen_sources)
-gtkconfdir = $(sysconfdir)/gtk
-gtkconf_DATA = gtkrc.az gtkrc.el gtkrc.eo gtkrc.he gtkrc.hy gtkrc.ja gtkrc.ko gtkrc.ru gtkrc.tr gtkrc.th gtkrc.uk gtkrc.iso-8859-2 gtkrc.iso-8859-5 gtkrc.iso-8859-13 gtkrc.iso-8859-14 gtkrc.iso-8859-15 gtkrc.zh_CN gtkrc.zh_TW.big5 gtkrc.ka_GE.georgianacademy gtkrc.ka_GE.georgianps gtkrc.vi_VN.tcvn gtkrc.vi_VN.viscii gtkrc.cp1251 gtkrc.cp1255
+gtkconfdir = $(datadir)/themes/Default/gtk
-+gtkconf_DATA = gtkrc.az gtkrc.el gtkrc.eo gtkrc.he gtkrc.hy gtkrc.ja gtkrc.ko gtkrc.ru gtkrc.tr gtkrc.th gtkrc.uk gtkrc.iso-8859-2 gtkrc.iso-8859-5 gtkrc.iso-8859-13 gtkrc.iso-8859-14 gtkrc.iso-8859-15 gtkrc.zh_CN gtkrc.ka_GE.georgianacademy gtkrc.ka_GE.georgianps gtkrc.vi_VN.tcvn gtkrc.vi_VN.viscii gtkrc.cp1251 gtkrc.cp1255
++gtkconf_DATA = gtkrc.az gtkrc.el gtkrc.eo gtkrc.he gtkrc.hy gtkrc.ja gtkrc.ko gtkrc.ru gtkrc.tr gtkrc.th gtkrc.uk gtkrc.iso-8859-2 gtkrc.iso-8859-5 gtkrc.iso-8859-13 gtkrc.iso-8859-14 gtkrc.iso-8859-15 gtkrc.zh_CN gtkrc.zh_TW.Big5 gtkrc.ka_GE.georgianacademy gtkrc.ka_GE.georgianps gtkrc.vi_VN.tcvn gtkrc.vi_VN.viscii gtkrc.cp1251 gtkrc.cp1255
#
-@@ -415,6 +413,7 @@
- $(INSTALL_DATA) $$p $(DESTDIR)$(gtkconfdir)/$$p; \
- fi; fi; \
- done
-+ $(INSTALL_DATA) gtkrc.zh_TW.big5 $(DESTDIR)$(gtkconfdir)/gtkrc.zh_TW.Big5
-
- uninstall-gtkconfDATA:
- @$(NORMAL_UNINSTALL)
-@@ -1362,7 +1361,7 @@
+@@ -1362,7 +1362,7 @@
uninstall-am: uninstall-libLTLIBRARIES uninstall-gtkconfDATA \
uninstall-libgtkincludeHEADERS uninstall-local
uninstall: uninstall-am
diff --git a/x11-toolkits/gtk12/pkg-plist b/x11-toolkits/gtk12/pkg-plist
index a66cda9012b5..67d1a614abae 100644
--- a/x11-toolkits/gtk12/pkg-plist
+++ b/x11-toolkits/gtk12/pkg-plist
@@ -1,131 +1,133 @@
bin/gtk-config
bin/gtk12-config
-include/gtk12/gdk/gdk.h
-include/gtk12/gdk/gdkcursors.h
-include/gtk12/gdk/gdki18n.h
-include/gtk12/gdk/gdkkeysyms.h
-include/gtk12/gdk/gdkprivate.h
-include/gtk12/gdk/gdkrgb.h
-include/gtk12/gdk/gdktypes.h
-include/gtk12/gdk/gdkx.h
-include/gtk12/gtk/gtk.h
-include/gtk12/gtk/gtkaccelgroup.h
-include/gtk12/gtk/gtkaccellabel.h
-include/gtk12/gtk/gtkadjustment.h
-include/gtk12/gtk/gtkalignment.h
-include/gtk12/gtk/gtkarg.h
-include/gtk12/gtk/gtkarrow.h
-include/gtk12/gtk/gtkaspectframe.h
-include/gtk12/gtk/gtkbbox.h
-include/gtk12/gtk/gtkbin.h
-include/gtk12/gtk/gtkbindings.h
-include/gtk12/gtk/gtkbox.h
-include/gtk12/gtk/gtkbutton.h
-include/gtk12/gtk/gtkcalendar.h
-include/gtk12/gtk/gtkcheckbutton.h
-include/gtk12/gtk/gtkcheckmenuitem.h
-include/gtk12/gtk/gtkclist.h
-include/gtk12/gtk/gtkcolorsel.h
-include/gtk12/gtk/gtkcombo.h
-include/gtk12/gtk/gtkcompat.h
-include/gtk12/gtk/gtkcontainer.h
-include/gtk12/gtk/gtkctree.h
-include/gtk12/gtk/gtkcurve.h
-include/gtk12/gtk/gtkdata.h
-include/gtk12/gtk/gtkdebug.h
-include/gtk12/gtk/gtkdialog.h
-include/gtk12/gtk/gtkdnd.h
-include/gtk12/gtk/gtkdrawingarea.h
-include/gtk12/gtk/gtkeditable.h
-include/gtk12/gtk/gtkentry.h
-include/gtk12/gtk/gtkenums.h
-include/gtk12/gtk/gtkeventbox.h
-include/gtk12/gtk/gtkfeatures.h
-include/gtk12/gtk/gtkfilesel.h
-include/gtk12/gtk/gtkfixed.h
-include/gtk12/gtk/gtkfontsel.h
-include/gtk12/gtk/gtkframe.h
-include/gtk12/gtk/gtkgamma.h
-include/gtk12/gtk/gtkgc.h
-include/gtk12/gtk/gtkhandlebox.h
-include/gtk12/gtk/gtkhbbox.h
-include/gtk12/gtk/gtkhbox.h
-include/gtk12/gtk/gtkhpaned.h
-include/gtk12/gtk/gtkhruler.h
-include/gtk12/gtk/gtkhscale.h
-include/gtk12/gtk/gtkhscrollbar.h
-include/gtk12/gtk/gtkhseparator.h
-include/gtk12/gtk/gtkimage.h
-include/gtk12/gtk/gtkinputdialog.h
-include/gtk12/gtk/gtkinvisible.h
-include/gtk12/gtk/gtkitem.h
-include/gtk12/gtk/gtkitemfactory.h
-include/gtk12/gtk/gtklabel.h
-include/gtk12/gtk/gtklayout.h
-include/gtk12/gtk/gtklist.h
-include/gtk12/gtk/gtklistitem.h
-include/gtk12/gtk/gtkmain.h
-include/gtk12/gtk/gtkmarshal.h
-include/gtk12/gtk/gtkmenu.h
-include/gtk12/gtk/gtkmenubar.h
-include/gtk12/gtk/gtkmenufactory.h
-include/gtk12/gtk/gtkmenuitem.h
-include/gtk12/gtk/gtkmenushell.h
-include/gtk12/gtk/gtkmisc.h
-include/gtk12/gtk/gtknotebook.h
-include/gtk12/gtk/gtkobject.h
-include/gtk12/gtk/gtkoptionmenu.h
-include/gtk12/gtk/gtkpacker.h
-include/gtk12/gtk/gtkpaned.h
-include/gtk12/gtk/gtkpixmap.h
-include/gtk12/gtk/gtkplug.h
-include/gtk12/gtk/gtkpreview.h
-include/gtk12/gtk/gtkprivate.h
-include/gtk12/gtk/gtkprogress.h
-include/gtk12/gtk/gtkprogressbar.h
-include/gtk12/gtk/gtkradiobutton.h
-include/gtk12/gtk/gtkradiomenuitem.h
-include/gtk12/gtk/gtkrange.h
-include/gtk12/gtk/gtkrc.h
-include/gtk12/gtk/gtkruler.h
-include/gtk12/gtk/gtkscale.h
-include/gtk12/gtk/gtkscrollbar.h
-include/gtk12/gtk/gtkscrolledwindow.h
-include/gtk12/gtk/gtkselection.h
-include/gtk12/gtk/gtkseparator.h
-include/gtk12/gtk/gtksignal.h
-include/gtk12/gtk/gtksocket.h
-include/gtk12/gtk/gtkspinbutton.h
-include/gtk12/gtk/gtkstatusbar.h
-include/gtk12/gtk/gtkstyle.h
-include/gtk12/gtk/gtktable.h
-include/gtk12/gtk/gtktearoffmenuitem.h
-include/gtk12/gtk/gtktext.h
-include/gtk12/gtk/gtkthemes.h
-include/gtk12/gtk/gtktipsquery.h
-include/gtk12/gtk/gtktogglebutton.h
-include/gtk12/gtk/gtktoolbar.h
-include/gtk12/gtk/gtktooltips.h
-include/gtk12/gtk/gtktree.h
-include/gtk12/gtk/gtktreeitem.h
-include/gtk12/gtk/gtktypebuiltins.h
-include/gtk12/gtk/gtktypeutils.h
-include/gtk12/gtk/gtkvbbox.h
-include/gtk12/gtk/gtkvbox.h
-include/gtk12/gtk/gtkviewport.h
-include/gtk12/gtk/gtkvpaned.h
-include/gtk12/gtk/gtkvruler.h
-include/gtk12/gtk/gtkvscale.h
-include/gtk12/gtk/gtkvscrollbar.h
-include/gtk12/gtk/gtkvseparator.h
-include/gtk12/gtk/gtkwidget.h
-include/gtk12/gtk/gtkwindow.h
-lib/libgdk-12.a
-lib/libgdk-12.so
-lib/libgdk-12.so.2
-lib/libgtk-12.a
-lib/libgtk-12.so
-lib/libgtk-12.so.2
+include/gtk-1.2/gdk/gdk.h
+include/gtk-1.2/gdk/gdkcursors.h
+include/gtk-1.2/gdk/gdki18n.h
+include/gtk-1.2/gdk/gdkkeysyms.h
+include/gtk-1.2/gdk/gdkprivate.h
+include/gtk-1.2/gdk/gdkrgb.h
+include/gtk-1.2/gdk/gdktypes.h
+include/gtk-1.2/gdk/gdkx.h
+include/gtk-1.2/gtk/gtk.h
+include/gtk-1.2/gtk/gtkaccelgroup.h
+include/gtk-1.2/gtk/gtkaccellabel.h
+include/gtk-1.2/gtk/gtkadjustment.h
+include/gtk-1.2/gtk/gtkalignment.h
+include/gtk-1.2/gtk/gtkarg.h
+include/gtk-1.2/gtk/gtkarrow.h
+include/gtk-1.2/gtk/gtkaspectframe.h
+include/gtk-1.2/gtk/gtkbbox.h
+include/gtk-1.2/gtk/gtkbin.h
+include/gtk-1.2/gtk/gtkbindings.h
+include/gtk-1.2/gtk/gtkbox.h
+include/gtk-1.2/gtk/gtkbutton.h
+include/gtk-1.2/gtk/gtkcalendar.h
+include/gtk-1.2/gtk/gtkcheckbutton.h
+include/gtk-1.2/gtk/gtkcheckmenuitem.h
+include/gtk-1.2/gtk/gtkclist.h
+include/gtk-1.2/gtk/gtkcolorsel.h
+include/gtk-1.2/gtk/gtkcombo.h
+include/gtk-1.2/gtk/gtkcompat.h
+include/gtk-1.2/gtk/gtkcontainer.h
+include/gtk-1.2/gtk/gtkctree.h
+include/gtk-1.2/gtk/gtkcurve.h
+include/gtk-1.2/gtk/gtkdata.h
+include/gtk-1.2/gtk/gtkdebug.h
+include/gtk-1.2/gtk/gtkdialog.h
+include/gtk-1.2/gtk/gtkdnd.h
+include/gtk-1.2/gtk/gtkdrawingarea.h
+include/gtk-1.2/gtk/gtkeditable.h
+include/gtk-1.2/gtk/gtkentry.h
+include/gtk-1.2/gtk/gtkenums.h
+include/gtk-1.2/gtk/gtkeventbox.h
+include/gtk-1.2/gtk/gtkfeatures.h
+include/gtk-1.2/gtk/gtkfilesel.h
+include/gtk-1.2/gtk/gtkfixed.h
+include/gtk-1.2/gtk/gtkfontsel.h
+include/gtk-1.2/gtk/gtkframe.h
+include/gtk-1.2/gtk/gtkgamma.h
+include/gtk-1.2/gtk/gtkgc.h
+include/gtk-1.2/gtk/gtkhandlebox.h
+include/gtk-1.2/gtk/gtkhbbox.h
+include/gtk-1.2/gtk/gtkhbox.h
+include/gtk-1.2/gtk/gtkhpaned.h
+include/gtk-1.2/gtk/gtkhruler.h
+include/gtk-1.2/gtk/gtkhscale.h
+include/gtk-1.2/gtk/gtkhscrollbar.h
+include/gtk-1.2/gtk/gtkhseparator.h
+include/gtk-1.2/gtk/gtkimage.h
+include/gtk-1.2/gtk/gtkinputdialog.h
+include/gtk-1.2/gtk/gtkinvisible.h
+include/gtk-1.2/gtk/gtkitem.h
+include/gtk-1.2/gtk/gtkitemfactory.h
+include/gtk-1.2/gtk/gtklabel.h
+include/gtk-1.2/gtk/gtklayout.h
+include/gtk-1.2/gtk/gtklist.h
+include/gtk-1.2/gtk/gtklistitem.h
+include/gtk-1.2/gtk/gtkmain.h
+include/gtk-1.2/gtk/gtkmarshal.h
+include/gtk-1.2/gtk/gtkmenu.h
+include/gtk-1.2/gtk/gtkmenubar.h
+include/gtk-1.2/gtk/gtkmenufactory.h
+include/gtk-1.2/gtk/gtkmenuitem.h
+include/gtk-1.2/gtk/gtkmenushell.h
+include/gtk-1.2/gtk/gtkmisc.h
+include/gtk-1.2/gtk/gtknotebook.h
+include/gtk-1.2/gtk/gtkobject.h
+include/gtk-1.2/gtk/gtkoptionmenu.h
+include/gtk-1.2/gtk/gtkpacker.h
+include/gtk-1.2/gtk/gtkpaned.h
+include/gtk-1.2/gtk/gtkpixmap.h
+include/gtk-1.2/gtk/gtkplug.h
+include/gtk-1.2/gtk/gtkpreview.h
+include/gtk-1.2/gtk/gtkprivate.h
+include/gtk-1.2/gtk/gtkprogress.h
+include/gtk-1.2/gtk/gtkprogressbar.h
+include/gtk-1.2/gtk/gtkradiobutton.h
+include/gtk-1.2/gtk/gtkradiomenuitem.h
+include/gtk-1.2/gtk/gtkrange.h
+include/gtk-1.2/gtk/gtkrc.h
+include/gtk-1.2/gtk/gtkruler.h
+include/gtk-1.2/gtk/gtkscale.h
+include/gtk-1.2/gtk/gtkscrollbar.h
+include/gtk-1.2/gtk/gtkscrolledwindow.h
+include/gtk-1.2/gtk/gtkselection.h
+include/gtk-1.2/gtk/gtkseparator.h
+include/gtk-1.2/gtk/gtksignal.h
+include/gtk-1.2/gtk/gtksocket.h
+include/gtk-1.2/gtk/gtkspinbutton.h
+include/gtk-1.2/gtk/gtkstatusbar.h
+include/gtk-1.2/gtk/gtkstyle.h
+include/gtk-1.2/gtk/gtktable.h
+include/gtk-1.2/gtk/gtktearoffmenuitem.h
+include/gtk-1.2/gtk/gtktext.h
+include/gtk-1.2/gtk/gtkthemes.h
+include/gtk-1.2/gtk/gtktipsquery.h
+include/gtk-1.2/gtk/gtktogglebutton.h
+include/gtk-1.2/gtk/gtktoolbar.h
+include/gtk-1.2/gtk/gtktooltips.h
+include/gtk-1.2/gtk/gtktree.h
+include/gtk-1.2/gtk/gtktreeitem.h
+include/gtk-1.2/gtk/gtktypebuiltins.h
+include/gtk-1.2/gtk/gtktypeutils.h
+include/gtk-1.2/gtk/gtkvbbox.h
+include/gtk-1.2/gtk/gtkvbox.h
+include/gtk-1.2/gtk/gtkviewport.h
+include/gtk-1.2/gtk/gtkvpaned.h
+include/gtk-1.2/gtk/gtkvruler.h
+include/gtk-1.2/gtk/gtkvscale.h
+include/gtk-1.2/gtk/gtkvscrollbar.h
+include/gtk-1.2/gtk/gtkvseparator.h
+include/gtk-1.2/gtk/gtkwidget.h
+include/gtk-1.2/gtk/gtkwindow.h
+lib/libgdk-1.2.so.0
+lib/libgdk-1.2.so.0.9.1
+lib/libgdk.a
+lib/libgdk.so
+lib/libgtk-1.2.so.0
+lib/libgtk-1.2.so.0.9.1
+lib/libgtk.a
+lib/libgtk.so
libdata/pkgconfig/gdk.pc
libdata/pkgconfig/gtk+.pc
share/aclocal/gtk.m4
@@ -220,7 +222,6 @@ share/themes/Default/gtk/gtkrc.yi
share/themes/Default/gtk/gtkrc.zh_CN
share/themes/Default/gtk/gtkrc.zh_TW.Big5
man/man1/gtk-config.1.gz
-@exec mkdir -p %D/lib/gtk/themes/engines
%%NLS%%@dirrmtry share/locale/sp/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/sp
@dirrm lib/gtk/themes/engines
@@ -228,7 +229,7 @@ man/man1/gtk-config.1.gz
@dirrm lib/gtk
@dirrm share/themes/Default/gtk
@dirrmtry share/themes/Default
-@dirrm include/gtk12/gtk
-@dirrm include/gtk12/gdk
-@dirrm include/gtk12
-@unexec rmdir %D/share/themes 2>/dev/null || /usr/bin/true
+@dirrmtry share/themes
+@dirrm include/gtk-1.2/gtk
+@dirrm include/gtk-1.2/gdk
+@dirrm include/gtk-1.2
diff --git a/x11-toolkits/p5-Gtk/Makefile b/x11-toolkits/p5-Gtk/Makefile
index 81db0e303607..2d16da63d6cd 100644
--- a/x11-toolkits/p5-Gtk/Makefile
+++ b/x11-toolkits/p5-Gtk/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Gtk
PORTVERSION= 0.7010
+PORTREVISION= 1
CATEGORIES= x11-toolkits lang perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-