aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-02 23:33:36 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-02 23:33:36 +0000
commit6a9e56c097dba3f2203b97be03c2ee465da77c8e (patch)
tree8e62cfe664fb23fd123f8179cd2ea472d4a62cec /x11-toolkits
parent9d33c0c3c3b802ad35eefa5f556c5af60581d4a8 (diff)
downloadports-6a9e56c097dba3f2203b97be03c2ee465da77c8e.tar.gz
ports-6a9e56c097dba3f2203b97be03c2ee465da77c8e.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/ocaml-lablgtk/Makefile81
-rw-r--r--x11-toolkits/ocaml-lablgtk/distinfo6
-rw-r--r--x11-toolkits/ocaml-lablgtk/pkg-plist115
3 files changed, 116 insertions, 86 deletions
diff --git a/x11-toolkits/ocaml-lablgtk/Makefile b/x11-toolkits/ocaml-lablgtk/Makefile
index 608923f80f96..d78c265b6918 100644
--- a/x11-toolkits/ocaml-lablgtk/Makefile
+++ b/x11-toolkits/ocaml-lablgtk/Makefile
@@ -6,19 +6,39 @@
#
PORTNAME= lablgtk
-PORTVERSION= 1.2.5
-PORTREVISION= 3
+PORTVERSION= 1.2.7
+PORTREVISION= 0
CATEGORIES= x11-toolkits
MASTER_SITES= http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/ \
ftp://ftp.inria.fr/lang/caml-light/bazar-ocaml/
PKGNAMEPREFIX= ocaml-
PKGNAMESUFFIX= ${SFXGL}${SFXGNOME}${SFXGLADE}
-MAINTAINER= rk@ronald.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= An Objective Caml interface to gtk+
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml
-RUN_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml
+USE_GMAKE= yes
+USE_GNOME= gtk12
+USE_OCAML= yes
+ALL_TARGET= all opt
+CONFIGURE_ENV= USE_DOTOPT=1 GTK_CONFIG=${GTK_CONFIG} \
+ LIBDIR=${LOCALBASE}/lib/ocaml BINDIR=${PREFIX}/bin \
+ INSTALLDIR=${PREFIX}/lib/ocaml/${PORTNAME} \
+ DLLDIR=${PREFIX}/lib/ocaml/stublibs
+
+OPTIONS= GL "Enable OpenGL support" on \
+ GNOME "Enable GNOME support" off \
+ GLADE "Enable Glade support" off
+
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+
+MASTERPORT= ${PORTSDIR}/devel/ocaml-camlidl
+PATTERN= [[:space:]]*(do|then)?[[:space:]]*)cp([[:space:]]
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
.if defined(WITHOUT_GL)
PLIST_SUB+= GL="@comment "
SFXGL= -nogl
@@ -29,36 +49,41 @@ RUN_DEPENDS+= lablgl:${PORTSDIR}/graphics/ocaml-lablgl
LIB_DEPENDS+= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
CONFIGURE_ENV+= USE_GL=1
.endif
-.if defined(WITHOUT_GNOME)
-PLIST_SUB+= GNOME="@comment "
-SFXGNOME= -nognome
-.else
+
+.if defined(WITH_GNOME)
PLIST_SUB+= GNOME=""
USE_GNOME= gdkpixbuf
CONFIGURE_ENV+= USE_GNOME=1
-.endif
-.if defined(WITHOUT_GLADE)
-PLIST_SUB+= GLADE="@comment "
-SFXGLADE= -noglade
.else
+PLIST_SUB+= GNOME="@comment "
+SFXGNOME= -nognome
+.endif
+
+.if defined(WITH_GLADE)
PLIST_SUB+= GLADE=""
-.if defined(WITHOUT_GNOME)
+.if defined(WITH_GNOME)
+USE_GNOME+= libglade
+.else
LIB_DEPENDS+= glade.4:${PORTSDIR}/devel/libglade
BUILD_DEPENDS+= libglade-config:${PORTSDIR}/devel/libglade
-.else
-USE_GNOME+= libglade
.endif
CONFIGURE_ENV+= USE_GLADE=1
+.else
+PLIST_SUB+= GLADE="@comment "
+SFXGLADE= -noglade
.endif
-USE_GMAKE= yes
-USE_GNOME+= gtk12
-ALL_TARGET= all opt
-EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
-DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-CONFIGURE_ENV+= USE_DOTOPT=1 GTK_CONFIG=${GTK_CONFIG}
-CONFIGURE_ENV+= LIBDIR=${PREFIX}/lib/ocaml BINDIR=${PREFIX}/bin
-CONFIGURE_ENV+= INSTALLDIR=${PREFIX}/lib/ocaml/lablgtk
+post-extract:
+ @${REINPLACE_CMD} -E \
+ -e 's,(${PATTERN}+.*lablgtkto),\1\$${BSD_INSTALL_SCRIPT} \3,' \
+ -e 's,(${PATTERN}+.*INSTALLDIR),\1\$${BSD_INSTALL_DATA} \3,' \
+ -e 's,(${PATTERN}+.*BINDIR),\1\$${BSD_INSTALL_SCRIPT} \3,' \
+ -e 's,(${PATTERN}+.*LIBDIR),\1\$${BSD_INSTALL_DATA} \3,' \
+ -e 's,(${PATTERN}+.*DLLDIR),\1\$${BSD_INSTALL_DATA} \3,' \
+ ${WRKSRC}/src/Makefile
+
+ @${REINPLACE_CMD} -E -e '/^DLLDIR[[:space:]]*=[[:space:]]*.*/d' \
+ ${WRKSRC}/Makefile
do-configure:
@(cd ${WRKSRC} && ${GMAKE} configure ${CONFIGURE_ENV})
@@ -71,11 +96,11 @@ post-install:
@${MKDIR} ${EXAMPLESDIR}/GL
@${INSTALL_DATA} ${WRKSRC}/examples/GL/* ${EXAMPLESDIR}/GL
.endif
-.if !defined(WITHOUT_GNOME)
+.if defined(WITH_GNOME)
@${MKDIR} ${EXAMPLESDIR}/xmhtml
@${INSTALL_DATA} ${WRKSRC}/examples/xmhtml/* ${EXAMPLESDIR}/xmhtml
.endif
-.if !defined(WITHOUT_GLADE)
+.if defined(WITH_GLADE)
@${MKDIR} ${EXAMPLESDIR}/glade
@${INSTALL_DATA} ${WRKSRC}/examples/glade/* ${EXAMPLESDIR}/glade
.endif
@@ -84,4 +109,6 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
.endif
-.include <bsd.port.mk>
+ @${INSTALL_DATA} ${WRKSRC}/META ${PREFIX}/lib/ocaml/${PORTNAME}
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/ocaml-lablgtk/distinfo b/x11-toolkits/ocaml-lablgtk/distinfo
index 3c8c71b6a27d..02d392f1c233 100644
--- a/x11-toolkits/ocaml-lablgtk/distinfo
+++ b/x11-toolkits/ocaml-lablgtk/distinfo
@@ -1,3 +1,3 @@
-MD5 (lablgtk-1.2.5.tar.gz) = 92628c756d2d3e2706b59d0382f23c19
-SHA256 (lablgtk-1.2.5.tar.gz) = bfc8dd0ede2bc418e2ddf110619dd8cbf3e75443ae5f4f27bca7f765521d6e6b
-SIZE (lablgtk-1.2.5.tar.gz) = 463565
+MD5 (lablgtk-1.2.7.tar.gz) = 73a797e3a459190fdcaa8288935f6fb9
+SHA256 (lablgtk-1.2.7.tar.gz) = a83939042872397b1c14715c778566249775aaa16d2d24af4832ec13bebf3d3e
+SIZE (lablgtk-1.2.7.tar.gz) = 468443
diff --git a/x11-toolkits/ocaml-lablgtk/pkg-plist b/x11-toolkits/ocaml-lablgtk/pkg-plist
index 8182037afa84..10560c7e656e 100644
--- a/x11-toolkits/ocaml-lablgtk/pkg-plist
+++ b/x11-toolkits/ocaml-lablgtk/pkg-plist
@@ -4,6 +4,7 @@ bin/lablgtk
%%GNOME%%lib/ocaml/stublibs/dlllablgnome.so
lib/ocaml/stublibs/dlllablgtk.so
%%GL%%lib/ocaml/stublibs/dlllablgtkgl.so
+lib/ocaml/lablgtk/META
lib/ocaml/lablgtk/gBin.cmi
lib/ocaml/lablgtk/gBin.cmx
lib/ocaml/lablgtk/gBin.ml
@@ -207,60 +208,62 @@ lib/ocaml/lablgtk/ml_gtk.h
lib/ocaml/lablgtk/varcc
lib/ocaml/lablgtk/wrappers.h
lib/ocaml/lablgtk/xml_lexer.mli
-%%GL%%share/examples/ocaml/lablgtk/GL/gears.ml
-%%GL%%share/examples/ocaml/lablgtk/GL/morph3d.ml
-%%GL%%share/examples/ocaml/lablgtk/GL/planet.ml
-%%GL%%share/examples/ocaml/lablgtk/GL/scene.ml
-%%GL%%share/examples/ocaml/lablgtk/GL/simple.ml
-%%GL%%share/examples/ocaml/lablgtk/GL/tutorial-2.ml
-%%GL%%share/examples/ocaml/lablgtk/GL/tutorial-3.ml
-%%GL%%share/examples/ocaml/lablgtk/GL/tutorial-4.ml
-%%GL%%share/examples/ocaml/lablgtk/GL/tutorial-5.ml
-%%GLADE%%share/examples/ocaml/lablgtk/glade/glade_demo.ml
-%%GLADE%%share/examples/ocaml/lablgtk/glade/gladecalc.ml
-%%GLADE%%share/examples/ocaml/lablgtk/glade/project1.glade
-%%GLADE%%share/examples/ocaml/lablgtk/glade/project2.glade
-%%GNOME%%share/examples/ocaml/lablgtk/xmhtml/test.ml
-share/examples/ocaml/lablgtk/image256x256.rgb
-share/examples/ocaml/lablgtk/buttons.ml
-share/examples/ocaml/lablgtk/calc.ml
-share/examples/ocaml/lablgtk/calendar.ml
-share/examples/ocaml/lablgtk/clist.ml
-share/examples/ocaml/lablgtk/combo.ml
-share/examples/ocaml/lablgtk/counter.ml
-share/examples/ocaml/lablgtk/csview.ml
-share/examples/ocaml/lablgtk/dcalendar.ml
-share/examples/ocaml/lablgtk/drawing.ml
-share/examples/ocaml/lablgtk/editor.ml
-share/examples/ocaml/lablgtk/entry.ml
-share/examples/ocaml/lablgtk/events.ml
-share/examples/ocaml/lablgtk/fifteen.ml
-share/examples/ocaml/lablgtk/fixed_editor.ml
-share/examples/ocaml/lablgtk/fixpoint.ml
-share/examples/ocaml/lablgtk/giotest.ml
-share/examples/ocaml/lablgtk/hello.ml
-share/examples/ocaml/lablgtk/image.ml
-share/examples/ocaml/lablgtk/kaimono.ml
-share/examples/ocaml/lablgtk/label.ml
-share/examples/ocaml/lablgtk/lissajous.ml
-share/examples/ocaml/lablgtk/nihongo.ml
-share/examples/ocaml/lablgtk/pousse.ml
-share/examples/ocaml/lablgtk/progressbar.ml
-share/examples/ocaml/lablgtk/radiobuttons.ml
-share/examples/ocaml/lablgtk/rpn.ml
-share/examples/ocaml/lablgtk/scrolledwin.ml
-share/examples/ocaml/lablgtk/socket.ml
-share/examples/ocaml/lablgtk/testdnd.ml
-share/examples/ocaml/lablgtk/testgtk.ml
-share/examples/ocaml/lablgtk/testinput.ml
-share/examples/ocaml/lablgtk/tictactoe.ml
-share/examples/ocaml/lablgtk/tron.ml
-share/examples/ocaml/lablgtk/test.xpm
-%%PORTDOCS%%share/doc/ocaml/lablgtk/README
+%%GL%%%%EXAMPLESDIR%%/GL/gears.ml
+%%GL%%%%EXAMPLESDIR%%/GL/morph3d.ml
+%%GL%%%%EXAMPLESDIR%%/GL/planet.ml
+%%GL%%%%EXAMPLESDIR%%/GL/scene.ml
+%%GL%%%%EXAMPLESDIR%%/GL/simple.ml
+%%GL%%%%EXAMPLESDIR%%/GL/tutorial-2.ml
+%%GL%%%%EXAMPLESDIR%%/GL/tutorial-3.ml
+%%GL%%%%EXAMPLESDIR%%/GL/tutorial-4.ml
+%%GL%%%%EXAMPLESDIR%%/GL/tutorial-5.ml
+%%GLADE%%%%EXAMPLESDIR%%/glade/glade_demo.ml
+%%GLADE%%%%EXAMPLESDIR%%/glade/gladecalc.ml
+%%GLADE%%%%EXAMPLESDIR%%/glade/project1.glade
+%%GLADE%%%%EXAMPLESDIR%%/glade/project2.glade
+%%GNOME%%%%EXAMPLESDIR%%/xmhtml/test.ml
+%%EXAMPLESDIR%%/image256x256.rgb
+%%EXAMPLESDIR%%/buttons.ml
+%%EXAMPLESDIR%%/calc.ml
+%%EXAMPLESDIR%%/calendar.ml
+%%EXAMPLESDIR%%/clist.ml
+%%EXAMPLESDIR%%/combo.ml
+%%EXAMPLESDIR%%/counter.ml
+%%EXAMPLESDIR%%/csview.ml
+%%EXAMPLESDIR%%/dcalendar.ml
+%%EXAMPLESDIR%%/drawing.ml
+%%EXAMPLESDIR%%/editor.ml
+%%EXAMPLESDIR%%/entry.ml
+%%EXAMPLESDIR%%/events.ml
+%%EXAMPLESDIR%%/fifteen.ml
+%%EXAMPLESDIR%%/fixed_editor.ml
+%%EXAMPLESDIR%%/fixpoint.ml
+%%EXAMPLESDIR%%/giotest.ml
+%%EXAMPLESDIR%%/hello.ml
+%%EXAMPLESDIR%%/image.ml
+%%EXAMPLESDIR%%/kaimono.ml
+%%EXAMPLESDIR%%/label.ml
+%%EXAMPLESDIR%%/lissajous.ml
+%%EXAMPLESDIR%%/nihongo.ml
+%%EXAMPLESDIR%%/pixview.ml
+%%EXAMPLESDIR%%/pousse.ml
+%%EXAMPLESDIR%%/progressbar.ml
+%%EXAMPLESDIR%%/radiobuttons.ml
+%%EXAMPLESDIR%%/rpn.ml
+%%EXAMPLESDIR%%/scrolledwin.ml
+%%EXAMPLESDIR%%/socket.ml
+%%EXAMPLESDIR%%/testdnd.ml
+%%EXAMPLESDIR%%/testgtk.ml
+%%EXAMPLESDIR%%/testinput.ml
+%%EXAMPLESDIR%%/tictactoe.ml
+%%EXAMPLESDIR%%/tron.ml
+%%EXAMPLESDIR%%/test.xpm
+%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm lib/ocaml/lablgtk
-%%GL%%@dirrm share/examples/ocaml/lablgtk/GL
-%%GNOME%%@dirrm share/examples/ocaml/lablgtk/xmhtml
-%%GLADE%%@dirrm share/examples/ocaml/lablgtk/glade
-@dirrm share/examples/ocaml/lablgtk
-%%PORTDOCS%%@dirrm share/doc/ocaml/lablgtk
-%%PORTDOCS%%@dirrm share/doc/ocaml
+%%GL%%@dirrm %%EXAMPLESDIR%%/GL
+%%GNOME%%@dirrm %%EXAMPLESDIR%%/xmhtml
+%%GLADE%%@dirrm %%EXAMPLESDIR%%/glade
+@dirrm %%EXAMPLESDIR%%
+@dirrmtry share/examples/ocaml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrmtry share/doc/ocaml