aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-06-21 14:26:33 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-06-21 14:26:33 +0000
commit6332627a9ecc273dc07c25caef6a86c92d01f05e (patch)
tree72a589c9fb6cf7e5aed7cefc9f37c8ba10a63511 /x11-toolkits
parentdb853aaf18572fbafc88ca00c42d6a4c29cbf324 (diff)
downloadports-6332627a9ecc273dc07c25caef6a86c92d01f05e.tar.gz
ports-6332627a9ecc273dc07c25caef6a86c92d01f05e.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox17/Makefile4
-rw-r--r--x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp11
2 files changed, 10 insertions, 5 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 388daf1740aa..ce65219ed975 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -46,10 +46,6 @@ MAN1= reswrap.1 shutterbug.1 adie.1 PathFinder.1 calculator.1 \
.include <bsd.port.pre.mk>
-.if ${ARCH} == i386
-BROKEN= does not build
-.endif
-
.if defined(WITHOUT_JPEG)
CONFIGURE_ARGS+=--disable-jpeg
.else
diff --git a/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp b/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
index 9fd0773b7ec3..93b7dda399bf 100644
--- a/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
+++ b/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
@@ -1,5 +1,5 @@
--- lib/FXAtomic.cpp.orig 2012-04-27 18:46:09.000000000 +0200
-+++ lib/FXAtomic.cpp 2012-06-20 10:39:15.000000000 +0200
++++ lib/FXAtomic.cpp 2012-06-21 15:22:43.000000000 +0200
@@ -298,7 +298,7 @@
LONGLONG duet[2]={(LONGLONG)a,(LONGLONG)b};
return (_InterlockedCompareExchange128((LONGLONG volatile*)ptr,(LONGLONG)cmpb,(LONGLONG)cmpa,duet));
@@ -9,3 +9,12 @@
register FXbool ret;
__asm__ __volatile__ ("xchgl %%esi, %%ebx\n\t"
"lock\n\t"
+@@ -308,7 +308,7 @@
+ "xchgl %%esi, %%ebx\n\t" : "=a"(ret) : "D"(ptr), "a"(cmpa), "d"(cmpb), "S"(a), "c"(b) : "memory", "cc");
+ return ret;
+ #else
+- register TBool ret;
++ register FXbool ret;
+ __asm__ __volatile__ ("lock\n\t"
+ "cmpxchg8b (%1)\n\t"
+ "setz %%al\n\t"