aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-08-10 20:11:43 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-08-10 20:11:43 +0000
commit819fb13a71f67403f2ce639116e0e9f8abe5ea55 (patch)
tree68564ca828b39717b7fd1a403c7188e24b053a4b /x11-toolkits
parent4fe366ebb58002a75b28413bf23513fe377d5101 (diff)
downloadports-819fb13a71f67403f2ce639116e0e9f8abe5ea55.tar.gz
ports-819fb13a71f67403f2ce639116e0e9f8abe5ea55.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/scintilla/Makefile14
-rw-r--r--x11-toolkits/scintilla/distinfo6
-rw-r--r--x11-toolkits/scintilla/files/patch-aa37
-rw-r--r--x11-toolkits/scintilla/pkg-plist2
4 files changed, 37 insertions, 22 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 9bb6278ebed8..6dda425ee4b4 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -6,8 +6,7 @@
# $MCom: ports/x11-toolkits/scintilla/Makefile,v 1.3 2006/09/17 21:58:56 marcus Exp $
PORTNAME= scintilla
-PORTVERSION= 1.73
-PORTREVISION= 1
+PORTVERSION= 1.74
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scintilla.org/
@@ -15,7 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= scite${PORTVERSION:S/.//g}
EXTRACT_SUFX= .tgz
-MAINTAINER= gnome@FreeBSD.org
+MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= A full-featured free source code editing component for GTK+
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
@@ -29,9 +28,11 @@ USE_LDCONFIG= yes
.if defined(WITH_GTK2)
USE_GNOME= gtk20
PKGNAMESUFFIX:= -gtk2
+PLIST_SUB+= GTK2="" GTK1="@comment "
.else
USE_GNOME= gtk12
MAKE_ARGS+= GTK1=yes
+PLIST_SUB+= GTK2="@comment " GTK1=""
.endif
.include <bsd.port.pre.mk>
@@ -50,4 +51,11 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../bin/libscintilla_lexers.so.1 ${PREFIX}/lib
${LN} -sf ${PREFIX}/lib/libscintilla_lexers.so.1 ${PREFIX}/lib/libscintilla_lexers.so
+post-install:
+.if defined(WITH_GTK2)
+ ${TOUCH} ${PREFIX}/include/scintilla/.scintilla-gtk2
+.else
+ ${TOUCH} ${PREFIX}/include/scintilla/.scintilla-gtk1
+.endif
+
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index 42865a3eb17d..2e960f42ad4e 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1,3 +1,3 @@
-MD5 (scite173.tgz) = 0e8e4139b5f5db445b3da9ff070d9d3a
-SHA256 (scite173.tgz) = 1dde09224162f3dadd440ba08beb1f425c997e73559e2107f4fc4bfd52a779c4
-SIZE (scite173.tgz) = 1343699
+MD5 (scite174.tgz) = 09ad25f1fa6dab3feec41dba2480047f
+SHA256 (scite174.tgz) = 10640a1c4bde4b1f5726085c95f7a139a044853911ebeaffa58f42aa26359e01
+SIZE (scite174.tgz) = 1460459
diff --git a/x11-toolkits/scintilla/files/patch-aa b/x11-toolkits/scintilla/files/patch-aa
index 1fbdc0407b85..34a970d0f75a 100644
--- a/x11-toolkits/scintilla/files/patch-aa
+++ b/x11-toolkits/scintilla/files/patch-aa
@@ -1,5 +1,5 @@
---- makefile.orig Fri Oct 15 19:41:26 2004
-+++ makefile Sun Oct 16 02:51:33 2005
+--- makefile.orig Fri Aug 10 15:26:43 2007
++++ makefile Fri Aug 10 15:31:26 2007
@@ -8,16 +8,17 @@
# To force GTK+ 1 build, define GTK1 on the make command line.
@@ -35,36 +35,36 @@
# If explicit setting of GTK1 or GTK2 then use that else look for
# pkg-config which is an OK indication that GTK2 is available
ifdef GTK2
--CONFIGFLAGS=pkg-config --cflags gtk+-2.0
+-CONFIGFLAGS=$(shell pkg-config --cflags gtk+-2.0)
+CONFIGFLAGS=pkg-config --cflags gtk+-2.0 gthread-2.0
MARSHALLER=scintilla-marshal.o
else
ifdef GTK1
--CONFIGFLAGS=gtk-config --cflags
+-CONFIGFLAGS=$(shell gtk-config --cflags)
+CONFIGFLAGS=pkg-config --cflags gtk+ gthread
else
ifneq (,$(findstring /,$(shell whereis pkg-config)))
--CONFIGFLAGS=pkg-config --cflags gtk+-2.0
+-CONFIGFLAGS=$(shell pkg-config --cflags gtk+-2.0)
+CONFIGFLAGS=pkg-config --cflags gtk+-2.0 gthread-2.0
MARSHALLER=scintilla-marshal.o
else
--CONFIGFLAGS=gtk-config --cflags
-+CONFIGFLAGS=gtk-config --cflags gtk+ gthread
+-CONFIGFLAGS=$(shell gtk-config --cflags)
++CONFIGFLAGS=pkg-config --cflags gtk+ gthread
endif
endif
endif
.cxx.o:
-- $(CC) `$(CONFIGFLAGS)` $(CXXFLAGS) -c $<
+- $(CC) $(CONFIGFLAGS) $(CXXFLAGS) -c $<
+ $(CC) $(PICFLAGS) `$(CONFIGFLAGS)` $(CXXFLAGS) -c $<
.c.o:
-- $(CCOMP) `$(CONFIGFLAGS)` $(CXXFLAGS) -w -c $<
+- $(CCOMP) $(CONFIGFLAGS) $(CXXFLAGS) -w -c $<
+ $(CCOMP) $(PICFLAGS) `$(CONFIGFLAGS)` $(CXXFLAGS) -w -c $<
#++Autogenerated -- run src/LexGen.py to regenerate
#**LEXOBJS=\\\n\(\*.o \)
-@@ -72,7 +73,7 @@
- LexTeX.o LexVB.o LexVerilog.o LexVHDL.o LexYAML.o
+@@ -75,22 +76,24 @@
+ LexVHDL.o LexYAML.o
#--Autogenerated -- end of automatically generated section
-all: $(COMPLIB)
@@ -72,15 +72,20 @@
clean:
rm -f *.o $(COMPLIB)
-@@ -83,10 +84,11 @@
- $(COMPLIB): DocumentAccessor.o WindowAccessor.o KeyWords.o StyleContext.o Document.o CallTip.o \
+
+ deps:
+- $(CC) -MM $(CONFIGFLAGS) $(CXXFLAGS) *.cxx ../src/*.cxx | sed -e 's/\/usr.* //' | grep [a-zA-Z] >deps.mak
++ $(CC) -MM `$(CONFIGFLAGS)` $(CXXFLAGS) *.cxx ../src/*.cxx | sed -e 's/\/usr.* //' | grep [a-zA-Z] >deps.mak
+
+ $(COMPLIB): DocumentAccessor.o WindowAccessor.o KeyWords.o StyleContext.o \
+ CharClassify.o Decoration.o Document.o CallTip.o \
ScintillaBase.o ContractionState.o Editor.o ExternalLexer.o PropSet.o PlatGTK.o \
- KeyMap.o LineMarker.o ScintillaGTK.o CellBuffer.o ViewStyle.o \
-- RESearch.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o \
+ KeyMap.o LineMarker.o PositionCache.o ScintillaGTK.o CellBuffer.o ViewStyle.o \
+ RESearch.o RunStyles.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o \
- $(MARSHALLER) $(LEXOBJS)
- $(AR) rc $@ $^
- $(RANLIB) $@
-+ RESearch.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o $(MARSHALLER)
++ $(MARSHALLER)
+ $(AR) `$(CONFIGFLAGS:cflags=libs)` -o $@ $^
+
+$(LEXRLIB): $(LEXOBJS)
diff --git a/x11-toolkits/scintilla/pkg-plist b/x11-toolkits/scintilla/pkg-plist
index d96935c51c4c..326d6526aa74 100644
--- a/x11-toolkits/scintilla/pkg-plist
+++ b/x11-toolkits/scintilla/pkg-plist
@@ -1,3 +1,5 @@
+%%GTK1%%include/scintilla/.scintilla-gtk1
+%%GTK2%%include/scintilla/.scintilla-gtk2
include/scintilla/Accessor.h
include/scintilla/KeyWords.h
include/scintilla/Platform.h