aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2001-01-07 13:10:07 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2001-01-07 13:10:07 +0000
commit67256d7659a90f1c82f8453ffbdd37c09941c619 (patch)
tree48446cf3d951f3fe57674bd1486fcb9d3360a404 /x11-toolkits
parentb90e296f2f05617b55bb168436a4f875363f99d3 (diff)
downloadports-67256d7659a90f1c82f8453ffbdd37c09941c619.tar.gz
ports-67256d7659a90f1c82f8453ffbdd37c09941c619.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/xmhtml/Makefile49
-rw-r--r--x11-toolkits/xmhtml/files/patch-aa55
-rw-r--r--x11-toolkits/xmhtml/pkg-plist398
3 files changed, 239 insertions, 263 deletions
diff --git a/x11-toolkits/xmhtml/Makefile b/x11-toolkits/xmhtml/Makefile
index 5ef806e32ab4..60fa399a581a 100644
--- a/x11-toolkits/xmhtml/Makefile
+++ b/x11-toolkits/xmhtml/Makefile
@@ -7,53 +7,44 @@
PORTNAME= XmHTML
PORTVERSION= 1.1.7
+PORTREVISION= 1
CATEGORIES= x11-toolkits www
MASTER_SITES= http://www.xs4all.nl/~ripley/XmHTML/dist/
MAINTAINER= Lars.Koeller@Uni-Bielefeld.de
+BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-REQUIRES_MOTIF= yes
-USE_GMAKE= yes
-USE_LIBTOOL= yes
-USE_X_PREFIX= yes
USE_MOTIF= yes
-
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+MAKE_ENV= CC="${LIBTOOL} ${CC}"
INSTALLS_SHLIB= yes
-EXMP_DIR= ${X11BASE}/share/examples/${DISTNAME}/
-DOCS_DIR= ${X11BASE}/share/doc/${DISTNAME}/
-
-EXMP_DIR= ${PREFIX}/share/examples/${DISTNAME}/
-DOCS_DIR= ${PREFIX}/share/doc/${DISTNAME}/
-
-post-patch:
- ${TOUCH} ${WRKSRC}/configure
- ${CHMOD} 755 ${WRKSRC}/configure
+EXMP_DIR= ${PREFIX}/share/examples/${PORTNAME}
+DOCS_DIR= ${PREFIX}/share/doc/${PORTNAME}
post-build:
${RM} -rf ${WRKSRC}/examples/.libs ${WRKSRC}/examples/*.lo ${WRKSRC}/examples/*.o
${RM} -rf ${WRKSRC}/book/.libs ${WRKSRC}/book/*.lo ${WRKSRC}/book/*.o
${RM} -rf ${WRKSRC}/contrib/.libs ${WRKSRC}/contrib/*.lo ${WRKSRC}/contrib/*.o
-pre-install:
- ${ECHO} "installing examples into ${EXMP_DIR}"
- @ ${MKDIR} ${EXMP_DIR}
- @ tar -C ${WRKSRC} -cpf- book contrib examples|tar -xvpf- -C ${EXMP_DIR}
- ${ECHO} "installing docs into ${DOCS_DIR}"
- @ ${MKDIR} ${DOCS_DIR}
- @ (cd ${WRKSRC}/html; tar -cpf- * | tar -xvpf- -C ${DOCS_DIR} )
-
do-install:
${LIBTOOL} --mode=install ${INSTALL_DATA} \
- ${WRKSRC}/lib/libXmHTML.la ${X11BASE}/lib
- ${RM} -f ${X11BASE}/lib/libXmHTML.la
- ${MKDIR} ${X11BASE}/include/XmHTML
- ${INSTALL_DATA} ${WRKSRC}/include/XmHTML/*.h ${X11BASE}/include/XmHTML
-
-post-install:
- @ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+ ${WRKSRC}/lib/libXmHTML.la ${PREFIX}/lib
+ ${RM} -f ${PREFIX}/lib/libXmHTML.la
+ @${MKDIR} ${PREFIX}/include/XmHTML
+ ${INSTALL_DATA} ${WRKSRC}/include/XmHTML/*.h ${PREFIX}/include/XmHTML
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples into ${EXMP_DIR}"
+ @${MKDIR} ${EXMP_DIR}
+ ${TAR} -C ${WRKSRC} -cpf- book contrib examples | \
+ ${TAR} -C ${EXMP_DIR} -xpf-
+ @${ECHO_MSG} "===> Installing docs into ${DOCS_DIR}"
+ @${MKDIR} ${DOCS_DIR}
+ ${TAR} -C ${WRKSRC}/html -cpf- . | ${TAR} -C ${DOCS_DIR} -xpf-
+.endif
.include <bsd.port.mk>
diff --git a/x11-toolkits/xmhtml/files/patch-aa b/x11-toolkits/xmhtml/files/patch-aa
index 83a65adcb931..88f171a35abf 100644
--- a/x11-toolkits/xmhtml/files/patch-aa
+++ b/x11-toolkits/xmhtml/files/patch-aa
@@ -1,5 +1,5 @@
-*** Makefile.orig Thu Feb 4 01:43:27 1999
---- Makefile Sat Aug 5 15:29:56 2000
+*** Makefile.org Sat Jan 6 19:35:41 2001
+--- Makefile Sat Jan 6 19:46:00 2001
***************
*** 40,46 ****
# remove the examples directory from this line.
@@ -13,11 +13,28 @@
# remove the examples directory from this line.
# If you want to build the XmHTML tutorial examples, add the book directory.
-! SUBDIRS= lib http examples tools book contrib
+! SUBDIRS= lib http
# some common definitions
#
***************
+*** 55,61 ****
+ RANLIB= ranlib
+
+ SHELL = /bin/sh
+! MAKE = make
+ # change this to makedepend if your system doesn't have gcc
+ MAKEDEPEND= gccmakedep
+
+--- 55,61 ----
+ RANLIB= ranlib
+
+ SHELL = /bin/sh
+! #MAKE = make
+ # change this to makedepend if your system doesn't have gcc
+ MAKEDEPEND= gccmakedep
+
+***************
*** 64,72 ****
# Compiler Settings #
# #
@@ -32,8 +49,8 @@
# Compiler Settings #
# #
#####################
-! CC = libtool gcc
-! CFLAGS = -O2 -funroll-loops -pipe -ansi
+! #CC = gcc
+! #CFLAGS = -g -funroll-loops -Wall -pipe -ansi
! #LDFLAGS =
# The following flags are *very* usefull if you are getting unresolved
@@ -105,12 +122,12 @@
! PLATFORMINC=-I../../include/XmHTML -I${X11BASE}/include
else
ifeq ($(PLATFORM),gtk)
-! PLATFORMINC=-I../../include/gtk-xmhtml -I${LOCALBASE}/include
+! PLATFORMINC=-I../../include/gtk-xmhtml -I${X11BASE}/include
endif
endif
***************
-*** 192,208 ****
+*** 192,201 ****
# Motif version (default)
ifeq ($(PLATFORM),Motif)
@@ -121,14 +138,7 @@
else
- # gtk version (only supported port for now)
- ifeq($(PLATFORM),gtk)
-
-! LIBDIR = -L/usr/local/lib
- LIBS = -lgdk -lgtk -lX11
-
- # endif gtk
---- 192,208 ----
+--- 192,201 ----
# Motif version (default)
ifeq ($(PLATFORM),Motif)
@@ -138,18 +148,3 @@
! LIBS = ${MOTIFLIB} -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE
else
-
- # gtk version (only supported port for now)
- ifeq($(PLATFORM),gtk)
-
-! LIBDIR = -L${X11BASE}/lib
- LIBS = -lgdk -lgtk -lX11
-
- # endif gtk
-***************
-*** 308,311 ****
- tools/scansrc.sh ./lib/common > docs/sources.desc
- tools/scansrc.sh ./lib/Motif >> docs/sources.desc
- tools/scansrc.sh ./lib/gtk >> docs/sources.desc
--
---- 308,310 ----
diff --git a/x11-toolkits/xmhtml/pkg-plist b/x11-toolkits/xmhtml/pkg-plist
index 19cc4f762a11..d871b73e439b 100644
--- a/x11-toolkits/xmhtml/pkg-plist
+++ b/x11-toolkits/xmhtml/pkg-plist
@@ -1,200 +1,3 @@
-share/doc/XmHTML-1.1.7/GPL.html
-share/doc/XmHTML-1.1.7/LGPL.html
-share/doc/XmHTML-1.1.7/XmHTML.html
-share/doc/XmHTML-1.1.7/apps.html
-share/doc/XmHTML-1.1.7/changes.html
-share/doc/XmHTML-1.1.7/copyrights.html
-share/doc/XmHTML-1.1.7/custom_map.html
-share/doc/XmHTML-1.1.7/custom_map.txt
-share/doc/XmHTML-1.1.7/datatypes.html
-share/doc/XmHTML-1.1.7/debug.html
-share/doc/XmHTML-1.1.7/extensions.html
-share/doc/XmHTML-1.1.7/font_map.html
-share/doc/XmHTML-1.1.7/getit.html
-share/doc/XmHTML-1.1.7/legals.html
-share/doc/XmHTML-1.1.7/man.html
-share/doc/XmHTML-1.1.7/parser.html
-share/doc/XmHTML-1.1.7/parser_prog.html
-share/doc/XmHTML-1.1.7/parser_ref.html
-share/doc/XmHTML-1.1.7/procedures.html
-share/doc/XmHTML-1.1.7/progguide.html
-share/doc/XmHTML-1.1.7/structures.html
-share/doc/XmHTML-1.1.7/xmhtml_prog.html
-share/doc/XmHTML-1.1.7/man/AllocCol.html
-share/doc/XmHTML-1.1.7/man/AncGetId.html
-share/doc/XmHTML-1.1.7/man/AncScrId.html
-share/doc/XmHTML-1.1.7/man/AncScrNm.html
-share/doc/XmHTML-1.1.7/man/CrtHTML.html
-share/doc/XmHTML-1.1.7/man/FontInfo.html
-share/doc/XmHTML-1.1.7/man/FrGtChld.html
-share/doc/XmHTML-1.1.7/man/FreeCol.html
-share/doc/XmHTML-1.1.7/man/GetTitle.html
-share/doc/XmHTML-1.1.7/man/GtHdAttr.html
-share/doc/XmHTML-1.1.7/man/GtURLTyp.html
-share/doc/XmHTML-1.1.7/man/HTGIFStr.html
-share/doc/XmHTML-1.1.7/man/HTGtVer.html
-share/doc/XmHTML-1.1.7/man/HTML.html
-share/doc/XmHTML-1.1.7/man/HTObject.html
-share/doc/XmHTML-1.1.7/man/HTPLCStr.html
-share/doc/XmHTML-1.1.7/man/HTPapSiz.html
-share/doc/XmHTML-1.1.7/man/ImCrFrIn.html
-share/doc/XmHTML-1.1.7/man/ImCreate.html
-share/doc/XmHTML-1.1.7/man/ImDefPrc.html
-share/doc/XmHTML-1.1.7/man/ImDestro.html
-share/doc/XmHTML-1.1.7/man/ImFreeAl.html
-share/doc/XmHTML-1.1.7/man/ImFreeIn.html
-share/doc/XmHTML-1.1.7/man/ImGZFSup.html
-share/doc/XmHTML-1.1.7/man/ImGetTyp.html
-share/doc/XmHTML-1.1.7/man/ImGifGzf.html
-share/doc/XmHTML-1.1.7/man/ImImgMap.html
-share/doc/XmHTML-1.1.7/man/ImInfo.html
-share/doc/XmHTML-1.1.7/man/ImPLCCon.html
-share/doc/XmHTML-1.1.7/man/ImPLCKil.html
-share/doc/XmHTML-1.1.7/man/ImPLCSus.html
-share/doc/XmHTML-1.1.7/man/ImReplac.html
-share/doc/XmHTML-1.1.7/man/ImUpdate.html
-share/doc/XmHTML-1.1.7/man/Redispla.html
-share/doc/XmHTML-1.1.7/man/TxtGtFmt.html
-share/doc/XmHTML-1.1.7/man/TxtGtSrc.html
-share/doc/XmHTML-1.1.7/man/TxtGtStr.html
-share/doc/XmHTML-1.1.7/man/TxtScrLn.html
-share/doc/XmHTML-1.1.7/man/TxtStStr.html
-share/doc/XmHTML-1.1.7/man/TxtStrWl.html
-share/doc/XmHTML-1.1.7/man/XYToInfo.html
-share/doc/XmHTML-1.1.7/man/XmImage.html
-share/doc/XmHTML-1.1.7/man/man.map
-share/doc/XmHTML-1.1.7/man/man.tmpl
-share/doc/XmHTML-1.1.7/man/empty.html
-share/examples/XmHTML-1.1.7/book/Imakefile
-share/examples/XmHTML-1.1.7/book/Makefile
-share/examples/XmHTML-1.1.7/book/Makefile.orig
-share/examples/XmHTML-1.1.7/book/Makefile.org
-share/examples/XmHTML-1.1.7/book/autosize_html
-share/examples/XmHTML-1.1.7/book/autosize_html.c
-share/examples/XmHTML-1.1.7/book/forced_html
-share/examples/XmHTML-1.1.7/book/forced_html.c
-share/examples/XmHTML-1.1.7/book/html
-share/examples/XmHTML-1.1.7/book/html.c
-share/examples/XmHTML-1.1.7/book/html_browser
-share/examples/XmHTML-1.1.7/book/html_browser.c
-share/examples/XmHTML-1.1.7/book/simple_html
-share/examples/XmHTML-1.1.7/book/simple_html.c
-share/examples/XmHTML-1.1.7/book/simple_html2
-share/examples/XmHTML-1.1.7/book/simple_html2.c
-share/examples/XmHTML-1.1.7/book/work_window.c
-share/examples/XmHTML-1.1.7/contrib/Makefile
-share/examples/XmHTML-1.1.7/contrib/Makefile.org
-share/examples/XmHTML-1.1.7/contrib/README
-share/examples/XmHTML-1.1.7/contrib/VUEorDT.c
-share/examples/XmHTML-1.1.7/contrib/drawBttn.c
-share/examples/XmHTML-1.1.7/contrib/example_5.c
-share/examples/XmHTML-1.1.7/contrib/gif_decode.c
-share/examples/XmHTML-1.1.7/contrib/htmltest.c
-share/examples/XmHTML-1.1.7/contrib/netscape.c
-share/examples/XmHTML-1.1.7/contrib/swallow.c
-share/examples/XmHTML-1.1.7/contrib/swallow2
-share/examples/XmHTML-1.1.7/contrib/swallow2.c
-share/examples/XmHTML-1.1.7/examples/HTMLDemos.ad
-share/examples/XmHTML-1.1.7/examples/Imakefile
-share/examples/XmHTML-1.1.7/examples/Makefile
-share/examples/XmHTML-1.1.7/examples/Makefile.org
-share/examples/XmHTML-1.1.7/examples/Makefile.orig
-share/examples/XmHTML-1.1.7/examples/README
-share/examples/XmHTML-1.1.7/examples/cache.c
-share/examples/XmHTML-1.1.7/examples/cache.h
-share/examples/XmHTML-1.1.7/examples/example_1
-share/examples/XmHTML-1.1.7/examples/example_1.c
-share/examples/XmHTML-1.1.7/examples/example_2
-share/examples/XmHTML-1.1.7/examples/example_2.c
-share/examples/XmHTML-1.1.7/examples/example_4
-share/examples/XmHTML-1.1.7/examples/example_4.c
-share/examples/XmHTML-1.1.7/examples/form-test.pl
-share/examples/XmHTML-1.1.7/examples/ftypes.h
-share/examples/XmHTML-1.1.7/examples/gif_decode.c
-share/examples/XmHTML-1.1.7/examples/history.c
-share/examples/XmHTML-1.1.7/examples/history.h
-share/examples/XmHTML-1.1.7/examples/menu.c
-share/examples/XmHTML-1.1.7/examples/menu.h
-share/examples/XmHTML-1.1.7/examples/menuItems.h
-share/examples/XmHTML-1.1.7/examples/misc.c
-share/examples/XmHTML-1.1.7/examples/misc.h
-share/examples/XmHTML-1.1.7/examples/visual.c
-share/examples/XmHTML-1.1.7/examples/test-pages/README
-share/examples/XmHTML-1.1.7/examples/test-pages/animation1.html
-share/examples/XmHTML-1.1.7/examples/test-pages/animation2.html
-share/examples/XmHTML-1.1.7/examples/test-pages/animation3.html
-share/examples/XmHTML-1.1.7/examples/test-pages/black.jpg
-share/examples/XmHTML-1.1.7/examples/test-pages/bug.gif
-share/examples/XmHTML-1.1.7/examples/test-pages/chinese.html
-share/examples/XmHTML-1.1.7/examples/test-pages/comments.html
-share/examples/XmHTML-1.1.7/examples/test-pages/cyrillic.html
-share/examples/XmHTML-1.1.7/examples/test-pages/dark_side.html
-share/examples/XmHTML-1.1.7/examples/test-pages/dusan.html
-share/examples/XmHTML-1.1.7/examples/test-pages/emailed.gif
-share/examples/XmHTML-1.1.7/examples/test-pages/empty.html
-share/examples/XmHTML-1.1.7/examples/test-pages/empty1.html
-share/examples/XmHTML-1.1.7/examples/test-pages/english.html
-share/examples/XmHTML-1.1.7/examples/test-pages/eye.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye1.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye10.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye11.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye12.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye13.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye14.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye15.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye16.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye17.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye18.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye19.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye2.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye20.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye21.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye22.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye23.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye24.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye3.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye4.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye5.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye6.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye7.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye8.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/eye9.xpm
-share/examples/XmHTML-1.1.7/examples/test-pages/face.html
-share/examples/XmHTML-1.1.7/examples/test-pages/font-stuff.html
-share/examples/XmHTML-1.1.7/examples/test-pages/form-test.html
-share/examples/XmHTML-1.1.7/examples/test-pages/frame.html
-share/examples/XmHTML-1.1.7/examples/test-pages/frame1.html
-share/examples/XmHTML-1.1.7/examples/test-pages/frame2.html
-share/examples/XmHTML-1.1.7/examples/test-pages/frame3.html
-share/examples/XmHTML-1.1.7/examples/test-pages/frame4.html
-share/examples/XmHTML-1.1.7/examples/test-pages/frame5.html
-share/examples/XmHTML-1.1.7/examples/test-pages/icons.html
-share/examples/XmHTML-1.1.7/examples/test-pages/image-layout.html
-share/examples/XmHTML-1.1.7/examples/test-pages/image-map.html
-share/examples/XmHTML-1.1.7/examples/test-pages/null_end.html
-share/examples/XmHTML-1.1.7/examples/test-pages/null_end1.html
-share/examples/XmHTML-1.1.7/examples/test-pages/pass7_sml.png
-share/examples/XmHTML-1.1.7/examples/test-pages/png.html
-share/examples/XmHTML-1.1.7/examples/test-pages/pnglogo-blk-tiny.png
-share/examples/XmHTML-1.1.7/examples/test-pages/root.html
-share/examples/XmHTML-1.1.7/examples/test-pages/symbol.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table1.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table10.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table11.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table2.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table3.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table4.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table5.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table6.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table7.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table7.html.swp
-share/examples/XmHTML-1.1.7/examples/test-pages/table8.html
-share/examples/XmHTML-1.1.7/examples/test-pages/table9.html
-share/examples/XmHTML-1.1.7/examples/test-pages/unclosed.html
-share/examples/XmHTML-1.1.7/examples/test-pages/unclosed1.html
-lib/libXmHTML.a
-lib/libXmHTML.so
-lib/libXmHTML.so.1
include/XmHTML/Balloon.h
include/XmHTML/BalloonP.h
include/XmHTML/HTML.h
@@ -208,11 +11,198 @@ include/XmHTML/debug_menu.h
include/XmHTML/resources.h
include/XmHTML/tka.h
include/XmHTML/toolkit.h
-@dirrm share/examples/XmHTML-1.1.7/examples/test-pages
-@dirrm share/examples/XmHTML-1.1.7/examples
-@dirrm share/examples/XmHTML-1.1.7/book
-@dirrm share/examples/XmHTML-1.1.7/contrib
-@dirrm share/examples/XmHTML-1.1.7
-@dirrm share/doc/XmHTML-1.1.7/man
-@dirrm share/doc/XmHTML-1.1.7
+lib/libXmHTML.a
+lib/libXmHTML.so
+lib/libXmHTML.so.1
+share/doc/XmHTML/GPL.html
+share/doc/XmHTML/LGPL.html
+share/doc/XmHTML/XmHTML.html
+share/doc/XmHTML/apps.html
+share/doc/XmHTML/changes.html
+share/doc/XmHTML/copyrights.html
+share/doc/XmHTML/custom_map.html
+share/doc/XmHTML/custom_map.txt
+share/doc/XmHTML/datatypes.html
+share/doc/XmHTML/debug.html
+share/doc/XmHTML/extensions.html
+share/doc/XmHTML/font_map.html
+share/doc/XmHTML/getit.html
+share/doc/XmHTML/legals.html
+share/doc/XmHTML/man.html
+share/doc/XmHTML/man/AllocCol.html
+share/doc/XmHTML/man/AncGetId.html
+share/doc/XmHTML/man/AncScrId.html
+share/doc/XmHTML/man/AncScrNm.html
+share/doc/XmHTML/man/CrtHTML.html
+share/doc/XmHTML/man/FontInfo.html
+share/doc/XmHTML/man/FrGtChld.html
+share/doc/XmHTML/man/FreeCol.html
+share/doc/XmHTML/man/GetTitle.html
+share/doc/XmHTML/man/GtHdAttr.html
+share/doc/XmHTML/man/GtURLTyp.html
+share/doc/XmHTML/man/HTGIFStr.html
+share/doc/XmHTML/man/HTGtVer.html
+share/doc/XmHTML/man/HTML.html
+share/doc/XmHTML/man/HTObject.html
+share/doc/XmHTML/man/HTPLCStr.html
+share/doc/XmHTML/man/HTPapSiz.html
+share/doc/XmHTML/man/ImCrFrIn.html
+share/doc/XmHTML/man/ImCreate.html
+share/doc/XmHTML/man/ImDefPrc.html
+share/doc/XmHTML/man/ImDestro.html
+share/doc/XmHTML/man/ImFreeAl.html
+share/doc/XmHTML/man/ImFreeIn.html
+share/doc/XmHTML/man/ImGZFSup.html
+share/doc/XmHTML/man/ImGetTyp.html
+share/doc/XmHTML/man/ImGifGzf.html
+share/doc/XmHTML/man/ImImgMap.html
+share/doc/XmHTML/man/ImInfo.html
+share/doc/XmHTML/man/ImPLCCon.html
+share/doc/XmHTML/man/ImPLCKil.html
+share/doc/XmHTML/man/ImPLCSus.html
+share/doc/XmHTML/man/ImReplac.html
+share/doc/XmHTML/man/ImUpdate.html
+share/doc/XmHTML/man/Redispla.html
+share/doc/XmHTML/man/TxtGtFmt.html
+share/doc/XmHTML/man/TxtGtSrc.html
+share/doc/XmHTML/man/TxtGtStr.html
+share/doc/XmHTML/man/TxtScrLn.html
+share/doc/XmHTML/man/TxtStStr.html
+share/doc/XmHTML/man/TxtStrWl.html
+share/doc/XmHTML/man/XYToInfo.html
+share/doc/XmHTML/man/XmImage.html
+share/doc/XmHTML/man/empty.html
+share/doc/XmHTML/man/man.map
+share/doc/XmHTML/man/man.tmpl
+share/doc/XmHTML/parser.html
+share/doc/XmHTML/parser_prog.html
+share/doc/XmHTML/parser_ref.html
+share/doc/XmHTML/procedures.html
+share/doc/XmHTML/progguide.html
+share/doc/XmHTML/structures.html
+share/doc/XmHTML/xmhtml_prog.html
+share/examples/XmHTML/book/Imakefile
+share/examples/XmHTML/book/Makefile
+share/examples/XmHTML/book/Makefile.org
+share/examples/XmHTML/book/Makefile.orig
+share/examples/XmHTML/book/autosize_html.c
+share/examples/XmHTML/book/forced_html.c
+share/examples/XmHTML/book/html.c
+share/examples/XmHTML/book/html_browser.c
+share/examples/XmHTML/book/simple_html.c
+share/examples/XmHTML/book/simple_html2.c
+share/examples/XmHTML/book/work_window.c
+share/examples/XmHTML/contrib/Makefile
+share/examples/XmHTML/contrib/Makefile.org
+share/examples/XmHTML/contrib/README
+share/examples/XmHTML/contrib/VUEorDT.c
+share/examples/XmHTML/contrib/drawBttn.c
+share/examples/XmHTML/contrib/example_5.c
+share/examples/XmHTML/contrib/gif_decode.c
+share/examples/XmHTML/contrib/htmltest.c
+share/examples/XmHTML/contrib/netscape.c
+share/examples/XmHTML/contrib/swallow.c
+share/examples/XmHTML/contrib/swallow2.c
+share/examples/XmHTML/examples/HTMLDemos.ad
+share/examples/XmHTML/examples/Imakefile
+share/examples/XmHTML/examples/Makefile
+share/examples/XmHTML/examples/Makefile.org
+share/examples/XmHTML/examples/Makefile.orig
+share/examples/XmHTML/examples/README
+share/examples/XmHTML/examples/cache.c
+share/examples/XmHTML/examples/cache.h
+share/examples/XmHTML/examples/example_1.c
+share/examples/XmHTML/examples/example_2.c
+share/examples/XmHTML/examples/example_4.c
+share/examples/XmHTML/examples/form-test.pl
+share/examples/XmHTML/examples/ftypes.h
+share/examples/XmHTML/examples/gif_decode.c
+share/examples/XmHTML/examples/history.c
+share/examples/XmHTML/examples/history.h
+share/examples/XmHTML/examples/menu.c
+share/examples/XmHTML/examples/menu.h
+share/examples/XmHTML/examples/menuItems.h
+share/examples/XmHTML/examples/misc.c
+share/examples/XmHTML/examples/misc.h
+share/examples/XmHTML/examples/test-pages/README
+share/examples/XmHTML/examples/test-pages/animation1.html
+share/examples/XmHTML/examples/test-pages/animation2.html
+share/examples/XmHTML/examples/test-pages/animation3.html
+share/examples/XmHTML/examples/test-pages/black.jpg
+share/examples/XmHTML/examples/test-pages/bug.gif
+share/examples/XmHTML/examples/test-pages/chinese.html
+share/examples/XmHTML/examples/test-pages/comments.html
+share/examples/XmHTML/examples/test-pages/cyrillic.html
+share/examples/XmHTML/examples/test-pages/dark_side.html
+share/examples/XmHTML/examples/test-pages/dusan.html
+share/examples/XmHTML/examples/test-pages/emailed.gif
+share/examples/XmHTML/examples/test-pages/empty.html
+share/examples/XmHTML/examples/test-pages/empty1.html
+share/examples/XmHTML/examples/test-pages/english.html
+share/examples/XmHTML/examples/test-pages/eye.xpm
+share/examples/XmHTML/examples/test-pages/eye1.xpm
+share/examples/XmHTML/examples/test-pages/eye10.xpm
+share/examples/XmHTML/examples/test-pages/eye11.xpm
+share/examples/XmHTML/examples/test-pages/eye12.xpm
+share/examples/XmHTML/examples/test-pages/eye13.xpm
+share/examples/XmHTML/examples/test-pages/eye14.xpm
+share/examples/XmHTML/examples/test-pages/eye15.xpm
+share/examples/XmHTML/examples/test-pages/eye16.xpm
+share/examples/XmHTML/examples/test-pages/eye17.xpm
+share/examples/XmHTML/examples/test-pages/eye18.xpm
+share/examples/XmHTML/examples/test-pages/eye19.xpm
+share/examples/XmHTML/examples/test-pages/eye2.xpm
+share/examples/XmHTML/examples/test-pages/eye20.xpm
+share/examples/XmHTML/examples/test-pages/eye21.xpm
+share/examples/XmHTML/examples/test-pages/eye22.xpm
+share/examples/XmHTML/examples/test-pages/eye23.xpm
+share/examples/XmHTML/examples/test-pages/eye24.xpm
+share/examples/XmHTML/examples/test-pages/eye3.xpm
+share/examples/XmHTML/examples/test-pages/eye4.xpm
+share/examples/XmHTML/examples/test-pages/eye5.xpm
+share/examples/XmHTML/examples/test-pages/eye6.xpm
+share/examples/XmHTML/examples/test-pages/eye7.xpm
+share/examples/XmHTML/examples/test-pages/eye8.xpm
+share/examples/XmHTML/examples/test-pages/eye9.xpm
+share/examples/XmHTML/examples/test-pages/face.html
+share/examples/XmHTML/examples/test-pages/font-stuff.html
+share/examples/XmHTML/examples/test-pages/form-test.html
+share/examples/XmHTML/examples/test-pages/frame.html
+share/examples/XmHTML/examples/test-pages/frame1.html
+share/examples/XmHTML/examples/test-pages/frame2.html
+share/examples/XmHTML/examples/test-pages/frame3.html
+share/examples/XmHTML/examples/test-pages/frame4.html
+share/examples/XmHTML/examples/test-pages/frame5.html
+share/examples/XmHTML/examples/test-pages/icons.html
+share/examples/XmHTML/examples/test-pages/image-layout.html
+share/examples/XmHTML/examples/test-pages/image-map.html
+share/examples/XmHTML/examples/test-pages/null_end.html
+share/examples/XmHTML/examples/test-pages/null_end1.html
+share/examples/XmHTML/examples/test-pages/pass7_sml.png
+share/examples/XmHTML/examples/test-pages/png.html
+share/examples/XmHTML/examples/test-pages/pnglogo-blk-tiny.png
+share/examples/XmHTML/examples/test-pages/root.html
+share/examples/XmHTML/examples/test-pages/symbol.html
+share/examples/XmHTML/examples/test-pages/table1.html
+share/examples/XmHTML/examples/test-pages/table10.html
+share/examples/XmHTML/examples/test-pages/table11.html
+share/examples/XmHTML/examples/test-pages/table2.html
+share/examples/XmHTML/examples/test-pages/table3.html
+share/examples/XmHTML/examples/test-pages/table4.html
+share/examples/XmHTML/examples/test-pages/table5.html
+share/examples/XmHTML/examples/test-pages/table6.html
+share/examples/XmHTML/examples/test-pages/table7.html
+share/examples/XmHTML/examples/test-pages/table7.html.swp
+share/examples/XmHTML/examples/test-pages/table8.html
+share/examples/XmHTML/examples/test-pages/table9.html
+share/examples/XmHTML/examples/test-pages/unclosed.html
+share/examples/XmHTML/examples/test-pages/unclosed1.html
+share/examples/XmHTML/examples/visual.c
+@dirrm share/examples/XmHTML/examples/test-pages
+@dirrm share/examples/XmHTML/examples
+@dirrm share/examples/XmHTML/contrib
+@dirrm share/examples/XmHTML/book
+@dirrm share/examples/XmHTML
+@dirrm share/doc/XmHTML/man
+@dirrm share/doc/XmHTML
@dirrm include/XmHTML