aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-09-13 06:20:16 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-09-13 06:20:16 +0000
commitef64ca31abb55f18743cd1050d4d134b118623f6 (patch)
tree1683a44b5e3b909da1403d9e50d8424fdd7b9442 /x11-toolkits
parentbb247c5e03d5bdfd3d8ce9c261b0f9adf1f25f6e (diff)
downloadports-ef64ca31abb55f18743cd1050d4d134b118623f6.tar.gz
ports-ef64ca31abb55f18743cd1050d4d134b118623f6.zip
x11-toolkits/qt5-gtkplatform: fix build with modern Qt
- update to the last commit in the repo which adds support for the Qt in ports - deprecate as upstream abandonned the project Approved by: Greg V <greg@unrelenting.technology> (maintainer) Differential Revision: https://reviews.freebsd.org/D26415
Notes
Notes: svn path=/head/; revision=548455
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt5-gtkplatform/Makefile9
-rw-r--r--x11-toolkits/qt5-gtkplatform/distinfo6
-rw-r--r--x11-toolkits/qt5-gtkplatform/files/patch-src_qgtkintegration.cpp28
-rw-r--r--x11-toolkits/qt5-gtkplatform/files/patch-src_qgtkwindow__render.cpp15
-rw-r--r--x11-toolkits/qt5-gtkplatform/pkg-plist18
5 files changed, 28 insertions, 48 deletions
diff --git a/x11-toolkits/qt5-gtkplatform/Makefile b/x11-toolkits/qt5-gtkplatform/Makefile
index 54d413aa92e7..6e33d8f18b42 100644
--- a/x11-toolkits/qt5-gtkplatform/Makefile
+++ b/x11-toolkits/qt5-gtkplatform/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= gtkplatform
-DISTVERSION= 0.2.2
+DISTVERSION= 0.2.4-11
+DISTVERSIONSUFFIX= -g1149f4f
CATEGORIES= x11-toolkits
PKGNAMEPREFIX= qt5-
@@ -11,6 +12,9 @@ COMMENT= GTK platform backend for Qt 5
LICENSE= LGPL3 GPLv2+
LICENSE_COMB= dual
+DEPRECATED= Archived upstream
+EXPIRATION_DATE= 2021-04-15
+
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libinput.so:x11/libinput \
@@ -28,7 +32,8 @@ USE_GL= gl egl
USE_GITHUB= yes
GH_ACCOUNT= CrimsonAS
-BROKEN= Does not build with Qt 5.14
+pre-configure:
+ cd ${WRKSRC} && syncqt.pl -module QtGtkExtras -version 0.2.4
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/qt5/plugins/platforms/libqgtk.so
diff --git a/x11-toolkits/qt5-gtkplatform/distinfo b/x11-toolkits/qt5-gtkplatform/distinfo
index 363ec12d7968..ecd93b7ee0d9 100644
--- a/x11-toolkits/qt5-gtkplatform/distinfo
+++ b/x11-toolkits/qt5-gtkplatform/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1515330807
-SHA256 (CrimsonAS-gtkplatform-0.2.2_GH0.tar.gz) = 09110aa247cf7c01fc84d2f35d02b2f9c582a7b04cbff6de0a5afb2a22eae809
-SIZE (CrimsonAS-gtkplatform-0.2.2_GH0.tar.gz) = 61045
+TIMESTAMP = 1599927925
+SHA256 (CrimsonAS-gtkplatform-0.2.4-11-g1149f4f_GH0.tar.gz) = c1c90b46be42a0fa07a89b92b20acedbba7161c88d95b11c518221011bb3a7e3
+SIZE (CrimsonAS-gtkplatform-0.2.4-11-g1149f4f_GH0.tar.gz) = 62925
diff --git a/x11-toolkits/qt5-gtkplatform/files/patch-src_qgtkintegration.cpp b/x11-toolkits/qt5-gtkplatform/files/patch-src_qgtkintegration.cpp
deleted file mode 100644
index 5efea4c6c19c..000000000000
--- a/x11-toolkits/qt5-gtkplatform/files/patch-src_qgtkintegration.cpp
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/qgtkintegration.cpp.orig 2019-07-13 09:12:31 UTC
-+++ src/qgtkintegration.cpp
-@@ -131,7 +131,11 @@ void QGtkIntegration::onMonitorAdded(GdkMonitor *monit
- {
- qDebug() << "Added " << monitor;
- m_screens.append(new QGtkScreen(monitor));
-- screenAdded(m_screens.at(m_screens.count() - 1));
-+ #if (QT_VERSION >= QT_VERSION_CHECK(5, 13, 0))
-+ QWindowSystemInterface::handleScreenAdded(m_screens.at(m_screens.count() - 1));
-+ #else
-+ screenAdded(m_screens.at(m_screens.count() - 1));
-+ #endif
- }
-
- void QGtkIntegration::onMonitorRemoved(GdkMonitor *monitor)
-@@ -139,7 +143,11 @@ void QGtkIntegration::onMonitorRemoved(GdkMonitor *mon
- qDebug() << "Removed " << monitor;
- for (int i = 0; i < m_screens.count(); ++i) {
- if (m_screens.at(i)->monitor() == monitor) {
-- removeScreen(m_screens.at(i)->screen());
-+ #if (QT_VERSION >= QT_VERSION_CHECK(5, 13, 0))
-+ QWindowSystemInterface::handleScreenRemoved(m_screens.at(i));
-+ #else
-+ removeScreen(m_screens.at(i)->screen());
-+ #endif
- m_screens.removeAt(i);
- return;
- }
diff --git a/x11-toolkits/qt5-gtkplatform/files/patch-src_qgtkwindow__render.cpp b/x11-toolkits/qt5-gtkplatform/files/patch-src_qgtkwindow__render.cpp
deleted file mode 100644
index d1a10196eefc..000000000000
--- a/x11-toolkits/qt5-gtkplatform/files/patch-src_qgtkwindow__render.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
-Fix build against Qt5-5.12.0
-
---- src/qgtkwindow_render.cpp.orig 2017-12-18 21:17:27 UTC
-+++ src/qgtkwindow_render.cpp
-@@ -121,7 +121,9 @@ void QGtkWindow::onWindowTickCallback()
- if (m_wantsUpdate) {
- m_wantsUpdate = false;
- TRACE_EVENT_ASYNC_END0("gfx", "QGtkWindow::requestUpdate", this);
-- QWindowPrivate::get(window())->deliverUpdateRequest();
-+
-+ QPlatformWindow *platformWindow = window()->handle();
-+ platformWindow->deliverUpdateRequest();
- }
- }
-
diff --git a/x11-toolkits/qt5-gtkplatform/pkg-plist b/x11-toolkits/qt5-gtkplatform/pkg-plist
index 490f4c319cf0..c4ee946adeab 100644
--- a/x11-toolkits/qt5-gtkplatform/pkg-plist
+++ b/x11-toolkits/qt5-gtkplatform/pkg-plist
@@ -1,3 +1,21 @@
+%%QT_INCDIR%%/QtGtkExtras/QGtkHeaderBar
+%%QT_INCDIR%%/QtGtkExtras/QGtkRefPtr
+%%QT_INCDIR%%/QtGtkExtras/QtGtkExtras
+%%QT_INCDIR%%/QtGtkExtras/QtGtkExtrasDepends
+%%QT_INCDIR%%/QtGtkExtras/QtGtkExtrasVersion
+%%QT_INCDIR%%/QtGtkExtras/qgtkextrasglobal.h
+%%QT_INCDIR%%/QtGtkExtras/qgtkheaderbar.h
+%%QT_INCDIR%%/QtGtkExtras/qgtkrefptr.h
+%%QT_INCDIR%%/QtGtkExtras/qtgtkextrasversion.h
lib/cmake/Qt5Gui/Qt5Gui_QGtkIntegrationPlugin.cmake
+%%QT_LIBDIR%%/libQt5GtkExtras.prl
+%%QT_LIBDIR%%/libQt5GtkExtras.so
+%%QT_LIBDIR%%/libQt5GtkExtras.so.5
+%%QT_LIBDIR%%/libQt5GtkExtras.so.5.9
+%%QT_LIBDIR%%/libQt5GtkExtras.so.5.9.0
+%%DEBUG%%%%QT_LIBDIR%%/libQt5GtkExtras.so.5.9.0.debug
+%%QT_MKSPECDIR%%/modules/qt_lib_gtkextras.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_gtkextras_private.pri
%%QT_PLUGINDIR%%/platforms/libqgtk.so
%%DEBUG%%%%QT_PLUGINDIR%%/platforms/libqgtk.so.debug
+libdata/pkgconfig/Qt5GtkExtras.pc