aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2011-11-18 08:38:07 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2011-11-18 08:38:07 +0000
commit14e785efa104325cc2ae5f7aa11d9c31ab5c4234 (patch)
treeb241a2c72e7e23f8d2e88670a560e23afcadf14a /x11-toolkits
parentf0510870252ae4f1663f967dc78e8f72e37ebe8e (diff)
downloadports-14e785efa104325cc2ae5f7aa11d9c31ab5c4234.tar.gz
ports-14e785efa104325cc2ae5f7aa11d9c31ab5c4234.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gigi/Makefile27
-rw-r--r--x11-toolkits/gigi/distinfo4
-rw-r--r--x11-toolkits/gigi/files/patch-CG-adobe-cmath.hpp22
-rw-r--r--x11-toolkits/gigi/files/patch-SConstruct57
-rw-r--r--x11-toolkits/gigi/pkg-plist10
5 files changed, 18 insertions, 102 deletions
diff --git a/x11-toolkits/gigi/Makefile b/x11-toolkits/gigi/Makefile
index af0e3c4a1c97..add8c80c93d6 100644
--- a/x11-toolkits/gigi/Makefile
+++ b/x11-toolkits/gigi/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gigi
-PORTVERSION= 0.6.0.813
-PORTREVISION= 2
+PORTVERSION= 0.8.0.1048
PORTEPOCH= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_LOCAL}
@@ -20,11 +19,9 @@ LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
boost_python.4:${PORTSDIR}/devel/boost-python-libs \
freetype.9:${PORTSDIR}/print/freetype2
-BROKEN= does not compile
-
USE_GCC= 4.4+
-USE_SCONS= yes
-SCONS_ARGS= prefix="" pkgconfigdir="" build_tutorials=0
+USE_CMAKE= yes
+CMAKE_ARGS= -DBUILD_TUTORIALS:BOOL=OFF
USE_BZIP2= yes
USE_SDL= sdl
USE_LDCONFIG= yes
@@ -48,24 +45,12 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
PLIST_SUB+= OGRE=""
GIGI_LIBS+= GiGiOgre GiGiOgrePlugin_OIS
.else
-SCONS_ARGS+= build_ogre_driver=0 build_ogre_ois_plugin=0
+CMAKE_ARGS+= -DBUILD_OGRE_DRIVER:BOOL=OFF -DBUILD_OGRE_OIS_PLUGIN:BOOL=OFF
PLIST_SUB+= OGRE="@comment "
.endif
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|png_infopp_NULL|NULL|g' -e 's|int_p_NULL|NULL|g' \
- -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/src/GIL/extension/io/png_dynamic_io.hpp \
- ${WRKSRC}/src/GIL/extension/io/png_io_private.hpp
- @${REINPLACE_CMD} -e 's|Clr\.cpp|ClrConstants\.cpp|g' \
- ${WRKSRC}/src/SConscript
-
post-build:
- @${REINPLACE_CMD} -Ee 's,^(prefix|(lib|include)dir)=,&${PREFIX},' \
+ @${REINPLACE_CMD} -Ee 's,^prefix=.*,prefix=${PREFIX},' \
${WRKSRC}/*.pc
do-install:
@@ -83,7 +68,7 @@ maint-gen-distfile:
${ECHO_CMD} "ERROR: the distfile already exists."; \
${FALSE}; \
fi
- svn export https://${PORTNAME}.svn.sourceforge.net/svnroot/${PORTNAME}/trunk ${PORTNAME}
+ svn export -r 1048 https://${PORTNAME}.svn.sourceforge.net/svnroot/${PORTNAME}/trunk ${PORTNAME}
tar cjf ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}
${RM} -rf ${PORTNAME}
diff --git a/x11-toolkits/gigi/distinfo b/x11-toolkits/gigi/distinfo
index 24c0461b27cc..451dfe1fd300 100644
--- a/x11-toolkits/gigi/distinfo
+++ b/x11-toolkits/gigi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gigi-0.6.0.813.tar.bz2) = 5bb4a5d4947803a3158851087fe8a3a0de0a198cb981d83a807742e1739ac7bc
-SIZE (gigi-0.6.0.813.tar.bz2) = 1039348
+SHA256 (gigi-0.8.0.1048.tar.bz2) = e3ef65425b29be2b983a2532ed30d30d03810298f436992330420bd33a423ad2
+SIZE (gigi-0.8.0.1048.tar.bz2) = 2004428
diff --git a/x11-toolkits/gigi/files/patch-CG-adobe-cmath.hpp b/x11-toolkits/gigi/files/patch-CG-adobe-cmath.hpp
deleted file mode 100644
index b52e0ba26740..000000000000
--- a/x11-toolkits/gigi/files/patch-CG-adobe-cmath.hpp
+++ /dev/null
@@ -1,22 +0,0 @@
-
---- GG/adobe/cmath.hpp.orig 2011-01-05 13:35:35.631436941 +0200
-+++ GG/adobe/cmath.hpp 2011-01-05 13:35:50.973926288 +0200
-@@ -37,14 +37,14 @@
-
- #define ADOBE_HAS_CPP_CMATH
-
--#elif ((__GNUC__ == 4) && (__GNUC_MINOR__ <= 4))
-+#elif ((__GNUC__ == 4) && (__GNUC_MINOR__ <= 6))
- /*
- The currently supported version of GNUC has C99 extensions in math.h. But no TR1 extensions.
- */
- #define ADOBE_HAS_C99_MATH_H
-
- #else
--#error "Unknown GCC compiler configuration for cmath (last known version is 4.0.1)."
-+#error "Unknown GCC compiler configuration for cmath (last known version is 4.6.0)."
- #endif
-
- #elif defined(_MSC_VER)
-
-
diff --git a/x11-toolkits/gigi/files/patch-SConstruct b/x11-toolkits/gigi/files/patch-SConstruct
deleted file mode 100644
index c43b6eb44d4e..000000000000
--- a/x11-toolkits/gigi/files/patch-SConstruct
+++ /dev/null
@@ -1,57 +0,0 @@
---- SConstruct.orig 2009-04-09 16:43:28.000000000 +0200
-+++ SConstruct 2009-04-09 16:56:22.000000000 +0200
-@@ -82,6 +82,11 @@
- options.Add('with_ois', 'Root directory of OIS installation (only applicable when build_ogre_ois_plugin=1)')
- options.Add('with_ois_include', 'Specify exact include dir for OIS headers (only applicable when build_ogre_ois_plugin=1)')
- options.Add('with_ois_libdir', 'Specify exact library dir for OIS library (only applicable when build_ogre_ois_plugin=1)')
-+options.Add('CC', 'C compiler')
-+options.Add('CXX', 'C++ compiler')
-+options.Add('CCFLAGS', 'C compiler flags', Split(''))
-+options.Add('CPPPATH', 'Compiler include path', Split(''))
-+options.Add('LIBPATH', 'Linker library path', Split(''))
-
-
-
-@@ -155,6 +160,10 @@
- if os.environ.has_key('PKG_CONFIG_PATH'):
- env['ENV']['PKG_CONFIG_PATH'] = os.environ['PKG_CONFIG_PATH']
-
-+env['CCFLAGS'] = Split(env['CCFLAGS'])
-+env['CPPPATH'] = Split(env['CPPPATH'])
-+env['LIBPATH'] = Split(env['LIBPATH'])
-+
- if env.has_key('use_distcc') and env['use_distcc']:
- env['CC'] = 'distcc %s' % env['CC']
- env['CXX'] = 'distcc %s' % env['CXX']
-@@ -301,6 +310,15 @@
- else:
- print 'Configuring unknown system (assuming the system is POSIX-like) ...'
-
-+ # pthreads
-+ if str(Platform()) == 'posix':
-+ if env['multithreaded']:
-+ if conf.CheckCHeader('pthread.h') and conf.CheckLib('pthread', 'pthread_create', autoadd = 0):
-+ env.Append(CCFLAGS = ['-pthread'])
-+ env.Append(LINKFLAGS = ['-pthread'])
-+ else:
-+ Exit(1)
-+
- signals_namespace = 'signals'
- if OptionValue('boost_signals_namespace', env):
- signals_namespace = OptionValue('boost_signals_namespace', env)
-@@ -318,15 +336,6 @@
- if not conf.CheckBoost(boost_version_string, boost_libs, conf, not ms_linker):
- Exit(1)
-
-- # pthreads
-- if str(Platform()) == 'posix':
-- if env['multithreaded']:
-- if conf.CheckCHeader('pthread.h') and conf.CheckLib('pthread', 'pthread_create', autoadd = 0):
-- env.Append(CCFLAGS = ['-pthread'])
-- env.Append(LINKFLAGS = ['-pthread'])
-- else:
-- Exit(1)
--
- # GL and GLU
- if str(Platform()) == 'win32':
- env.Append(LIBS = [
diff --git a/x11-toolkits/gigi/pkg-plist b/x11-toolkits/gigi/pkg-plist
index 8dcf6fe20bd1..bdd7f6301820 100644
--- a/x11-toolkits/gigi/pkg-plist
+++ b/x11-toolkits/gigi/pkg-plist
@@ -1,4 +1,6 @@
+include/GG/AdamDlg.h
include/GG/AdamGlue.h
+include/GG/AdamParser.h
include/GG/AlignmentFlags.h
include/GG/Base.h
include/GG/BrowseInfoWnd.h
@@ -14,13 +16,20 @@ include/GG/DynamicGraphic.h
include/GG/Edit.h
include/GG/Enum.h
include/GG/EveGlue.h
+include/GG/EveLayout.h
+include/GG/EveParser.h
include/GG/EventPump.h
include/GG/Exception.h
+include/GG/Export.h
+include/GG/ExpressionParser.h
+include/GG/ExpressionWriter.h
include/GG/Flags.h
include/GG/Font.h
include/GG/FontFwd.h
include/GG/GUI.h
+include/GG/GroupBox.h
include/GG/Layout.h
+include/GG/Lexer.h
include/GG/ListBox.h
include/GG/Menu.h
include/GG/MultiEdit.h
@@ -52,6 +61,7 @@ include/GG/TabWnd.h
include/GG/TextControl.h
include/GG/Texture.h
include/GG/Timer.h
+include/GG/Token.h
include/GG/UnicodeCharsets.h
include/GG/Wnd.h
include/GG/WndEditor.h