aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep-i18n
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-06-09 14:24:35 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-06-09 14:24:35 +0000
commit07f7bc041c995988b7a3abcc147c8b8ce0c2c983 (patch)
tree51d94d901b04ac6229560d92c043621d4a48cf49 /x11-wm/afterstep-i18n
parentdc7dd580ed61834ab34f5b08fc9a43c3b7d92af8 (diff)
downloadports-07f7bc041c995988b7a3abcc147c8b8ce0c2c983.tar.gz
ports-07f7bc041c995988b7a3abcc147c8b8ce0c2c983.zip
Notes
Diffstat (limited to 'x11-wm/afterstep-i18n')
-rw-r--r--x11-wm/afterstep-i18n/Makefile6
-rw-r--r--x11-wm/afterstep-i18n/files/patch-afterstep::icons.c21
2 files changed, 25 insertions, 2 deletions
diff --git a/x11-wm/afterstep-i18n/Makefile b/x11-wm/afterstep-i18n/Makefile
index e8bfa931ddee..3ad3bc249542 100644
--- a/x11-wm/afterstep-i18n/Makefile
+++ b/x11-wm/afterstep-i18n/Makefile
@@ -7,17 +7,19 @@
PORTNAME= afterstep-i18n
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= x11-wm afterstep
MASTER_SITES= ${MASTER_SITE_AFTERSTEP} \
${MASTER_SITE_LOCAL} \
http://www.itlb.te.noda.tus.ac.jp/~manome/afterstep/archive/ \
- http://www.itlb.te.noda.tus.ac.jp/~manome/afterstep/archive/icons/
+ http://www.itlb.te.noda.tus.ac.jp/~manome/afterstep/archive/icons/:icon
# former for ${MASTER_SITE_AFTERSTEP}, latter for ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= archives/1.0 kuriyama
DISTNAME= AfterStep-1.0
DISTFILES= ${DISTNAME}.tar.gz \
unofficial-I18N.98Feb27.tar.gz \
- kterm.xpm kterm2.xpm KTerm-AS.xpm netscape4.xpm
+ kterm.xpm:icon kterm2.xpm:icon KTerm-AS.xpm:icon \
+ netscape4.xpm:icon
EXTRACT_ONLY= ${DISTNAME}.tar.gz \
unofficial-I18N.98Feb27.tar.gz
diff --git a/x11-wm/afterstep-i18n/files/patch-afterstep::icons.c b/x11-wm/afterstep-i18n/files/patch-afterstep::icons.c
new file mode 100644
index 000000000000..c9c43d64a784
--- /dev/null
+++ b/x11-wm/afterstep-i18n/files/patch-afterstep::icons.c
@@ -0,0 +1,21 @@
+$FreeBSD$
+
+--- afterstep/icons.c.orig Thu Mar 20 19:09:21 1997
++++ afterstep/icons.c Sun May 26 18:15:10 2002
+@@ -779,10 +779,12 @@
+ }
+ }
+
+- if(tmp_win->flags & ICON_MOVED)
+- CreateIconWindow(tmp_win,tmp_win->icon_x_loc,tmp_win->icon_y_loc);
+- else
+- CreateIconWindow(tmp_win, def_x, def_y);
++ if(tmp_win->icon_pixmap_w == None) {
++ if(tmp_win->flags & ICON_MOVED)
++ CreateIconWindow(tmp_win,tmp_win->icon_x_loc,tmp_win->icon_y_loc);
++ else
++ CreateIconWindow(tmp_win, def_x, def_y);
++ }
+
+ AutoPlace(tmp_win);
+ tmp_win->flags |= ICONIFIED;