aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep-stable
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /x11-wm/afterstep-stable
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'x11-wm/afterstep-stable')
-rw-r--r--x11-wm/afterstep-stable/Makefile3
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterImage-export.c11
-rw-r--r--x11-wm/afterstep-stable/files/patch-libAfterImage-import.c19
3 files changed, 32 insertions, 1 deletions
diff --git a/x11-wm/afterstep-stable/Makefile b/x11-wm/afterstep-stable/Makefile
index 767fb0ac83e8..f4fb56f4caeb 100644
--- a/x11-wm/afterstep-stable/Makefile
+++ b/x11-wm/afterstep-stable/Makefile
@@ -7,6 +7,7 @@
PORTNAME= afterstep
PORTVERSION= 2.2.11
+PORTREVISION= 1
CATEGORIES= x11-wm afterstep
MASTER_SITES= ftp://ftp.afterstep.org/stable/ \
SF/${PORTNAME}/AfterStep/${PORTVERSION}
@@ -19,7 +20,7 @@ LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
execinfo.1:${PORTSDIR}/devel/libexecinfo \
freetype.9:${PORTSDIR}/print/freetype2 \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
rplay.1:${PORTSDIR}/audio/rplay \
rsvg-2.2:${PORTSDIR}/graphics/librsvg2 \
tiff.4:${PORTSDIR}/graphics/tiff \
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterImage-export.c b/x11-wm/afterstep-stable/files/patch-libAfterImage-export.c
new file mode 100644
index 000000000000..2c5e7660c5bb
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-libAfterImage-export.c
@@ -0,0 +1,11 @@
+--- libAfterImage/export.c.orig 2010-09-23 22:52:15.000000000 +0200
++++ libAfterImage/export.c 2012-05-06 07:25:17.000000000 +0200
+@@ -496,7 +496,7 @@
+ png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
+ if ( png_ptr != NULL )
+ if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
+ info_ptr = NULL ;
diff --git a/x11-wm/afterstep-stable/files/patch-libAfterImage-import.c b/x11-wm/afterstep-stable/files/patch-libAfterImage-import.c
new file mode 100644
index 000000000000..bef85880f392
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-libAfterImage-import.c
@@ -0,0 +1,19 @@
+--- libAfterImage/import.c.orig 2010-09-23 22:57:57.000000000 +0200
++++ libAfterImage/import.c 2012-05-06 09:30:26.000000000 +0200
+@@ -40,6 +40,7 @@
+ # else
+ # include <png.h>
+ # endif
++# include <pngpriv.h>
+ #else
+ # include <setjmp.h>
+ # ifdef HAVE_JPEG
+@@ -1251,7 +1252,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if ( !setjmp (png_ptr->jmpbuf))
++ if ( !setjmp (png_jmpbuf(png_ptr)))
+ {
+ ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
+