aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep-stable
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2014-05-18 13:21:12 +0000
committerGreg Lewis <glewis@FreeBSD.org>2014-05-18 13:21:12 +0000
commite5b6b9ebc7b056cd04836fae0fa40e83d50a95fd (patch)
tree6282d3d2696bc7fb1d49e3a83f933fc755c56665 /x11-wm/afterstep-stable
parent4f2b719234c9b07c812cc47d7531d4dcbc6606c0 (diff)
downloadports-e5b6b9ebc7b056cd04836fae0fa40e83d50a95fd.tar.gz
ports-e5b6b9ebc7b056cd04836fae0fa40e83d50a95fd.zip
Notes
Diffstat (limited to 'x11-wm/afterstep-stable')
-rw-r--r--x11-wm/afterstep-stable/Makefile18
-rw-r--r--x11-wm/afterstep-stable/files/patch-configure27
-rw-r--r--x11-wm/afterstep-stable/files/patch-tools-installastheme.pl.in8
-rw-r--r--x11-wm/afterstep-stable/files/patch-tools-makeastheme.pl.in8
-rw-r--r--x11-wm/afterstep-stable/pkg-plist3
5 files changed, 59 insertions, 5 deletions
diff --git a/x11-wm/afterstep-stable/Makefile b/x11-wm/afterstep-stable/Makefile
index f80aaa7701a5..f01b995f1e27 100644
--- a/x11-wm/afterstep-stable/Makefile
+++ b/x11-wm/afterstep-stable/Makefile
@@ -22,12 +22,13 @@ LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
tiff:${PORTSDIR}/graphics/tiff
RUN_DEPENDS= xli:${PORTSDIR}/graphics/xli
-USE_BZIP2= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig shebangfix tar:bzip2
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 librsvg2 pango
USE_XORG+= ice sm x11 xcomposite xcursor xdamage xext xfixes xi xinerama \
xrandr xrender
GNU_CONFIGURE= yes
+SHEBANG_FILES= tools/ascommand.pl \
+ tools/importasmenu
MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS+=--disable-ascp \
--enable-i18n \
@@ -37,6 +38,7 @@ CONFIGURE_ARGS+=--disable-ascp \
--with-jpeg-includes="${LOCALBASE}/include" \
--with-png-includes="${LOCALBASE}/include" \
--with-gif
+MAKE_ENV+= HOME=-
WRKSRC= ${WRKDIR}/${PORTNAME}-devel-${PORTVERSION}
@@ -58,7 +60,6 @@ CONFIGURE_ARGS+= --enable-different-looknfeels
CONFIGURE_ARGS+= --disable-savewindows
.endif
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if exists(${PREFIX}/share/gnome/wm-properties)
@@ -67,6 +68,12 @@ PLIST_SUB+= GNOME=""
PLIST_SUB+= GNOME="@comment "
.endif
+.if ${OSVERSION} >= 1000000
+STATIC_LIBEXECINFO=
+.else
+STATIC_LIBEXECINFO= ${LOCALBASE}/lib/libexecinfo.a
+.endif
+
post-extract:
${CP} ${FILESDIR}/monitor_bsd.xpm \
${WRKSRC}/afterstep/desktop/icons/xml/monitor-bsd.xpm
@@ -88,9 +95,12 @@ post-patch:
@${REINPLACE_CMD} -e 's,ft_version,libafterstep_version,g' \
${WRKSRC}/${f}
.endfor
-.for f in configure libAfterBase/configure libAfterConf/Makefile.in libAfterImage/configure
+.for f in configure libAfterBase/configure libAfterConf/Makefile.in libAfterImage/configure tools/makeastheme.pl.in tools/installastheme.pl.in
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
${WRKSRC}/${f}
.endfor
+ @${REINPLACE_CMD} \
+ -e 's,%%STATIC_LIBEXECINFO%%,${STATIC_LIBEXECINFO},g' \
+ ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/x11-wm/afterstep-stable/files/patch-configure b/x11-wm/afterstep-stable/files/patch-configure
index cbed477c23ac..10811140ecb7 100644
--- a/x11-wm/afterstep-stable/files/patch-configure
+++ b/x11-wm/afterstep-stable/files/patch-configure
@@ -2,6 +2,33 @@ $FreeBSD$
--- configure Sat Jun 24 21:55:24 2006
+++ configure.orig Sat Jun 24 21:54:41 2006
+@@ -7955,7 +7955,7 @@
+ fi
+
+ if test "x$enable_staticlibs" = "xyes"; then
+- AFTERBASE_LIB="../../libAfterBase/libAfterBase.a"
++ AFTERBASE_LIB="../../libAfterBase/libAfterBase.a %%STATIC_LIBEXECINFO%%"
+ AFTERIMAGE_LIB="../../libAfterImage/libAfterImage.a"
+ AFTERSTEP_LIB="../../libAfterStep/libAfterStep.a"
+ AFTERCONF_LIB="../../libAfterConf/libAfterConf.a"
+@@ -7974,7 +7974,7 @@
+ LIBPROG='$(LIB_SHARED_CYG)'
+ LIBINSTALL="install.cyg"
+ else
+- AFTERBASE_LIB="../../libAfterBase/libAfterBase.so"
++ AFTERBASE_LIB="../../libAfterBase/libAfterBase.so %%STATIC_LIBEXECINFO%%"
+ AFTERIMAGE_LIB="../../libAfterImage/libAfterImage.so"
+ AFTERSTEP_LIB="../../libAfterStep/libAfterStep.so"
+ AFTERCONF_LIB="../../libAfterConf/libAfterConf.so"
+@@ -7985,7 +7985,7 @@
+ fi
+ fi
+
+-AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a"
++AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a %%STATIC_LIBEXECINFO%%"
+ AFTERIMAGE_STATIC_LIB="../../libAfterImage/libAfterImage.a"
+ AFTERSTEP_STATIC_LIB="../../libAfterStep/libAfterStep.a"
+ AFTERCONF_STATIC_LIB="../../libAfterConf/libAfterConf.a"
@@ -7660,7 +7660,7 @@
fi
diff --git a/x11-wm/afterstep-stable/files/patch-tools-installastheme.pl.in b/x11-wm/afterstep-stable/files/patch-tools-installastheme.pl.in
new file mode 100644
index 000000000000..20b286f93c28
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-tools-installastheme.pl.in
@@ -0,0 +1,8 @@
+--- tools/installastheme.pl.in.orig 2014-05-17 11:39:07.000000000 -0700
++++ tools/installastheme.pl.in 2014-05-17 11:39:14.000000000 -0700
+@@ -1,4 +1,4 @@
+-#!@PERL@
++#!%%LOCALBASE%%/bin/perl
+
+ use strict;
+ use Cwd;
diff --git a/x11-wm/afterstep-stable/files/patch-tools-makeastheme.pl.in b/x11-wm/afterstep-stable/files/patch-tools-makeastheme.pl.in
new file mode 100644
index 000000000000..221d9fcae545
--- /dev/null
+++ b/x11-wm/afterstep-stable/files/patch-tools-makeastheme.pl.in
@@ -0,0 +1,8 @@
+--- tools/makeastheme.pl.in.orig 2014-05-17 11:41:45.000000000 -0700
++++ tools/makeastheme.pl.in 2014-05-17 11:41:52.000000000 -0700
+@@ -1,4 +1,4 @@
+-#!@PERL@
++#!%%LOCALBASE%%/usr/bin/perl
+
+ use strict;
+
diff --git a/x11-wm/afterstep-stable/pkg-plist b/x11-wm/afterstep-stable/pkg-plist
index 1c15bcc7736e..a809a5fb6663 100644
--- a/x11-wm/afterstep-stable/pkg-plist
+++ b/x11-wm/afterstep-stable/pkg-plist
@@ -1377,7 +1377,7 @@ lib/libAfterStep.a
%%DATADIR%%/wharf
%%DATADIR%%/winlist
%%DATADIR%%/wintabs
-share/gnome/wm-properties/AfterStep.desktop
+share/applications/AfterStep.desktop
@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%/start/7_About_AfterStep
@dirrm %%DATADIR%%/start/5_Quit
@@ -1454,3 +1454,4 @@ share/gnome/wm-properties/AfterStep.desktop
@dirrm include/libAfterStep
@dirrm include/libAfterConf
@dirrm include/libASGTK
+@dirrmtry share/applications