aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep/Makefile
diff options
context:
space:
mode:
authorHidetoshi Shimokawa <simokawa@FreeBSD.org>1999-01-10 14:54:28 +0000
committerHidetoshi Shimokawa <simokawa@FreeBSD.org>1999-01-10 14:54:28 +0000
commit0c521e6110ee7b54cae37a4e047c75f910941781 (patch)
tree58f8a063a3866e145b1928daf24f530383e82085 /x11-wm/afterstep/Makefile
parent1136e15539a2352ed615f7bffc3b84fbc9a54e04 (diff)
downloadports-0c521e6110ee7b54cae37a4e047c75f910941781.tar.gz
ports-0c521e6110ee7b54cae37a4e047c75f910941781.zip
Notes
Diffstat (limited to 'x11-wm/afterstep/Makefile')
-rw-r--r--x11-wm/afterstep/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index 91c04d6e66ab..3a064325e650 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -3,7 +3,7 @@
# Date created: October 29th 1996
# Whom: jfitz@FreeBSD.ORG
#
-# $Id: Makefile,v 1.22 1998/09/17 00:32:56 asami Exp $
+# $Id: Makefile,v 1.23 1999/01/05 01:10:02 steve Exp $
#
DISTNAME= AfterStep-1.0
@@ -20,6 +20,18 @@ INSTALL_TARGET= install install.man
MANCOMPRESSED= yes
MAN1= afterstep.1 asclock.1 Animate.1 Audio.1 Auto.1 Banner.1 Pager.1 Wharf.1
+SRCDIRS= afterstep \
+ modules/Animate modules/Audio modules/Auto \
+ modules/Banner modules/Pager modules/Wharf \
+ modules/Wharf/ASSound
+
+post-patch:
+ @ for i in ${SRCDIRS}; do \
+ cd ${WRKSRC}/$$i; \
+ mv Imakefile Imakefile.orig; \
+ sed -e 's/#ifdef AlphaArchitecture/#if defined(AlphaArchitecture) \&\& !defined(FreeBSDArchitecture)/' < Imakefile.orig > Imakefile; \
+ done
+
pre-build:
@ cd ${WRKSRC}; sh MakeMakefiles