aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/afterstep
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-10-24 14:19:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-10-24 14:19:00 +0000
commit0b6fa4e68d26b37032b040231fb266329bf978a5 (patch)
treef86d7b36037dd2fe6415d107ba6af4402c7eb00a /x11-wm/afterstep
parentb61df8b3244e53ac4837c8326dd6cfa56d6cd32a (diff)
downloadports-0b6fa4e68d26b37032b040231fb266329bf978a5.tar.gz
ports-0b6fa4e68d26b37032b040231fb266329bf978a5.zip
Notes
Diffstat (limited to 'x11-wm/afterstep')
-rw-r--r--x11-wm/afterstep/Makefile18
-rw-r--r--x11-wm/afterstep/files/patch-icons.c (renamed from x11-wm/afterstep/files/patch-afterstep::icons.c)2
-rw-r--r--x11-wm/afterstep/scripts/configure8
3 files changed, 12 insertions, 16 deletions
diff --git a/x11-wm/afterstep/Makefile b/x11-wm/afterstep/Makefile
index 1b93f19c9475..9f3710dbd7bc 100644
--- a/x11-wm/afterstep/Makefile
+++ b/x11-wm/afterstep/Makefile
@@ -13,15 +13,15 @@ MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
MASTER_SITE_SUBDIR= archives/${PORTVERSION}
DISTNAME= AfterStep-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
COMMENT= Window manager originally based on the Bowman NeXTSTEP clone
RUN_DEPENDS= asclock:${PORTSDIR}/x11-clocks/asclock
NO_LATEST_LINK= yes
-USE_X_PREFIX= yes
USE_XPM= yes
USE_IMAKE= yes
+USE_REINPLACE= yes
INSTALL_TARGET= install install.man
MANCOMPRESSED= yes
MAN1= afterstep.1 Animate.1 Audio.1 Auto.1 Banner.1 Pager.1 Wharf.1
@@ -32,6 +32,10 @@ SRCDIRS= afterstep \
modules/Wharf/ASSound
post-patch:
+ ${REINPLACE_CMD} \
+ -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/configure.h \
+ ${WRKSRC}/sample.steprc
@ for i in ${SRCDIRS}; do \
cd ${WRKSRC}/$$i; \
${MV} Imakefile Imakefile.orig; \
@@ -39,7 +43,7 @@ post-patch:
done
pre-build:
- @ cd ${WRKSRC}; sh MakeMakefiles
+ @ cd ${WRKSRC}; ${SH} MakeMakefiles
post-install:
@ ${MKDIR} ${PREFIX}/lib/X11/afterstep/backgrounds/
@@ -55,14 +59,14 @@ post-install:
@${ECHO_MSG} " reinstall this port with -DWITH_HICOLOR_ICONS"
@${ECHO_MSG} " defined"
.endif
- @for file in AFstep.xpm penguin.xpm monitor_bsd.xpm; do \
- ${CP} ${FILESDIR}/$$file ${WRKSRC}/icons/8bit; \
+ @for i in AFstep.xpm penguin.xpm monitor_bsd.xpm; do \
+ ${CP} ${FILESDIR}/$$i ${WRKSRC}/icons/8bit; \
done
${INSTALL_DATA} ${WRKSRC}/icons/8bit/*.xpm ${PREFIX}/include/X11/pixmaps/
.endif
@ ${MKDIR} ${PREFIX}/lib/X11/afterstep/doc/
- @for file in CHANGES CREDITS README README.8bit INSTALL FAQ module-interface.txt; do \
- ${INSTALL_DATA} ${WRKSRC}/$$file ${PREFIX}/lib/X11/afterstep/doc/; \
+ @for i in CHANGES CREDITS README README.8bit INSTALL FAQ module-interface.txt; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$i ${PREFIX}/lib/X11/afterstep/doc/; \
done
.include <bsd.port.pre.mk>
diff --git a/x11-wm/afterstep/files/patch-afterstep::icons.c b/x11-wm/afterstep/files/patch-icons.c
index c9c43d64a784..04bd11ae88a1 100644
--- a/x11-wm/afterstep/files/patch-afterstep::icons.c
+++ b/x11-wm/afterstep/files/patch-icons.c
@@ -1,4 +1,4 @@
-$FreeBSD$
+$FreeBSD: /tmp/pcvs/ports/x11-wm/afterstep/files/patch-icons.c,v 1.1 2005-10-24 14:19:00 dinoex Exp $
--- afterstep/icons.c.orig Thu Mar 20 19:09:21 1997
+++ afterstep/icons.c Sun May 26 18:15:10 2002
diff --git a/x11-wm/afterstep/scripts/configure b/x11-wm/afterstep/scripts/configure
deleted file mode 100644
index 0b1ba89bbcb1..000000000000
--- a/x11-wm/afterstep/scripts/configure
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/usr/bin/perl
-#
-
-eval '(exit $?0)' && eval 'exec /usr/bin/perl -S $0 ${1+"$@"}'
-& eval 'exec /usr/bin/perl -S $0 $argv:q'
-if 0;
-
-system( "/usr/bin/perl -pi -e 's|%%PREFIX%%|$ENV{'PREFIX'}|g' $ENV{'WRKSRC'}/sample.steprc $ENV{'WRKSRC'}/configure.h" );