aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/antiwm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-09 12:59:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-09 12:59:00 +0000
commitd0bd9acc957cbe3c39229b757d8c2b35966a8438 (patch)
tree88bcc3dedd3f617721403acbef115028f4b99be3 /x11-wm/antiwm
parentb701c8380f79e53adc078da4f8b650acf6e7659c (diff)
downloadports-d0bd9acc957cbe3c39229b757d8c2b35966a8438.tar.gz
ports-d0bd9acc957cbe3c39229b757d8c2b35966a8438.zip
Notes
Diffstat (limited to 'x11-wm/antiwm')
-rw-r--r--x11-wm/antiwm/Makefile38
-rw-r--r--x11-wm/antiwm/distinfo3
-rw-r--r--x11-wm/antiwm/files/patch-Makefile47
-rw-r--r--x11-wm/antiwm/pkg-descr5
4 files changed, 93 insertions, 0 deletions
diff --git a/x11-wm/antiwm/Makefile b/x11-wm/antiwm/Makefile
new file mode 100644
index 000000000000..7db248bf3bb9
--- /dev/null
+++ b/x11-wm/antiwm/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: antiwm
+# Date created: 2009-01-30
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= antiwm
+PORTVERSION= 0.0.3
+CATEGORIES= x11-wm
+MASTER_SITES= SF
+
+MAINTAINER= adox@mcx2.org
+COMMENT= A minimalist window manager inspired by Ratpoison
+
+USE_XORG= x11
+
+PLIST_FILES= bin/antiwm
+PORTDOCS= README LICENSE
+
+pre-everything::
+ @${ECHO_MSG} "You can build antiwm with your own conf.h using the ANTIWM_CONF knob:"
+ @${ECHO_MSG} "make ANTIWM_CONF=/path/to/antiwm/conf.h install clean"
+
+post-extract:
+.if defined(ANTIWM_CONF)
+ @${ECHO_MSG} "creating conf.h from ${ANTIWM_CONF}"
+ @${CP} ${ANTIWM_CONF} ${WRKSRC}/conf.h
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/antiwm/distinfo b/x11-wm/antiwm/distinfo
new file mode 100644
index 000000000000..11c507a9b95b
--- /dev/null
+++ b/x11-wm/antiwm/distinfo
@@ -0,0 +1,3 @@
+MD5 (antiwm-0.0.3.tar.gz) = 5764f780e1a0004e5f2f16053636ed59
+SHA256 (antiwm-0.0.3.tar.gz) = 5167fbba12dec38f9065ad9a2c2c5dbce0e9c37a593f4ea186cbbf470dc3c7e7
+SIZE (antiwm-0.0.3.tar.gz) = 8373
diff --git a/x11-wm/antiwm/files/patch-Makefile b/x11-wm/antiwm/files/patch-Makefile
new file mode 100644
index 000000000000..b89d73dc6614
--- /dev/null
+++ b/x11-wm/antiwm/files/patch-Makefile
@@ -0,0 +1,47 @@
+--- Makefile.orig 2008-08-01 02:59:17.000000000 +0200
++++ Makefile 2009-02-01 10:00:20.000000000 +0100
+@@ -1,22 +1,36 @@
+ # install directory
+-INSTALL_DIR=/usr/local/bin
++PREFIX?= /usr/local/
+
+ # enable debug messages
+ DEBUG = -DDEBUG
+
+-CC = gcc
+-LIBS = -lX11
+-LDFLAGS = -L/usr/lib
+-CFLAGS = -O2 -Wall -I/usr/X11R6/include
++# compiler and linker
++CC?= gcc
++
++# paths
++X11INC = $(LOCALBASE)/include
++X11LIB = $(LOCALBASE)/lib
++
++# includes and libs
++INCS = -I. -I/usr/include -I${X11INC}
++LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
++
++# flags
++LDFLAGS+= ${LIBS}
++CFLAGS+= ${INCS}
+
+ SRC = main.o events.o manage.o list.o bar.o
+ HEADERS = bar.h conf.h data.h events.h list.h manage.h antiwm.h
+
++all: antiwm
++
+ antiwm: $(SRC)
+- gcc $(SRC) -o $@ $(CFLAGS) $(LDFLAGS) $(LIBS)
++ gcc $(SRC) -o $@ $(CFLAGS) $(LDFLAGS)
+
+-install: antiwm
+- cp antiwm $(INSTALL_DIR)
++install: all
++ @mkdir -p ${DESTDIR}${PREFIX}/bin
++ @cp -f antiwm ${PREFIX}/bin
++ @chmod 755 ${DESTDIR}${PREFIX}/bin/antiwm
+
+ %.o : %.c $(HEADERS)
+ $(CC) -c $(CFLAGS) $(DEBUG) $< -o $@
diff --git a/x11-wm/antiwm/pkg-descr b/x11-wm/antiwm/pkg-descr
new file mode 100644
index 000000000000..3174817b1bb9
--- /dev/null
+++ b/x11-wm/antiwm/pkg-descr
@@ -0,0 +1,5 @@
+AntiWM is a small and simple window manager with a focus on
+productivity and utility. Inspired by ratpoison, AntiWM is
+keyboard driven and handles all windows fullscreen.
+
+WWW: http://sourceforge.net/projects/antiwm