aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/awesome/files
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-04-25 12:54:54 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-04-25 12:54:54 +0000
commiteffc2a5a9802e5873bf609d564516e9ff3ead39f (patch)
tree4e4ec911ec86d14439b564e16436f186b25e6b3f /x11-wm/awesome/files
parente39207bd80b1336dfd5caa058554bcf3887d251b (diff)
downloadports-effc2a5a9802e5873bf609d564516e9ff3ead39f.tar.gz
ports-effc2a5a9802e5873bf609d564516e9ff3ead39f.zip
Notes
Diffstat (limited to 'x11-wm/awesome/files')
-rw-r--r--x11-wm/awesome/files/patch-Makefile37
-rw-r--r--x11-wm/awesome/files/patch-config.mk29
2 files changed, 0 insertions, 66 deletions
diff --git a/x11-wm/awesome/files/patch-Makefile b/x11-wm/awesome/files/patch-Makefile
deleted file mode 100644
index 6e50397d077d..000000000000
--- a/x11-wm/awesome/files/patch-Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
---- Makefile.orig 2007-12-11 22:57:57.000000000 +0200
-+++ Makefile 2007-12-11 22:58:58.000000000 +0200
-@@ -10,7 +10,7 @@
- SRCCLIENT = awesome-client.c awesome-client-common.c util.c
- OBJCLIENT = ${SRCCLIENT:.c=.o}
-
--all: options awesome awesome-client
-+all: options awesome awesome-client man
-
- options:
- @echo awesome build options:
-@@ -64,19 +64,19 @@
-
- install: strip install-unstrip
-
--install-unstrip: awesome awesome-client man
-+install-unstrip: awesome awesome-client
- @echo installing executable file to ${DESTDIR}${PREFIX}/bin
- @install -d ${DESTDIR}${PREFIX}/bin
- @install -m 755 awesome awesome-client ${DESTDIR}${PREFIX}/bin
-- @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
-- @install -d ${DESTDIR}${MANPREFIX}/man1
-- @install -m 644 ${DOCS:.txt=} ${DESTDIR}${MANPREFIX}/man1
-+ @echo installing manual page to ${DESTDIR}${MANPREFIX}/man/man1
-+ @install -d ${DESTDIR}${MANPREFIX}/man/man1
-+ @install -m 644 ${DOCS:.txt=} ${DESTDIR}${MANPREFIX}/man/man1
-
- uninstall:
- @echo removing executable file from ${DESTDIR}${PREFIX}/bin
- @rm ${DESTDIR}${PREFIX}/bin/awesome ${DESTDIR}${PREFIX}/bin/awesome-client
-- @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
-- @rm ${DESTDIR}${MANPREFIX}/man1/awesome.1 ${DESTDIR}${MANPREFIX}/man1/awesome-client.1
-+ @echo removing manual page from ${DESTDIR}${MANPREFIX}/man/man1
-+ @rm ${DESTDIR}${MANPREFIX}/man/man1/awesome.1 ${DESTDIR}${MANPREFIX}/man/man1/awesome-client.1
-
- doc:
- @echo generating documentation
diff --git a/x11-wm/awesome/files/patch-config.mk b/x11-wm/awesome/files/patch-config.mk
deleted file mode 100644
index 0e38337e4457..000000000000
--- a/x11-wm/awesome/files/patch-config.mk
+++ /dev/null
@@ -1,29 +0,0 @@
---- config.mk.o 2007-11-18 06:20:55.000000000 +0200
-+++ config.mk 2007-11-18 06:23:43.000000000 +0200
-@@ -8,20 +8,18 @@
- LAYOUTS = layouts/tile.c layouts/floating.c layouts/max.c
-
- # paths
--PREFIX = /usr/local
--MANPREFIX = ${PREFIX}/share/man
-
--X11INC = /usr/include/X11
--X11LIB = /usr/lib/X11
-+X11INC = ${LOCALBASE}/include
-+X11LIB = ${LOCALBASE}/lib
-
- # includes and libs
- INCS = -I. -I/usr/include -I${X11INC} `pkg-config --cflags libconfuse xft cairo`
- LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 `pkg-config --libs libconfuse xft cairo` -lXext -lXrandr -lXinerama
-
- # flags
--CFLAGS = -fgnu89-inline -std=gnu99 -ggdb3 -pipe -Wall -Wextra -W -Wchar-subscripts -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wsign-compare -Wunused -Wuninitialized -Winit-self -Wpointer-arith -Wredundant-decls -Wno-format-zero-length -Wmissing-prototypes -Wmissing-format-attribute -Wmissing-noreturn -O3 ${INCS} -DVERSION=\"${VERSION}\" -DRELEASE=\"${RELEASE}\"
--LDFLAGS = -ggdb3 ${LIBS}
--CLIENTLDFLAGS = -ggdb3
-+CFLAGS+= -pipe -Wall -W -Wchar-subscripts -Wshadow -Wcast-align -Wwrite-strings -Wunused -Wuninitialized -Wpointer-arith -Wredundant-decls -Wmissing-prototypes ${INCS} -DVERSION=\"${VERSION}\" -DRELEASE=\"${RELEASE}\"
-+LDFLAGS+= ${LIBS}
-+CLIENTLDFLAGS+= ${LIBS}
-
- # compiler and linker
--CC = cc
-+CC?= cc