aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/blackbox/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-03-11 19:25:25 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-03-11 19:25:25 +0000
commit93a87917469e877b6055e8274006b943e2d1151f (patch)
treec01ec412d9ec7408caad6c2bfaa30391a154406e /x11-wm/blackbox/Makefile
parent1b481b766e7a0cf26ea68fdcbd0ad7e5bf5d04d9 (diff)
downloadports-93a87917469e877b6055e8274006b943e2d1151f.tar.gz
ports-93a87917469e877b6055e8274006b943e2d1151f.zip
Notes
Diffstat (limited to 'x11-wm/blackbox/Makefile')
-rw-r--r--x11-wm/blackbox/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/x11-wm/blackbox/Makefile b/x11-wm/blackbox/Makefile
index 4ddec794d0ad..161d21d1c6e7 100644
--- a/x11-wm/blackbox/Makefile
+++ b/x11-wm/blackbox/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= blackbox
-PORTVERSION= 0.65.0
+PORTVERSION= 0.70.0
CATEGORIES= x11-wm
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= blackboxwm
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dako@bsdberlin.org
COMMENT= A small and fast window manager for X11R6
RUN_DEPENDS= bsetbg:${PORTSDIR}/x11-wm/boxtools
@@ -21,11 +21,14 @@ MAN1= blackbox.1
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+USE_ICONV= yes
+USE_GNOME= pkgconfig gnomehack
+USE_GCC= 3.3+
-pre-patch:
- ${REINPLACE_CMD} -e 's#-pedantic##' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's#nls src util#nls src#' ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -E 's/^SUBDIRS/#SUBDIRS/' ${WRKSRC}/doc/Makefile.in
- ${REINPLACE_CMD} -e 's# bsetroot.1 bsetbg.1##' ${WRKSRC}/doc/Makefile.in
+post-patch:
+ @${REINPLACE_CMD} -e 's#-pedantic##' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's#nls src util#nls src#' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -E 's/^SUBDIRS/#SUBDIRS/' ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's# bsetroot.1 bsetbg.1##' ${WRKSRC}/doc/Makefile.in
.include <bsd.port.mk>