aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/cl-stumpwm
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-03-11 22:54:58 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-03-11 22:54:58 +0000
commitd9f2006450b61f053354d152781b9a372c0b9e23 (patch)
tree7fc4fe30238f646da8c0d4ca155ceae3062a5119 /x11-wm/cl-stumpwm
parent6b20abc952bfce94ad28d2e07947cd84f9efe97d (diff)
Notes
Diffstat (limited to 'x11-wm/cl-stumpwm')
-rw-r--r--x11-wm/cl-stumpwm/Makefile37
-rw-r--r--x11-wm/cl-stumpwm/distinfo3
-rw-r--r--x11-wm/cl-stumpwm/pkg-descr19
3 files changed, 59 insertions, 0 deletions
diff --git a/x11-wm/cl-stumpwm/Makefile b/x11-wm/cl-stumpwm/Makefile
new file mode 100644
index 000000000000..518b8d9417f2
--- /dev/null
+++ b/x11-wm/cl-stumpwm/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: stumpwm
+# Date created: 2008-02-20
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= stumpwm
+PORTVERSION= 0.9.2
+CATEGORIES= x11-wm
+MASTER_SITES= SAVANNAH
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= A tiling, keyboard driven Window Manager written in Common Lisp
+
+BUILD_DEPENDS= clisp:${PORTSDIR}/lang/clisp
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-lisp=clisp
+
+PLIST_FILES= bin/stumpwm
+INFO= stumpwm
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/clisp) || !defined(PACKAGE_BUILDING)
+. if !exists(${LOCALBASE}/lib/clisp/full/clx.o)
+IGNORE= requires lang/clisp built with CLX_NEW option ON
+. endif
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/stumpwm ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/stumpwm.info ${PREFIX}/${INFO_PATH}
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/cl-stumpwm/distinfo b/x11-wm/cl-stumpwm/distinfo
new file mode 100644
index 000000000000..847c07600bf0
--- /dev/null
+++ b/x11-wm/cl-stumpwm/distinfo
@@ -0,0 +1,3 @@
+MD5 (stumpwm-0.9.2.tgz) = 11103fe61602ee978f1177a74738f3d0
+SHA256 (stumpwm-0.9.2.tgz) = 40caaa02ebab53f1449b85268c9d94783aff0a19c6f6c120dd646f905e1655ba
+SIZE (stumpwm-0.9.2.tgz) = 418202
diff --git a/x11-wm/cl-stumpwm/pkg-descr b/x11-wm/cl-stumpwm/pkg-descr
new file mode 100644
index 000000000000..de5e223b33cf
--- /dev/null
+++ b/x11-wm/cl-stumpwm/pkg-descr
@@ -0,0 +1,19 @@
+Stumpwm is a tiling, keyboard driven X11 Window Manager written entirely in0
+Common Lisp.
+
+If you're tired of flipping through themes like channel-surfing, and going
+from one perfect-except-for-just-one-thing window manager to another
+even-more-broken-in-some-other-way then perhaps Stumpwm can help.
+
+Stumpwm attempts to be customizable yet visually minimal. There are no window
+decorations, no icons, and no buttons. It does have various hooks to attach
+your personal customizations, and variables to tweak.
+
+* Hack the good hack.
+* Debug your good hack.
+* Customize your window manager.
+
+While it's running. That's right. With a 100% Common Lisp window manager
+there's no stopping the hacks. Just re-eval and GO!
+
+WWW: http://www.nongnu.org/stumpwm/