aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compiz-fusion
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-10-29 19:22:40 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-10-29 19:22:40 +0000
commit31eb629e5b1a851158122b649c82d32a5a6038c8 (patch)
tree5f63abbbbb1f4ea9e9f1c1a47d4ad8596421652d /x11-wm/compiz-fusion
parent1ea36b8f14cbf9e0029472c38f9ebacc04c88331 (diff)
downloadports-31eb629e5b1a851158122b649c82d32a5a6038c8.tar.gz
ports-31eb629e5b1a851158122b649c82d32a5a6038c8.zip
Notes
Diffstat (limited to 'x11-wm/compiz-fusion')
-rw-r--r--x11-wm/compiz-fusion/Makefile58
-rw-r--r--x11-wm/compiz-fusion/pkg-descr3
-rw-r--r--x11-wm/compiz-fusion/pkg-plist1
3 files changed, 62 insertions, 0 deletions
diff --git a/x11-wm/compiz-fusion/Makefile b/x11-wm/compiz-fusion/Makefile
new file mode 100644
index 000000000000..6aca368cb6a7
--- /dev/null
+++ b/x11-wm/compiz-fusion/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: compiz-fusion
+# Date created: 2007-10-22
+# Whom: Robert C. Noland III <rnoland@2hip.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= compiz-fusion
+PORTVERSION= 0.6.0
+#PORTREVISION= 0
+CATEGORIES= x11-wm
+MASTER_SITES= # none
+DISTFILES= # none
+EXTRACT_ONLY= # none
+
+MAINTAINER= rnoland@2hip.net
+COMMENT= Metaport of compiz-fusion
+
+LIB_DEPENDS= compizconfig:${PORTSDIR}/x11-wm/libcompizconfig
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz \
+ ${LOCALBASE}/lib/compiz/libanimation.so:${PORTSDIR}/x11-wm/compiz-fusion-plugins-main \
+ ${LOCALBASE}/bin/ccsm:${PORTSDIR}/x11-wm/ccsm
+
+NO_BUILD= yes
+
+OPTIONS= EXTRA "Enable extra plugins" on \
+ UNSUP "Enable unsupported plugins" off \
+ EMERALD "Enable emerald window decorator" on \
+ GCONF "Enable the gconf backend" on
+# Hold off on this until I can get a clean tb run...
+# KCONFIG "Enable kconfig backend" off
+
+do-install: # empty
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_EXTRA)
+RUN_DEPENDS+= ${LOCALBASE}/lib/compiz/libaddhelper.so:${PORTSDIR}/x11-wm/compiz-fusion-plugins-extra
+.endif
+
+.if defined(WITH_UNSUP)
+RUN_DEPENDS+= ${LOCALBASE}/lib/compiz/libfakeargb.so:${PORTSDIR}/x11-wm/compiz-fusion-plugins-unsupported
+.endif
+
+.if !defined(WITHOUT_EMERALD)
+RUN_DEPENDS+= ${LOCALBASE}/bin/emerald:${PORTSDIR}/x11-wm/emerald \
+ ${LOCALBASE}/share/emerald/themes/Adonis_Mod/theme.ini:${PORTSDIR}/x11-themes/emerald-themes
+.endif
+
+.if !defined(WITHOUT_GCONF)
+RUN_DEPENDS+= ${LOCALBASE}/lib/compizconfig/backends/libgconf.so:${PORTSDIR}/x11-wm/compizconfig-backend-gconf
+.endif
+
+#.if defined(WITH_KCONFIG)
+#RUN_DEPENDS+= ${LOCALBASE}/lib/compizconfig/backends/libkconfig.so:${PORTSDIR}/x11-wm/compizconfig-backend-kconfig
+#.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/compiz-fusion/pkg-descr b/x11-wm/compiz-fusion/pkg-descr
new file mode 100644
index 000000000000..21e24545da2f
--- /dev/null
+++ b/x11-wm/compiz-fusion/pkg-descr
@@ -0,0 +1,3 @@
+This is a metaport for compiz-fusion.
+
+WWW: http://forums.compiz-fusion.org/
diff --git a/x11-wm/compiz-fusion/pkg-plist b/x11-wm/compiz-fusion/pkg-plist
new file mode 100644
index 000000000000..8fb5cc4556d5
--- /dev/null
+++ b/x11-wm/compiz-fusion/pkg-plist
@@ -0,0 +1 @@
+@comment $FreeBSD$