aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compiz-plugins-unsupported/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2020-06-15 19:23:47 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2020-06-15 19:23:47 +0000
commitf1401925c5b373ef4bf5e2f9226db2287b1933f1 (patch)
treef5a4d1c9ec863ad2c6de22e5dd727b46f626abe7 /x11-wm/compiz-plugins-unsupported/Makefile
parentd4046e96a5a81c9b016db01cb70dcc6c96e9d28f (diff)
downloadports-f1401925c5b373ef4bf5e2f9226db2287b1933f1.tar.gz
ports-f1401925c5b373ef4bf5e2f9226db2287b1933f1.zip
Notes
Diffstat (limited to 'x11-wm/compiz-plugins-unsupported/Makefile')
-rw-r--r--x11-wm/compiz-plugins-unsupported/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-wm/compiz-plugins-unsupported/Makefile b/x11-wm/compiz-plugins-unsupported/Makefile
new file mode 100644
index 000000000000..9e4ba18bd823
--- /dev/null
+++ b/x11-wm/compiz-plugins-unsupported/Makefile
@@ -0,0 +1,51 @@
+# Created by: Robert Noland <rnoland@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= compiz-plugins-unsupported
+PORTVERSION= 0.8.8
+PORTREVISION= 7
+CATEGORIES= x11-wm
+MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/ \
+ https://BSDforge.com/prolects/source/x11-wm/compiz-plugins-unsupported/
+
+MAINTAINER= portmaster@BSDforge.com
+COMMENT= Plugins for Compiz Composite Window Manager
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcairo.so:graphics/cairo \
+ libstartup-notification-1.so:x11/startup-notification
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:x11-wm/compiz \
+ ${LOCALBASE}/libdata/pkgconfig/bcop.pc:devel/compiz-bcop \
+ ${LOCALBASE}/libdata/pkgconfig/compiz-text.pc:x11-wm/compiz-plugins-main
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= gl gmake gnome libtool:keepla pathfix pkgconfig tar:bzip2 xorg
+USE_GL= yes
+USE_GNOME= gconf2 intltool libxslt
+USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama xorgproto xrandr
+USE_LDCONFIG= yes
+
+GCONF_SCHEMAS= compiz-atlantis.schemas \
+ compiz-cubemodel.schemas \
+ compiz-elements.schemas \
+ compiz-fakeargb.schemas \
+ compiz-mswitch.schemas \
+ compiz-snow.schemas \
+ compiz-tile.schemas
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --enable-schemas
+
+OPTIONS_DEFINE= NLS
+OPTIONS_DEFAULT= NLS
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime gettext-tools
+
+.include <bsd.port.mk>