aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compizconfig-python
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2007-09-06 20:05:06 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2007-09-06 20:05:06 +0000
commit7d0fb890a0fd27edbbb499f67b4a6f711ec715f5 (patch)
tree6ac7c8bd139ce5398c2b8c45510b667aa3cf7934 /x11-wm/compizconfig-python
parent12e6537916fcc74687b03276188b85bfd71235fe (diff)
downloadports-7d0fb890a0fd27edbbb499f67b4a6f711ec715f5.tar.gz
ports-7d0fb890a0fd27edbbb499f67b4a6f711ec715f5.zip
Notes
Diffstat (limited to 'x11-wm/compizconfig-python')
-rw-r--r--x11-wm/compizconfig-python/Makefile37
-rw-r--r--x11-wm/compizconfig-python/distinfo3
-rw-r--r--x11-wm/compizconfig-python/pkg-descr3
-rw-r--r--x11-wm/compizconfig-python/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/x11-wm/compizconfig-python/Makefile b/x11-wm/compizconfig-python/Makefile
new file mode 100644
index 000000000000..e0d3fddcf265
--- /dev/null
+++ b/x11-wm/compizconfig-python/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: compizconfig-python
+# Date created: 2007-08-17
+# Whom: Robert Noland <rnoland@2hip.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= compizconfig-python
+PORTVERSION= 0.5.2
+#PORTREVISION= 0
+CATEGORIES= x11-wm
+MASTER_SITES= http://releases.compiz-fusion.org/${PORTVERSION}/
+
+MAINTAINER= rnoland@2hip.net
+COMMENT= Python bindings for the compizconfig library
+
+BUILD_DEPENDS= \
+ ${LOCALBASE}/libdata/pkgconfig/compiz.pc:${PORTSDIR}/x11-wm/compiz \
+ ${LOCALBASE}/libdata/pkgconfig/libcompizconfig.pc:${PORTSDIR}/x11-wm/libcompizconfig \
+ ${PYTHON_SITELIBDIR}/Pyrex/Distutils/__init__.py:${PORTSDIR}/devel/pyrex
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PYTHON= yes
+USE_GNOME= gnomehack glib20
+USE_AUTOTOOLS= libtool:15
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.pre.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/compizconfig-python/distinfo b/x11-wm/compizconfig-python/distinfo
new file mode 100644
index 000000000000..dc67dbf0ad8c
--- /dev/null
+++ b/x11-wm/compizconfig-python/distinfo
@@ -0,0 +1,3 @@
+MD5 (compizconfig-python-0.5.2.tar.bz2) = d3bb6415a3f0adc626e2f5e2bdef4495
+SHA256 (compizconfig-python-0.5.2.tar.bz2) = 8bd8ffde02f2d0d3bc5ed754beaa5f94c69fc43ecdfefc1fba3ec0298c943e1c
+SIZE (compizconfig-python-0.5.2.tar.bz2) = 254604
diff --git a/x11-wm/compizconfig-python/pkg-descr b/x11-wm/compizconfig-python/pkg-descr
new file mode 100644
index 000000000000..05411746fc3a
--- /dev/null
+++ b/x11-wm/compizconfig-python/pkg-descr
@@ -0,0 +1,3 @@
+Python bindings for the compizconfig library
+
+WWW: http://forums.compiz-fusion.org/
diff --git a/x11-wm/compizconfig-python/pkg-plist b/x11-wm/compizconfig-python/pkg-plist
new file mode 100644
index 000000000000..a3490dcec356
--- /dev/null
+++ b/x11-wm/compizconfig-python/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/compizconfig.so
+%%PYTHON_SITELIBDIR%%/compizconfig.la
+%%PYTHON_SITELIBDIR%%/compizconfig.a
+libdata/pkgconfig/compizconfig-python.pc