aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/compton
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-06-25 16:22:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-06-25 16:22:46 +0000
commit066591fe1313508c46ba1e36b12a9f5bee013ac0 (patch)
tree92cdafad85d2fc69831833cfb7a9fa791f4a0a39 /x11-wm/compton
parent9521c502ad9c868ac8dc19afe9cd39cc0b9ba724 (diff)
downloadports-066591fe1313508c46ba1e36b12a9f5bee013ac0.tar.gz
ports-066591fe1313508c46ba1e36b12a9f5bee013ac0.zip
Notes
Diffstat (limited to 'x11-wm/compton')
-rw-r--r--x11-wm/compton/Makefile82
-rw-r--r--x11-wm/compton/distinfo2
-rw-r--r--x11-wm/compton/files/patch-Makefile35
-rw-r--r--x11-wm/compton/files/patch-c2.h15
-rw-r--r--x11-wm/compton/pkg-descr14
-rw-r--r--x11-wm/compton/pkg-plist6
6 files changed, 154 insertions, 0 deletions
diff --git a/x11-wm/compton/Makefile b/x11-wm/compton/Makefile
new file mode 100644
index 000000000000..7f22bc1630ec
--- /dev/null
+++ b/x11-wm/compton/Makefile
@@ -0,0 +1,82 @@
+# $FreeBSD$
+
+PORTNAME= compton
+PORTVERSION= 20130619
+CATEGORIES= x11-wm
+
+MAINTAINER= femc7488@gmail.com
+COMMENT= Feature-rich compositing window manager for X11
+
+LICENSE= MIT
+
+LIB_DEPENDS= config:${PORTSDIR}/devel/libconfig
+RUN_DEPENDS= xprop:${PORTSDIR}/x11/xprop \
+ xwininfo:${PORTSDIR}/x11/xwininfo
+
+USE_GITHUB= yes
+GH_ACCOUNT= chjj
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= c02b3fa
+
+USE_XORG= xcomposite xdamage xrandr xrender
+USE_GMAKE= yes
+USES= pkgconfig
+
+MAKE_ARGS= COMPTON_VERSION=git-${PORTVERSION}-${GH_COMMIT} \
+ XDGDIR=${LOCALBASE}/etc/xdg
+ALL_TARGET= ${PORTNAME}
+
+OPTIONS_DEFINE= PCRE DRM OPENGL DBUS DOCS
+OPTIONS_DEFAULT= PCRE DRM OPENGL
+
+PCRE_DESC= Blacklist support (via libpcre)
+DRM_DESC= DRM support
+DOCS_DESC= Build manpages (requires AsciiDoc/DocBook)
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPCRE}
+LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
+.else
+MAKE_ARGS+= NO_REGEX_PCRE=yes
+.endif
+
+.if ${PORT_OPTIONS:MDRM}
+LIB_DEPENDS+= drm:${PORTSDIR}/graphics/libdrm
+.else
+MAKE_ARGS+= NO_VSYNC_DRM=yes
+.endif
+
+.if ${PORT_OPTIONS:MOPENGL}
+USE_GL= gl
+.else
+MAKE_ARGS+= NO_VSYNC_OPENGL=yes
+.endif
+
+.if ${PORT_OPTIONS:MDBUS}
+LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+.else
+MAKE_ARGS+= NO_DBUS=yes
+.endif
+
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS= a2x:${PORTSDIR}/textproc/asciidoc \
+ xsltproc:${PORTSDIR}/textproc/libxslt \
+ ${LOCALBASE}/share/xml/docbook/4.5/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml-450 \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
+ALL_TARGET+= docs
+MAKE_ARGS+= DOCDIR=${DOCSDIR} MANDIR=${MANPREFIX}/man/man1
+MAN1= compton.1 compton-trans.1
+PORTDOCS= README.md cdbus-driver.sh
+.endif
+
+post-patch:
+# Adjust the location of configuration file
+ @${REINPLACE_CMD} -e '/config_system_dir/s|/etc|${LOCALBASE}/etc|' \
+ ${WRKSRC}/src/compton.c
+# Replace OpenGL 3.2+ glFramebufferTexture() with glFramebufferTexture2D()
+ @${REINPLACE_CMD} -e \
+ '/glFramebufferTexture/s|tex_scr2|GL_TEXTURE_2D, &| ; \
+ s|glFramebufferTexture|&2D|' ${WRKSRC}/src/opengl.c
+
+.include <bsd.port.mk>
diff --git a/x11-wm/compton/distinfo b/x11-wm/compton/distinfo
new file mode 100644
index 000000000000..ab8c310d0486
--- /dev/null
+++ b/x11-wm/compton/distinfo
@@ -0,0 +1,2 @@
+SHA256 (compton-20130619.tar.gz) = 241d5653952d697d5a7752601e15690a824f5ee6a391739eccdd3a7b836f23ea
+SIZE (compton-20130619.tar.gz) = 138921
diff --git a/x11-wm/compton/files/patch-Makefile b/x11-wm/compton/files/patch-Makefile
new file mode 100644
index 000000000000..98962218bcf4
--- /dev/null
+++ b/x11-wm/compton/files/patch-Makefile
@@ -0,0 +1,35 @@
+--- Makefile.orig 2013-05-21 09:26:18.000000000 +0800
++++ Makefile 2013-06-25 20:53:32.000000000 +0800
+@@ -112,22 +112,23 @@
+ $(CC) $(CFG) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS) $(LIBS)
+
+ man/%.1: man/%.1.asciidoc
+- a2x --format manpage $<
++ a2x -v --format manpage $<
+
+ man/%.1.html: man/%.1.asciidoc
+ asciidoc $<
+
+ docs: $(MANPAGES) $(MANPAGES_HTML)
+
+-install: $(BINS) docs
+- @install -d "$(DESTDIR)$(BINDIR)" "$(DESTDIR)$(MANDIR)" "$(DESTDIR)$(APPDIR)"
+- @install -m755 $(BINS) "$(DESTDIR)$(BINDIR)"/
+- @install -m644 $(MANPAGES) "$(DESTDIR)$(MANDIR)"/
+- @install -m644 compton.desktop "$(DESTDIR)$(APPDIR)"/
++install: $(BINS)
++ @install -d "$(DESTDIR)$(BINDIR)" "$(DESTDIR)$(APPDIR)" "$(DESTDIR)$(XDGDIR)"
++ install -m755 $(BINS) "$(DESTDIR)$(BINDIR)"/
++ install -m644 compton.desktop "$(DESTDIR)$(APPDIR)"/
++ install -m644 compton.sample.conf "$(DESTDIR)$(XDGDIR)"/
+ ifneq "$(DOCDIR)" ""
+- @install -d "$(DESTDIR)$(DOCDIR)"
+- @install -m644 README.md compton.sample.conf "$(DESTDIR)$(DOCDIR)"/
+- @install -m755 dbus-examples/cdbus-driver.sh "$(DESTDIR)$(DOCDIR)"/
++ @install -d "$(DESTDIR)$(DOCDIR)" "$(DESTDIR)$(MANDIR)"
++ install -m644 $(MANPAGES) "$(DESTDIR)$(MANDIR)"/
++ install -m644 README.md "$(DESTDIR)$(DOCDIR)"/
++ install -m755 dbus-examples/cdbus-driver.sh "$(DESTDIR)$(DOCDIR)"/
+ endif
+
+ uninstall:
diff --git a/x11-wm/compton/files/patch-c2.h b/x11-wm/compton/files/patch-c2.h
new file mode 100644
index 000000000000..3e5b23825698
--- /dev/null
+++ b/x11-wm/compton/files/patch-c2.h
@@ -0,0 +1,15 @@
+--- src/c2.h.orig 2013-02-06 01:40:34.000000000 +0800
++++ src/c2.h 2013-02-06 01:40:53.000000000 +0800
+@@ -35,10 +35,8 @@
+ /// Pointer to a condition tree.
+ typedef struct {
+ bool isbranch : 1;
+- union {
+- c2_b_t *b;
+- c2_l_t *l;
+- };
++ c2_b_t *b;
++ c2_l_t *l;
+ } c2_ptr_t;
+
+ /// Initializer for c2_ptr_t.
diff --git a/x11-wm/compton/pkg-descr b/x11-wm/compton/pkg-descr
new file mode 100644
index 000000000000..6a57918e70ce
--- /dev/null
+++ b/x11-wm/compton/pkg-descr
@@ -0,0 +1,14 @@
+Compton is a compositor for X11, which was forked from Dana Jansens' fork
+of xcompmgr, and heavily refactored.
+
+Most prominent changes from the original xcompmgr:
+
+ - OpenGL/GLX backend in addition to the old X Render backend
+ - Inactive window transparency and dimming
+ - Titlebar/frame and menu transparency
+ - Shadows for ARGB windows, e.g. terminals with transparency
+ - Colored shadows; new fade system
+ - Blur of background of transparent windows, window color inversion
+ - Configuration file support with blacklisting
+
+WWW: https://github.com/chjj/compton
diff --git a/x11-wm/compton/pkg-plist b/x11-wm/compton/pkg-plist
new file mode 100644
index 000000000000..052e0f66b016
--- /dev/null
+++ b/x11-wm/compton/pkg-plist
@@ -0,0 +1,6 @@
+bin/compton
+bin/compton-trans
+etc/xdg/compton.sample.conf
+share/applications/compton.desktop
+@dirrmtry share/applications
+@dirrmtry etc/xdg